Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
24.05.2019, 07:20:20

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 591056
  • Themen insgesamt: 47865
  • Heute online: 467
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 8
Gäste: 226
Gesamt: 234

Autor Thema: [gelöst]  LMDE 3 "cindy" LXDE UND !! CEWE Software 'Saturn Fotoservice Version 6.2.1  (Gelesen 2058 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: LMDE 3 "cindy" LXDE UND !! CEWE Software 'Saturn Fotoservice Version 6.2.1
« Antwort #30 am: 05.03.2019, 19:19:46 »
Voilà: und hier die entsprechenden Ergebnisse:

volker@volker:~$ dpkg -l libgstreamer* | egrep '^ii '
ii  libgstreamer-plugins-bad1.0-0:i386  1:1.10.4-dmo2 i386         GStreamer development files for libraries from the "bad" set
ii  libgstreamer-plugins-base1.0-0:i386 1.10.4-1      i386         GStreamer libraries from the "base" set
ii  libgstreamer1.0-0:i386              1.10.4-1      i386         Core GStreamer libraries and elements
volker@volker:~$

volker@volker:~$ apt depends libgstreamer1.0-0
libgstreamer1.0-0
  Hängt ab von: libc6
  Hängt ab von: libcap2
  Hängt ab von: libglib2.0-0
  Hängt ab von: libcap2-bin
  Beschädigt: gstreamer1.0-plugins-base
  Schlägt vor: gstreamer1.0-tools
volker@volker:~$

volker@volker:~$ apt rdepends libgstreamer1.0-0
libgstreamer1.0-0
Reverse Depends:
  voctomix-core
  libwebkit2gtk-4.0-37-gtk2
  libwebkit2gtk-4.0-37
  mp3splt-gtk
  libextractor3
  handbrake-gtk
  gstreamer1.0-vaapi
  gstreamer1.0-plugins-ugly
  libgstreamer-plugins-bad1.0-0
  gstreamer1.0-plugins-bad
  gstreamer1.0-libav
  xneur
  libxneur
  xfburn
  libwxgtk-media3.0-0v5
  workrave
  libwine-development
  libwebkitgtk-3.0-0
  libwebkitgtk-1.0-0
  libwebkit2gtk-4.0-37-gtk2
  libwebkit2gtk-4.0-37
  voctomix-gui
  libgstreamer1.0-0-dbg
  vagalume
  uget
  tumbler
  tracker-extract
  totem
  libtotem0
  libtelepathy-farstream3
  subtitleeditor
  libsubtitleeditor0
  subtitlecomposer
  spice-client-gtk
  libspice-client-gtk-3.0-5
  libspice-client-glib-2.0-8
  sound-juicer
  silverjuke
  shotwell
  rygel-playbin
  rygel
  librygel-renderer-gst-2.6-2
  ruby-gstreamer
  roger-router-cli
  rhythmbox-plugins
  rhythmbox
  librhythmbox-core10
  libqt5webkit5
  libqtwebkit4
  libqt5multimedia5-plugins
  libqgsttools-p1
  qtgstreamer-plugins-qt5
  qtgstreamer-plugins
  libqtgstreamerutils-1.0-0
  libqtgstreamer-1.0-0
  libqt5gstreamerutils-1.0-0
  libqt5gstreamer-1.0-0
  octave-psychtoolbox-3
  gstreamer1.0-pocketsphinx
  plainbox-provider-checkbox
  pitivi
  pinpoint
  pidgin-sipe
  pidgin
  libpurple0
  finch
  phonon4qt5-backend-gstreamer
  phonon-backend-gstreamer
  pdf-presenter-console
  parole
  packagekit
  gstreamer1.0-packagekit
  libgstreamer-ocaml
  liquidsoap-plugin-gstreamer
  libreoffice-avmedia-backend-gstreamer
  gstreamer-qapt
  gstreamer1.0-nice
  libextractor3
  libdmapsharing-3.0-2
  libcanberra-gstreamer
  knowthelist
  python3-kivy
  python-kivy
  iptux
  handbrake
  libgupnp-dlna-2.0-3
  libgtkpod1
  libatomicparsley0
  gtkpod
  gthumb
  libgstreamermm-1.0-dev
  libgstreamermm-1.0-1
  libgstreamer1.0-dev
  gstreamer1.0-tools
  alarm-clock-applet
  gir1.2-gstreamer-1.0
  gstreamer1.0-vaapi
  libges-1.0-0
  ges1.0-tools
  gst123
  libgstrtspserver-1.0-0
  gstreamer1.0-rtsp
  python3-gst-1.0-dbg
  python3-gst-1.0
  python-gst-1.0-dbg
  python-gst-1.0
  gstreamer1.0-plugins-ugly
  gstreamer1.0-pulseaudio
  gstreamer1.0-plugins-good
  gstreamer1.0-espeak
  libgstreamer-plugins-base1.0-0
  gstreamer1.0-x
  gstreamer1.0-plugins-base-apps
  gstreamer1.0-plugins-base
  gstreamer1.0-alsa
  libgstreamer-plugins-bad1.0-0
  gstreamer1.0-plugins-bad
  gstreamer1.0-libav
  gstreamer1.0-fluendo-mp3
  grilo-plugins-0.3
  goobox
  gnome-twitch-player-backend-gstreamer-opengl
  gnome-twitch-player-backend-gstreamer-cairo
  gnome-sushi
  gnome-subtitles
  gnome-shell-pomodoro
  gnome-shell
  gmediarender
  gcompris
  gamine
  gambas3-gb-media
  fso-deviced-player-gstreamer
  frogr
  florence
  libfarstream-0.2-5
  gir1.2-farstream-0.2
  libevview3-3
  empathy
  gstreamer1.0-crystalhd
  libcogl-gst20
  libclutter-gst-3.0-0
  gstreamer1.0-clutter-3.0
  clementine
  cinnamon
  libcheese8
  cheese
  byzanz
  buzztrax
  libbrasero-media3-1
  brasero-cdrkit
  brasero
  betaradio
  baresip-gstreamer
  banshee-extension-mirage
  banshee-extension-lastfmfingerprint
  banshee
  cinnamon
  xplayer
  pix
  libxplayer0
volker@volker:~$

Und nun ??? ???
« Letzte Änderung: 05.03.2019, 19:23:19 von Schnuggibutzerl »

Bitte warten  ;D

Hi;
Und nun
Wenn ich das man wüsste.
Klar zu erkennen ist das du die Neue Version 1.0: "libgstreamer1.0-0:i386" als 32Bit Version passend zu deinem System installiert hast.

Warum nun die "Kaufland Foto Software" eine fehlende -0.1 Version anmeckert liegt vermutlich an der Kaufland Software, die einen anderen Entwicklungsstand hatte als es bei Mint/Ubuntu jetzt Stand ist (Rosa / Tessa).
Off-Topic:
Wie schon geschrieben hier kommt ein Anderer Fehler aber Kaufland Foto öffnet sich und funktioniert.

Unklar ist mir welche(s) Paket(e) noch fehlen.
Vergleichend sind hier noch die Pakete "libgstreamer-plugins-good"und "libgstreamer-gl1.0-0" vorhanden, bei dir (32Bit) wären das "libgstreamer-plugins-good1.0-0:i386" und "libgstreamer-gl1.0-0:i386". Die Beiden könntest in einem Rutsch installieren: apt install libgstreamer-plugins-good1.0-0:i386 libgstreamer-gl1.0-0:i386und dann gucken ob und wie Kaufland im Terminal startet und die Meldung hier zeigen.

Für deine Übersicht:
dpkg -l libgstreamer* | egrep '^ii ' = zeigt die installierten libgstreamer* Pakete an
apt depends libgstreamer1.0-0 = zeigt dessen Abhängigkeit zu anderen Paketen an
apt rdepends libgstreamer1.0-0 = zeigt an welche Pakete bzw. Anwendungen auf die bereits installierten Bibliotheken (Pakete) zugreifen.
« Letzte Änderung: 05.03.2019, 20:03:26 von kuehhe1 »

CEWE hat noch immer nicht begriffen, dass ich kein !!! Ubuntu- System, sondern inzwischen das Debian-9-System habe. Da scheine ich auch nicht mehr weiter zu kommen  :-[
Die teilten mir z. B.: mit, ich solle nachstehende Anweisungen bitte zeilenweise in einem Terminal-Fenster ausführen.

wget http://fr.archive.ubuntu.com/ubuntu/pool/main/g/gst-plugins-base0.10/libgstreamer-plugins-base0.10-0_0.10.36-1_amd64.deb

wget http://fr.archive.ubuntu.com/ubuntu/pool/universe/g/gstreamer0.10/libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb

sudo dpkg -i libgstreamer*.deb


@ kuehhe1:

vielen Dank für deinen Einsatz. Ich versuche nicht !!! das Kaufland-, sondern das Saturn-Programm ans Laufen zu kriegen - da scheint auch noch ein weiteres Missverständnis vorzuliegen, wobei ich es sehr sehr schätze, dass du dich meiner Sache so sehr annimmst und dich einsetzt :) :) Ob der obige Hinweis: "ich solle nachstehende Anweisungen bitte zeilenweise in einem Terminal-Fenster ausführen" uns weiterbringt ??

Hier die letzte Terminaleingabe:

volker@volker:~$ apt install libgstreamer-plugins-good1.0-0:i386 libgstreamer-gl1.0-0:i386
[sudo] Passwort für volker:       
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket libgstreamer-plugins-good1.0-0:i386 kann nicht gefunden werden.
E: Mittels des Musters »libgstreamer-plugins-good1.0-0« konnte kein Paket gefunden werden.
E: Mittels regulärem Ausdruck »libgstreamer-plugins-good1.0-0« konnte kein Paket gefunden werden.
E: Paket libgstreamer-gl1.0-0:i386 kann nicht gefunden werden.
E: Mittels des Musters »libgstreamer-gl1.0-0« konnte kein Paket gefunden werden.
E: Mittels regulärem Ausdruck »libgstreamer-gl1.0-0« konnte kein Paket gefunden werden.
volker@volker:~$
« Letzte Änderung: 05.03.2019, 20:12:49 von Schnuggibutzerl »

Dauernd System wechseln wird kaum was bringen

Ich versuche nicht !!! das Kaufland-, sondern das Saturn-Programm ans Laufen zu kriegen
Soweit mir bekannt ist die Basis der aktuellen Fotosoftware egal ob Kaufland, Saturn, DM, Rossmann usw.  von CEWE. Unterschied ist der in der speziellen Software hinterlegte Vertriebsweg, also Tel.Nr., Hotline usw. und natürlich das Design, alle aktuellen Versionen sind nur noch in 64Bit erhältlich.
Ich habe hier vergleichsweise die Original CEWE Software und die von Kaufland als 64Bit. Version installiert und die unterscheiden sich in ihrer Ordnerstruktur und inhaltlich nicht voneinander, auch das Installationsprozedere ist identisch.

Die teilten mir z. B.: mit, ich solle nachstehende Anweisungen bitte zeilenweise in einem Terminal-Fenster ausführen.
wget http://fr.archive.ubuntu.com/ubuntu/pool/main/g/gst-plugins-base0.10/libgstreamer-plugins-base0.10-0_0.10.36-1_amd64.deb
wget http://fr.archive.ubuntu.com/ubuntu/pool/universe/g/gstreamer0.10/libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb
sudo dpkg -i libgstreamer*.deb
Das wird dich bei einem installierten 32Bit System auch nicht weiterbringen, siehe:
derzeit aktuellen BS = LMDE 3 "cindy" LXDE gar nicht mehr
System:    Host: volker Kernel: 4.9.0-8-686 i686 (32 bit)

Da du inzwischen etwas anderes installiert hast:
sondern inzwischen das Debian-9-System habe.
und zu 32 oder 64bit keine Angabe machst  :o bin ich bei Debian-9 und oder 32Bit nun Aussen vor und wünsche dir gutes Gelingen.  ;)
« Letzte Änderung: 06.03.2019, 11:24:00 von kuehhe1 »

Wenn diese Software ein 0.10 gstreamer Paket braucht, d.h. das es so in der .deb-Installationsdatei hinterlegt ist, lässt es sich so nicht installieren. Möglichkeiten gibt's immer viele, nicht alle sind benutzerfreundlich.

Ich vermute jetzt mal, dass die Software im Prinzip auch mit den 1.0 Paketen funktionieren würde, nur lässt sie sich wegen der Abhängigkeit nicht installieren.

Du könntest Abhilfe schaffen und mal kurz das Repo von Debian Jessie hinzuschalten, das Programm installieren und im Anschluss das Repo wieder entfernen. Schau dir an, was dann genau passiert. Wenn jetzt alle gstreamer1.0 Bibliotheken zugunsten der alten 0.10 Versionen entfernt werden ist das keine gute Idee. Können sie parallel existieren, ist dein Problem gelöst. Teste so etwas immer zuerst in einer Live-Umgebung.

Die zweite Möglichkeit wäre, das Debian-Paket zu öffnen. In der debian/control Datei kannst du dann die Abhängigkeiten ändern und du kannst es dann wieder einpacken.

Das gestaltet sich in der Praxis öfter mal schwierig, aber gemacht hab ich es schon. Manchmal werden auch heute bei Programmen unsinnige Abhängigkeiten mitgezogen, weil das vor Jahren vielleicht mal erforderlich war und das was sinnvoll ist, kommt nicht automatisch mit. Hier sieht man dann auch wie gut ein Maintainer seine Pakete pflegt.
« Letzte Änderung: 06.03.2019, 11:20:44 von dphn »

@ kuehhe1:

ja, bin in der Tat wohl mit meinem LMDE 3 "cindy" LXDE ganz offensichtlich bei Debian-9 "Stretch" und meine hardware ein 32-Bit-System - SORRY; dennoch vielen vielen Dank für dein Engagement und deinen Einsatz !  ;)

ja, bin in der Tat wohl mit meinem LMDE 3 "cindy" LXDE ganz offensichtlich bei Debian-9 "Stretch"
könntest du dich einfach mal klarer ausdrücken was du JETZT installiert hast LMDE 3 "cindy" oder Debian-9
oder zeig einfach inxi -S

volker@volker:~$ inxi -S
System:    Host: volker Kernel: 4.9.0-8-686 i686 (32 bit)
           Desktop: LXDE (Openbox 3.6.1) Distro: LMDE 3 (cindy)
volker@volker:~$

Irgendwie dachte ich - warum auch immer - dass Debian-9 ='Stretch' unweigerlich Bestandteil meines derzeitigen BS' sei  ???

Debian stretch ist die Basis auf der LMDE 3 cindy aufsetzt. Der Unterbau eben. Die Software kommt aus den offiziellen Debian stretch Repos und aus einem Linux Mint Repo. Die Entwickler von Linux Mint erfinden ja das Rad nicht neu. Sie steuern Pakete zur Konfiguration sowie eigene Software bei, die es in dieser Form unter einem reinen Debian System nicht gibt. Es sind also Ergänzungen, die das System leichter zugänglich machen und optisch ansprechend gestalten.

Debian stretch ist die Basis auf der LMDE 3 cindy aufsetzt. Der Unterbau eben. Die Software kommt aus den offiziellen Debian stretch Repos und aus einem Linux Mint Repo.

Ganz genauso eben in diesem Sinne habe ich es doch auch gemeint - dies ist aber wohl zunächst bei kuehhe1 SO !! nicht angekommen:

könntest du dich einfach mal klarer ausdrücken was du JETZT installiert hast LMDE 3 "cindy" oder Debian-9

Da die Saturn Fotosoftware nun installiert ist kannst du dieses Thema ja auf gelöst setzten.
Dazu deinen Ersten Beitrag "Ändern"und das "Präfix" setzen.

Interessanter Verlauf hier:
https://www.cewe-community.com/forum/ch/viewtopic.php?f=2&t=12217
selbst die Windows-User sind da mit dem Grafiktreiber arm dran.
Da hilft auch das versteckte Argument nicht, dass der Entwickler schon 270 Versionen der der Cewe-Fotobuch-Software erstellt habe. Ich nutze nur ältere Versionen und lehne das Update ab, so geht es, auch im Linux. Seit der Version 6.2.1. gibt es da Probleme, ich habe 6.0. und noch was bei mir laufen.
« Letzte Änderung: 22.03.2019, 07:36:13 von berlinerbaer »

Off-Topic:
Gar nicht lustig finde ich immer die Nachfrage des CEWE Support welcher Grafikkarten Treiber installiert sei, Hersteller oder Fenster. Dabei bringt das Fenstersystem doch zu 99% alle Treiber mit und lässt oft Herstellertreiber mangels Certifizierung gar nicht zu. Ich denke mal das Cewe da noch einiges an Hausaufgaben leisten muss.
« Letzte Änderung: 22.03.2019, 15:17:25 von kuehhe1 »