Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
06.04.2020, 10:42:07

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 651533
  • Themen insgesamt: 52744
  • Heute online: 605
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Kernel Upgrade und Docker Probleme  (Gelesen 897 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Kernel Upgrade und Docker Probleme
« am: 22.02.2019, 18:49:45 »
Version Linux Mint 19 Tara 64-bit
Kernel Linux 4.15.0-45-generic x86_64
MATE 1.20.1

Ich habe ursprünglich versucht OpenRave zum Laufen zu bringen,
dies ist mit Linux Mint 19 scheinbar nicht so leicht da
Dieses PPA unterstützt bionic nichtUnd Linux Mint 19 basiert offenbar auf bionic beaver.

OpenRave von Source aufzubauen hat auch nicht funktioniert und endete mit Fehlermeldungen.

Nun die nächste  Strategie war es OpenRave über einen Container von Docker laufen zu lassen.
Ich habe also zwecks Installation folgende Befehle eingegeben:
sudo apt-get remove docker docker-engine docker.io containerd runc
sudo apt-get remove docker-ce docker-ce-cli containerd.io

sudo apt-get install apt-transport-https ca-certificates curl gnupg-agent software-properties-common
curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
sudo add-apt-repository "deb [arch=amd64] https://download.docker.com/linux/ubuntu $(. /etc/os-release; echo "$UBUNTU_CODENAME") stable"

sudo apt-get update

sudo apt-get install docker-ce docker-ce-cli containerd.io

Wenn ich nun
systemctl status dockereingebe erhalte ich folgende Meldungen
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.291290364+01:00" level=warning msg="Your kernel does not support swap memory limit"
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.291420756+01:00" level=warning msg="Your kernel does not support cgroup rt period"
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.291451859+01:00" level=warning msg="Your kernel does not support cgroup rt runtime"
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.293061992+01:00" level=info msg="Loading containers: start."
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.610522375+01:00" level=info msg="Default bridge (docker0) is assigned with an IP address 172.17.0.0/16. Daemon option --bip can be used
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.876799672+01:00" level=info msg="Loading containers: done."
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.977373240+01:00" level=info msg="Docker daemon" commit=6247962 graphdriver(s)=overlay2 version=18.09.2
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.977488846+01:00" level=info msg="Daemon has completed initialization"
Feb 22 16:43:28 Slavs-Lenovo systemd[1]: Started Docker Application Container Engine.
Feb 22 16:43:28 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:28.032400446+01:00" level=info msg="API listen on /var/run/docker.sock"

Nach etwas Recherche, scheint es so, als würde ein aktuellerer Kernel nötig sein, welcher cgroup und swap memory unterstützt.
Ich habe mir also die Anleitung hier angesehen https://www.wikihow.com/Install-and-Upgrade-to-a-New-Kernel-on-Linux-Mint
Aber bevor ich irgendwas am Kernel mache will ich zuvor lieber Rat und ein paar fragen klären.

Wenn ich über die Aktualisierungsverwaltung auf die Kernel Einstellungen gehe sind die Kernel in zwei Gruppen geteilt.
4.15 und 4.18
der neuste 4.15 (4.15.0-45) ist der, der derzeit aktiv ist.
der neuste 4.18 ist 4.18.0-15.

Laut https://www.kernel.org ist der neuste stabile Kernel 4.20.11

Warum werden mir nur Kernels im 4.15 und 4.18 Bereich angezeigt und nicht der Neuste ?
Ist es empfehlenswert immer den neusten stabilen Kernel zu installieren?
Früher dachte ich immer 'Neu ist immer besser', aber seit Linux und vor allem Linux Mint musste ich feststellen,
dass nicht alles 'neu' unterstützt wie z.B. die PPA von OpenRave.

Hat jemand einen Rat oder Hinweise zum Kernel Upgrade oder zum Problem mit Docker oder vielleicht auch OpenRave ??





Re: Kernel Upgrade und Docker Probleme
« Antwort #1 am: 22.02.2019, 19:17:53 »
Laut https://www.kernel.org ist der neuste stabile Kernel 4.20.11

Warum werden mir nur Kernels im 4.15 und 4.18 Bereich angezeigt und nicht der Neuste ?

Die 4.15er und 4.18er sind Distributionskernel die von Ubuntu für Ubuntu und somit auch für Linux Mint gepflegt werden.
Der 4.20.11 ist ein Mainline - Kernel
Für Ubuntu und Linux Mint gibt es da UKUU = Ubuntu Kernel Update Utility  um Mainline - Kernel zu installieren und UKUU informiert auch über neue Kernel.

Installation erfolgt im Terminal:
sudo add-apt-repository ppa:teejee2008/ppasudo apt-get update && sudo apt-get install ukuu
« Letzte Änderung: 22.02.2019, 19:35:14 von tommix »

thebookkeeper

  • aka AnanasDampf
  • *****
Re: Kernel Upgrade und Docker Probleme
« Antwort #2 am: 22.02.2019, 20:10:02 »
Zitat
Dieses PPA unterstützt bionic nicht ...
Und Linux Mint 19 basiert offenbar auf bionic beaver ...
Mit einfachen Worten, Linux Mint 19 und bionic beaver sind neu/aktuell, aber Openrave bzw. Openrave-PPA ist veraltet.
https://launchpad.net/~openrave/+archive/ubuntu/release



Evtl. funktioniert noch die Fork-Version für xenial
https://launchpad.net/~wjwwood/+archive/ubuntu/openrave-fork
Oder Wine installieren und Openrave-Windows-Version von hier => https://sourceforge.net/projects/openrave/files/latest_stable/
« Letzte Änderung: 22.02.2019, 20:35:07 von thebookkeeper »

Re: Kernel Upgrade und Docker Probleme
« Antwort #3 am: 24.02.2019, 11:25:43 »
Moin,
Der 4.20.11 ist ein Mainline - Kernel
bedingt durch mein Hardware-Problem auf HP Probook 470 wurde mir auf: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1811254
eine Lösung für mein hier diskutiertes Thema: https://www.linuxmintusers.de/index.php?topic=51737.msg729721#msg729721
mit dem Kernel 4.19.0-13.14 und neuerdings 4.20 angeboten. Aktuell hatte ich mit ukuu den bereinigten Kernel 4.20.11 und gerade auf Kernel 4.20.12 aktualisiert.

Wenn ich das hier und in anderen Themen richtig gelesen habe, kann ich aber für diesen Mainline-Kernel 4.20 kein ppa hinzufügen, damit Updates über die Aktualisierungsverwaltung angezeigt und eingespielt werden könnten, muss also weiterhin mit ukuu Upgraden?

kuehhe1@HP470:~$ inxi -S
System:    Host: HP470 Kernel: 4.20.12-042012-generic x86_64 bits: 64 Desktop: Cinnamon 4.0.9 Distro: Linux Mint 19.1 Tessa
kuehhe1@HP470:~$ dpkg -l ukuu* | egrep '^ii '
ii  ukuu           18.9.3-0~201902031503~ubuntu18.04.1 amd64        Kernel Update Utility for Ubuntu-based distributions



« Letzte Änderung: 02.03.2019, 12:20:02 von kuehhe1 »

Re: Kernel Upgrade und Docker Probleme
« Antwort #4 am: 24.02.2019, 11:35:20 »
muss also weiterhin mit ukuu Upgraden?

Ja, Ukuu meldet sich aber je nach Einstellung wird alle 3 Stunden (Standart) geschaut, ob ein neuer Mainline-Kernel vorhanden ist.
« Letzte Änderung: 24.02.2019, 11:42:22 von tommix »

Re: Kernel Upgrade und Docker Probleme
« Antwort #5 am: 24.02.2019, 11:42:52 »
Edit:  ;D ;D

Re: Kernel Upgrade und Docker Probleme
« Antwort #6 am: 24.02.2019, 11:56:24 »
ok, und bisher hat sich ukuu auch zuverlässig gemeldet. ;)
Edit:Hat sich gerade überschnitten, aber Danke trotzdem.
Habs so eingestellt.
ukuu Settings
ukuu Settings

Und mit Timeshift hab ich Überblick
Timeshift Stand 24 02 2019
Timeshift Stand 24 02 2019

« Letzte Änderung: 24.02.2019, 12:08:36 von kuehhe1 »

Re: Kernel Upgrade und Docker Probleme
« Antwort #7 am: 25.02.2019, 11:50:59 »
Also nur um nochmal den Fokus auf mein Problem zu legen.
Ich habe meinen Kernel auf die aktuellste Version gebracht (4.20.12)
die Fehlermeldungen haben sich allerdings nicht verändert.
Docker meldet weiterhin:
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.291290364+01:00" level=warning msg="Your kernel does not support swap memory limit"
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.291420756+01:00" level=warning msg="Your kernel does not support cgroup rt period"
Feb 22 16:43:27 Slavs-Lenovo dockerd[5910]: time="2019-02-22T16:43:27.291451859+01:00" level=warning msg="Your kernel does not support cgroup rt runtime