Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
23.03.2019, 16:10:57

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21725
  • Letzte: mel1203
Statistiken
  • Beiträge insgesamt: 580850
  • Themen insgesamt: 47031
  • Heute online: 585
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [erledigt] WLAN wird nicht erkannt bzw deaktiviert  (Gelesen 884 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

odbThreadstarter

  • **
[erledigt] WLAN wird nicht erkannt bzw deaktiviert
« am: 18.02.2019, 10:45:10 »
Hallo zusammen
Ich habe auf dem HP Mini meiner Frau das Linux Mint 19.1 xfce installiert.
War auch alles ok soweit, bis ich eben nach längerer Zeit das HP wieder angemacht habe, um neue updates aufzuspielen. Dabei ist mir aufgefallen, dass das WLAN/Router zwar erkannt aber nicht angenommen wird. Heißt, das Anmeldefenster öffnet sich um das WLAN Passwort einzugeben, doch Nach Bestätigung poppt es trotzdem immer wieder auf. Habe mal die Verbindung getrennt, gelöscht, neu konfiguriert - keine Chance. Per LAN funktioniert alles einwandfrei.
Ich hoffe, ihr habt ne Lösung.
Vielen Dank

Ein paar Daten
System:
  Host: stephie-admin Kernel: 4.15.0-45-generic x86_64 bits: 64
  Desktop: Xfce 4.12.3 Distro: Linux Mint 19.1 Tessa
Machine:
  Type: Laptop System: Hewlett-Packard product: HP Mini 210-2000
  v: 0590100000202B00000300100 serial: <filter>
  Mobo: Hewlett-Packard model: 1584 v: 85.20 serial: <filter>
  BIOS: Hewlett-Packard v: F.02 date: 08/09/2010
Battery:
  ID-1: BAT0 charge: 20.3 Wh condition: 65.5/65.5 Wh (100%)
CPU:
  Topology: Single Core model: Intel Atom N455 bits: 64 type: MT
  L2 cache: 512 KiB
  Speed: 998 MHz min/max: 1000/1666 MHz Core speeds (MHz): 1: 1183 2: 1213
Graphics:
  Device-1: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics
  driver: i915 v: kernel
  Display: x11 server: X.Org 1.19.6 driver: intel
  unloaded: fbdev,modesetting,vesa resolution: 1024x600~60Hz
  OpenGL: renderer: Mesa DRI Intel Pineview M v: 1.4 Mesa 18.2.2
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.0-45-generic
Network:
  Device-1: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter
  driver: wl
  IF: wlp1s0 state: dormant mac: <filter>
  Device-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet
  driver: r8169
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 111.79 GiB used: 7.75 GiB (6.9%)
  ID-1: /dev/sda vendor: Crucial model: CT120BX500SSD1 size: 111.79 GiB
Partition:
  ID-1: / size: 109.53 GiB used: 7.75 GiB (7.1%) fs: ext4 dev: /dev/sda1
Sensors:
  System Temperatures: cpu: 43.0 C mobo: 23.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 154 Uptime: 28m Memory: 1.94 GiB used: 627.6 MiB (31.7%)
  Shell: bash inxi: 3.0.27
« Letzte Änderung: 22.02.2019, 10:16:40 von odb »

odbThreadstarter

  • **
Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #1 am: 18.02.2019, 11:48:16 »
So, denke das Problem ist gelöst.
Habe alle WLAN Einstellungen zurückgesetzt bzw gelöscht und nur den LAN Anschluss aktiviert gelassen. In der Treiberverwaltung auf "dieses Gerät nicht verwenden" gewchselt, systemneustart, dann eine komplett neue wlan verbindung konfiguriert, systemneustart, anschließend in die treiberverwaltung rein und wieder zurück auf "dieses gerät verwenden".
nach mehreren neustarts verbindet sich der pc bzw bleibt mit dem router verbunden.
ich hoffe, es bleibt dabei.
schönen tach

odbThreadstarter

  • **
Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #2 am: 18.02.2019, 22:09:56 »
Nabend, ich nochmal.
Leider zu früh gefreut, denn jetzt ca 10 Std später habe ich das selbe Problem erneut. Keine WLAN Verbindung möglich. Jetzt muss ich passen.  Ist die xfce Version evtl nicht kompatibel mit der Hardware? Freue mich über Hilfe
Danke

Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #3 am: 19.02.2019, 06:11:29 »
Hallo,
der Treiber unterstützt nur die Funkkanäle 1-11, da die Systeminterne Regionseinstellung über iw nicht funktioniert (kein Full-MAC Treiber, unterstützt wird nur cfg80211). Der eigene WLAN-Router muss also entsprechend fest auf einen günstigen Kanal zwischen 1+11 eingestellt sein (keine aut. Kanalwahl)!

odbThreadstarter

  • **
Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #4 am: 20.02.2019, 09:53:56 »
Hi Flash63
Ich werde es mal probierten und später berichten. ich danke dir schonmal

odbThreadstarter

  • **
Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #5 am: 20.02.2019, 10:21:44 »
Es hat leider nicht funktioniert, keine Ahnung warum. Habe im Router manuell einen Kanal eingestellt und alles neu gestartet. Am HP wird mir als Hinweis das Netzwerk eingeblendet, welches gefunden wurde, doch wenn ich es auswähle und den NEtzwerkschlüssel eingebe passiert nichts. Es poppt nur immer wieder das Fenster zur Passworteingabe auf. In der Taskleiste erscheint auch nicht das typische Wlan-Symbol sonder nur ein kleiner Kreis.

Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #6 am: 20.02.2019, 10:40:59 »
Hallo,
dann funktioniert WLAN grundsätzlich, aber die Verbindungsaufnahme scheitert.
* Verschlüsselung des Routers auf rein WPA2-AES (CCMP) einstellen, kein Mischmodus mit TKIP verwenden
* Kennwort in den Einstellungen des Network-Manager überprüfen und ggf. korrigieren (Verbindungsprofil editieren):
sudo -H nm-connection-editor... oder über Mausklick auf das Icon im Panel „Verbindungen bearbeiten

odbThreadstarter

  • **
Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #7 am: 20.02.2019, 11:03:27 »
Hi
Im Router ist alles korrekt eingestellt. Eben habe ich nochmal das Profil am HP gelöscht und das system neu gestartet. Komischerweise hat das das HP direkt mit dem WLan verbunden ohne das ich ein passwort eingeben musste. schon seltsam, aber nach 3 neustarts ist das wlan immer noch verbunden. ich raff nix mehr. muss ich in der netzwerk-konfig was wichtiges ändern.
z.b. Alle benutzer dürfen das netzwerk verwenden oder was in den ip4 oder ip6 einstellungen?

Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #8 am: 20.02.2019, 11:27:26 »
Ok, mit Verbindung können wir ja nun ein paar Einstellungen überprüfen.
* IPv6 kann mann normalerweise auf „Ignorieren“ setzen.
* „Alle Benutzer dürfen das Netzwerk verwenden“ wenn eben weitere Benutzer ohne Netzwerk-Konfigurationsberechtigung existieren

Verbindungsprofile, Konfiguration und Umgebungsscan abfragen:
iwconfig
ifconfig -a
route -n
nmcli -f NAME,TYPE,AUTOCONNECT,ACTIVE,DEVICE con
cat /etc/NetworkManager/NetworkManager.conf
ls -l /etc/resolv.conf
lsmod | egrep 'brcm|b43|wl|cfg80|hp|ac|as'
sudo iwlist wlp1s0 scan | egrep -i 'cell|chan|essid|wpa|cipher|qual'

odbThreadstarter

  • **
Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #9 am: 20.02.2019, 14:06:57 »
Im Moment noch alles stabil. Hat das auch vielleicht etwas mit der xcfe Version zu tun oder hätte ich mit cinnamon oder Mate das gleiche Problem. Habe auf einem uralten Laptop Ubuntu 12.04LTS drauf und der lief immer per WLAN ohne Probleme, egal ob Autokanal Oder nicht.

Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #10 am: 20.02.2019, 17:00:39 »
Du möchtest die Einstellungen also nicht überprüfen und das Problem mit der Kanalbeschränkung ggf. nicht beseitigen? Dann markiere den Beitrag hier noch als gelöst.
Zitat
Habe auf einem uralten Laptop Ubuntu 12.04LTS drauf und der lief immer per WLAN ohne Probleme, egal ob Autokanal Oder nicht.
Dann benutze den doch einfach  ;)

odbThreadstarter

  • **
Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #11 am: 20.02.2019, 22:04:40 »
hi flash63
sorry, das wollte ich damit nicht sagen. natürlich würde ich gerne das problem lösen. im moment hab ich im router einen festen kanal eingestellt. im wlan konfigmenü von linux habe ich dann die bandfrequenz von auto auf 2,4ghz gestellt und bei kanal steht jetzt "vorgabe". damit läufts, seltsam ist nur, das es anfangs problemlos lief ohne was am router oder unter linux verändern musste.
die terminal eingaben kommen
danke
« Letzte Änderung: 21.02.2019, 11:41:31 von odb »

odbThreadstarter

  • **
Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #12 am: 20.02.2019, 22:12:32 »
so, hab mir die befehle mal ins terminal kopiert. da sind ganz schön viele pers. daten dabei. die möchte ich nicht alle hier eintragen. kann man das irgendwie eingrenzen?

Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #13 am: 21.02.2019, 07:37:35 »
Wo meinst Du denn, dass personenbezogene Daten abgefragt werden?

Re: WLAN wird nicht erkannt bzw deaktiviert
« Antwort #14 am: 21.02.2019, 11:15:58 »
...möglicherweise OT......

Dass es bei Distribution "A" klappt und bei "B" nicht auf einem anderen Gerät, hängt nicht zwingend an der Distribution - sondern sehr oft an unterschiedlicher verbauter Hardware. Die Treiber sind ja i.d.R. im Kernel drin (hier gibt es wieder Unterschiede je nach Distribution, was individuell mitgebracht wird .... 4.4x .... 4.9x .... 4.15 etc.).

Manchmal läuft WLAN-Hardware direkt - manchmal muss aber auch extern noch ein Treiber eingebunden werden, was mehr oder weniger aufwändig ist.

Um schlussendlich den Grund abzuklären, sind @Flash63´s Empfehlungen einfach richtig .... er ist sozusagen der WLAN-Gott!
:-)

« Letzte Änderung: 21.02.2019, 12:35:15 von Michelle_Br »