Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.08.2019, 15:51:45

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22409
  • Letzte: pecomit
Statistiken
  • Beiträge insgesamt: 604058
  • Themen insgesamt: 48915
  • Heute online: 692
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  kein Gigabit mit BCM5755 in Dell Notebook  (Gelesen 1294 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #15 am: 30.01.2019, 20:00:14 »
keine Änderung

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #16 am: 30.01.2019, 20:20:41 »
Tja, was nun?
Du kannst höchsten noch versuchen Gigabit zu erzwingen und die automatik zu deaktivieren.
sudo ethtool -s  enp9s0 speed 1000 autoneg offMehr fällt mir gerade nicht mehr ein.

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #17 am: 31.01.2019, 09:14:52 »
~ $ sudo ethtool -s  enp9s0 speed 1000 autoneg off
Cannot set new settings: Invalid argument
  not setting speed
  not setting autoneg

Ich glaube das hatte ich auch schon mal versucht.
Bevor ich hier gefragt habe, habe ich alles was ich so zusammen googlen konnte schon durch.

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #18 am: 31.01.2019, 18:04:08 »
BIOS zurückgesetzt, alles nochmal überprüft, nichts gefunden.

Speed hart auf 1000 setzen führt dazu das ich keine Verbindung mehr habe.

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #19 am: 31.01.2019, 19:40:04 »
debian live cd gebootet, auch nur 100

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #20 am: 01.02.2019, 09:16:54 »
Hallo,
frage doch zunächst einmal ab
sudo ethtool enp9s0
cat /var/log/syslog | egrep -i 'tg3|tigon|firm|err|fail'

Wie sieht die Netzwerkinfrastruktur aus (Rechner  direkt am Router oder über Switch)?
Was für ein Router/Switch wird verwendet?
Powermanagement am Switch/Router für den entsprechenden Ethernetport ist deaktiviert?
Port am Router/Switch wechseln.

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #21 am: 01.02.2019, 10:34:22 »
Feb  1 08:12:31 bittermint kernel: [    1.800525] tg3 0000:09:00.0 eth0: Tigon3 [partno(BCM95755m) rev a002] (PCI Express) MAC address 00:1d:09:b4:df:a0
Feb  1 08:12:31 bittermint kernel: [    1.800530] tg3 0000:09:00.0 eth0: attached PHY is 5755 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])
Feb  1 08:12:31 bittermint kernel: [    1.800533] tg3 0000:09:00.0 eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
Feb  1 08:12:31 bittermint kernel: [    1.800536] tg3 0000:09:00.0 eth0: dma_rwctrl[76180000] dma_mask[64-bit]
Feb  1 08:12:31 bittermint kernel: [    1.823491] tg3 0000:09:00.0 enp9s0: renamed from eth0

Das mit dem Switch/Router habe ich weiter oben schon alles durch.
Anderes Kabel, anderer Switch, usw.
Ein anderes Notebook am gleichen Kabel verbindet mit 1000.

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #22 am: 02.02.2019, 09:04:32 »
Ja, allerdings war das nicht eindeutig wann jeweils mit ethtool abgefragt wurde. Du müsstest eindeutig und jeweils einzeln vergleichen wenn direkt an der FB oder dem Switch angeschlossen. Du hast ja auch auch anscheinend mehrere Switches(!?).

Auffällig ist auch, dass zwei verschiedene Gegenstellen unterschiedliche Geschwindigkeiten anbieten:
Advertised link modes:  10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Half 1000baseT/Full
und der direkte Anschlusspartner:
Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                     100baseT/Half 100baseT/Full
Schalte die/den anderen  Switch mal ab, bzw. trenne deren Uplink-Leitung und schließe den Client erneut direkt an die FB an. Zu dem hast Du bisher nicht beantwortet ...
* Typ der FB
* Typ der Switches (managed oder „doof“)
* genauerer Aufbau der Infrastruktur
* Konfiguration DHCP-Server, Gateway und DNS (ist da irgendwo möglicherweise etwas doppelt?)

In aktueller Konfiguration abfragen und wenn nur die FB direkt angeschlossen ist:
sudo ethtool enp9s0
sudo netstat -tulpen | grep -iE '53|dns'
sudo ss -pan 'sport = 53'
arp -a
ifconfig -a
route -n
ip -4 neigh
Einmalig:
cat /etc/NetworkManager/NetworkManager.conf
cat /etc/network/interfaces

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #23 am: 02.02.2019, 12:07:41 »
Ok, topology:

- eine 6490 (mit 1Gbps ports enabled und überprüft)
 - daran hängt das Notebook (am gleichen Kabel, ein anderer PC, läuft mit 1Gbps, getestet)
 - auch an der 6490 ein devolo  DINrail 1200 pro
 - sonst nichts

- an anderen Stellen im Haus jeweils verschiedene devolos
 - im Büro ein devolo 1200+ wifi ac
 - daran ein "doofer" 1Gbps switch
 - daran mehrere Rechner, alle laufen mit 1Gbps
 - über devolo kommen so zwischen 200 und 600 Mbps

- natürlich auch WLAN, (an 2 Stellen über devolo, läuft auch super)

Mir ist jetzt nicht ganz klar was DNS uns alle meine IPs und MACs damit zu tun haben sollen.
Das Notebook verbindet an keinem getesteten port mit 1Gbps, auch nicht wenn es ganz alleine dran hängt.
Das Notebook kann aber 1Gbps unter Windows.

Settings for enp9s0:
Supported ports: [ TP ]
Supported link modes:   10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Half 1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Half 1000baseT/Full
Advertised pause frame use: Symmetric
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                     100baseT/Half 100baseT/Full
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
MDI-X: on
Supports Wake-on: g
Wake-on: g
Current message level: 0x000000ff (255)
       drv probe link timer ifdown ifup rx_err tx_err
Link detected: yes




enp9s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.116  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 fe80::5761:a72f:1ae2:ef85  prefixlen 64  scopeid 0x20<link>
        inet6 2a02:8109:a40:2e80:d906:5d45:b98d:f1ec  prefixlen 64  scopeid 0x0<global>
        ether 00:1d:09:b4:df:a0  txqueuelen 1000  (Ethernet)
        RX packets 37276  bytes 24131986 (24.1 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 16623  bytes 2432473 (2.4 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 982  bytes 224728 (224.7 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 982  bytes 224728 (224.7 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp12s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:1c:bf:9d:50:92  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

« Letzte Änderung: 02.02.2019, 12:40:48 von oppiman »

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #24 am: 02.02.2019, 13:30:10 »
Wenn irgendwann nur Gigabit offeriert wird, keine „partner advertised link modes“, dann könntest Du also mal ein ...
sudo ethtool -s enp9s0 speed 1000 duplex full autoneg on ... versuchen.

Zitat
Mir ist jetzt nicht ganz klar was DNS uns alle meine IPs und MACs damit zu tun haben sollen.
Ich verwende hier neben einer FB als vDSL-Modem/1st NAT und DECT Basis einen nachgeschalteten 10Port Router/Switch & 16 Port managed Switch auf welchem mehrere DHCP/DNS-Server für div, Subnetze, & VLan, ein tansparenter Proxy, Firewall und noch einen Raspi als DNS-Resolver (Pi-Hole) für zwei Teilnetze.

Fehlerursache wäre theoretisch z.B. Gastnetzwerk der FB über Ethernetport 4, welcher Rückwärts über einen der anderen Router/Switches einen Loop erzeugt.

Man kann für jeden Port die Verbindungs- und Übertragungsgeschwindigkeit festlegen (10/100/1000/FD/HD), auch wenn es sich um GBit-Ports handelt, es wird also bei Bedarf gedrosselt. Sollten Fehler auftreten, ist es wichtig zu wissen, welcher DHCP-Server den Client versorgt, an welchem Port dieser angeschlossen ist und welche aktiven Geräte da noch Einfluss nehmen könnten. Ich bin z.B. schon mal an einer Konfiguration fast verzweifelt, weil ich die Beschriftung für zwei Ports vertauscht hatte und die Konfiguration dadurch ebenfalls vertauscht war.

Ganz fix ist da mal ein Häkchen bei der Konfiguration einzelner Geräte nicht oder falsch gesetzt. Der Fehler verschleppt sich ja auch auf ein Live-System, daher sollte man zunächst ausschließen, dass es sich um ein Konfigurationsproblem irgendwo im Netzwerk handelt.

→ also der Problemrechner direkt an die FB  (Port 1 oder 2) und sonst nichts anschließen, wenn das zwischendurch mal möglich ist, ohne andere Netzwerkteilnehmer längere Zeit abzuschalten.

Ansonsten könnte es noch ein Konflikt mit der Gerätefirmware sein, wenn Du das Gerät bei einem Wechsel zwischen Win und Linux nicht über einen gewissen Zeitraum komplett ausschaltest, sonder „nur“ neu startest, da die Firmware dann nicht vollständig entladen wird.
« Letzte Änderung: 02.02.2019, 13:39:43 von Flash63 »

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #25 am: 02.02.2019, 14:12:07 »
Wenn irgendwann nur Gigabit offeriert wird, keine „partner advertised link modes“, dann könntest Du also mal ein ...
sudo ethtool -s enp9s0 speed 1000 duplex full autoneg on ... versuchen.
Hatte ich schon versucht. Dann ist der Link weg.


Zitat
→ also der Problemrechner direkt an die FB  (Port 1 oder 2) und sonst nichts anschließen, wenn das zwischendurch mal möglich ist, ohne andere Netzwerkteilnehmer längere Zeit abzuschalten.
hatte ich auch schon, mehrfach

Zitat
Ansonsten könnte es noch ein Konflikt mit der Gerätefirmware sein, wenn Du das Gerät bei einem Wechsel zwischen Win und Linux nicht über einen gewissen Zeitraum komplett ausschaltest, sonder „nur“ neu startest, da die Firmware dann nicht vollständig entladen wird.
Darüber habe ich schonmal was gelesen. Das Notebook war aber auch schon über Stunden aus und wurde dann mit Mint gebootet.

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #26 am: 02.02.2019, 14:19:23 »
Hatte ich schon versucht. Dann ist der Link weg. Bisher wurde das ja auch immer angeboten, was IMHO nicht normal/Standard ist.
Wenn irgendwann nur Gigabit offeriert wird, keine „partner advertised link modes“, dann könntest Du also mal ein ...

Bedeutet im Umkehrschluss, dass der aktuelle (Verbindungs-)Partner Gigabit nicht unterstützt und die manuelle Umstellung nicht funktionieren kann. Der (Verbindungs-)Partner kann in diesem Fall eigentlich auch nicht die FB sein.

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #27 am: 02.02.2019, 14:51:46 »
Richtig gefolgert.
Aber da ist nur ein Kabel, sichtbar, CAT6, das von Notebook zu Fritzbox geht.
Alles andere ab.
Gleiches Spiel wenn das Notebook nur zusammen mit der devolo 1200+ ac an einem doofen d-link switch hängt.

Alle anderen Geräte am gleichen Kabel, am gleichen Switch getestet, verbinden mit 1Gbps.

Es ist echt verrückt.

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #28 am: 02.02.2019, 15:18:32 »
Ganz anderer Ansatz: BIOS aktualisieren. Windows ist ja noch installiert, sollte also kein Problem sein. Version A17 aus 2013 ist verfügbar (A15 aus 2010 ist installiert)

https://www.dell.com/support/home/de/de/debsdt1/drivers/driversdetails?driverid=4k8t4

Re: kein Gigabit mit BCM5755 in Dell Notebook
« Antwort #29 am: 02.02.2019, 18:47:36 »
Danke, wie konnte ich das übersehen.
Normalerweise schaue ich immer auf das BIOS...
Wird probiert.