Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
16.07.2019, 08:50:48

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22253
  • Letzte: RobinHood
Statistiken
  • Beiträge insgesamt: 598806
  • Themen insgesamt: 48492
  • Heute online: 495
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [erledigt] Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.  (Gelesen 1670 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« am: 14.01.2019, 18:56:18 »
Hallo ich habe folgendes Problem, habe wie beschrieben unter jeglicher distri internetabbrüche, unter Windows allerdings nicht.
und ich wollte ungern wieder auf Windows wechseln, habe dies jetzt nur gemacht um zu schauen ob das problem dort auch vorhanden ist was nicht der fall ist.

Mainboard MSI Krait 970a am3+
angeschlossen per Lan Realtek® 8111E Gigabit LAN


Hoffe jemand hat hier eine idee wie ich das Problem beseitigen kann.
« Letzte Änderung: 18.01.2019, 16:46:24 von Tk1988 »

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #1 am: 14.01.2019, 19:00:46 »
Dann zeig uns doch mal deine Netzwerkkarten mit
inxi -nz(inxi ist nur bei Mint vorinstalliert!)
Ausgabe bitte zur besseren Lesbarkeit als Text im Codeblock zeigen. Dazu die # Taste über dem Textfeld klicken und die Ausgabe zwischen die geklammerten Tags einfügen.

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #2 am: 14.01.2019, 19:03:15 »
Habe jetzt grad wieder Windows drauf wiegesagt um zu schauen ob das problem hier auch auftritt dies tut es aber nicht.
Dies ist das was mir die befehle gestern ausgespuckt haben noch auf mint 19.1

lspci -nnk | grep -i net -A2
05:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
Subsystem: Micro-Star International Co., Ltd. [MSI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1462:7693]
Kernel driver in use: r8169
Kernel modules: r8169

Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Micro-Star MSI driver: r8169 v: 2.3LK-NAPI port: d000
  bus ID: 05:00.0
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>

: enp5s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::e876:91:b059:aada  prefixlen 64  scopeid 0x20<link>
        ether 4c:cc:6a:ae:e7:5c  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 33  bytes 4966 (4.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Lokale Schleife)
        RX packets 767  bytes 50847 (50.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 767  bytes 50847 (50.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Mit Internet : enp5s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.27  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 2a02:8108:1240:3fc8:647e:a165:580e:3549  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::e876:91:b059:aada  prefixlen 64  scopeid 0x20<link>
        inet6 2a02:8108:1240:3fc8:bbbc:474e:62fd:6f15  prefixlen 64  scopeid 0x0<global>
        ether 4c:cc:6a:ae:e7:5c  txqueuelen 1000  (Ethernet)
        RX packets 17777  bytes 17678060 (17.6 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8966  bytes 2984872 (2.9 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Lokale Schleife)
        RX packets 1587  bytes 119664 (119.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1587  bytes 119664 (119.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #3 am: 14.01.2019, 19:12:32 »
Internetabbrüche per LAN ist eher selten. ;)
Zu 99,9% haben die Leute hier mit so einem Problem WLAN...
Kabelwackler sollten allerdings auch bei Win auftreten, insofern bin ich überfragt.

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #4 am: 14.01.2019, 19:17:23 »
Kann das evtl was mit den treibern zu tun haben? das der da nicht so ganz mitspielt?

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #5 am: 14.01.2019, 19:27:09 »
Die Vermutung liegt zumindest nahe. Neuerer Kernel bringt evtl. besseren Treiber mit?!?

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #6 am: 14.01.2019, 19:29:35 »
ich hatte zuletzt den 4.15  oder höher weiß nicht mehr genau aber er war über 4.15 kernel da ging es dann 1 tag dann war wieder ärger, aber kann es sein das man am besten den herstellertreiber für solch komponenten verwendet?

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #7 am: 14.01.2019, 19:34:48 »
Einen "Herstellertreiber" wirst du nicht bekommen, der kümmert sich nicht um Linux. Der einzige Treiber, der existiert, ist im Kernel. ;)

Du kannst bei Mint 19.1 den Kernel 4.18 installieren, das ist der derzeit aktuellste für Mint erhältliche.

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #8 am: 14.01.2019, 19:48:04 »
also leztzten endes muss es an linux liegen, da unter windows keinerlei probleme. zuletzt war es so das nach 15 min das internet schon weg war also ein abbruch kam, ich dann neustarten musste bzw herrunter fahren damit er sich wieder verbinden konnte.

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #9 am: 14.01.2019, 19:52:30 »
Wie gesagt: neuere Kernel testen. Ansonsten hat unser Profi flash63 vllt. noch eine Idee...

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #10 am: 14.01.2019, 19:57:03 »
wäre ja optimal wenns dann klappt,alle 15 min den pc neustarten ist auch uncool vorallem wenn man grad am zocken ist^^

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #11 am: 15.01.2019, 09:42:10 »
Wurde DHCP oder eine feste IP im Router zugeordnet?
Wurden im Router Ports reserviert?
Wobei wenns unter Windows funktioniert scheiden die oberen Verdächtigen eigentlich aus.
Du könntest aber die Windows Netzwerk-Einstellungen (IPv4/IPv6) kontollieren und vergleichen.

Eine andere Möglichkeit wäre das in der Ethernet-Netzwerkeinstellung IPv6 deaktiviert wurde, da gehen zwar die Meinungen auseinander aber diverse Berichte zeigen das es unvorteilhaft ist nur mit IPv4 zu verbinden, also versuchen auch IPv6 zu aktivieren.
Sind die Netzwerkabbrüche regelmäßig also immer gleiche Zeitabstände?

zuletzt war es so das nach 15 min das internet schon weg war also ein abbruch kam, ich dann neustarten musste bzw herrunter fahren damit er sich wieder verbinden konnte.
dann versuch doch beim nächsten Abbruch das Netzwerk neu zu starten:
systemctl restart network-managerder Befehl erfordert das root-Kennwort, danach trennt der Netzwerk-Manager alle Geräte und Verbindungen und stellt sie anschließend wieder her.

Ansonsten hat unser Profi flash63 vllt. noch eine Idee...
;)
« Letzte Änderung: 15.01.2019, 11:15:18 von kuehhe1 »

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #12 am: 15.01.2019, 11:17:32 »
... mal so ins Blaue orakelt......

Meint Ihr wirklich, dass eine Lan-Verbindung Treiberprobleme hat? Ich meine, ausschließen kann man das nie - aber mal zur Anamnese.....

- steht nach einem Neustart die Verbindung immer stabil und bricht erst nach den 15min laufend wieder ab?
- hast Du mal getestet, ob nach einem Neustart bei bestehender Verbindung ein Wackeln am Kabel (sowohl am Router als auch am PC!) einen Verbindungsabbruch provozieren läßt?
- Hast Du mal geschaut, ob ggfs. die Netzwerkbuchse verdreckt sein könnte ... Staubflusen o.ä.
- Dass das Kabel einen weg hat, ist wohl eher unwahrscheinlich, wenn es fest verlegt ist, oder? Frei rumlaufende Haustiere gibt es nicht, oder?

Ich weiß - alles nur rumgestochere, aber mich verwirrt, dass ca. 15min die Verbindung besteht?!

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #13 am: 15.01.2019, 13:59:32 »
Willst du die IPv4/IPv6 Problematik ausschließen, dann lass folgende Befehle jeweils im eigenen Terminal ausführen und warte auf den Internetabbruch.

ping4 google.deping6 google.de
Kackt eines der beiden ab, während das andere frisch fröhlich weiter lläuft, dann hast du da höchstwarscheinlich ein Problem.

Machen beide gleichzeitig die Grätsche (also mit der maximalen differenz von ca. 5sek), dann liegts NICHT an der IPv6.

BTW: Würde mich auch sehr wundern, wenn es an IPv4/IPv6 liegt.

Du hast noch nix zu deiner Infrastruktur (LAN) gesagt. Hast du evtl. ne Fritzbox und den Port, wo dein Rechner dran hängt noch im "green" Mode?

Re: Unter Linux (Mint,Manjaro,Ubuntu) internetabbrüche.
« Antwort #14 am: 16.01.2019, 16:08:48 »
Sry für die Späte Antwort ,Also das Internet Neustarten habe ich diverse male gemacht, es wird eine aktive Verbindung angezeigt aber es kommt halt nichts durch und dann wird mir angezeigt verbindung verloren bzw keine verbindung vorhanden..
Wenn ich neustarte ist es ab und an direkt wieder da aber nicht immer, dann muss ich noch 1-2 weitere male neustarten.
Es ist nicht immer nur 15 min, mal ne halbe std mal ne std mal ein tag, Meine frau sitzt dann meist neben mir mit ihrem Laptop auch per LAN mit Windows 10,
und da läuft es ohne Probleme, jetzt auf Windows 10 bei mir auch kein einziger Ausfall.

IPV4 und 6 sind Aktiv, habe es mit als auch ohne IPV6 probiert, keine Besserung.habe eine Fritzbox,
Kabel 6490, Alle Ports sind nicht auf Greenmode da ich ein 1gbit Heimnetzwerk habe zwecks Streaming von Games uvm.
Habe auch herausgefunden das im Live Systenm linux mint 19.1 der r8169 zum tragen kommt, da scheint das internet nicht abzubrechen,
 im normalbetrieb haut der mir aber noch den r8168 drauf neben den r8169. Kann das damit evtl zusammenhängen?
Und inwiefern meinst du wenn ich diese beiden anpinge und einer aufgibt ich ein problem habe?
« Letzte Änderung: 16.01.2019, 16:14:27 von Tk1988 »