Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.06.2019, 18:22:30

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22182
  • Letzte: dave_4k
Statistiken
  • Beiträge insgesamt: 595537
  • Themen insgesamt: 48252
  • Heute online: 609
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  Pause beim Bootvorgang  (Gelesen 433 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Pause beim Bootvorgang
« am: 10.01.2019, 14:16:57 »
Hallo!

Ich habe mir einen neuen PC gebaut (ct-Bauvorschlag Ryzen) und Linux Mint Cinnamon 19.1 installiert. So weit, so gut. Doch trotz SSD dauert der Bootvorgang sehr lange. Nach dem BIOS-Bildschirm bleibt der Monitor erst einmal einige Zeit schwarz, bis das Mint-Logo erscheint.

In den Logfiles habe ich entdeckt, dass es eine Pause von über 30 Sek. gibt.
Hier mal ein Ausschnitt aus dmesg

[    1.860549] usbcore: registered new interface driver usb-storage
[    1.861327] usbcore: registered new interface driver uas
[    2.148396] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    2.148726] ata2.00: supports DRM functions and may not be fully accessible
[    2.149634] ata2.00: ATA-11: Samsung SSD 860 EVO 1TB, RVT02B6Q, max UDMA/133
[    2.149635] ata2.00: 1953525168 sectors, multi 1: LBA48 NCQ (depth 32), AA
[    2.151894] ata2.00: supports DRM functions and may not be fully accessible
[    2.154573] ata2.00: configured for UDMA/133
[    2.154919] scsi 1:0:0:0: Direct-Access     ATA      Samsung SSD 860  2B6Q PQ: 0 ANSI: 5
[    2.155041] ata2.00: Enabling discard_zeroes_data
[    2.155072] sd 1:0:0:0: Attached scsi generic sg0 type 0
[    2.155084] sd 1:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
[    2.155091] sd 1:0:0:0: [sda] Write Protect is off
[    2.155092] sd 1:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    2.155103] sd 1:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    2.155207] ata2.00: Enabling discard_zeroes_data
[    2.156214]  sda: sda1 sda2
[    2.156321] ata2.00: Enabling discard_zeroes_data
[    2.157425] sd 1:0:0:0: [sda] supports TCG Opal
[    2.157426] sd 1:0:0:0: [sda] Attached SCSI disk
[    2.471976] ata3: SATA link down (SStatus 0 SControl 300)
[    2.877391] scsi 10:0:0:0: Direct-Access     Generic  MassStorageClass 1209 PQ: 0 ANSI: 6
[    2.877956] scsi 10:0:0:1: Direct-Access     Generic  MassStorageClass 1209 PQ: 0 ANSI: 6
[    2.878616] scsi 10:0:0:2: Direct-Access     Generic  MassStorageClass 1209 PQ: 0 ANSI: 6
[    2.879347] scsi 10:0:0:3: Direct-Access     Generic  MassStorageClass 1209 PQ: 0 ANSI: 6
[    2.880156] scsi 10:0:0:4: Direct-Access     Generic  MassStorageClass 1209 PQ: 0 ANSI: 6
[    2.880335] sd 10:0:0:0: Attached scsi generic sg1 type 0
[    2.880423] sd 10:0:0:1: Attached scsi generic sg2 type 0
[    2.880495] sd 10:0:0:2: Attached scsi generic sg3 type 0
[    2.880582] sd 10:0:0:3: Attached scsi generic sg4 type 0
[    2.880660] sd 10:0:0:4: Attached scsi generic sg5 type 0
[    2.885491] sd 10:0:0:0: [sdb] Attached SCSI removable disk
[    2.885780] random: fast init done
[    2.886039] sd 10:0:0:1: [sdc] Attached SCSI removable disk
[    2.886738] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[    2.886743] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[    2.886750] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[    2.926564] sd 10:0:0:3: [sde] Attached SCSI removable disk
[    2.928531] sd 10:0:0:2: [sdd] Attached SCSI removable disk
[    2.929207] sd 10:0:0:4: [sdf] Attached SCSI removable disk
[    2.952033] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    2.953960] ata4.00: ATAPI: ASUS    BC-12D2HT, 1.00, max UDMA/100
[    2.958591] ata4.00: configured for UDMA/100
[    2.965278] scsi 3:0:0:0: CD-ROM            ASUS     BC-12D2HT        1.00 PQ: 0 ANSI: 5
[    3.014083] sr 3:0:0:0: [sr0] scsi3-mmc drive: 1x/1x writer dvd-ram cd/rw xa/form2 cdda tray
[    3.014084] cdrom: Uniform CD-ROM driver Revision: 3.20
[    3.014180] sr 3:0:0:0: Attached scsi CD-ROM sr0
[    3.014215] sr 3:0:0:0: Attached scsi generic sg6 type 5
[    3.329114] ata5: SATA link down (SStatus 0 SControl 330)
[    3.804413] ata6: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    3.806294] ata6.00: ATA-9: WDC WD30EFRX-68AX9N0, 80.00A80, max UDMA/133
[    3.806296] ata6.00: 5860533168 sectors, multi 16: LBA48 NCQ (depth 32), AA
[    3.806831] ata6.00: configured for UDMA/133
[    3.807527] scsi 5:0:0:0: Direct-Access     ATA      WDC WD30EFRX-68A 0A80 PQ: 0 ANSI: 5
[    3.807878] sd 5:0:0:0: Attached scsi generic sg7 type 0
[    3.807922] sd 5:0:0:0: [sdg] 5860533168 512-byte logical blocks: (3.00 TB/2.73 TiB)
[    3.807923] sd 5:0:0:0: [sdg] 4096-byte physical blocks
[    3.807931] sd 5:0:0:0: [sdg] Write Protect is off
[    3.807932] sd 5:0:0:0: [sdg] Mode Sense: 00 3a 00 00
[    3.807948] sd 5:0:0:0: [sdg] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    3.865502]  sdg: sdg1
[    3.865790] sd 5:0:0:0: [sdg] Attached SCSI disk
[    4.120376] ata7: SATA link down (SStatus 0 SControl 330)
[    4.434691] ata8: SATA link down (SStatus 0 SControl 330)
[    6.136009] raid6: sse2x1   gen()  9349 MB/s
[    6.184006] raid6: sse2x1   xor()  8772 MB/s
[    6.232005] raid6: sse2x2   gen() 18473 MB/s
[    6.280005] raid6: sse2x2   xor() 11944 MB/s
[    6.328003] raid6: sse2x4   gen() 18995 MB/s
[    6.376005] raid6: sse2x4   xor() 10326 MB/s
[    6.424006] raid6: avx2x1   gen() 21316 MB/s
[    6.472005] raid6: avx2x1   xor() 15720 MB/s
[    6.520004] raid6: avx2x2   gen() 28417 MB/s
[    6.568005] raid6: avx2x2   xor() 17172 MB/s
[    6.616005] raid6: avx2x4   gen() 29057 MB/s
[    6.664004] raid6: avx2x4   xor() 14024 MB/s
[    6.664005] raid6: using algorithm avx2x4 gen() 29057 MB/s
[    6.664005] raid6: .... xor() 14024 MB/s, rmw enabled
[    6.664005] raid6: using avx2x2 recovery algorithm
[    6.666152] xor: automatically using best checksumming function   avx
[    6.676884] Btrfs loaded, crc32c=crc32c-intel
[   38.950262] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[   39.102812] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[   39.124653] systemd[1]: Detected architecture x86-64.
[   39.134786] systemd[1]: Set hostname to <Ryzen>.
[   39.201387] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[   39.201635] systemd[1]: Set up automount Arbitrary Executable File Formats File System Automount Point.
[   39.201644] systemd[1]: Reached target User and Group Name Lookups.
[   39.201738] systemd[1]: Created slice System Slice.
[   39.201816] systemd[1]: Created slice system-postgresql.slice.
[   39.201858] systemd[1]: Listening on /dev/initctl Compatibility Named Pipe.
[   39.201902] systemd[1]: Listening on Journal Socket.
[   39.207112] random: crng init done
[   39.207114] random: 7 urandom warning(s) missed due to ratelimiting
[   39.214587] lp: driver loaded but no devices found
[   39.215700] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro
[   39.217438] RPC: Registered named UNIX socket transport module.
[   39.217439] RPC: Registered udp transport module.
[   39.217439] RPC: Registered tcp transport module.
[   39.217439] RPC: Registered tcp NFSv4.1 backchannel transport module.
[   39.217587] ppdev: user-space parallel port driver
[   39.254828] systemd-journald[548]: Received request to flush runtime journal from PID 1
[   39.259833] Adding 2097148k swap on /swapfile.  Priority:-2 extents:6 across:2260988k SSFS
[   39.306878] wmi_bus wmi_bus-PNP0C14:01: WQAA data block query control method not found
[   39.333183] ccp 0000:0a:00.2: enabling device (0000 -> 0002)
[   39.334256] ccp 0000:0a:00.2: ccp enabled
[   39.334322] ccp 0000:0a:00.2: enabled
[   39.336639] ipmi message handler version 39.2
[   39.337538] ipmi device interface
[   39.391158] cryptd: max_cpu_qlen set to 1000
[   39.396077] AVX2 version of gcm_enc/dec engaged.
[   39.396079] AES CTR mode by8 optimization enabled
[   39.405387] snd_hda_intel 0000:09:00.1: Disabling MSI
[   39.405394] snd_hda_intel 0000:09:00.1: Handle vga_switcheroo audio client
[   39.405497] snd_hda_intel 0000:0b:00.3: enabling device (0000 -> 0002)
[   39.423748] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC1220: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line
[   39.423750] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   39.423751] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   39.423752] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[   39.423753] snd_hda_codec_realtek hdaudioC1D0:    dig-out=0x1e/0x0
[   39.423753] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[   39.423755] snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
[   39.423756] snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
[   39.423756] snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a
[   39.518880] PKCS#7 signature not signed with a trusted key
[   39.518892] nvidia: loading out-of-tree module taints kernel.
[   39.518898] nvidia: module license 'NVIDIA' taints kernel.
[   39.518899] Disabling lock debugging due to kernel taint
[   39.528217] nvidia: module verification failed: signature and/or required key missing - tainting kernel

Hat jemand eine Idee, wo dran das liegt; und besser wie ich das beseitige?

küstenjung
« Letzte Änderung: 11.01.2019, 12:06:54 von küstenjung »

Re: Pause beim Bootvorgang
« Antwort #1 am: 10.01.2019, 14:31:14 »
Willkommen küstenjung!

Falls du kein Btrfs nutzt, könnte eventuell das Entfernen dieser btrfs-Pakete
sudo apt-get purge btrfs-tools btrfs-progshelfen, bei mir hat es was gebracht.
« Letzte Änderung: 10.01.2019, 14:42:39 von helli »


Re: Pause beim Bootvorgang
« Antwort #3 am: 10.01.2019, 21:45:15 »
Falls du kein Btrfs nutzt, könnte eventuell das Entfernen dieser btrfs-Pakete
sudo apt-get purge btrfs-tools btrfs-progshelfen, bei mir hat es was gebracht.

Habe ich entfernt, hat leider nichts gebracht.

Re: Pause beim Bootvorgang
« Antwort #4 am: 10.01.2019, 21:56:36 »
https://github.com/linuxmint/linuxmint/issues/33

Ich hatte vorher keine Swap-Partition, nur eine 2 GB große Swapdatei (32 GB RAM).
Ich habe eine Swap-Partition (40 GB) eingerichtet und in /etc/fstab eingebunden (per UUID).
Diese UUID habe ich in /etc/initramfs-tools/conf.d/resume eingetragen
Dann habe ich /usr/share/initramfs-tools/scripts/local-premount/resume gelöscht und update-initramfs -ukall ausgeführt.

Ich habe nicht genau verstanden, ob alle diese Schritte notwendig waren und vor allem was der letzte Schritt bewirkt, aber jetzt fluscht es.  ;D

Habe ich denn bei der Installation irgend etwas falsch gemacht? Normal kann dieses Verhalten doch nicht sein.

küstenjung

Linux_4_Ever

  • Gast
Re: Pause beim Bootvorgang
« Antwort #5 am: 11.01.2019, 00:20:06 »
Unter 19.1 brauchst Du keine SWAP-Partition (bei 32GB sowieso nicht).
Bei der Installation wird eine SWAP-Datei im Wurzelverzeichnis erstellt (nennt sich swapfile).
Einzusehen in der fstab.
Möglicherweise ist das Kontraproduktiv auch noch eine Partition dafür anzulegen.

Da die SWAP-Datei auf der SSD liegt ergibt sich natürlich kein Geschwindigkeitsnachteil.
« Letzte Änderung: 11.01.2019, 00:24:24 von Linux_4_Ever »