Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.03.2019, 09:37:44

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21709
  • Letzte: MarinAG
Statistiken
  • Beiträge insgesamt: 580074
  • Themen insgesamt: 46976
  • Heute online: 557
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  Apache2 und PHP  (Gelesen 310 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Apache2 und PHP
« am: 06.01.2019, 14:45:38 »
Hi,

Mint 19 geholt und neu installiert.
Apache2 und DB ist auch drauf.
An sich scheint so weit auch zu funktionieren.
- "Apache2 Ubuntu Default Page" ist sichtbar auf localhost.
- phpinfo.php wird auch angezeigt.
- HTML-Seiten werden angezeigt

Allerdings:
wenn eine PHP-Datei aufgerufen wird, dann wird eine LEERE SEITE angezeigt. Keine Meldung, einfach nichts  :(

Die Verzeichnisrechte sind gesetzt.

Die Apache2 Installation habe ich diesmal nicht mit Lampp gemacht, sondern manuell.


Muss irgendwo (config?) noch die PHP-Version eingefügt werden?



Danke Euch!

---------------------------

phpinfo.php zeigt das an:
PHP Version 7.2.10-0ubuntu0.18.04.1
php --version liefert das:
PHP 7.2.10-0ubuntu0.18.04.1 (cli) (built: Sep 13 2018 13:45:02) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.10-0ubuntu0.18.04.1, Copyright (c) 1999-2018, by Zend Technologies

Mint-Version:
Distributor ID:   LinuxMint
Description:   Linux Mint 19.1 Tessa
Release:   19.1
Codename:   tessa

Re: Apache2 und PHP
« Antwort #1 am: 06.01.2019, 15:42:39 »
wenn eine PHP-Datei aufgerufen wird, dann wird eine LEERE SEITE angezeigt. Keine Meldung, einfach nichts
phpinfo.php ist auch eine PHP-Seite und die funktioniert ja, oder?
Würde dann vermuten, das was mit den nicht funktionierenden Seiten nicht stimmt.
Wie wird denn diese Seite angezeigt?
<?php

echo Hello World

Re: Apache2 und PHP
« Antwort #2 am: 06.01.2019, 16:54:00 »
Hi atze,

danke für die Antwort.

Ja, phpinfo.php wird richtig angezeigt, auch die Tabellen.

Oben steht:

PHP Version 7.2.10-0ubuntu0.18.04.1
dann das
System Linux gp-R59P-R60P-R61P 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64
Build Date Sep 13 2018 13:45:02
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php/7.2/apache2
Loaded Configuration File /etc/php/7.2/apache2/php.ini
Scan this dir for additional .ini files /etc/php/7.2/apache2/conf.d
Additional .ini files parsed /etc/php/7.2/apache2/conf.d/10-mysqlnd.ini, /etc/php/7.2/apache2/conf.d/10-opcache.ini, /etc/php/7.2/apache2/conf.d/10-pdo.ini, /etc/php/7.2/apache2/conf.d/15-xml.ini, /etc/php/7.2/apache2/conf.d/20-calendar.ini, /etc/php/7.2/apache2/conf.d/20-ctype.ini, /etc/php/7.2/apache2/conf.d/20-dom.ini, /etc/php/7.2/apache2/conf.d/20-exif.ini, /etc/php/7.2/apache2/conf.d/20-fileinfo.ini, /etc/php/7.2/apache2/conf.d/20-ftp.ini, /etc/php/7.2/apache2/conf.d/20-gettext.ini, /etc/php/7.2/apache2/conf.d/20-iconv.ini, /etc/php/7.2/apache2/conf.d/20-json.ini, /etc/php/7.2/apache2/conf.d/20-mbstring.ini, /etc/php/7.2/apache2/conf.d/20-mysqli.ini, /etc/php/7.2/apache2/conf.d/20-pdo_mysql.ini, /etc/php/7.2/apache2/conf.d/20-phar.ini, /etc/php/7.2/apache2/conf.d/20-posix.ini, /etc/php/7.2/apache2/conf.d/20-readline.ini, /etc/php/7.2/apache2/conf.d/20-shmop.ini, /etc/php/7.2/apache2/conf.d/20-simplexml.ini, /etc/php/7.2/apache2/conf.d/20-sockets.ini, /etc/php/7.2/apache2/conf.d/20-sysvmsg.ini, /etc/php/7.2/apache2/conf.d/20-sysvsem.ini, /etc/php/7.2/apache2/conf.d/20-sysvshm.ini, /etc/php/7.2/apache2/conf.d/20-tokenizer.ini, /etc/php/7.2/apache2/conf.d/20-wddx.ini, /etc/php/7.2/apache2/conf.d/20-xmlreader.ini, /etc/php/7.2/apache2/conf.d/20-xmlwriter.ini, /etc/php/7.2/apache2/conf.d/20-xsl.ini
PHP API 20170718
PHP Extension 20170718
Zend Extension 320170718
Zend Extension Build API320170718,NTS
PHP Extension Build API20170718,NTS
Debug Build no
Thread Safety disabled
Zend Signal Handling enabled
Zend Memory Manager enabled
Zend Multibyte Support provided by mbstring
IPv6 Support enabled
DTrace Support available, disabled
Registered PHP Streams https, ftps, compress.zlib, php, file, glob, data, http, ftp, phar
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2
Registered Stream Filters zlib.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, convert.iconv.*

<?
echo "Hallo world";
?>

Datei hallo.php konnte ohne Probleme in www-Verzeichnis gespeichert werden.

Beim Aufrufen wurde eine LEERE Seite angezeigt.
Keine Meldung, kein Fehler, absolut nichts.

Die Apache2-Test-Seite (HTML) wird auch richtig angezeigt:

Apache2 Ubuntu Default Page
It works!
This is the default welcome page used to test the correct operation of the Apache2 server after  .... usw. .... usw.

Ich programmiere seit Jahren PHP und die Files sind o.k.

Re: Apache2 und PHP
« Antwort #3 am: 06.01.2019, 17:06:43 »
hallo.html

<html>
Hallo World.
</html>

funktioniert auch


Re: Apache2 und PHP
« Antwort #4 am: 06.01.2019, 17:12:15 »
MOMENT!
Ich habe es ;-), gleich nochmal mit etwas anderem checken, aber scheint jetzt zu funktionieren.
Wenn ja, hole die LÖsung gleich nach.

Re: Apache2 und PHP
« Antwort #5 am: 06.01.2019, 17:27:32 »
So funktioniert:
Zitat
<?php
echo "Hallo world";
?>


php.ini ist so eingestellt:

; This directive determines whether or not PHP will recognize code between
; <? and ?> tags as PHP source which should be processed as such. It is
; generally recommended that <?php and ?> should be used and that this feature
; should be disabled, as enabling it may result in issues when generating XML
; documents, however this remains supported for backward compatibility reasons.
; Note that this directive does not control the <?= shorthand tag, which can be
; used regardless of this directive.
; Default Value: On
; Development Value: Off
; Production Value: Off
; http://php.net/short-open-tag
short_open_tag = Off

short_open_tag = Off auf
short_open_tag = [b]On[/b]geändert

und funktioniert.

Danke Euch ;-)