Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.01.2019, 07:02:50

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21412
  • Letzte: glaze59
Statistiken
  • Beiträge insgesamt: 567195
  • Themen insgesamt: 46030
  • Heute online: 433
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 6
Gäste: 307
Gesamt: 313

Autor Thema:  Kann broken pakages nicht mehr löschen  (Gelesen 273 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Kann broken pakages nicht mehr löschen
« am: 04.01.2019, 21:46:48 »
Ich nutze hier ein Linux Mint Mate 18.3

Ich wollte meine Dosbox aktualisieren und habe daher von hier: https://debian.pkgs.org/10/debian-maamd64.deb.html

diverse .deb Datein herunter geladen und wollte diese mittels

sudo dpkg -i *.deb

installieren. Das brach dann mit einem Fehler ab und teilte mir mit, das es nicht geht.

OK, dachte ich und löschte die .deb Dateien wieder.

Wenn ich nun aber normal Aktualisieren will schreibt der mir:

sudo aptitude upgrade
Resolving dependencies...               
Unable to resolve dependencies for the upgrade: no solution found.
Unable to safely resolve dependencies, try running with --full-resolver.

starte ich synaptic, sagt er mir dass ich 13 "broken" packages habe. Also habe ich es mal mit

sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libasound2:i386 : Breaks: libasound2 (!= 1.1.0-0ubuntu1)
 libasound2 : Depends: libasound2-data (>= 1.1.7-2) but 1.1.0-0ubuntu1 is installed
              Breaks: libasound2:i386 (!= 1.1.7-2)
 libasound2-dev : Depends: libasound2 (= 1.1.0-0ubuntu1)
 libgcc1 : Depends: gcc-8-base (= 8.2.0-13) but it is not installable
           Breaks: libgcc1:i386 (!= 1:8.2.0-13) but 1:6.0.1-0ubuntu1 is installed
 libgcc1:i386 : Breaks: libgcc1 (!= 1:6.0.1-0ubuntu1) but 1:8.2.0-13 is installed
 libsdl1.2-dev : Depends: libsdl1.2debian (= 1.2.15+dfsg1-3) but 1.2.15+dfsg2-4 is installed
 libsdl1.2debian:i386 : Breaks: libsdl1.2debian (!= 1.2.15+dfsg1-3) but 1.2.15+dfsg2-4 is installed
 libsdl1.2debian : Breaks: libsdl1.2debian:i386 (!= 1.2.15+dfsg2-4) but 1.2.15+dfsg1-3 is installed
 libstdc++6 : Depends: gcc-8-base (= 8.2.0-13) but it is not installable
              Breaks: libstdc++6:i386 (!= 8.2.0-13) but 5.4.0-6ubuntu1~16.04.11 is installed
 libstdc++6:i386 : Breaks: libstdc++6 (!= 5.4.0-6ubuntu1~16.04.11) but 8.2.0-13 is installed
 zlib1g : Breaks: zlib1g:i386 (!= 1:1.2.11.dfsg-1) but 1:1.2.8.dfsg-2ubuntu4.1 is installed
 zlib1g:i386 : Breaks: zlib1g (!= 1:1.2.8.dfsg-2ubuntu4.1) but 1:1.2.11.dfsg-1 is installed
 zlib1g-dev : Depends: zlib1g (= 1:1.2.8.dfsg-2ubuntu4.1) but 1:1.2.11.dfsg-1 is installed
E: Unmet dependencies. Try using -f.

versucht. Nun weis ich was alles kaputt ist, aber wie mache ich das wieder weg ?

Wenn ich in Synaptic bei allen Broken Packages auf remove complete wähle, dann sagt er mir das er noch ettliche 100 weitere Packete löscht (sieht aus als ob der dann mein komplettes system platt macht) deswegen habe ich das mal noch nicht gemacht.

Könnt ihr mir helfen, so das mein System wieder läuft ?

Ich habe die Frage auch schon hier gestellt:
https://forum.ubuntuusers.de/topic/kann-broken-pakages-nicht-mehr-loeschen/
« Letzte Änderung: 04.01.2019, 23:27:05 von corpsman »

Re: Kann broken pakages nicht mehr löschen
« Antwort #1 am: 04.01.2019, 22:58:33 »
Dort haben die nur Linux Mint gelesen und die Antwort verweigert mit dem Verweis ich soll es hier stellen.
Off-Topic:
Das ist sehr verkürzt dargestellt und nur die halbe Wahrheit. Es gibt dort auch konstruktive Antworten und Hilfsversuche, was doch jeder sehen kann, wenn er dem Link folgt … nicht sehr klug, solche  Behauptungen.
Mein Mitleid hält sich in Grenzen.
« Letzte Änderung: 04.01.2019, 23:03:09 von aexe »

Re: Kann broken pakages nicht mehr löschen
« Antwort #2 am: 04.01.2019, 23:38:47 »
Habe es gelöscht, als ich das geschrieben habe wars noch so ...

Sorry sollte sich jemand auf den Schlipps getreten fühlen.

Aktuell haben wir es übrigns noch nicht gelöst Aktuell ist es so, dass der Befehl:

Zitat
corpsman@corpsman ~ $ sudo apt-get install --reinstall zlib1g:i386=1:1.2.8.dfsg-2ubuntu4.1 libasound2=1.1.0-0ubuntu1 libgcc1=1:6.0.1-0ubuntu1 libsdl1.2debian=1.2.15+dfsg1-3 libstdc++6=5.4.0-6ubuntu1~16.04.11 libstdc++6:i386=5.4.0-6ubuntu1~16.04.11 zlib1g=1:1.2.8.dfsg-2ubuntu4.1 libpng16-16=1.6.20-2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be DOWNGRADED:
  libasound2 libgcc1 libpng16-16 libsdl1.2debian libstdc++6 zlib1g
0 upgraded, 0 newly installed, 4 reinstalled, 6 downgraded, 0 to remove and 0 not upgraded.
12 not fully installed or removed.
Need to get 0 B/1.172 kB of archives.
After this operation, 61,4 kB disk space will be freed.
Do you want to continue? [Y/n]
E: Internal Error, No file name for zlib1g:i386
corpsman@corpsman ~ $

nicht geht.

Re: Kann broken pakages nicht mehr löschen
« Antwort #3 am: 04.01.2019, 23:51:37 »
Sorry sollte sich jemand auf den Schlipps getreten fühlen.
Ich nicht.

Re: Kann broken pakages nicht mehr löschen
« Antwort #4 am: 05.01.2019, 07:58:00 »
Ich wollte meine Dosbox aktualisieren und habe daher von hier: https://debian.pkgs.org/10/debian-maamd64.deb.html

diverse .deb Datein herunter geladen ...


Link ergibt

 

Timeshift hast du wohl nicht aktiviert.

Also - eigene Daten sichern und neu installieren!

Re: Kann broken pakages nicht mehr löschen
« Antwort #5 am: 05.01.2019, 09:33:07 »
hallo kalle123, das Thema ist längst erledigt - sogar ganz ohne Neuinstallation https://forum.ubuntuusers.de/topic/kann-broken-pakages-nicht-mehr-loeschen/4/

Re: Kann broken pakages nicht mehr löschen
« Antwort #6 am: 05.01.2019, 09:46:45 »
hallo kalle123, das Thema ist längst erledigt - sogar ganz ohne Neuinstallation https://forum.ubuntuusers.de/topic/kann-broken-pakages-nicht-mehr-loeschen/4/


@Matrix.

Ich liebe solche Links  ;D
 

Re: Kann broken pakages nicht mehr löschen
« Antwort #7 am: 05.01.2019, 09:52:14 »
wenn @corpsman ausgeschlafen hat ( Problem war ca. um 02:00 Uhr gelöst )
wird er diesen thread hoffentlich auf "gelöst" setzen
Wie - siehe Bild

Re: Kann broken pakages nicht mehr löschen
« Antwort #8 am: 05.01.2019, 09:54:56 »
@kalle123, ich häng dir mal ein Bildchen an.  :P
« Letzte Änderung: 05.01.2019, 10:47:18 von Matrix »

Re: Kann broken pakages nicht mehr löschen
« Antwort #9 am: 05.01.2019, 10:49:49 »
@Matrix.

Dank dir.

Aber um mir solche "Murksereien" anzuschauen, melde ich mich nicht in noch einem Forum an.  :D

Re: Kann broken pakages nicht mehr löschen
« Antwort #10 am: 05.01.2019, 10:54:23 »
Off-Topic:
Ich freue mich, ebenfalls noch eine Antwort schreiben zu können:
"Zur Sache kann ich nichts sagen"

Broken pakages, broken links …
Ein Thread zum Erbrechen.

@ kalle123
Es ist nicht verkehrt, einen Account bei den ubuntuusers.de zu haben.
Da gibt es gelegentlich auch interessante Dinge zu lesen.
Manchmal nicht für jeden. :D
« Letzte Änderung: 05.01.2019, 11:02:03 von aexe »

Re: Kann broken pakages nicht mehr löschen
« Antwort #11 am: 05.01.2019, 11:13:24 »
Off-Topic:
Off-Topic:
Es ist nicht verkehrt, einen Account bei den ubuntuusers.de zu haben.
Da gibt es gelegentlich auch interessante Dinge zu lesen.
Manchmal nicht für jeden. :D

Bin beim "Original" in beiden Foren. Das sollte reichen  ;D