Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
15.06.2019, 23:02:37

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 594190
  • Themen insgesamt: 48132
  • Heute online: 525
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?  (Gelesen 420 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« am: 27.12.2018, 11:38:59 »
Hallo Zusammen,
habe gerade das alte LMDE 2 Mate 32 Bit durch eine Neuinstallation von LMDE 3 LXDE 32 Bit ersetzt.
Der Rechner ist ein Acer Travelmate 290 - also wirklich alt - leider funktioniert der Klick on Tapping nicht mehr in der Grundkonfiguration des Touchpads, habe mich inzwischen soweit belesen, als dass hier wohl bei LXDE und auch aufgrund Wayland's libinput keine Aktivierung per GUI möglich ist:
https://www.ubuntuvibes.com/2017/04/how-to-configure-touchpad-in-ubuntu.html

Hier noch einpaar Angaben zum Rechner:
acer@travelmate:~$ inxi fz
CPU~Single core Intel Pentium M (-UP-) speed~1700 MHz (max) Kernel~4.9.0-8-686 i686 Up~8 min Mem~421.8/1496.8MB HDD~80.0GB(12.1% used) Procs~129 Client~Shell inxi~2.3.5

Hier eine Übersicht der vorhandenen Touchpads:
acer@travelmate:~$ xinput list
⎡ Virtual core pointer                    id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS GlidePoint                id=11 [slave  pointer  (2)]
⎣ Virtual core keyboard                    id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard              id=5 [slave  keyboard (3)]
    ↳ Power Button                            id=6 [slave  keyboard (3)]
    ↳ Video Bus                                id=7 [slave  keyboard (3)]
    ↳ Power Button                            id=8 [slave  keyboard (3)]
    ↳ Sleep Button                            id=9 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            id=10 [slave  keyboard (3)]
    ↳ BRLTTY 5.4 Linux Screen Driver Keyboard id=12 [slave  keyboard (3)]

Und hier noch die aktuellen Touchpad-Einstellungen des GlidePoint:
acer@travelmate:~$ xinput list-props "11"
Device 'AlpsPS/2 ALPS GlidePoint':
Device Enabled (130): 1
Coordinate Transformation Matrix (132): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Tapping Enabled (268): 0
libinput Tapping Enabled Default (269): 0
libinput Tapping Drag Enabled (270): 1
libinput Tapping Drag Enabled Default (271): 1
libinput Tapping Drag Lock Enabled (272): 0
libinput Tapping Drag Lock Enabled Default (273): 0
libinput Tapping Button Mapping Enabled (274): 1, 0
libinput Tapping Button Mapping Default (275): 1, 0
libinput Accel Speed (276): 0.000000
libinput Accel Speed Default (277): 0.000000
libinput Natural Scrolling Enabled (278): 0
libinput Natural Scrolling Enabled Default (279): 0
libinput Send Events Modes Available (253): 1, 1
libinput Send Events Mode Enabled (254): 0, 0
libinput Send Events Mode Enabled Default (255): 0, 0
libinput Left Handed Enabled (280): 0
libinput Left Handed Enabled Default (281): 0
libinput Scroll Methods Available (282): 0, 1, 0
libinput Scroll Method Enabled (283): 0, 1, 0
libinput Scroll Method Enabled Default (284): 0, 1, 0
libinput Middle Emulation Enabled (285): 1
libinput Middle Emulation Enabled Default (286): 1
libinput Disable While Typing Enabled (287): 1
libinput Disable While Typing Enabled Default (288): 1
Device Node (256): "/dev/input/event6"
Device Product ID (257): 2, 8
libinput Drag Lock Buttons (289): <no items>
libinput Horizontal Scroll Enabled (290): 1

Ich vermute diese Zeile hier ist die zu ändernde Einstellung:
libinput Tapping Enabled (268): 0
Muss ich hier wirklich die 60-libinput.conf erstellen und editieren um die Funktion (die übrigens mit LMDE 2 bereits in der Grundkonfiguration aktiv war) mit dem Tapping zu haben - gibts ev. einen einfacheren Weg?

Schon mal Danke vorab!
« Letzte Änderung: 05.01.2019, 11:25:15 von tempograd »

Re: LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« Antwort #1 am: 27.12.2018, 12:18:45 »
Gibt es denn bei Deinem LMDE nicht unter "Einstellungen > Maus und Touchpad > Touchpad" folgende Dialogbox:

Re: LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« Antwort #2 am: 27.12.2018, 12:23:16 »
Hallo aexe,
leider nein, ich hab nur folgende Möglichkeiten:
Touchpad Einstellungen LMDE3 LXDE
Touchpad Einstellungen LMDE3 LXDE

Re: LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« Antwort #3 am: 27.12.2018, 12:40:01 »
Ah, sorry. Hab das LXDE übersehen.
Da fehlt die Einstellung, soweit ich weiß.
Kann im Moment keine Alternative anbieten.

Mein Bild ist von einem Cinnamon.

Re: LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« Antwort #4 am: 27.12.2018, 13:00:21 »
Funktioniert denn synclient ?
Dann evtl. synclient MaxTapTime=0 versuchen.

Re: LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« Antwort #5 am: 27.12.2018, 13:13:00 »
Ist nicht installiert:
acer@travelmate:~$ synclient
The program 'synclient' is currently not installed.  To run 'synclient' please ask your administrator to install the package 'xserver-xorg-input-synaptics'
synclient: command not found

Re: LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« Antwort #6 am: 27.12.2018, 13:15:53 »
sudo apt install xserver-xorg-input-synaptics

Danach prüfen: grep -i "Using input driver" /var/log/Xorg.0.log
« Letzte Änderung: 27.12.2018, 13:19:24 von aexe »

Re: LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« Antwort #7 am: 27.12.2018, 16:01:22 »
Habs installiert, hier die Ausgabe:
acer@travelmate:~$ grep -i "Using input driver" /var/log/Xorg.0.log
[    27.217] (II) Using input driver 'libinput' for 'Power Button'
[    27.360] (II) Using input driver 'libinput' for 'Video Bus'
[    27.362] (II) Using input driver 'libinput' for 'Power Button'
[    27.365] (II) Using input driver 'libinput' for 'Sleep Button'
[    27.368] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[    27.370] (II) Using input driver 'libinput' for 'AlpsPS/2 ALPS GlidePoint'
[    27.374] (II) Using input driver 'libinput' for 'BRLTTY 5.4 Linux Screen Driver Keyboard'

und nochmal:
acer@travelmate:~$ synclient
Couldn't find synaptics properties. No synaptics driver loaded?
« Letzte Änderung: 27.12.2018, 16:05:34 von tempograd »

Re: LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« Antwort #8 am: 28.12.2018, 14:34:51 »
Hab nun auch mal die Möglichkeit aus dem Link versucht, aber auch die 60-libinput.conf hat nicht den gewünschten Erfolg gebracht.

Off-Topic:
Zwar OT, aber ich hab leider auch feststellen müssen, das der Shutdown nicht ordentlich funktioniert. aktuell löse ich das über:
systemctl poweroff

Aber irgendwie stellt mich das alles nicht sonderlich zufrieden. Das alte LMDE 2, das ja in wenigen Tagen aus dem Support fällt, funktionierte ohne derartige Einschränkungen - ja klar die Kiste ist alt, aber trotzdem ärgerlich.

An sich würde es ja erstaunlich flüssig mit LMDE 3 LXDE laufen.

Aber ich werde die LMDE 3 Installation erstmal durch ein LM19 LXDE 32 Bit ersetzen. Bleibt jedoch die Touchpad Problematik.
« Letzte Änderung: 31.12.2018, 13:44:26 von tempograd »

Re: LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« Antwort #9 am: 31.12.2018, 13:53:13 »
Hallo Zusammen,
gibt es eine Möglichkeit, ev. diese Einstellungen zu editieren?
acer@TravelMate:~$ xinput list-props "11"
Device 'AlpsPS/2 ALPS GlidePoint':
Device Enabled (133): 1
Coordinate Transformation Matrix (135): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Tapping Enabled (271): 0
libinput Tapping Enabled Default (272): 0
libinput Tapping Drag Enabled (273): 1
libinput Tapping Drag Enabled Default (274): 1
libinput Tapping Drag Lock Enabled (275): 0
libinput Tapping Drag Lock Enabled Default (276): 0
libinput Tapping Button Mapping Enabled (277): 1, 0
libinput Tapping Button Mapping Default (278): 1, 0
libinput Natural Scrolling Enabled (279): 0
libinput Natural Scrolling Enabled Default (280): 0
libinput Disable While Typing Enabled (281): 1
libinput Disable While Typing Enabled Default (282): 1
libinput Scroll Methods Available (283): 0, 1, 0
libinput Scroll Method Enabled (284): 0, 1, 0
libinput Scroll Method Enabled Default (285): 0, 1, 0
libinput Middle Emulation Enabled (286): 1
libinput Middle Emulation Enabled Default (287): 1
libinput Accel Speed (288): 0.000000
libinput Accel Speed Default (289): 0.000000
libinput Left Handed Enabled (290): 0
libinput Left Handed Enabled Default (291): 0
libinput Send Events Modes Available (256): 1, 1
libinput Send Events Mode Enabled (257): 0, 0
libinput Send Events Mode Enabled Default (258): 0, 0
Device Node (259): "/dev/input/event6"
Device Product ID (260): 2, 8
libinput Drag Lock Buttons (292): <no items>
libinput Horizontal Scroll Enabled (293): 1

Irgendwie muss es doch gehen diese zwei Zeilen zu ändern, bzw. von "0" auf "1" zu setzen:

libinput Tapping Enabled (271): 0
libinput Tapping Enabled Default (272): 0

Bin mir ziemlich sicher damit wäre der Funktionsumfang des Touchpads wieder wie gewohnt.

Wollte jetzt nicht nochmal einen zweiten Thread aufmachen - auch wenn ich jetzt LMDE 3 LXDE durch LM 19 LXDE 32 Bit ersetzt haben.

Zur Sicherheit hier nochmal ein neues:
acer@TravelMate:~$ inxi -Fz
System:    Host: TravelMate Kernel: 4.15.0-20-generic i686 bits: 32
           Desktop: LXDE (Openbox 3.6.1) Distro: Linux Mint 19 Tara
Machine:   Device: portable System: Acer product: TravelMate 290 v: 290 serial: N/A
           Mobo: Intel model: 855GM v: FAB-2 serial: N/A
           BIOS: ACER v: V2.00 date: 07/29/2004
CPU:       Single core Intel Pentium M (-UP-) cache: 2048 KB
           speed: 1700 MHz (max)
Graphics:  Card: Intel 82852/855GM Integrated Graphics Device
           Display Server: x11 (X.Org 1.19.6 )
           drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1024x768@47.52hz, 1024x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel 852GM/855GM x86/MMX/SSE2
           version: 1.3 Mesa 18.0.5
Audio:     Card Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
           driver: snd_intel8x0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
           driver: 8139too
           IF: enp1s1 state: down mac: <filter>
           Card-2: Intel PRO/Wireless LAN 2100 3B Mini PCI Adapter
           driver: ipw2100
           IF: wlp1s2 state: up mac: <filter>
Drives:    HDD Total Size: 80.0GB (26.1% used)
           ID-1: /dev/sda model: SAMSUNG_HM080GC size: 80.0GB
Partition: ID-1: / size: 23G used: 13G (58%) fs: ext4 dev: /dev/sda6
           ID-2: /home size: 47G used: 3.4G (8%) fs: ext4 dev: /dev/sda7
           ID-3: swap-1 size: 4.09GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 133 Uptime: 13 min Memory: 361.4/1488.8MB
           Client: Shell (bash) inxi: 2.3.56

Re: LMDE 3 LXDE 32 Bit - wie Touchpad Klick on Tapping aktivieren?
« Antwort #10 am: 05.01.2019, 11:24:56 »
Lösung gefunden: apt install xserver-xorg-input-synapticsNochmals Danke an DeVIL-i386.
Jetzt läuft auf dem 15 Jahre alten Travelmate alles perfekt.....und ich bin immer noch erstaunt wie flüssig.
LM bleibt einfach Klasse!!