Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.09.2019, 11:06:44

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22558
  • Letzte: Weber-J
Statistiken
  • Beiträge insgesamt: 608559
  • Themen insgesamt: 49264
  • Heute online: 595
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs  (Gelesen 2102 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #30 am: 22.08.2019, 18:42:05 »
Hallo,
hat denn Niemand eine Idee wie ich weiter vorgehen muss??

bugs.launchpad.net hat sich heute erneut gemeldet: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1811254
jedoch komme ich mit der darin verlinkten Seite nicht weiter: https://wiki.ubuntu.com/Testing/EnableProposed

Im vorausgegangen Verlauf wurde mir von bugs.launchpad.net ein Bug-Fix Bericht in deren Antwort #32 gemeldet: This bug was fixed in the package linux - 4.19.0-13.14

---------------
linux (4.19.0-13.14) disco; urgency=medium

aber in der Aktualisierungsverwaltung ist Kernel 4.19 doch gar nicht erreichbar.

Beim aktuellen Kernel 4.15.0-58 muss ich durch Einfügen der Zeile: options snd-hda-intel mode=mute-led-gpioin:/etc/modprobe.d/alsa-base.confden LED-Hotkey-Support aktivieren, nach Speichern, Neustart zeigt alsamixer einen Schalter für "Mute" an. In Kernel 5.0 werden ohne jegliche Anpassung zwei Schalter für Speaker- und Mikro- Mute angezeigt, siehe Screenshots. :-\

Also ist der Bug-Fix bis Heute nicht in die Kernellinie 4.15 eingeflossen.
Ich bleibe aktuell bei Kernel 5.0.0-25

Anhänge zeigen alsamixer:
1. mit Kernel 4.15 nach erforderlicher Korrektur
2. mit Kernel 5.0.0-25, ohne Korrektur
« Letzte Änderung: 23.08.2019, 07:25:37 von kuehhe1 »

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #31 am: 26.08.2019, 15:05:05 »
Moin,
Launchpad (Kleber Sacilotto de Souza <kleber.souza@canonical.com>) hat sich heute erneut gemeldet:
Zitat
Hi @kuehhe1,
Please do not change the status of the bug tasks to 'Fix Released', this is done automatically by the Launchpad bot when the fix is available in -updated. The comment regarding the verification is asking for tests with the Bionic kernel currently in -proposed, which is 4.15.0-60.67. Version 4.15.0-58.64 doesn't contain the fix, so it's expected to fail. Would you be able to test the fix again with kernel 4.15.0-60.67?
Thank you.

** Changed in: linux (Ubuntu Bionic)
       Status: Fix Released => Fix Committed

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1811254
dann werde ich mal schauen wie und ob ich das hinbekomme und erst mal Timeshift bemühen...

Leider wird Kernel 4.15.0-60.67 (noch) nicht in uKuu angeboten, dann eben das Prozedere manuell nach Anleitung von: https://wiki.ubuntu.com/Testing/EnableProposed und der Akt-Verwaltung die Quelle hinzugefügt:
deb http://archive.ubuntu.com/ubuntu/ bionic-proposed restricted main multiverse universe
und diese Datei erstellt und getestet:
Zitat
Create the file /etc/apt/preferences.d/proposed-updates with this content:

Package: *
Pin: release a=bionic-proposed
Pin-Priority: 400
With this preference file in place, Update Manager, Synaptic, Aptitude and Apt won't ask for upgrades from the -proposed repositories.

You can test this by simulating an upgrade with apt:

sudo apt-get upgrade -s
in der Simulation wird mir nun Kernel: 4.15.0-60.67 angeboten.
Kernel wird installiert:dpkg -l | grep linux-image
ii  linux-image-4.15.0-58-generic                 4.15.0-58.64                                amd64        Signed kernel image generic
ii  linux-image-4.15.0-60-generic                 4.15.0-60.67                                amd64        Signed kernel image generic
ii  linux-image-generic                           4.15.0.60.62                                amd64        Generic Linux kernel image
Neustart und schauen wie es um den LED-Hotkey-Support steht......

.....mit Kernel 4.15.0-60.67 funktionieren nun die Hotkey-LEDs [f5] und [f8] ohne die optionale Anpassung in: /etc/modprobe.d/alsa-base.conf , dieser Bug scheint gefixt, alsamixer zeigt einen Schalter für "MUTE" an, siehe Anhang #1  :D
Der "Launchpad CVE Tracker": https://bugs.launchpad.net/bugs/cve/2018-16880 zeigt den Workflow

Da der Test-Kernel 4.15.0-60.67 in der Akt.-Verwaltung als "nicht unterstützt" angezeigt, siehe Anhang #2 und ich nun das Prozedere kenne und sehe das es prinzipiell funktioniert setze ich dennoch das System mit Timeshift auf Kernel 4.15.0-58 zurück und lebe mit der optionalen Anpassung in: /etc/modprobe.d/alsa-base.conf bis die Änderung in den Kernel des Repos einfließt. 8)

Die Hotkey-LED [f11] Wlan On-Off leuchtet jedoch weiterhin permanent, zu dem Bug erhielt ich noch keine Rückmeldung: https://bugzilla.kernel.org/show_bug.cgi?id=202367#c0 :(

« Letzte Änderung: 28.08.2019, 18:39:00 von kuehhe1 »

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #32 am: 02.09.2019, 21:28:24 »
Nabend,
was lange währt,
heute wurde wie von bugs.launchpad.net angekündigt, der Kernel 4.15.0-60.67 über die Akt.-Verwaltung angeboten, installiert und als: "wird bis 2023 unterstützt" angezeigt.

.....mit Kernel 4.15.0-60.67 funktionieren nun meine Hotkey-LEDs [f5] und [f8] ohne die optionale Anpassung in: /etc/modprobe.d/alsa-base.conf , dieser Bug ist gefixt, alsamixer zeigt einen Schalter für "MUTE". :D
kuehhe1@HP470:~$ dpkg -l | grep linux-image
ii  linux-image-4.15.0-60-generic                 4.15.0-60.67                                amd64        Signed kernel image generic
ii  linux-image-generic
kuehhe1@HP470:~$ inxi -Fz
System:    Host: HP470 Kernel: 4.15.0-60-generic x86_64 bits: 64 Desktop: Cinnamon 4.2.4 Distro: Linux Mint 19.2 Tina
Machine:   Type: Laptop System: HP product: HP ProBook 470 G5 v: N/A serial: <filter>
           Mobo: HP model: 837F v: KBC Version 02.35.00 serial: <filter> UEFI: HP v: Q85 Ver. 01.08.01 date: 07/18/2019
Battery:   ID-1: BAT0 charge: 41.1 Wh condition: 41.1/41.1 Wh (100%)
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP L2 cache: 6144 KiB
           Speed: 3402 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 3401 2: 3400 3: 3400 4: 3400 5: 3400 6: 3400 7: 3401
           8: 3400
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: NVIDIA GM108M [GeForce 930MX] driver: nvidia v: 430.26
           Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa tty: N/A
           OpenGL: renderer: GeForce 930MX/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k4.15.0-60-generic
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168
           IF: enp2s0 state: down mac: <filter>
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
           IF: wlp3s0 state: up mac: <filter>
Drives:    Local Storage: total: 704.24 GiB used: 195.93 GiB (27.8%)
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC401 HFS256GD9TNG-62A0A size: 238.47 GiB
           ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
Partition: ID-1: / size: 19.56 GiB used: 12.69 GiB (64.9%) fs: ext4 dev: /dev/nvme0n1p6
           ID-2: /home size: 68.43 GiB used: 5.64 GiB (8.2%) fs: ext4 dev: /dev/nvme0n1p8
           ID-3: swap-1 size: 10.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p7
Sensors:   System Temperatures: cpu: 34.0 C mobo: 33.0 C gpu: nvidia temp: 33 C
           Fan Speeds (RPM): N/A
Info:      Processes: 309 Uptime: 1m Memory: 7.47 GiB used: 1.67 GiB (22.3%) Shell: bash inxi: 3.0.32

Nun gehts an die nächste Instanz:
Zitat
Kleber Sacilotto de Souza (kleber-souza) wrote 9 hours ago:   #41
Hi @kuehhe1,

Thank you for your feedback.
Based on your comment #40, I am going to mark the verification failed for Bionic and the Launhpad bot will mark the bug as 'Fix Released' once the kernel is promoted to -updated. After that happens, please feel free to re-open it so we can work on the issue that's still present for [f11].

Thank you.
denn die Hotkey-LED [f11] Wlan On-Off leuchtet noch permanent.....
« Letzte Änderung: 07.09.2019, 23:02:46 von kuehhe1 »