Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.06.2019, 18:20:39

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22182
  • Letzte: dave_4k
Statistiken
  • Beiträge insgesamt: 595537
  • Themen insgesamt: 48252
  • Heute online: 609
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs  (Gelesen 1463 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #15 am: 06.01.2019, 20:49:49 »
Eigentlich sollte der Treiber Download mit einem Win10 gehen, eine Seriennummer brauchst du nicht, aber den HP Typ: Probook 470 G5 Notebook-PC.

Der Treiber ist ca. 4MB groß geht hier ja nicht, ich könnte ihn extrahieren, im Win Extraktionsordner sind es sieben Dateien.

Ok ich starte zu Win10 und schaue nach dem Link:
Alle Treiber:
https://support.hp.com/de-de/drivers/selfservice/hp-probook-470-g5-notebook-pc/17047161/model/17047165?sku=3KZ03EA
Edit: sehe gerade die Seite erfordert Win.

Dann eben den direkten DL-Link...

Wir brauchen den Wlan Tasten Treiber in der Sektion:
Treiber-Tastatur, Maus und Eingabegeräte:
HP WLAN-Tasten-Treiber 1.1.21.1 Rev.A   4.0 MB   14. Sept. 2017
https://ftp.hp.com/pub/softpaq/sp81501-82000/sp81886.exe

Interessenhalber hab ich hier noch eine HP Downloadseite mit teils davon hier installierter Software, der Zugriff ist unabhängig vom zugreifenden BS:
https://www8.hp.com/us/en/ads/clientmanagement/download.html
« Letzte Änderung: 07.01.2019, 10:39:49 von kuehhe1 »

secureIT

  • Gast
Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #16 am: 06.01.2019, 21:02:26 »
Der ftp-Link geht.

...... schaue ich mir morgen nach dem extrahieren der .exe mal an, ob das weiter führt.

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #17 am: 07.01.2019, 14:26:59 »
Aber nach einem Reboot LM19.1 > LM19.1 leuchtet die LED in der [f11] (Wlan) Taste wieder dauernd. Erfolgt ein Neustart erst zu Win10 und ein Reboot zu LM19.1 bleibt die LED in der Wlan-Taste [f11] wieder dunkel. Dieses Verhalten ist mir so in der ganzen Zeit noch nie aufgefallen
Ergänzung: wird nach einem Reboot von Win10 > LM19.1 der Suspend Modus aktiviert (systemctl suspend) und das System anschließend geweckt ist die LED in der Wlan-Taste [f11] auch wieder dauerhaft an.

Ein Treiber könnte noch mit involviert sein, der HP Hotkey-Support Treiber, möglich das er nicht nur für die Tasten Funktionen sondern auch für die LED's der betreffenden Tasten zuständig ist.
HP Hotkey Support 6.2.46.1 Rev.A, 50.1 MB, 8. Jun. 2018
Zitat
This package provides HP Hotkey support for special function keys on supported models that are running a supported operating system.
- Fixes an issue where Wireless LAN auto switching does not function properly on the system.
- Resolves certain volume key options.
https://ftp.hp.com/pub/softpaq/sp87501-88000/sp87683.exe
« Letzte Änderung: 07.01.2019, 14:40:03 von kuehhe1 »

secureIT

  • Gast
Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #18 am: 07.01.2019, 20:20:07 »
Hi,

Was ich herausgefunden habe:

Der Treiber beinhaltet ausser den normalen inf. cat. und .sys -Dateien auch noch eine
RadioMgr.exe.
Die .sys nimmt Bezug auf Diese, so dass eine Implementierung nicht möglich sein wird.
Der Treiber schlechthin ist ein wahres „Nightmare“ und verweist u.a. auf Ressourcen, ohne die er nicht funktionieren wird ( auch auf Inhalte der o.g. genannten .exe )

Interessant war ein Eintrag in der .inf ... : ACPI\HPQ6001, zu welchem einige Fundstücke in den Suchmaschinen vorliegen.

Trotzdem werden wir es damit nicht lösen können.

Eine manuelle Einstellung der LEDs ist nur für die Einträge möglich, die sich unter /sys/class/leds/
befinden.
https://www.kernel.org/doc/Documentation/leds/leds-class.txt

Die Steuerung der wifi-LED – u.a. der Anderen von dir genannten funktioniert über die Kernel-Module.
Diese beziehen die Zustands-Info via ACPI und triggern dann die LEDs.

In einem bug-Bericht zur mute-LED eines anderen ProBooks wurde darauf verwiesen, dass im Kernel-Modul die Anbindung via GPIO fehlte.
Infos zu GPIO hier :

https://www.kernel.org/doc/Documentation/devicetree/bindings/leds/leds-gpio.txt

und hier :

https://www.kernel.org/doc/html/latest/driver-api/gpio/board.html

Mein Resume …… derzeit leider nichts zu machen ausser einen Bug-Bericht zu erstellen……... :(

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #19 am: 08.01.2019, 17:52:40 »
Was ich herausgefunden habe:
Also zuerst einmal vielen Dank für deine Nachforschungen, mit meinem aktuell viral verseuchten Schädel hätte ich gar nichts dazu gefunden. Zumindest hab ich durch dich nun Ansatzweise einen Einblick wie es funktionieren könnte und was GPIO überhaupt ist: https://www.kernel.org/doc/html/latest/driver-api/gpio/intro.html

Es scheint wirklich ein nicht lösbares Problem hier unter LinuxMint zu sein wobei ich eigentlich noch froh sein kann das unter Win10 die LED's in den Hotkey's so funktionieren wie sie sollen.

Bin natürlich auch deinen Fundstücken zu "ACPI\HPQ6001" im Netz gefolgt, dort wird ersichtlich das dieses Problem bereits seit ca. 2012 besteht.

Und wenn im Kernel-Modul die Anbindung via GPIO fehlt, so denke ich das auch ein Bug-Bericht nichts daran ändern wird, für einige spezielle HP-Probook's werden die Entwickler wohl kaum etwas ändern, oder?

Somit kann ich mich deinem Resume nur anschließen:
Mein Resume …… derzeit leider nichts zu machen
Außer: Man betitelt die Einzige, unter LinuxMint, permanent leuchtende LED als Orientierungslicht zur Wlan-Taste.  :D
« Letzte Änderung: 08.01.2019, 18:44:23 von kuehhe1 »

secureIT

  • Gast
Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #20 am: 08.01.2019, 18:15:19 »
Mit "Anbindung fehlte" meinte ich nicht, dass es im Grundsatz nicht geht, sondern dass die ID nicht im Kernel steht.

Wenn Du Dir diesen Bug-Bericht durchliest : AW # 29
Zitat
The necessary bits to make LED work are all in the kernel, we just need to add new ID to let the driver knows this machine also needs "mute-led-gpio" functionality.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1705586


..... nachdem dazu ein Fix herauskam, denke ich, dass auch in Deinem Fall ein bug-Bericht auf launchpad zu einem Fix führen könnte....

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #21 am: 09.01.2019, 08:08:08 »
we just need to add new ID to let the driver knows this machine also needs "mute-led-gpio" functionality.


Ok, bei einem Probook 440 G4 hat man es für die Mike-Mute LED, dort war es nur der Hotkey [f6], hinbekommen.

Und wenn ich dortige Antwort #32 , #33 richtig gelesen habe bedarf es ausser der Änderung in:
/etc/modprobe.d/alsa-base.confund Ergänzung um:
options snd-hda-intel mode=mute-led-gpionoch eines zusätzlichen Kernel-Patches, da die Ergänzung allein hier nicht zum Erfolg führt.
Auch die bisher unbeachtete "LED Einstellung" in "alsamixer" habe ich kontrolliert. Das Patch scheint die passende GPIO ID in den Kernel zu schreiben, gut möglich das es ausserdem auch noch Kernel abhängig ist. Wie käme ich denn an den Patch in Form einer Datei, denn auf der Seite finde ich ihn nicht? Und falls das hier: http://mailman.alsa-project.org/pipermail/alsa-devel/2017-July/123128.html  ein Patch wäre, verstehe ich nicht wie und wo ich das einbinde, eine Kernel-Patch ist absolutes Neuland. Vermutlich geht das alles nur nach Registrierung auf Launchpad...

denke ich, dass auch in Deinem Fall ein bug-Bericht auf launchpad zu einem Fix führen könnte....
Ich habe mir das dortige Prozedere mal angesehen, wobei mir der Weg, Registrieren, Hochladen der Fehlerbeschreibung incl. aller erforderlichen Logs, schon allein wegen der erforderlichen Übersetzerei.....ziemlich holperig würde.

Nichts desto Trotz hab ich die Seiten durchgeackert: https://bugs.launchpad.net/ubuntu/+source/linux/+filebug und auch die dort weiter verlinkte Seite: https://wiki.ubuntu.com/Hotkeys/Troubleshooting abgearbeitet. Dort wurden zwei Hotkey-Test empfohlen die ich ebenfalls ausgeführte.

Beim Test mit "xev" bringen die Tasten [f5], [f8] und [f11] jeweils Rückmeldungen:
kuehhe1@HP470:~$ xev | sed -n 's/^.*state \([0-9].*\), keycode *\([0-9]\+\) *\(.*\), .*$/keycode \2 = \3, state = \1/p'
keycode 71 = (keysym 0xffc2, F5), state = 0x10
keycode 71 = (keysym 0xffc2, F5), state = 0x10
keycode 74 = (keysym 0xffc5, F8), state = 0x10
keycode 74 = (keysym 0xffc5, F8), state = 0x10
keycode 95 = (keysym 0xffc8, F11), state = 0x10
keycode 95 = (keysym 0xffc8, F11), state = 0x10

Nächsten Test mit "acpi_listen":
kuehhe1@HP470:~$ acpi_listen
button/mute MUTE 00000080 00000000 K
button/f20 F20 00000080 00000000 K
wobei button/mute der [f5] und button/f20 der [f8] entspricht, aber die [f11] Taste bringt hierbei keine Rückmeldung, vermutlich ein Grund für das differenzierte Tasten/LED Verhalten nach einem Kaltstart. Ausserdem fällt mir auf das bei Betätigung vom Hotkey [f11] Wlan On/Off kein Popup am unteren Schreibtisch-Rand wie bei Lautsprecher-Mute und Mikro-Mute geöffnet wird.

Die erstellten LOG-Dateien:
Zitat
acpi_listen.txt
apt-cache-policy
dmesg.log
lsb_release
lsinput.log
lspci-vnvn.log
udev-db.txt
version.log
xev keypress test.txt
xkbcomp.txt
xkbmap.txt

Fehlt "nur noch" der Bug-Bericht .....erstellt....

Edit: Hab das Fehlerbild in Antwort #3 um zwei Versuche ergänzt, müsste ich aus dieser Erkenntnis nicht sogar zwei, drei Bugs an launchpad senden?  ::)

Momentan vertrage ich, wegen der nervenden Vieren, nur leichte Kost gebe mich aber nur ungern geschlagen. :'(

Bug Bericht bei launchpad eingestellt:
10.01.2019, 17:18 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1811254
10.01.2019, 17:30 Status changed to Confirmed
« Letzte Änderung: 17.02.2019, 07:50:49 von kuehhe1 »

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #22 am: 18.01.2019, 16:45:53 »
Heute erhielt ich eine Rückmeldung von >Anthony Wong< auf: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1811254

Nach Korrektur der/etc/modprobe.d/alsa-base.confund einfügen der Zeile:options snd-hda-intel mode=mute-led-gpiozeigen nun schon mal die LED's in den Hotkeys [f5] Speaker-Mute und [f8] Mikro-Mute bei Betätigung Funktion und entsprechen auch dem Schreibtisch Popup. Diese beiden LED's werden auch von Alsamixer "Mute-LED" beinflusst und können damit aktiviert und deaktiviert werden.

Ich hatte bereits eine sehr, sehr ähnliche Korrektur aus einem anderen launchpad-Thema eingefügt aber da waren zwei Leerzeichen zuviel enthalten.
Falsch war: options snd-hda-intel mode_=_mute-led-gpio
Richtig ist: options snd-hda-intel mode=mute-led-gpio

Also sind die GPIO-LED ID's tatsächlich schon im Kernel implementiert, sie müssen nur entsprechend aktiviert werden.
Aufgrund dessen hab ich in /etc/modprobe.d/ nachgeschaut ob in den dortigen *.conf irgend ein anderer Eintrag etwaiger LED's besteht, denn es gibt ja mehrere bereits funktionierende LED's im Keybord, aber davon ist nichts zu erkennen.

Jedenfalls bin ich wieder ein/zwei Schritte weiter. :D

Nun fehlt noch eine Korrektur für die LED im Hotkey [f11] Wlan Ein/Aus.
« Letzte Änderung: 17.02.2019, 07:53:06 von kuehhe1 »

secureIT

  • Gast
Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #23 am: 18.01.2019, 17:49:30 »
Off-Topic:
Hartnäckigkeit zahlt sich eben doch aus ........  ;)

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #24 am: 18.01.2019, 21:14:29 »
Lauchpad hat einen Testkernel bereitgestellt, den habe ich installiert und getestet:
Zitat
Before you boot into the test kernel in #20, please remove "options snd-hda-intel model=mute-led-gpio" from /etc/modprobe.d/alsa-base.conf first.
If it works, I will send the proper fix to upstream so that you no longer need to modify /etc/modprobe.d/alsa-base.conf.
diese Kernel Pakete sind nun installiert:
~$ dpkg -l *4.15.0-43* | egrep '^ii '
ii  linux-headers-4.15.0-43                4.15.0-43.46          all          Header files related to Linux kernel version 4.15.0
ii  linux-headers-4.15.0-43-generic        4.15.0-43.46lp1811254 amd64        Linux kernel headers for version 4.15.0 on 64 bit x86 SMP
ii  linux-image-unsigned-4.15.0-43-generic 4.15.0-43.46lp1811254 amd64        Linux kernel image for version 4.15.0 on 64 bit x86 SMP
ii  linux-modules-4.15.0-43-generic        4.15.0-43.46lp1811254 amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
ii  linux-modules-extra-4.15.0-43-generic  4.15.0-43.46lp1811254 amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP

Mit dem bereitgestellten Test-Kernel 4.15.0-43 funktionieren jetzt die LED's in den Hotkey's [f5] Speaker-Mute und [f8] Mikro Ein-Aus, somit zwei Fehler weniger.  :)

@secureIT, deine Ermutigung und die Mühe den Bug auf Launchpad zu berichten hat sich gelohnt, es läuft auf Lauchpad ...
Status: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1811254

Die Sache ist aber noch nicht ganz abgeschlossen, denn die LED im Hotkey [f11] Wlan Ein-Aus benötigt eine andere Korrektur.
« Letzte Änderung: 18.02.2019, 12:50:57 von kuehhe1 »

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LED's
« Antwort #25 am: 21.01.2019, 19:17:54 »
Update:
Heute hat sich nochmals >Anthony Wong auf bugs.launchpad.net< gemeldet: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1811254

Wie empfohlen bin ich nun wieder mit dem Standard Kernel: linux (4.15.0-43.46) bionic; urgency=mediumund der Korrektur in: /etc/modprobe.d/alsa-base.confmit der Ergänzung: options snd-hda-intel mode=mute-led-gpiounterwegs.
Die gefundenen Lösungen im bereitgestellten Test-Kernel würden in zukünftige Kernel einfließen.  ;)

Das Problem der permanent leuchtenden LED im Hotkey [f11] ist eine Andere Baustelle,
gemeldet bei: https://bugzilla.kernel.org/show_bug.cgi?id=202367
« Letzte Änderung: 18.02.2019, 17:58:04 von kuehhe1 »

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #26 am: 16.02.2019, 09:46:00 »
Update,
auch wenn ich hier den Alleinunterhalter mime möchte ich diese Neuigkeit mitteilen da sie nicht nur mein:HP Probook 470 G5 betrifft,
sondern auch diese Typen: HP Probook 450 G4, HP Probook 450 G5, HP Probook 640 G2 und Envy Serie

Email von: >bugs.launchpad.net<: die gemeldeten Fehler wurden mit Kernel 4.19.19 gefixt.
Nachzulesen auf:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1811254
und
https://lwn.net/Articles/778113/
und
https://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19.24/0004-debian-changelog.patch

launchpad Fix-Bericht im Anhang: lounchpad-kernel-fix-comment-32.txt

Da im Fix keine Download-Quelle für den Kernel angegeben wurde hab ich mit >ukuu< nach Kernel >4.19.19< gesucht und >4.19.19-041919-generic< installiert. Die zuvor im offiziellen Kernel 4.15.0-45 erforderliche Korrektur in:/etc/modprobe.d/alsa-base.confmittels # auskommentiert:# options snd-hda-intel mode=mute-led-gpioNach Neustart mit Kernel >4.19.19-041919-generic< zeigen nun die Status-LED's in den Hotkey's [f5] Speaker-Mute und [f8] Mikro-Mute auch den Zustand (On / Off) an, siehe Anhang.

Da >ukuu< auch höhe Versionen als 4.19.19 anzeigt, wurde ich neugierig und habe mir die Changes angesehen und zuletzt den ebenfalls Bugbereinigten >4.19.24< installiert. Bisher bemerkte ich keine Systemauffälligkeiten, Tastatur, Grafik, Sound, Drucker, Scanner soweit i.O. :D

Die Aktual.-Verwaltung zeigt den/die Installierten Mainline-Kernelversion und kann damit auch deinstalliert werden:
Aktual.-Verw. Mainline-Kernel 4.19.24 041924
Aktual.-Verw. Mainline-Kernel 4.19.24 041924

dpkg -l | grep linux-[ghit]
ii  linux-headers-4.19.24-041924                4.19.24-041924.201902200632                 all          Header files related to Linux kernel version 4.19.24
ii  linux-headers-4.19.24-041924-generic        4.19.24-041924.201902200632                 amd64        Linux kernel headers for version 4.19.24 on 64 bit x86 SMP
ii  linux-image-unsigned-4.19.24-041924-generic 4.19.24-041924.201902200632                 amd64        Linux kernel image for version 4.19.24 on 64 bit x86 SMP

Einige Fragen an die Kernel-Experten im Forum, die aus der Antwort #30 von Anthony Wong auf launchpad resultieren:
Zitat
3. and see when their update will flow into future kernels. ;)
a) EDITbetrifft die Bereinigung nur diesen (Mainline) Kernel 4.19.19-041919?
b) wird dieser Bug-bereinigte Kernel 4.19.19-041919 zukünftig upgedatet? EDIT: 4.19.20, 4.19.21, 4.19.22, 4.19.23 und 4.19.24 wurden heute ebenfalls Bug bereinigt.
c) oder resultiert daraus gar eine neue Kernel-Linie?
d) muss ich nun bei der Kernellinie 4.19.19 >.24 bleiben, denn die wird ja offiziell noch nicht unterstützt?
e) oder wäre es besser mit dem offiziellen Kernel 4.15.0-45, incl. der Korrektur in: /etc/modprobe.d/alsa-base.conf, weiter zu arbeiten und auf eine Bugkorrektur in 4.15.0-46 zu warten?

Update: Beim testen der Kernel-Linien 4.20.1 > 4.20.10 und 5.0.0-rc1 > rc6 mit >ukuu< zeigt sich damit weiterhin der Bug.
Update: Das Bug-Fix fließt ab 4.20.11-042011 in den Mainline-Kernel ein ;D
Update:installierten Mainline-Kernel können nur mit ukuu aktualisiert werden, aktueller Kernel > 4.20.13-042013 siehe Crosspost: https://www.linuxmintusers.de/index.php?topic=53801.msg731477#msg731477

Die nach Kaltstart>LM19.1 permanent leuchtende Status-LED im Hotkey [f11] ist eine andere Baustelle bei: https://bugzilla.kernel.org/show_bug.cgi?id=202367
Bisher erfolgte leider noch keine Rückmeldung, deren Prozedere ist mir noch unbekannt.

Bedauerlich auch das @secureIT nicht mehr an Bord ist, aber vielleicht liest er ja als "Gast" weiter mit.
« Letzte Änderung: 06.03.2019, 16:22:55 von kuehhe1 »

Re: HP ProBook 470 G5, LM19 Cin, Problem mit Hotkey Status LEDs
« Antwort #27 am: 05.03.2019, 12:55:43 »
Update,
nach Bereitstellung des Kernel 5.0.0-050000 in Ukuu hab ich das Changelog kontrolliert, die zuvor ab > 4.20.11 eingeflossenen Korrekturen für die von "ALSA" abhängigen Hotkey LEDs sind nicht mehr protokolliert.

Mit Ukuu Installierte Kernel-Module:
dpkg -l | grep linux-[ghit]
ii  linux-headers-4.20.13-042013                4.20.13-042013.201902270533                 all          Header files related to Linux kernel version 4.20.13
ii  linux-headers-4.20.13-042013-generic        4.20.13-042013.201902270533                 amd64        Linux kernel headers for version 4.20.13 on 64 bit x86 SMP
ii  linux-headers-5.0.0-050000                  5.0.0-050000.201903032031                   all          Header files related to Linux kernel version 5.0.0
ii  linux-headers-5.0.0-050000-generic          5.0.0-050000.201903032031                   amd64        Linux kernel headers for version 5.0.0 on 64 bit x86 SMP
ii  linux-image-unsigned-4.20.13-042013-generic 4.20.13-042013.201902270533                 amd64        Linux kernel image for version 4.20.13 on 64 bit x86 SMP
ii  linux-image-unsigned-5.0.0-050000-generic   5.0.0-050000.201903032031                   amd64        Linux kernel image for version 5.0.0 on 64 bit x86 SMP
Bisher zeigten sich keine Systemauffälligkeiten.
Aktual.-Verw. Mainline-Kernel 5.0.0 050000
Aktual.-Verw. Mainline-Kernel 5.0.0 050000

Leider besteht damit der LED-Fehler im Hotkey [f11] (Wlan-Aus) weiterhin und ist eine andere Baustelle bei: https://bugzilla.kernel.org/show_bug.cgi?id=202367
« Letzte Änderung: 11.03.2019, 12:39:25 von kuehhe1 »