Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.03.2020, 09:28:59

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 23664
  • Letzte: WhatIf25
Statistiken
  • Beiträge insgesamt: 649424
  • Themen insgesamt: 52571
  • Heute online: 545
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [erledigt] Externe Festplatte schaltet beim Herunterfahren nicht ab  (Gelesen 2345 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Externe Festplatte schaltet beim Herunterfahren nicht ab
« am: 20.10.2018, 11:58:52 »
Hallo an Alle,
Ich habe eine externe Festplatte die wird von Linux Mint 19 beim Herunterfahren nicht ausgeschaltet von Windows 7 aber schon.
Es handelt sich dabei um eine Hitachi HDS 721010CLA332 1 TB HDD, eine 3.5 " interne meines ehemaligen PC die in einem externen Gehäuse von Logilink steckt.
Könnt Ihr mir helfen wie ich Linux dazu bringe die auszuschalten.
Wäre für eine Antwort dankbar
« Letzte Änderung: 02.11.2018, 10:40:22 von woolfman »

tml

  • Gast
Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #1 am: 20.10.2018, 17:06:13 »
https://www.linuxmintusers.de/index.php?topic=49999
Könnte vielleicht funktionieren...

Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #2 am: 22.10.2018, 13:25:52 »
Hi :)
in der firmware / bios
usb power u.ä. abschalten, damit die usb anschlüsse stromlos sind.

Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #3 am: 23.10.2018, 10:17:12 »
Vielen Dank für die Tipps
@ethron
Im UEFI meines Lenovo gibt es nur einen Punkt der mit USB zu tun hat und das ist USB-Legacy, das hat aber mit dem Power-Off Problem nichts zu tun.
Ich muß dazu sagen das UEFI vom Ideapad G580 Modell 20150 ist ein von Lenovo selbstgestricktes Minimal UEFI, da gibts weder Secure Boot noch andere in den in den "normalen" G 580 UEFIs vorhandenen Punkte. Ausserdem hat der nicht einmal Bluetooth wie die anderen.
Ich hab den im Jahr 2013 um € 502,00 bei Amazon erstanden was mir sehr günstig vorgekommen ist da die übrigen G 580 Modelle alle über € 700,00 gekostet haben. War wiedereinmal am falschen Platz gespart, den nach 2 Jahre war die HDD und der Speicher hinüber und ich hab dann die Samsung 850 EVO 500 GB und 16 GB Crucial Speicher nachgerüstet Kostenpunkt € 180,00, da hätte ich mir gleich einen der teureren Modelle kaufen können. Seit dem läuft Windows 7 seit 3 Jahren stabil ohne BSODs.
Aber das Jammern hilft mir auch nicht weiter. Habt Ihr vielleicht noch ein paar andere Tipps für mich.

Herzliche Grüße
woolfman




Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #4 am: 23.10.2018, 13:17:53 »
Hi :)
die desktop info fehlt... siehe meine sig ;)

Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #5 am: 24.10.2018, 07:39:11 »
Hallo ehtron,
Meine Version ist Linux Mint 19 - Cinnamon, aber was du mit Desktop Info meinst ist mir nicht klar, also bitte um Nachhilfe.

Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #6 am: 24.10.2018, 08:41:04 »
Dein Desktop ist Cinnamon!


Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #7 am: 24.10.2018, 08:49:55 »
Hallo,
wenn, dann lassen sich die USB-Anschlüsse im BIOS/UEFI bei ausgeschaltetem Rechner komplett abschalten. Die Option nennt sich normalerweise „Alway on USB“, und sorgt dafür, das die Ports bestromt bleiben, um z.B. Geräte laden zu können (Smartphone usw.)

Das ext. Festplattengehäuse muss hier aber eine separate Stromversorgung besitzen, da ja einen herkömmliche 3,5'' Desktop-Festplatte angeschlossen ist. Schaltest Du die Stromversorgung der Platte bzw. des ext. Gehäuses nicht aus? Windows sendet anscheinend nur einen Spinndown-Befehl an die Platte.

Unter Linux lässt sich das mittels hdparm in der /etc/hdparm steuern.
man  hd parm
# Beispiel (Laufwerksbezeichnung muss angepasst werden!)
sudo hdparm -y /dev/sdx
« Letzte Änderung: 24.10.2018, 09:03:51 von Flash63 »

Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #8 am: 24.10.2018, 13:51:03 »
Hi :)
du kannst mal schauen ob du die platte in
laufwerke
schlafen legen kannst (in bereitschaft gehen)
und in den einstellungen die bereitschaftszeit einstellen.

Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #9 am: 25.10.2018, 11:31:07 »
Vielen Dank für eure Anregungen aber es hilft nichts, mit hdparm -y schaltet sich die Festplatte zwar aus, wird aber beim Herunterfahren von Mint wieder aktiviert und läuft nach beendigtem Herunterfahren munter weiter, dasselbe beim ausschalten über Laufwerke. Bleibt nichts anderes übrig als nach beenden von Mint die Festplatte manuell auszuschalten.

Vielen Dank.

Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #10 am: 25.10.2018, 13:52:29 »
Hi :)
du solltest ja auch eine zeit setzen, die wird im laufwerk gespeichert... und könnte den shutdown überleben

Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #11 am: 26.10.2018, 10:03:26 »
Hallo ethron,
habe gerade mit dem Befehl sudo hdparm -I /dev/sdb1 | grep level nachgeschaut und das Ergebnis war Advanced power management level: disabled, kann das der Grund sein das das Abschalten deshalb nicht funktioniert und kann man das Advanced power management irgendwie mit hdparm einschalten.
Edit:
habs gerade mit sudo hdparm -B versucht APM level bleibt auf off, scheinbar funktioniert das APM mit dieser Festplatte nicht.
« Letzte Änderung: 26.10.2018, 10:43:44 von woolfman »

tml

  • Gast
Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #12 am: 26.10.2018, 11:10:30 »
Wenn es mit hdparm nicht funktioniert, probier es mit hd-idle.

Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #13 am: 26.10.2018, 13:42:09 »
Hi :)
sakkra... warum machst du es nicht einfach in
laufwerke?

Re: Externe Festplatte schaltet beim Herunterfahren nicht ab
« Antwort #14 am: 29.10.2018, 07:56:32 »
Hallo ethron,
bin scheinbar zu blöd dazu, starte aus dem Menu die App Laufwerke, wähle dann die Festplatte, ganz oben ist dann ein Power-Icon (Ballontip Ausschalten) klicke es an und es tut sich nichts, die Festplatte läuft munter weiter. Was mach ich falsch?