Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
17.10.2018, 09:58:54

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 552672
  • Themen insgesamt: 44593
  • Heute online: 442
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online
Mitglieder: 7
Gäste: 425
Gesamt: 432

Autor Thema:  WARNING: amdgpu dkms failed for running kernel  (Gelesen 403 mal)

0 Mitglieder und 2 Gäste betrachten dieses Thema.

WARNING: amdgpu dkms failed for running kernel
« am: 11.10.2018, 09:37:12 »
Hallo,

ich versuche schon länger mit Linux warm zu werden.
Nachdem mir die halbjährlichen Windows updates mir immer mehr Fehler bescherren, will das jetzt um so mehr.

Allerdings hab ich jetzt ein Problem mit der installation meiner Grafikkarte.
Beim versuch den AMDgpu 18.20-606296 und 18.30 zu installieren, bekomme ich am ende der Installation die Meldung :

WARNING: amdgpu dkms failed for running kernel
sonst nichts.

Linux Mint 19 Cinnamon 64 bit
 
CPU : R5 1600x
MB : MSI B350 Mortar
GPU : Asus R9 280-DC2T-3GD5
RAM: Corsair CMK16GX4M2B3200C16 2x 8GB 3200 CL16
Sound : Creative Sound Blaster X-Fi Titanium
SSD : Samsung 850Evo 500GB

versucht hab ich die Anleitung :
https://support.amd.com/en-us/kb-articles/Pages/Installation-Instructions-for-amdgpu-Graphics-Stacks.aspx

https://forums.linuxmint.com/viewtopic.php?t=272074

Ich hab die Fehlermeldung auch bereits gegoogelt und im Forum gesucht allerdings halfen mir die Ergebnisse nicht weiter.
Für Hilfe wäre ich echt dankbar.

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #1 am: 11.10.2018, 10:42:30 »
Hallo Picknicker,

was ich so googeln konnte ist das wohl ein Problem das auch Ubuntu hat.
Du hast auch schon die Lösung gefunden. Respekt.  ;)

So wie ich Deinen Text verstehe, ist also Mint 19 bereits installiert und es scheitert nur daran wie Du den Lösungsansatz richtig umsetzt?
« Letzte Änderung: 11.10.2018, 14:56:45 von gas103 »

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #2 am: 11.10.2018, 11:01:40 »
Hallo

anscheinend schon , ich seh die Lösung nicht. *Kopfkratz*

Installiert ist Mint 19. Kernel update auf 17 und 18 sowie eine aktualisierung hab ich auch schon durchgeführt.

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #3 am: 11.10.2018, 12:22:15 »
Ganz dumm gefragt...dkms ist installiert?

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #4 am: 11.10.2018, 12:37:14 »
Hallo

Vulkan hatte ich zuvor installiert,

nachdem
$ ./amdgpu-pro-install --opencl=legacy

zum selben Ergebnis führte :
WARNING: amdgpu dkms failed for running kernel

versuchte ich :
https://askubuntu.com/questions/1040474/warning-amdgpu-dkms-failed-for-running-kernel-on-both-16-04-18-04

apt install amdgpu-dkms libdrm-amdgpu-amdgpu1 libdrm-amdgpu1 libdrm2-amdgpu 

fehlermeldung blieb. Damit müßte dkms ja installiert sein?

Aber wahrscheinlich wird es sowas einfaches sein, was ich von Windows nicht kenne.
« Letzte Änderung: 11.10.2018, 12:59:42 von Picknicker »

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #5 am: 11.10.2018, 13:39:16 »
du installierst irgendwas von amd mitvl dkms... es gibt aber das paket dkms. Dazu siehe auch das ubuntuusers wiki. Einfach malbtesten mit apt install dkms. Wenns installiert ist, dann bin ich raus, wenn nicht nachholen.

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #6 am: 11.10.2018, 13:44:16 »
Hi :)
dkms ist unter mint standardmässig installiert...

das modul kommt mit dem aktuellen kernel nicht klar.. als kernel nutzen mit dem das treiber modul funktioniert.

ich frage mich, warum amdgpu-pro sein muss..
die amds laufen doch mittlerweile sehr gut mit den internen kernel modulen.

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #7 am: 11.10.2018, 13:47:42 »
Hallo

vielen Dank . Dies werde ich ausprobieren.
Ich dachte das Problem sei Treiberspezifisch, daher suchte ich in die Richtung.

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #8 am: 11.10.2018, 13:53:14 »
Hallo

weil ich Lutris mit Radeon Treiber den Blizzard Launcher nicht zum laufen bekomme.

Steam lief mit Proton ja , ...

Auf Phoronix stand das die unterstützten Polaris und Vega Karten erst ab Kernel 4.17 und 4.18 unterstützt werden .
Diese hatte ich ja auch versucht. Oder muß man verschiedene Versionen testen bis man den passenden hat?
« Letzte Änderung: 11.10.2018, 14:44:31 von Picknicker »

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #9 am: 11.10.2018, 16:26:00 »
Warm werden... eigentlich versuchst du doch Linux mit Windows zu benutzen. Da wirst du immer an irgend welche Grenzen stoßen.
Linux ist kein Windows. Ein guter Kompromiss wäre ein Dualboot System. Denke das man dich da schon daraufhin gewiesen hat.
Als Gamer macht das echt Sinn. Wenn das Spiel nicht nativ unter Linux läuft würde ich es unter Windows zocken.
« Letzte Änderung: 11.10.2018, 16:57:56 von Moridian »

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #10 am: 12.10.2018, 09:27:35 »
Moin,

also eigentlich wollte ich nur ein Linux Treiber unter Linux installieren, erstmal. :D

Ehtron hat wohl recht, ich habe gesten noch mal alles neu installiert und bei gleichbleibender Fehlermeldung.
Als ich "$ lspci -k" nachschaute , stand da :

installiert : amdgpu, Radeon
in benutzung : Radeon

Zum ausprobieren installiert ich den Rest auch noch (Wine, Lutris, Blizzard Launcer).
Beim starten aus dem Terminal von Lutris , stand dort die Meldung, das mindestens dms 3.00 benötigt wird und nur 2.50 installiert sei.

Also werde ich am Wochenende mal ein Kernel nach dem anderen testen.

Kann es sein das "amdgpu" nur bei Bedarf / Anwendung geladen wird?
Die Installation schein ja in Ordnung zu sein.

Zum Thema Dualboot, ich hatte 2 Jahre einen aber ...
wenn man Windows noch drauf hat geht man meist den bequemeren / schnelleren Weg. :-[

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #11 am: 12.10.2018, 12:41:02 »
Linux Mint 19 basiert auf dem 15er Kernel. Wenn man davon abweicht, ist man auf sich selbst gestellt. Neue Kernel sind mit ihren 100000 Flags nicht auf die Distribution abgestimmt! Da sollte man schon sehr, sehr genau wissen was man wie warum treibt - oder die Finger davon lassen.


Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #12 am: 12.10.2018, 13:55:16 »
Danke für den Tip

Re: WARNING: amdgpu dkms failed for running kernel
« Antwort #13 am: 15.10.2018, 10:58:05 »
Hallo,

der "amdgpu 18.20" ließ sich einfach nicht installieren.

Jetzt hab ich mir den "18.30" vorgenommen, dieser ließ sich leider auch nicht installieren und brach mit der Begründung falsches OS ab.

Ich habe nach Anleitung :
- https://forums.linuxmint.com/viewtopic.php?t=272074

Namen und Version an Ubuntu angepaßt in der "/etc/os-release file" und als Versuch auch im "amdgpu-pro-install script".
Bei der Installation von Amdcore anekommen bricht dieser wieder mit falsches OS ab.

Ich hab jetzt erstmal Ubuntu genommen dort, läßt sich der Treiber "18.30" ohne weiteres installieren.