Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
21.11.2018, 01:15:59

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21086
  • Letzte: Pemfakt
Statistiken
  • Beiträge insgesamt: 557526
  • Themen insgesamt: 45114
  • Heute online: 374
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 5
Gäste: 312
Gesamt: 317

Autor Thema:  Bootmenü erscheint erst nach 30 Sekunden  (Gelesen 705 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Bootmenü erscheint erst nach 30 Sekunden
« am: 12.09.2018, 12:41:29 »
Hallo zusammen,

die Festplatte meines Notebooks enthält aktuell 4 Systempartitionen, 3 davon mit Linux Mint Mate 19, eine mit Linux Mint Mate 18.3, außerdem noch 3 Partitionen für Daten. Die Platte (ssd) habe ich vor ein paar Tagen neu gekauft und gegen die alte ausgetauscht.

Gestern Abend gab es noch eine fünfte Systempartition mit Mint Mate 19, die hatte ich mir angelegt, um darauf mit neuer Software ein bisschen zu experimentieren. Unter diesem System wollte ich mir gestern mal die Systemschnappschüsse ansehen. Ich habe dann aus Versehen auf "Erstellen" geklickt und die Aktion gleich wieder abgebrochen. Anschließend wollte ich auf einer anderen Systempartition arbeiten, habe den Rechner neu gestartet und es erschien kein Bootmenü mehr. Dann habe ich mir von einem Livesystem aus mit testdisk meine Festplatte anzeigen lassen. Es gab keine bootbare Partition mehr darauf und meine Test-Systempartition war offenbar kaputt. Die habe ich also von testdisk löschen lassen und mir eine neue Partitionstabelle schreiben lassen. Dann habe ich nach der Anleitung von Ubuntuusers (https://wiki.ubuntuusers.de/GRUB_2/Reparatur/) mit der chroot-Methode grub neu installiert. Jetzt bootet der Rechner wieder, allerdings dauert es von der BIOS-Meldung bis das Bootmenü erscheint fast 30 Sekunden. Vor dem ganzen Desaster war es sofort da.

Hat jemand eine Idee, was der Grund für diesen langen Zeitraum zwischen BIOS-Meldung und Bootmenü sein könnte, und wie ich das ändern kann?

Gruß, Tais




Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #1 am: 12.09.2018, 13:58:51 »
Hallo,

Zeige mal bitte:
sudo parted --list
Danke

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #2 am: 12.09.2018, 14:06:34 »
Modell: ATA SanDisk SDSSDA48 (scsi)
Festplatte  /dev/sda:  480GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe   Typ       Dateisystem     Flags
 1      1049kB  480GB   480GB   extended                  LBA
 5      2097kB  42,3GB  42,2GB  logical   ext4
 6      42,3GB  74,7GB  32,4GB  logical   ext4
 7      74,7GB  107GB   32,4GB  logical   ext4
 8      139GB   171GB   32,0GB  logical   ext4
 9      171GB   198GB   27,2GB  logical   ext4
10      198GB   251GB   53,0GB  logical   ext4
11      251GB   337GB   85,5GB  logical   ext4
12      337GB   471GB   134GB   logical   ext4
13      471GB   480GB   9162MB  logical   linux-swap(v1)


Modell: TOSHIBA TransMemory (scsi)
Festplatte  /dev/sdb:  31,2GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 1      1049kB  31,2GB  31,2GB  primary  ext4

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #3 am: 12.09.2018, 14:09:35 »
Hi :)
update-grub von der haupt installation aus laufen lassen?

alte kernel entfernt?

wo steckt grub?
sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #4 am: 12.09.2018, 14:11:14 »
Noch nicht, ich probiere es und melde mich dann wieder. Danke schon mal für die Antwort.

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #5 am: 12.09.2018, 14:12:52 »
Ist das schon ein UEFI-Rechner?

inxi -Fz
Bei so vielen Partitionen hätte ich keine msdos Partitionstabelle genommen sondern gpt (geht auch bei BIOS-Rechnern).

Zudem fehlt auf des SSD der unpartitionierte Bereich, den man freilassen sollte.

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #6 am: 12.09.2018, 14:35:37 »
Ist das schon ein UEFI-Rechner?

Nein.

Hier ist inxi -Fz:

System:    Host: xxx-ThinkPad-X230 Kernel: 4.15.0-34-generic x86_64 bits: 64 Desktop: MATE 1.20.1
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: LENOVO product: 2325BF2 v: ThinkPad X230 serial: N/A
           Mobo: LENOVO model: 2325BF2 serial: N/A UEFI [Legacy]: LENOVO v: G2ETA2WW (2.62 ) date: 09/12/2014
Battery    BAT0: charge: 41.7 Wh 96.9% condition: 43.0/93.2 Wh (46%)
CPU:       Dual core Intel Core i5-3320M (-MT-MCP-) cache: 3072 KB
           clock speeds: max: 3300 MHz 1: 1213 MHz 2: 1365 MHz 3: 1306 MHz 4: 1295 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.02hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile version: 4.2 Mesa 18.0.5
Audio:     Card Intel 7 Series/C216 Family High Definition Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-34-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
           IF: wlp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 511.3GB (4.1% used)
           ID-1: /dev/sda model: SanDisk_SDSSDA48 size: 480.1GB
           ID-2: USB /dev/sdb model: TransMemory size: 31.2GB
Partition: ID-1: / size: 39G used: 9.1G (25%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 9.16GB used: 0.00GB (0%) fs: swap dev: /dev/sda13
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 2958
Info:      Processes: 183 Uptime: 7 min Memory: 852.2/7675.5MB Client: Shell (bash) inxi: 2.3.56

Bei so vielen Partitionen hätte ich keine msdos Partitionstabelle genommen sondern gpt (geht auch bei BIOS-Rechnern).

Warum?

Zudem fehlt auf des SSD der unpartitionierte Bereich, den man freilassen sollte.

Wozu ist der gut? Glaubst du, dass deshalb das Bootmenü so lang braucht, bis es erscheint?

update-grub hat nichts verändert.

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #7 am: 12.09.2018, 14:43:25 »
Zitat von: tommix am Heute um 14:12:52

    Ist das schon ein UEFI-Rechner?


Nein.

Doch! Mein Lenovo X220 hat schon UEFI!
Mobo: LENOVO model: 2325BF2 serial: N/A UEFI [Legacy]: LENOVO v: G2ETA2WW (2.62 ) date: 09/12/2014

Du nutzt ihn nur im BIOS - Mode.

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #8 am: 12.09.2018, 14:46:11 »

Du nutzt ihn nur im BIOS - Mode.

Genau. Ich dachte, das willst du wissen.

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #9 am: 12.09.2018, 15:55:14 »
Entschuldige, deinen Code für "Wo steckt Grub?" habe ich völlig übersehen (ich mache nebenbei gerade Mathe).

Hier die Antwort:
/dev/sda: GRUB 2 v1.99
/dev/sda1: Kein GRUB 00
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sda7: Kein GRUB 00
/dev/sda8: Kein GRUB 00
/dev/sda9: Kein GRUB 00
/dev/sda10: Kein GRUB 00
/dev/sda11: Kein GRUB 00
/dev/sda12: Kein GRUB 00
/dev/sda13: Kein GRUB 00
/dev/sdb: Kein GRUB 00
/dev/sdb1: Kein GRUB 00

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #10 am: 12.09.2018, 17:43:06 »
Hi :)
und kernel frage?

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #11 am: 13.09.2018, 12:02:47 »
Hallo, ich habe mich gestern nicht mehr gemeldet, weil ich gestern Abend noch einen Termin hatte, den ich beinahe vergessen hätte  :o, da musste ich dann ganz schnell weg  ;D.

Alte Kernel muss ich nicht entfernen, ich habe ja alle Systeme erst vor ein paar Tagen ganz frisch installiert. Aktuell habe ich nur 4.15.0-34, 4.15.0-33 und 4.15.0-20 auf dem Rechner.

Hier mein /boot-Verzeichnis:
abi-4.15.0-20-generic
abi-4.15.0-33-generic
abi-4.15.0-34-generic
config-4.15.0-20-generic
config-4.15.0-33-generic
config-4.15.0-34-generic
grub
initrd.img-4.15.0-20-generic
initrd.img-4.15.0-33-generic
initrd.img-4.15.0-34-generic
memtest86+.bin
memtest86+.elf
memtest86+_multiboot.bin
retpoline-4.15.0-20-generic
retpoline-4.15.0-33-generic
retpoline-4.15.0-34-generic
System.map-4.15.0-20-generic
System.map-4.15.0-33-generic
System.map-4.15.0-34-generic
vmlinuz-4.15.0-20-generic
vmlinuz-4.15.0-33-generic
vmlinuz-4.15.0-34-generic
« Letzte Änderung: 13.09.2018, 12:12:00 von tais »

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #12 am: 13.09.2018, 12:59:06 »
Hi :)
ich würde mal den ältesten per akt-verw. entfernen..  wozu braucht man 3?

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #13 am: 13.09.2018, 14:14:20 »
Ich habe jetzt auf allen Systempartitionen die alten Kernel gelöscht. Er braucht immer noch so lang, bis das Bootmenü kommt. Ich habe heute beim Entfernen der Kernel und gestern bei update-grub auch an den Meldungen während dieser Vorgänge beobachtet, dass er sehr lang braucht, bis er die Systempartitionen findet.

Re: Bootmenü erscheint erst nach 30 Sekunden
« Antwort #14 am: 14.09.2018, 12:43:31 »
Hi :)
Zitat
Ich habe jetzt auf allen Systempartitionen die alten Kernel gelöscht.
wie?

vermutlich nicht über die aktualisierungsverwaltung... obwohl ich es extra betont habe.