Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
20.03.2019, 23:06:31

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21718
  • Letzte: Seppiro
Statistiken
  • Beiträge insgesamt: 580323
  • Themen insgesamt: 46994
  • Heute online: 675
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  Kein WLAN LM19 und Realtek rtl8821ce  (Gelesen 2889 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #15 am: 01.09.2018, 11:51:31 »
Ich schubse das Thema noch einmal hoch, denn mit der Zeit baut sich eine gewisse Dringlichkeit auf, da es wohl mal wieder Zeit ist, die Aktualisierungsverwaltung zu bemühen - ich möchte ja ein sicheres und aktuelles System haben. Daher stellen sich mir verschiedene Fragen:

1) Wie schaffe ich es, dass der manuell installierte WLAN-Treiber im System so verankert wird, dass ich beim nächsten (Kernel?-)Update nicht wieder ohne WLAN dastehe?

Alternativ
2) Wie sage ich dem System, es möge doch bitte nur Aktualisierungen durchführen, die den WLAN-Treiber unberührt lassen.

Alternativ
3) Kann ich die Aktualisierung des Systems "testweise" durchführen und dann zurück, quasi eine Simulation durchführen?

Alternativ
4) Wie rolle ich eine Aktualisierung zurück, die den WLAN-Treiber "zerschossen" hat und wie finde ich überhaupt raus, welches Paket nun schuldig war.

Alternativ
5) Flash63 hatte einen neueren Treiber für den aktualisierten Kernel gefunden - wie mache ich das? Wohl googeln, aber wie sehe ich die Version, die ich brauche und wie erkenne ich diese bei den Suchergebnissen?

Vielen Dank noch einmal allen!

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #16 am: 01.09.2018, 13:09:26 »
Zu 1)
https://wiki.ubuntuusers.de/DKMS/
Zitat
… überwacht, ob zusätzliche Kernelmodule manuell installiert wurden und aktualisiert die Module immer dann, wenn ein neuer oder aktualisierter Kernel installiert wird.
erster Überblick: dkms status
« Letzte Änderung: 01.09.2018, 13:16:46 von aexe »

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #17 am: 01.09.2018, 14:49:02 »
mp@Gert:~$ dkms status
mp@Gert:~$
Nichts bedeutet ja normalerweise, keine Fehlermeldung. Aber bei einer Statusfrage? Gut, dass das hier im Newbiebereich ist :D.

Edit:
ls -l /var/lib/dkms
insgesamt 4
-rw-r--r-- 1 root root 6 Aug 31  2016 dkms_dbversion

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #18 am: 01.09.2018, 15:19:14 »
Falls es sich um ein Live-System handelt, ist ein Kernel-Update ohnehin nicht möglich.
Habe das gerade erst im Betreff entdeckt.
Gut, dass das hier im Newbiebereich ist
Wieso das?

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #19 am: 01.09.2018, 15:45:11 »
Es ist kein Live-System. Das Problem trat im live-System auf, wurde mit Hilfe behoben (Treiber runtergeladen und mit make kompiliert). Dann habe ich das erste mal die Aktualisierungsverwaltung durchlaufen lassen, woraufhin ich wieder kein WLAN hatte. Da es nahtlos ineinander überging, war ein neuer Thread nicht sinnvoll. Neue Treiber wurden gefunden und wieder mit make installiert (es war meine erste Installation von Quellcode, ich konnte und kann es noch nicht besser). Eigentlich blieb nur noch die Überführung in dkms offen. Deshalb habe ich den Thread noch einmal hochgeschubst, um das Thema abzuschließen. Vielleicht hätte man schon die erste Treiberinstallation mit dkms gemacht (?).
Es ist gut im Newbiebereich aufgehoben, weil ich völlig ahnungslos bin, was ich tun soll. Das DKMS-Wiki ist zwar recht ausführlich, aber der Treiber ist ja schon installiert (mit make) und ich will mir nicht nochmal eine Doppelinstallation auf das System frickeln.

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #20 am: 02.09.2018, 10:32:20 »
Hallo,
Du bist doch schon auf halbem Weg, eine Einzelinstallation des Treiber für den aktuellen Kernel hast Du schon erfolgreich durchgeführt. Mittels DKMS ist auch nicht so schwierig.
Schritt  1:
* DKMS installieren
sudo apt install dkms libelf-devSchritt 2:
* im Installtionsverzeichnis aufräumen (Objektdateien löschen) und installiertes Modul entfernen
cd rtl8821ce-driver
sudo make uninstall
make clean
sudo depmod -a
sudo update-initramfs -u
Schritt 3:
* die Datei dkms.conf im Installationsverzeichnis anlegen. So wie im Wiki beschrieben den Modulnamen usw. an die tatsächlichen Gegebenheiten anpassen
touch dkms.confDatei bearbeiten, folgenden Inhalt einfügen und abspeichern:
PACKAGE_NAME=rtl8821ce
PACKAGE_VERSION=5.2.5_23431.20170824
DEST_MODULE_LOCATION=/updates
BUILT_MODULE_NAME=8821ce
MAKE="'make' all"
CLEAN="'make' clean"
AUTOINSTALL="yes"
Schritt 4: Installation
* Quellcode nach /usr/src/... kopieren und über DKMS einbinden (die Prozedur wurde inzwischen etwas vereinfacht):
sudo cp -r ~/rtl8821ce-driver /usr/src/rtl8821ce-5.2.5_23431.20170824
sudo dkms install -m rtl8821ce -v 5.2.5_23431.20170824
# oder noch etwas einfacher:
sudo dkms install rtl8821ce/5.2.5_23431.20170824
Keine Fehler? Abschließend prüfen:
dkms status
modinfo 8821ce
Installation bei Bedarf wieder vollständig entfernen:
sudo dkms remove -m rtl8821ce -v 5.2.5_23431.20170824 --all
# wieder etwas einfacher:
sudo dkms remove rtl8821ce/5.2.5_23431.20170824 --all
sudo rm -r /usr/src/rtl8821ce*

Hinweis:
Da kein Full-Mac Treiber (iw funktioniert nicht) sollte die korrekte Konfiguration der Sendeleistung und Kanalfreigaben manuell geprüft über die beiden folgenden Modulparameter bei Bedarf eingestellt werden:
parm:           rtw_country_code:The default country code (in alpha2) (charp)
parm:           rtw_channel_plan:The default chplan ID when rtw_alpha2 is not specified or valid (int)
« Letzte Änderung: 02.09.2018, 10:41:49 von Flash63 »

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #21 am: 02.09.2018, 21:28:12 »
Lieber Flash63,

vielen, vielen Dank, ich werde mich demnächst mal daran machen - wir müssen morgen zur Steuerfachfrau. Ich melde mich dann.

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #22 am: 03.09.2018, 14:50:29 »
Hi :)
wenn man probleme beim automatischen kernel update vermutet, dies einfach in aktualisierungsverwaltung einstellungen
abschalten..
die beiden unteren clicker ausschalten.

achtung! fenster vorher nach unten vergrössern ;)

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #23 am: 03.09.2018, 21:29:34 »
Schritt eins, also die dkms-Installation habe ich ausgeführt. dkms status gibt aber immer noch keine Rückmeldung (falls das nicht normal ist).
mp@Gert:~$ dkms status
mp@Gert:~$ ls -l /var/lib/dkms
insgesamt 4
-rw-r--r-- 1 root root 6 Aug 31  2016 dkms_dbversion

Ich scheitere aber hieran:
* im Installtionsverzeichnis aufräumen (Objektdateien löschen) und installiertes Modul entfernen

Ich weiß nicht, wo das Installationsverzeichnis der mit make installierten Treiber ist.  Der Terminalbefehl gibt einen Fehler zurück. Es gibt den Ordner rtl8821ce-driver-master, aber das ist das von GitHub heruntergeladene Installationsverzeichnis.
mp@Gert:~$ cd rtl8821ce-driver
bash: cd: rtl8821ce-driver: Datei oder Verzeichnis nicht gefunden
mp@Gert:~$ cd rtl8821ce-driver-master

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #24 am: 04.09.2018, 05:35:39 »
Das ist egal, dein Verzeichnis lautet nur etwas anders, da Du den Quellcode über das zip-Archiv heruntergeladen hast, ich habe git verwendet.

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #25 am: 04.09.2018, 11:39:31 »
Es scheint funktioniert zu haben. Interessanterweise habe ich immer die WLAN- und Internetverbindung behalten. Ich hätte erwartet, die geht zwischendurch verloren.

mp@Gert:~$ cd rtl8821ce-driver-master/
mp@Gert:~/rtl8821ce-driver-master$ sudo make uninstall
[sudo] Passwort für mp:
rm -f /lib/modules/4.15.0-33-generic/kernel/drivers/net/wireless//8821ce.ko
/sbin/depmod -a 4.15.0-33-generic
mp@Gert:~/rtl8821ce-driver-master$ make clean
#make -C /lib/modules/4.15.0-33-generic/build M=/home/mp/rtl8821ce-driver-master clean
cd hal ; rm -fr */*/*/*.mod.c */*/*/*.mod */*/*/*.o */*/*/.*.cmd */*/*/*.ko
cd hal ; rm -fr */*/*.mod.c */*/*.mod */*/*.o */*/.*.cmd */*/*.ko
cd hal ; rm -fr */*.mod.c */*.mod */*.o */.*.cmd */*.ko
cd hal ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd core/efuse ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd core ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd os_dep/linux ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd os_dep ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd platform ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
rm -fr Module.symvers ; rm -fr Module.markers ; rm -fr modules.order
rm -fr *.mod.c *.mod *.o .*.cmd *.ko *~
rm -fr .tmp_versions
mp@Gert:~/rtl8821ce-driver-master$ sudo depmod -a
mp@Gert:~/rtl8821ce-driver-master$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-4.15.0-33-generic
mp@Gert:~/rtl8821ce-driver-master$ touch dkms.conf
mp@Gert:~/rtl8821ce-driver-master$ sudo cp -r ~/rtl8821ce-driver-master /usr/src/rtl8821ce-5.2.5_23431.20170824
mp@Gert:~/rtl8821ce-driver-master$ sudo dkms install -m rtl8821ce -v 5.2.5_23431.20170824

Creating symlink /var/lib/dkms/rtl8821ce/5.2.5_23431.20170824/source ->
                 /usr/src/rtl8821ce-5.2.5_23431.20170824

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
'make' all...............................
Signing module:
 - /var/lib/dkms/rtl8821ce/5.2.5_23431.20170824/4.15.0-33-generic/x86_64/module/8821ce.ko
Secure Boot not enabled on this system.
cleaning build area...

DKMS: build completed.

8821ce.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-33-generic/updates/

depmod...

DKMS: install completed.
mp@Gert:~/rtl8821ce-driver-master$ dkms status
rtl8821ce, 5.2.5_23431.20170824, 4.15.0-33-generic, x86_64: installed
mp@Gert:~/rtl8821ce-driver-master$ modinfo 8821ce
filename:       /lib/modules/4.15.0-33-generic/updates/8821ce.ko
version:        v5.2.5_23431.20170824
author:         Realtek Semiconductor Corp.
description:    Realtek Wireless Lan Driver
license:        GPL
srcversion:     DAD6270FFFA31816F110FA4
alias:          pci:v000010ECd0000C82Bsv*sd*bc*sc*i*
alias:          pci:v000010ECd0000C82Asv*sd*bc*sc*i*
alias:          pci:v000010ECd0000C821sv*sd*bc*sc*i*
depends:        cfg80211
retpoline:      Y
name:           8821ce
vermagic:       4.15.0-33-generic SMP mod_unload
signat:         PKCS#7
signer:         
sig_key:       
sig_hashalgo:   md4
parm:           rtw_ips_mode:The default IPS mode (int)
parm:           rtw_lps_level:The default LPS level (int)
parm:           rtw_usb_rxagg_mode:int
parm:           rtw_dynamic_agg_enable:int
parm:           rtw_drv_log_level:set log level when insert driver module, default log level is _DRV_INFO_ = 4 (uint)
parm:           rtw_tx_bw_mode:The max tx bw for 2.4G and 5G. format is the same as rtw_bw_mode (uint)
parm:           rtw_rx_ampdu_sz_limit_1ss:RX AMPDU size limit for 1SS link of each BW, 0xFF: no limitation (array of uint)
parm:           rtw_rx_ampdu_sz_limit_2ss:RX AMPDU size limit for 2SS link of each BW, 0xFF: no limitation (array of uint)
parm:           rtw_rx_ampdu_sz_limit_3ss:RX AMPDU size limit for 3SS link of each BW, 0xFF: no limitation (array of uint)
parm:           rtw_rx_ampdu_sz_limit_4ss:RX AMPDU size limit for 4SS link of each BW, 0xFF: no limitation (array of uint)
parm:           rtw_vht_enable:int
parm:           rtw_vht_rx_mcs_map:VHT RX MCS map (uint)
parm:           rtw_rf_config:int
parm:           rtw_country_code:The default country code (in alpha2) (charp)
parm:           rtw_channel_plan:The default chplan ID when rtw_alpha2 is not specified or valid (int)
parm:           rtw_excl_chs:exclusive channel array (array of uint)
parm:           rtw_btcoex_enable:BT co-existence on/off, 0:off, 1:on, 2:by efuse (int)
parm:           rtw_ant_num:Antenna number setting, 0:by efuse (int)
parm:           rtw_force_igi_lb:force IGI low-bound, 0:no specified (int)
parm:           rtw_qos_opt_enable:int
parm:           ifname:The default name to allocate for first interface (charp)
parm:           if2name:The default name to allocate for second interface (charp)
parm:           rtw_pwrtrim_enable:int
parm:           rtw_initmac:charp
parm:           rtw_special_rf_path:int
parm:           rtw_chip_version:int
parm:           rtw_rfintfs:int
parm:           rtw_lbkmode:int
parm:           rtw_network_mode:int
parm:           rtw_channel:int
parm:           rtw_mp_mode:int
parm:           rtw_wmm_enable:int
parm:           rtw_vrtl_carrier_sense:int
parm:           rtw_vcs_type:int
parm:           rtw_busy_thresh:int
parm:           rtw_ht_enable:int
parm:           rtw_bw_mode:int
parm:           rtw_ampdu_enable:int
parm:           rtw_rx_stbc:int
parm:           rtw_rx_ampdu_amsdu:int
parm:           rtw_tx_ampdu_amsdu:int
parm:           rtw_lowrate_two_xmit:int
parm:           rtw_power_mgnt:int
parm:           rtw_smart_ps:int
parm:           rtw_low_power:int
parm:           rtw_wifi_spec:int
parm:           rtw_full_ch_in_p2p_handshake:int
parm:           rtw_antdiv_cfg:int
parm:           rtw_antdiv_type:int
parm:           rtw_drv_ant_band_switch:int
parm:           rtw_single_ant_path:int
parm:           rtw_switch_usb_mode:int
parm:           rtw_enusbss:int
parm:           rtw_hwpdn_mode:int
parm:           rtw_hwpwrp_detect:int
parm:           rtw_hw_wps_pbc:int
parm:           rtw_check_hw_status:int
parm:           rtw_pci_aspm_enable:int
parm:           rtw_max_roaming_times:The max roaming times to try (uint)
parm:           rtw_mc2u_disable:int
parm:           rtw_80211d:Enable 802.11d mechanism (int)
parm:           rtw_notch_filter:0:Disable, 1:Enable, 2:Enable only for P2P (uint)
parm:           rtw_hiq_filter:0:allow all, 1:allow special, 2:deny all (uint)
parm:           rtw_adaptivity_en:0:disable, 1:enable (uint)
parm:           rtw_adaptivity_mode:0:normal, 1:carrier sense (uint)
parm:           rtw_adaptivity_dml:0:disable, 1:enable (uint)
parm:           rtw_adaptivity_dc_backoff:DC backoff for Adaptivity (uint)
parm:           rtw_adaptivity_th_l2h_ini:th_l2h_ini for Adaptivity (int)
parm:           rtw_adaptivity_th_edcca_hl_diff:th_edcca_hl_diff for Adaptivity (int)
parm:           rtw_amplifier_type_2g:BIT3:2G ext-PA, BIT4:2G ext-LNA (uint)
parm:           rtw_amplifier_type_5g:BIT6:5G ext-PA, BIT7:5G ext-LNA (uint)
parm:           rtw_RFE_type:default init value:64 (uint)
parm:           rtw_powertracking_type:default init value:64 (uint)
parm:           rtw_GLNA_type:default init value:0 (uint)
parm:           rtw_TxBBSwing_2G:default init value:0xFF (uint)
parm:           rtw_TxBBSwing_5G:default init value:0xFF (uint)
parm:           rtw_OffEfuseMask:default open Efuse Mask value:0 (uint)
parm:           rtw_FileMaskEfuse:default drv Mask Efuse value:0 (uint)
parm:           rtw_rxgain_offset_2g:default RF Gain 2G Offset value:0 (uint)
parm:           rtw_rxgain_offset_5gl:default RF Gain 5GL Offset value:0 (uint)
parm:           rtw_rxgain_offset_5gh:uint
parm:           rtw_rxgain_offset_5gm:default RF Gain 5GM Offset value:0 (uint)
parm:           rtw_pll_ref_clk_sel:force pll_ref_clk_sel, 0xF:use autoload value (uint)
parm:           rtw_tx_pwr_by_rate:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_tx_pwr_lmt_enable:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_target_tx_pwr_2g_a:2.4G target tx power (unit:dBm) of RF path A for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_2g_b:2.4G target tx power (unit:dBm) of RF path B for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_2g_c:2.4G target tx power (unit:dBm) of RF path C for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_2g_d:2.4G target tx power (unit:dBm) of RF path D for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_5g_a:5G target tx power (unit:dBm) of RF path A for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_5g_b:5G target tx power (unit:dBm) of RF path B for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_5g_c:5G target tx power (unit:dBm) of RF path C for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_5g_d:5G target tx power (unit:dBm) of RF path D for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_phy_file_path:The path of phy parameter (charp)
parm:           rtw_load_phy_file:PHY File Bit Map (int)
parm:           rtw_decrypt_phy_file:Enable Decrypt PHY File (int)
parm:           rtw_en_napi:int
parm:           rtw_en_gro:int


Ich werde nun mal die Aktualisierungsverwaltung bemühen und sehen, ob alles klappt.
Edit: In der Aktualisierungsverwaltung war nur "Kleinkram". Das nächste Kernelupdate wird Gewissheit bringen. Danke nochmals!
« Letzte Änderung: 04.09.2018, 12:50:17 von Hufeisen »

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #26 am: 16.09.2018, 21:29:59 »
Das erste Kernelupdate ist durch und ich hatte nach der Aktualisierung von 4.15.0-33 auf 4.15.0-34 wieder kein WLAN. Aktuell bin ich wieder mit dem alten Kernel unterwegs. Ich weiß nicht, woran es liegt. Eigentlich wurde der WLAN-Treiber ja ins dkms aufgenommen - das hätte also wohl nicht passieren dürfen?! Was soll ich nun am besten tun?

Hinweis für Erstleser: Es handelt sich nicht um ein Problem im Live-System, wie im Titel angedeutet. Wenn gewünscht, kann ich auch einen neuen Thread aufmachen, aber die Probleme im Livesystem setzten sich nahtlos nach der Installation und ersten Aktualisierung fort.

Re: Kein WLAN im LM19 Cinnamon live System
« Antwort #27 am: 17.09.2018, 16:41:26 »
Hi :)
du kannst den titel in deinem ersten post ändern....

dann bleib doch beim -33 er wenn der läuft... gibt momentan keine zwingenden grund kernel updates zu machen.

Re: Kein WLAN LM19 und Realtek rtl8821ce
« Antwort #28 am: 19.09.2018, 20:07:35 »
Gute Idee! Ich habe den Themennamen geändert. Mir wird wohl nichts anderes übrig bleiben, als für jeden Kernel den passenden Treiber zu laden. Wenn ich nach dem Treiber google, finde ich zum Beispiel diese Seite: https://github.com/endlessm/linux/tree/master/drivers/net/wireless/rtl8821ce
Wo kann ich erkennen, für welchen Kernel der Treiber erstellt wurde?

Re: Kein WLAN LM19 und Realtek rtl8821ce
« Antwort #29 am: 24.11.2018, 10:09:52 »
Inzwischen hat sich doch der Bedarf ergeben, das WLAN kernelübergreifend zum Laufen zu bringen. Da ich von verschiedenen Ryzenbugs betroffen bin und diese unter dem Kernel 4.19.4, soweit sich das jetzt sagen lässt, nicht auftreten, würde ich gerne in diesem Kernel den rtl8821ce Treiber haben bzw. den Versuch, den per dkms ins System zu integrieren noch einmal wagen wollen. Leider benötige ich dafür Hilfe. Aktuell bin ich wieder unter dem Kernel 15.0.33 aktiv, da ich hier WLAN habe. Im Kernel 4.19 ist (natürlich) der Versuch gescheitert, den Treiber mit make, make install und modprobe zu installieren. Ich habe auch nach einem Treiber für den neuen Kernel gesucht, aber nicht gefunden. Mit allem weiteren bin ich leider überfordert.  :'(
Ich werde versuchen, in der Stadt ein LAN-Kabel aufzutreiben, da wir unseres bis jetzt nicht finden konnten.

Edit: Darauf angesprochen, ist meiner Frau nun doch eingefallen, dass sie vor kurzem ein solches Kabel in der Hand hatte  ::). Weiter vorne im Thread sind ja die Befehle zur Installation per Kabel angegeben. Wie soll ich aber vorgehen? Installation per Kabel im neuen Kernel oder im alten und müsste ich dort dann erst den bestehenden Treibersalat löschen?
Edit: Kabel geht :)
« Letzte Änderung: 24.11.2018, 11:31:40 von Hufeisen »