Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
20.10.2018, 00:24:29

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 20932
  • Letzte: ropetti
Statistiken
  • Beiträge insgesamt: 553081
  • Themen insgesamt: 44628
  • Heute online: 404
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online
Mitglieder: 4
Gäste: 388
Gesamt: 392

Autor Thema: [gelöst]  Keine LAN-Verbindung zur Fritzbox  (Gelesen 1345 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Keine LAN-Verbindung zur Fritzbox
« am: 04.08.2018, 17:36:08 »
--- Linux Mint 17.3 MATE 64-bit ---

Hallo liebe Forumler,

bei mir läuft ein Acer-PC unter Windows 10 verbunden via Ethernet-Kabel mit einer Fritzbox 7490. Zusätzlich ist auf einem USB-Stick Linux-Mint 17.3 installiert.

Während unter Windows problemlos Internetverbindung möglich ist ("IP-Adresse automatisch beziehen") findet Linux keine Verbindung zur Fritzbox bzw. ins Internet (Verbindungsdaten im Anhang).

Mit einer Ausnahme: Wenn ich den Rechner runterfahre, die Fritzbox ganz ausschalte und nach einiger Wartezeit wieder einschalte und dann direkt Linux starte klappt die Verbindung einwandfrei. Auch nach nochmaligem Hochfahren und Starten von Linux ist alles in Ordnung.

Sobald ich aber dazwischen Windows starte und danach wieder Linux, findet Linux wieder keine Verbindung mehr.

Inzwischen bin ich mit meinem Linux-Latein am Ende :'( und würde mich über einen Tipp sehr freuen.

Helmut

« Letzte Änderung: 01.09.2018, 20:07:52 von Helmut_muc »

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #1 am: 04.08.2018, 17:59:26 »
Hi Helmut,
Hast Du in der Fritz!box für Deine Device statische IP vergeben/festgeegt? Ist immer besser als DHCP aktiv zu lassen.
Wieso hast Du LM au einem USB-Stick installier? Ist das ein Live-LM17.3? Dualboot ist doch kein Hexenwerk (mehr): 8)
Gib doch mal im Terminal folgendes ein und poste es hier. In der Ausgabe sind alle Infos zum LM17.3.
inxi -F && dmesg l grep -i

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #2 am: 04.08.2018, 19:20:55 »
Hi Im15user,

vielen Dank für Deine rasche Antwort. Eine statische IP hab ich bereits in der Fritzbox festgelegt mit 192.168.178.20.

Entstanden ist das Problem, nachdem die Telekom unseren Anschluss auf IP-Telefonie umgestellt hat und dabei die alte Fritzbox gegen die Fritzbox 7490 ausgetauscht hat.

Linux benütze ich nur gelegentlich, daher die Lösung über den USB-Stick. Ob es "Live-LM" ist, kann ich leider nicht sagen.

 Und hier noch die Ausgabe vom Terminal:

System:    Host: MINTPC Kernel: 4.4.0-116-generic x86_64 (64 bit) Desktop: MATE 1.12.0
           Distro: Linux Mint 17.3 Rosa
Machine:   Mobo: Acer model: Veriton Z4810G Bios: Acer v: P21-A1 date: 03/31/2014
CPU:       Dual core Intel Core i5-4570T (-HT-MCP-) cache: 4096 KB
           clock speeds: max: 3600 MHz 1: 2900 MHz 2: 2923 MHz 3: 2925 MHz 4: 2900 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           Display Server: X.Org 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
           GLX Renderer: Mesa DRI Intel Haswell Desktop GLX Version: 3.0 Mesa 10.1.3
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-116-generic
Network:   Card: Intel Ethernet Connection I217-V driver: e1000e
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: f8:0f:41:c4:69:3a
Drives:    HDD Total Size: 2016.4GB (1.0% used) ID-1: /dev/sda model: ST1000LM014 size: 1000.2GB
           ID-2: USB /dev/sdb model: Ultra_Fit size: 16.0GB ID-3: USB /dev/sdc model: 541010A9E680 size: 1000.2GB
Partition: ID-1: / size: 11G used: 8.7G (86%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 194 Uptime: 1 min Memory: 365.3/3851.0MB Client: Shell (bash) inxi: 2.2.28
dmesg: Ungültige Option -- i

Usage:
 dmesg [options]

Optionen:
 -C, --clear                 clear the kernel ring buffer
 -c, --read-clear            read and clear all messages
 -D, --console-off           disable printing messages to console
 -d, --show-delta            show time delta between printed messages
 -E, --console-on            enable printing messages to console
 -f, --facility <list>       restrict output to defined facilities
 -h, --help                  display this help and exit
 -k, --kernel                display kernel messages
 -l, --level <list>          restrict output to defined levels
 -n, --console-level <level> set level of messages printed to console
 -r, --raw                   print the raw message buffer
 -s, --buffer-size <size>    buffer size to query the kernel ring buffer
 -T, --ctime                 show human readable timestamp (could be
                             inaccurate if you have used SUSPEND/RESUME)
 -t, --notime                don't print messages timestamp
 -u, --userspace             display userspace messages
 -V, --version               output version information and exit
 -x, --decode                decode facility and level to readable string

Supported log facilities:
    kern - kernel messages
    user - random user-level messages
    mail - mail system
  daemon - system daemons
    auth - security/authorization messages
  syslog - messages generated internally by syslogd
     lpr - line printer subsystem
    news - network news subsystem

Supported log levels (priorities):
   emerg - system is unusable
   alert - action must be taken immediately
    crit - critical conditions
     err - error conditions
    warn - warning conditions
  notice - normal but significant condition
    info - informational
   debug - debug-level messages

Helmut

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #3 am: 09.08.2018, 15:45:59 »
oh lala, ein kleiner Dibveler von mir, da fehlt doch ein Bindestrich vor der Option l:
falsch:
inxi -F && dmesg l grep -i
richtig:
inxi -F && dmesg -l grep -iHat eine Weile gedauert, bis ich hier vorbei geschaut habe. Letzte Ferienwoche und meine kleinen "Nervensägen" ;D haben mich, haben uns in Dauer-Beschlag genommen.
Mein Tipp:
Neues Image von LM auf den Stick installieren, oder besser noch, wenn Du es willst und die Ressourcen passen, ein Dualboot installieren mit Win & LM.

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #4 am: 09.08.2018, 18:30:31 »
oh lala, ein kleiner Dibveler von mir,
Na ja, bei inxi fehlt das -z um sensible, private und hier irrelevante Daten zu verstecken und der Rest ist nur Quatsch dmesg -l grep -i
dmesg: unknown level 'grep'
Einfach sowas vor dem Posten selbst ausprobieren.  ;)
Ansonsten kenne ich mich mit Netzwerk leider auch nicht besonders gut aus.
« Letzte Änderung: 09.08.2018, 21:04:46 von aexe »

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #5 am: 09.08.2018, 19:37:08 »
Ich hab hier eine 7360. Kam auch ins Haus zur Umstellung auf IP Telefonie.

Das Handbuch zur deiner Fritzbox hast du? Zugriff über die Notfall IP Adresse unter LM auf die Konfiguration der box hast du auch. (Steht im Handbuch beschrieben.)

Ansonsten kontaktiere AVM in Berlin. Spitzensupport. Am besten per Telefon. Nummer steht hinten im Handbuch.
Die Jungs sind wirklich kompetent.

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #6 am: 09.08.2018, 20:32:36 »
Die feste IP nicht in der FritzBox angeben, sondern in der Netzwerkverbindung des jeweiligen OS.
Ich vermute, dass die Box durch die unterschiedlichen Host-Namen durcheinander kommt.

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #7 am: 10.08.2018, 08:22:10 »
Geh mal davon aus, dass das kein Linux persistent USB Stick ist.

Solltest das mal mit einem persistenten Stick probieren ...

 

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #8 am: 10.08.2018, 10:33:40 »
Die .20 ist in Default von DHCP vergeben und als statische IP NICHT nutzbar. Entweder in der Fritz dem DHCP einen kleineren Bereich reservieren oder die statische IP in den Bereich .1 nis .19 beschrenken.

Welche IP hat der PC eigentlich unter Windows? Welchen Namen hat er im LAN unter Windows - Linux?

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #9 am: 10.08.2018, 11:29:46 »
Hab hier ein Internet Radio im Wohnzimmer fix auf 20.

 

Kein Problem, zumindest mit meiner FRITZ!Box 7360. Wie es bei der 7490 ausschaut, weiß ich nicht  ;)

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #10 am: 10.08.2018, 17:30:19 »
Hi :)
vernünftige router (so auch die FB) merken wenn eine IP durch feste IP bereits belegt ist, und vergeben eine  andere dhcp..

box rebooten und dann
mal alle ip's in den netzwerkverbindungen der box löschen...

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #11 am: 10.08.2018, 17:38:41 »
DHCP hat einen Adressbereich (evtl. konfigurierbar).
Innerhalb diese Bereichs sollte man keine feste IP-Adresse vergeben, sondern ausserhalb!

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #12 am: 12.08.2018, 03:14:12 »
Danke schön an Euch für die vielen Tipps. Hab alles ausprobiert - leider ohne Erfolg:

- auch über die Notfall IP-Adresse lässt sich auf die Fritzbox nicht zugreifen
- die feste IP (192.168.178.20) hatte ich ohnehin bereits auch bei Linux Mint eingerichtet
- der USB-Stick mit dem Linux Mint hat mit der alten Fritzbox tadellos funtioniert
- habe statt der IP-Endung .20 mit .10 und .201 versucht - keine Änderung

Bei dem Tipp von ehtron weiß ich leider nicht, welche IP's ich da genau löschen soll.

Ist mir echt ein Rätsel wieso es nach einem Reboot der Fritzbox mit Linux Mint einwandfrei klappt, aber nichts mehr geht sobald ich einmal mit Windows dazwischen boote.

Helmut




Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #13 am: 12.08.2018, 08:44:24 »
- auch über die Notfall IP-Adresse lässt sich auf die Fritzbox nicht zugreifen


Wenn das schon nicht geht ...

(Aus dem Handbuch der 7490)

 

 
« Letzte Änderung: 12.08.2018, 08:55:50 von kalle123 »

Re: Keine LAN-Verbindung zur Fritzbox
« Antwort #14 am: 12.08.2018, 09:03:22 »
Off-Topic:
Welchen Nutzen hat es, Text in Form von Bildern in Beiträge einzufügen, wenn man doch Text auch einfach zitieren oder, noch einfacher, die Quelle verlinken kann (wenn sie aus dem Internet stammt)?
Nur weil es möglich ist, muss man das doch nicht machen.
Ich finde es unpraktisch und unnötig aufwändig.
« Letzte Änderung: 12.08.2018, 09:41:22 von aexe »