Paket w3af ist nicht verfügbar
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.08.2018, 13:57:17

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 544380
  • Themen insgesamt: 43754
  • Heute online: 370
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online

Autor Thema:  Paket w3af ist nicht verfügbar  (Gelesen 180 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Paket w3af ist nicht verfügbar
« am: 14.07.2018, 22:32:11 »
Hallo,
Ich versuche mit dem Tool Katoolin Tools von Kali Linux auf mein Linux Mint 19 MATE zu installieren. Beim Schritt, in welchem ich die Tools installieren soll, kommt diese Meldung:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paket w3af ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Für Paket »w3af« existiert kein Installationskandidat.

Was muss ich machen, damit ich an diesem Schritt voran komme?


Terminal Ausgaben:


apt-get update
OK:1 http://archive.canonical.com/ubuntu bionic InRelease
Ign:2 http://packages.linuxmint.com tara InRelease                             
OK:4 http://packages.linuxmint.com tara Release                               
OK:3 http://archive-3.kali.org/kali kali-rolling InRelease                     
OK:6 http://security.ubuntu.com/ubuntu bionic-security InRelease               
OK:7 http://archive.ubuntu.com/ubuntu bionic InRelease                     
OK:8 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
OK:9 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Paketlisten werden gelesen... Fertig 

grep -h '^[[:blank:]]*[^#[:blank:]]' /etc/apt/sources.list /etc/apt/sources.list.d/*.list
deb http://http.kali.org/kali kali-rolling main contrib non-free
deb http://packages.linuxmint.com tara main upstream import backport #id:linuxmint_main
deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ bionic partner

sudo apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 1539 nicht aktualisiert.

cat /etc/apt/sources.list
#deb cdrom:[Linux Mint 19 _Tara_ - Release amd64 20180626]/ bionic contrib main non-free
# Kali linux repositories | Added by Katoolin
deb http://http.kali.org/kali kali-rolling main contrib non-free

ls -la /etc/apt/sources.list.d
insgesamt 12
drwxr-xr-x 2 root root 4096 Jul 13 18:00 .
drwxr-xr-x 6 root root 4096 Jul 14 22:00 ..
-rw-r--r-- 1 root root  559 Jun 26 18:14 official-package-repositories.list

sudo apt-get install -s  swi-prolog
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libbsd-dev libbsd0 libedit-dev libedit2 libgmp-dev libgmp10 libgmpxx4ldbl
  libjpeg62-turbo libjs-jquery libncurses-dev libncurses6 libncursesw6
  libossp-uuid16 libreadline-dev libreadline7 libtinfo-dev libtinfo6
  swi-prolog-nox swi-prolog-x
Vorgeschlagene Pakete:
  gmp-doc libgmp10-doc libmpfr-dev ncurses-doc uuid readline-doc
  elpa-ediprolog
Empfohlene Pakete:
  javascript-common debhelper
Die folgenden NEUEN Pakete werden installiert:
  libbsd-dev libedit-dev libgmp-dev libgmpxx4ldbl libjpeg62-turbo libjs-jquery
  libncurses-dev libncurses6 libncursesw6 libossp-uuid16 libreadline-dev
  libtinfo-dev libtinfo6 swi-prolog swi-prolog-nox swi-prolog-x
Die folgenden Pakete werden aktualisiert (Upgrade):
  libbsd0 libedit2 libgmp10 libreadline7
4 aktualisiert, 16 neu installiert, 0 zu entfernen und 1535 nicht aktualisiert.
Inst libbsd0 [0.8.7-1] (0.9.1-1 kali-rolling [amd64])
Conf libbsd0 (0.9.1-1 kali-rolling [amd64])
Inst libgmp10 [2:6.1.2+dfsg-2] (2:6.1.2+dfsg-3 kali-rolling [amd64])
Conf libgmp10 (2:6.1.2+dfsg-3 kali-rolling [amd64])
Inst libtinfo6 (6.1+20180210-4 kali-rolling [amd64])
Conf libtinfo6 (6.1+20180210-4 kali-rolling [amd64])
Inst libreadline7 [7.0-3] (7.0-5 kali-rolling [amd64])
Conf libreadline7 (7.0-5 kali-rolling [amd64])
Inst libbsd-dev (0.9.1-1 kali-rolling [amd64])
Inst libncurses6 (6.1+20180210-4 kali-rolling [amd64])
Inst libedit2 [3.1-20170329-1] (3.1-20180525-1 kali-rolling [amd64])
Inst libncursesw6 (6.1+20180210-4 kali-rolling [amd64])
Inst libncurses-dev (6.1+20180210-4 kali-rolling [amd64])
Inst libtinfo-dev (6.1+20180210-4 kali-rolling [amd64])
Inst libedit-dev (3.1-20180525-1 kali-rolling [amd64])
Inst libgmpxx4ldbl (2:6.1.2+dfsg-3 kali-rolling [amd64])
Inst libgmp-dev (2:6.1.2+dfsg-3 kali-rolling [amd64])
Inst libjpeg62-turbo (1:1.5.2-2+b1 kali-rolling [amd64])
Inst libjs-jquery (3.2.1-1 kali-rolling [all])
Inst libossp-uuid16 (1.6.2-1.5+b6 kali-rolling [amd64])
Inst libreadline-dev (7.0-5 kali-rolling [amd64])
Inst swi-prolog-nox (7.6.4+dfsg-2 kali-rolling [amd64])
Inst swi-prolog-x (7.6.4+dfsg-2 kali-rolling [amd64])
Inst swi-prolog (7.6.4+dfsg-2 kali-rolling [amd64])
Conf libbsd-dev (0.9.1-1 kali-rolling [amd64])
Conf libncurses6 (6.1+20180210-4 kali-rolling [amd64])
Conf libedit2 (3.1-20180525-1 kali-rolling [amd64])
Conf libncursesw6 (6.1+20180210-4 kali-rolling [amd64])
Conf libncurses-dev (6.1+20180210-4 kali-rolling [amd64])
Conf libtinfo-dev (6.1+20180210-4 kali-rolling [amd64])
Conf libedit-dev (3.1-20180525-1 kali-rolling [amd64])
Conf libgmpxx4ldbl (2:6.1.2+dfsg-3 kali-rolling [amd64])
Conf libgmp-dev (2:6.1.2+dfsg-3 kali-rolling [amd64])
Conf libjpeg62-turbo (1:1.5.2-2+b1 kali-rolling [amd64])
Conf libjs-jquery (3.2.1-1 kali-rolling [all])
Conf libossp-uuid16 (1.6.2-1.5+b6 kali-rolling [amd64])
Conf libreadline-dev (7.0-5 kali-rolling [amd64])
Conf swi-prolog-nox (7.6.4+dfsg-2 kali-rolling [amd64])
Conf swi-prolog-x (7.6.4+dfsg-2 kali-rolling [amd64])
Conf swi-prolog (7.6.4+dfsg-2 kali-rolling [amd64])

Re: Paket w3af ist nicht verfügbar
« Antwort #1 am: 14.07.2018, 23:25:29 »
Ob das zu Mint 19 passt weiß ich allerdings nicht.
https://packages.debian.org/jessie/w3af
In Debian-Jessie ist es auch normal über die Quellen verfügbar.
In Debian-Stretch scheitert die Installation an den Abhängigkeiten.
« Letzte Änderung: 15.07.2018, 00:05:35 von helli »