Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
21.11.2018, 01:17:19

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21086
  • Letzte: Pemfakt
Statistiken
  • Beiträge insgesamt: 557526
  • Themen insgesamt: 45114
  • Heute online: 374
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 5
Gäste: 305
Gesamt: 310

Autor Thema: [erledigt] Mint 19 Cinnamon - rtcwake funktioniert nicht mehr wie bisher  (Gelesen 391 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Mint 19 Cinnamon - rtcwake funktioniert nicht mehr wie bisher
« am: 12.07.2018, 12:54:11 »
Moin,

bisher ging das Kommando
sudo rtcwake -m mem -t $(date -d '20180712 22:10' +%s)so wie es auch bei Ubuntu erklärt wird.
Neuerdings kommen Fehlermeldungen wie z.B.
rtcwake: Diese Option benötigt ein Argument -- >>t<<Und wenn ich help aufrufe kommt u.a.
Für weitere Einzelheiten siehe rtcwake(8)Wie komme ich denn an (8) heran???

Der Witz bei der ganzen Sache ist, dass o.g. Kommando auf einem Rechner so funktioniert, wie es soll und auf dem anderen Rechner diese Fehlermeldungen kommen.
Terminal-Kommandos können doch nicht von Rechner zu Rechner (beide Mint 19 mit gleichem Kernel) unterschiedlich verstanden werden, oder???
« Letzte Änderung: 13.07.2018, 17:24:25 von Mountain »

Re: Mint 19 Cinnamon - rtcwake funktioniert nicht mehr wie bisher
« Antwort #1 am: 12.07.2018, 14:17:00 »
Was ergibt denn auf dem "Fehlerrechner":
date -d '20180712 22:10' +%s?

Für weitere Einzelheiten siehe rtcwake(8)Wie komme ich denn an (8) heran???
man 8 rtcwake

Re: Mint 19 Cinnamon - rtcwake funktioniert nicht mehr wie bisher
« Antwort #2 am: 12.07.2018, 14:41:30 »
Was ergibt denn auf dem "Fehlerrechner":
date -d '20180712 22:10' +%s?
Ganz geheimnisvoll:
1531426200

Re: Mint 19 Cinnamon - rtcwake funktioniert nicht mehr wie bisher
« Antwort #3 am: 12.07.2018, 15:22:51 »
Des Rätsels Lösung: %s   Sekunden seit „1970-01-01 00:00:00 UTC“
Ergebnis von meinem Rechner ist dasselbe: date -d '20180712 22:10' +%s
1531426200

weitere Info zur Rechner-Zeit liefert: timedatectl
Vermutlich liegt der Zwirl aber woanders.
Zitat
rtcwake: Diese Option benötigt ein Argument -- >>t<<
>t< ist die Angabe der Aufwachzeit.
Was sagt denn: rtcwake --dry-run oder rtcwake show Ergibt das Unterschiede bei den verschiedenen Rechnern?
« Letzte Änderung: 12.07.2018, 15:55:19 von aexe »

Re: Mint 19 Cinnamon - rtcwake funktioniert nicht mehr wie bisher
« Antwort #4 am: 13.07.2018, 14:17:41 »
Vermutlich liegt der Zwirl aber woanders.
Zitat
rtcwake: Diese Option benötigt ein Argument -- >>t<<
Genau dort vermute ich den Fehler doch auch. Laut Manpage wird dort ein Datum als Unixtime verlangt - und genau das liefert die Kommandosubstitution aus dem Code von Mountain:
... $(date -d '20180712 22:10' +%s)
Ich hatte vermutet, das date das Datum nicht versteht, weil z.B. eine Locale nicht stimmt (tibetanisches Datumsformat oder sowas :D ). Vielleicht hatte sich dort aber auch ein Tippfehler eingeschlichen.

Re: Mint 19 Cinnamon - rtcwake funktioniert nicht mehr wie bisher
« Antwort #5 am: 13.07.2018, 15:09:53 »
Ich hatte vermutet, das date das Datum nicht versteht, weil z.B. eine Locale nicht stimmt (tibetanisches Datumsformat oder sowas :D ). Vielleicht hatte sich dort aber auch ein Tippfehler eingeschlichen.
Njet. Ich habe im Terminal beider Rechner dasselbe Kommando eingegeben - ohne Tippfehler und Tibetanische Zeit.

Re: Mint 19 Cinnamon - rtcwake funktioniert nicht mehr wie bisher
« Antwort #6 am: 13.07.2018, 15:56:57 »
Ich habe das hier auf dem "netten" Rechner eingegeben und er hat sofort richtig reagiert - um 15 Uhr 45 in den Ruhestand gegangen und um 15 Uhr 50 wieder aufgewacht.
sudo rtcwake -m mem -t $(date -d '20180713 15:50' +%s)
[sudo] Passwort für klaus:
rtcwake: RTC wird als UTC interpretiert …
rtcwake: aufwachen von „mem“ durch /dev/rtc0 bei Fri Jul 13 13:50:00 2018

Auf dem "bösen" Rechner kam bei gleichem Kommando das hier:
sudo rtcwake -m mem -t $(date -d '20180713 15:50' +%s)
date: zusätzlicher Operand »+%s“
„date --help“ liefert weitere Informationen.
rtcwake: Diese Option benötigt ein Argument -- »t«
Rufen Sie „rtcwake --help“ auf, um weitere Informationen zu erhalten.

Wie kann denn ein Linux-Terminal bei gleichem Betriebssystem und Kernel einmal ein Kommando ausführen und einmal nicht ausführen und bemängeln???

Re: Mint 19 Cinnamon - rtcwake funktioniert nicht mehr wie bisher
« Antwort #7 am: 13.07.2018, 16:30:56 »
Der Befehl funktioniert hier sowohl auf meinem 19er System als auch in einer 19er VM einwandfrei:
~ $ sudo rtcwake -m mem -t $(date -d '20180713 16:22' +%s)
rtcwake: RTC wird als UTC interpretiert …
rtcwake: aufwachen von „mem“ durch /dev/rtc0 bei Fri Jul 13 14:22:00 2018

Was ergibt denn
echo $SHELL

Re: Mint 19 Cinnamon - rtcwake funktioniert nicht mehr wie bisher
« Antwort #8 am: 13.07.2018, 17:24:09 »
Machmal geschehen ja doch noch Zeichen und Wunder - es geht plötzlich!
Ich habe das o.g. (unveränderte) Kommando ein paar Mal eingegeben und irgendwann hat der Rechner darauf reagiert.

......haben Linuxrechner ein Eigenleben.........????