Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
26.01.2021, 05:56:18

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25144
  • Letzte: bashnoob
Statistiken
  • Beiträge insgesamt: 711067
  • Themen insgesamt: 57475
  • Heute online: 428
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 6
Gäste: 292
Gesamt: 298

Autor Thema:  FAILED: modesetting - nach Installation von Mint 19  (Gelesen 1284 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ich habe mich heute hinreißen lassen, und habe Mint 19 Cinnemon komplett und ganz frisch auf meiner VM installiert.
Es funktioniert auch alles, aber ich bekomme "FAILED: modesetting" unter der Grafik angezeigt. Hat jemand eine Idee, was ich machen kann, um das zu beheben?

bepo@woodstock:~$ inxi -Fxz
System:    Host: woodstock Kernel: 4.15.0-24-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.7 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: oracle System: innotek product: VirtualBox v: 1.2 serial: N/A
           Mobo: Oracle model: VirtualBox v: 1.2 serial: N/A BIOS: innotek v: VirtualBox date: 12/01/2006
CPU:       Single core Intel Core i5-4690K (-UP-) arch: Haswell rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3) bmips: 7012 speed: 3506 MHz (max)
Graphics:  Card: InnoTek Systemberatung VirtualBox Graphics Adapter bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: (unloaded: fbdev,vesa) FAILED: modesetting
           Resolution: 1920x1095@59.97hz
           OpenGL: renderer: llvmpipe (LLVM 6.0, 256 bits) version: 3.3 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card Intel 82801AA AC'97 Audio Controller driver: snd_intel8x0 ports: d100 d200 bus-ID: 00:05.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network:   Card: Intel 82540EM Gigabit Ethernet Controller
           driver: e1000 v: 7.3.21-k8-NAPI port: d010 bus-ID: 00:03.0
           IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 107.4GB (8.9% used)
           ID-1: /dev/sda model: VBOX_HARDDISK size: 107.4GB
Partition: ID-1: / size: 98G used: 8.9G (10%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 152 Uptime: 15 min Memory: 1155.2/3945.1MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

Re: FAILED: modesetting - nach Installation von Mint 19
« Antwort #1 am: 06.07.2018, 21:26:16 »
Sieht bei mir genauso aus (VM Ubuntu Mate 18.04).
Sehe ich als Fehldiagnose von inxi, modesetting ist der Treiber für neuere Intelgrafik und hat in einer VM nichts zu suchen.
Der Treiber sollte vboxvideo sein.

Schau dir an lspci -nnk | grep -i vga -A2



Re: FAILED: modesetting - nach Installation von Mint 19
« Antwort #2 am: 06.07.2018, 22:07:06 »
Evtl. auch eine Option, eine neuere Version von inxi zu verwenden.
Das inxi aus den Standardquellen (v. 2.3.56) ist schon recht angestaubt.
Wie das mit dem Update zu machen ist, steht hier:
https://www.linuxmintusers.de/index.php?topic=48657.0

Mit Version 2.9 wurde das Programm komplett neu geschrieben und es sind mittlerweile etliche Fehlerkorrekturen eingeflossen.

Re: FAILED: modesetting - nach Installation von Mint 19
« Antwort #3 am: 07.07.2018, 14:21:23 »
Hi :)
läuft erst sauber wenn die gasterweiterung installiert ist... von richtiger einbindung des extension packs ganz zu schweigen ;)

Re: FAILED: modesetting - nach Installation von Mint 19
« Antwort #4 am: 07.07.2018, 14:47:20 »
Extension Pack und Gasterweiterung natürlich vorhanden bei mir ...

Re: FAILED: modesetting - nach Installation von Mint 19
« Antwort #5 am: 25.07.2018, 15:29:14 »
Ausgabe deines untenstehenden Befehls

00:02.0 VGA compatible controller [0300]: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef]
Kernel driver in use: vboxvideo
Kernel modules: vboxvideo

Sieht bei mir genauso aus (VM Ubuntu Mate 18.04).
Sehe ich als Fehldiagnose von inxi, modesetting ist der Treiber für neuere Intelgrafik und hat in einer VM nichts zu suchen.
Der Treiber sollte vboxvideo sein.

Schau dir an lspci -nnk | grep -i vga -A2

Re: FAILED: modesetting - nach Installation von Mint 19
« Antwort #6 am: 25.07.2018, 15:35:40 »
Hi :)
was für eine vbox läuft eigentlich? und was ist host?

Zitat
4.15.0-24
bekanntlich macht der gern probleme.. gehe mal auf einen neueren.

Re: FAILED: modesetting - nach Installation von Mint 19
« Antwort #7 am: 25.07.2018, 15:57:21 »
Meine VM Software ist VirtualBox 5.2.16-123759 mit dazugehoerigem Extension Pack.
Der Host ist Windows 10 Pro.

System:    Host: optos-VirtualBox Kernel: 4.15.0-29-generic x86_64 bits: 64 Desktop: Cinnamon 3.8.8
           Distro: Linux Mint 19 Tara
Machine:   Device: oracle System: innotek product: VirtualBox v: 1.2 serial: N/A
           Mobo: Oracle model: VirtualBox v: 1.2 serial: N/A BIOS: innotek v: VirtualBox date: 12/01/2006
Battery    BAT0: charge: 50.0 Wh 100.0% condition: 50.0/50.0 Wh (100%)
CPU:       Single core Intel Core i5-6300U (-UP-) cache: 3072 KB speed: 2496 MHz (max)
Graphics:  Card: InnoTek Systemberatung VirtualBox Graphics Adapter
           Display Server: x11 (X.Org 1.19.6 ) drivers: (unloaded: fbdev,vesa) FAILED: modesetting
           Resolution: 1920x1095@59.97hz
           OpenGL: renderer: llvmpipe (LLVM 6.0, 256 bits) version: 3.3 Mesa 18.0.0-rc5
Audio:     Card Intel 82801AA AC'97 Audio Controller driver: snd_intel8x0 Sound: ALSA v: k4.15.0-29-generic
Network:   Card: Intel 82540EM Gigabit Ethernet Controller driver: e1000
           IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: 08:00:27:67:4d:43
Drives:    HDD Total Size: 107.4GB (9.4% used)
           ID-1: /dev/sda model: VBOX_HARDDISK size: 107.4GB
Partition: ID-1: / size: 98G used: 9.5G (11%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 146 Uptime: 2 min Memory: 652.9/1993.5MB Client: Shell (bash) inxi: 2.3.56

Re: FAILED: modesetting - nach Installation von Mint 19
« Antwort #8 am: 25.07.2018, 16:04:20 »
Hi :)
Graphics:  Card: InnoTek Systemberatung VirtualBox Graphics Adapter
           Display Server: x11 (X.Org 1.19.6 )
           drivers: (unloaded: fbdev,vesa) FAILED: modesetting
           Resolution: 1680x944@59.96hz
macht er hier auch (5.2.10 aus den quellen, kernel 4.15.0-23)

habe bisher keine negativen auswirkungen bemerkt..