Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
21.09.2018, 04:45:06

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 20799
  • Letzte: Pathor
Statistiken
  • Beiträge insgesamt: 548876
  • Themen insgesamt: 44221
  • Heute online: 340
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online
Mitglieder: 2
Gäste: 228
Gesamt: 230

Autor Thema:  Terminal Vervollständigung funktioniert nicht nach Update  (Gelesen 523 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo ihr lieben,

ich bin noch ein frischling im umgang mit linux.

was mir allerdings heute nach der installation tara 19 aufgefallen ist.

das die autovervollständigung des apt-get ....... befehls nach dem update nicht mehr funktioniert

es wird nur die verzeichnisstruktur angezeigt nach betätigung der tab - taste

wollte es nur anmerken wenn es sich lösen lässt wäre es toll

apt-get -> -> kommt folgendes (die ordnerstruktur)

firefox_killer/
.font-unix/
.ICE-unix/
mintUpdate/
MozillaMailnews/


als normaler user funktioniert es tadellos auch mit sudo


thx


Re: Terminal Vervollständigung funktioniert nicht nach Update
« Antwort #1 am: 05.07.2018, 09:30:46 »
Hatte ich seltsamerweise auch gehabt. Bei mir fehlte die
.bashrc wenn ich nicht irre.

Auf jeden Fall die Config fürs Terminal, was im Home Ordner liegt.

Ich konnte mir mit meinem Laptop helfen, da da noch ein 18.3 läuft. Hab einfach die Datei per ssh kopiert.

Auch wenn es dir jetzt vielleicht nicht viel sagte, aber die anderen hier werden das verstehen. Ich bin auf Arbeit und hab nur das Handy. Da wirds schwer mit code Zeilen schreiben etc.


Edit:

Poste mal ein
"ls -la ~/" Befehl ohne Anführungszeichen ins Terminal kopieren und entern drücken
« Letzte Änderung: 05.07.2018, 09:35:13 von launacorp »

Re: Terminal Vervollständigung funktioniert nicht nach Update
« Antwort #2 am: 05.07.2018, 22:50:21 »
-rw-------  1 xxx    44 Jul  5 04:00 .bash_history
-rw-r--r--  1 xxx   220 Jul  4 23:30 .bash_logout
-rw-r--r--  1 xxx  3771 Jul  4 23:30 .bashrc


wahrscheinlich gehts dir um das

und danke für die hilfe bin ja newbie

Re: Terminal Vervollständigung funktioniert nicht nach Update
« Antwort #3 am: 06.07.2018, 04:41:20 »
Jetzt wäre noch ein cat ~/.bashrc sinnvoll.

Es sollte so etwas dabei heraus kommen:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm|xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
# We have color support; assume it's compliant with Ecma-48
# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
# a case would tend to support setf rather than setaf.)
color_prompt=yes
    else
color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    if [[ ${EUID} == 0 ]] ; then
        PS1='${debian_chroot:+($debian_chroot)}\[\033[01;31m\]\h\[\033[01;34m\] \W \$\[\033[00m\] '
    else
        PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\] \[\033[01;34m\]\w \$\[\033[00m\] '
    fi
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h \w \$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

if [ -x /usr/bin/mint-fortune ]; then
     /usr/bin/mint-fortune
fi

Wenn nicht, dann:

nano ~/.bashrcund die von mir gepostete Ausgabe dort hinein kopieren. Gespeichert wird dann mit der Tastenkombination "Strg+o" danach "Enter" und der Editor verlassen mit "Strg+x"

Re: Terminal Vervollständigung funktioniert nicht nach Update
« Antwort #4 am: 06.07.2018, 06:17:33 »
Ich vermute, dass für die Autovervollständigung folgender Abschnitt der ~/.bashrc von Bedeutung ist: # enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi
Sollte aber bei LinuxMint dem Standard entsprechen.
Ebenso wie -rw-r--r--  1 xxx xxx  3771 Jul  4 23:30 .bashrc wobei "xxx" den Benutzernamen kaschiert.

Das verstehe ich nicht:
als normaler user funktioniert es tadellos auch mit sudo
Was funktioniert denn nun und was nicht?
« Letzte Änderung: 06.07.2018, 06:52:19 von aexe »

Re: Terminal Vervollständigung funktioniert nicht nach Update
« Antwort #5 am: 06.07.2018, 07:02:09 »
Aexe, er meint, dass das Terminal auf komplett händisch eingegebene Befehle normal reagiert.

Re: Terminal Vervollständigung funktioniert nicht nach Update
« Antwort #6 am: 11.07.2018, 23:12:29 »
Ich definiere es etwas einfacher

apt-get up (tabulator ->) update upgrade

bei mir passiert das obere

apt-get up (tabulator ->)

irefox_killer/
.font-unix/
.ICE-unix/
mintUpdate/
MozillaMailnews/

thx für die hilfe

Re: Terminal Vervollständigung funktioniert nicht nach Update
« Antwort #7 am: 11.07.2018, 23:14:36 »
cat bash ergibt folgendes

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# ... or force ignoredups and ignorespace
HISTCONTROL=ignoredups:ignorespace

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
   # We have color support; assume it's compliant with Ecma-48
   # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
   # a case would tend to support setf rather than setaf.)
   color_prompt=yes
    else
   color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
#if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
#    . /etc/bash_completion
#fi





aber bei programmierung muss ich echt passen davon hab ich keine peilung,editieren kein thema

Re: Terminal Vervollständigung funktioniert nicht nach Update
« Antwort #8 am: 12.07.2018, 00:10:50 »
Ich vermute, dass für die Autovervollständigung folgender Abschnitt der ~/.bashrc von Bedeutung ist: # enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi
 
# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
#if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
#    . /etc/bash_completion
#fi
Den Code-Block habe ich bei dem 2. Zitat hinzugefügt.
Ändert aber nichts am Inhalt, macht ihn nur besser lesbar.
Fällt Dir ein Unterschied auf?