Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
08.12.2019, 03:14:40

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22918
  • Letzte: schawombo
Statistiken
  • Beiträge insgesamt: 623340
  • Themen insgesamt: 50335
  • Heute online: 602
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 2
Gäste: 338
Gesamt: 340

Autor Thema: [gelöst]  Linux Mint 19 Mate bootet langsam (vom Linux-Logo zum Anmeldebildschirm)  (Gelesen 10079 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hey!

Ich habe heute Linux Mint 19 Mate installiert und bei mehrmaligen reboots ist mir aufgefallen, dass das booten sehr lange dauert.
Allerdings geht hierbei die meiste Zeit beim Vorgang vom Linux-Symbol am Anfang zum Anmeldebildschirm drauf.
Nachdem ich im Grub Linux Mint ausgewählt habe, dauert es ca. 11 Sekunden, bis das Linux-Logo aufgetaucht und wieder verschwunden ist. Dann vergehen ganze 120 Sekunden bis die Anmeldemaske erscheint. Der Login funktioniert dann wieder in normaler Geschwindigkeit.

systemd-analyze blame:
10.101s ntp.service
          6.343s NetworkManager-wait-online.service
           351ms NetworkManager.service
           286ms udisks2.service
           251ms dev-sda5.device
           206ms systemd-resolved.service
           179ms ubuntu-system-adjustments.service
           177ms networkd-dispatcher.service
           135ms systemd-journal-flush.service
           120ms ModemManager.service
           113ms lightdm.service
           112ms accounts-daemon.service
           107ms avahi-daemon.service
           104ms plymouth-quit-wait.service
            84ms upower.service
            73ms speech-dispatcher.service
            69ms networking.service
            69ms grub-common.service
            68ms rsyslog.service
            67ms systemd-udev-trigger.service
            63ms lm-sensors.service
            62ms apparmor.service
            59ms polkit.service

systemd-analyze time:
Startup finished in 4.383s (kernel) + 16.298s (userspace) = 20.681s
graphical.target reached after 16.287s in userspace

Hat jemand eine Idee, woran das liegen könnte? Unter Mint 18.3 hatte ich keinerlei Probleme.

Aktiver Kernel ist 4.15.0-24

Danke für Eure Antworten!
« Letzte Änderung: 03.07.2018, 22:45:44 von flist »

Aktiver Kernel ist 4.15.0-24

Mit dem 24er Kernel haben einige Leute Probleme - boote mal mit einem älteren Kernel. Gibt auch schon ein paar Threads dazu.

Tatsächlich... mit dem 20er funktionierts ohne Probleme. Danke dir!

Habe nach langen stöbern im Netz, im Debian Forum einen interessanten Post gefunden. Dem nach braucht man nur
sudo apt install havegedinstallieren und der Spuck ist vorbei.
Bei mir hat es voll gefunzt.

Hallo Olli, habe es eben ausprobiert und es läuft alles tadellos. Super.

Nolan

...und der Spuck ist vorbei.

Spuk vorbei. Erste Sahne!  :)

Ausprobiert, leider Spuk nicht vorbei. Naja, ansonsten läuft. Andere Kernel ausprobiert ! Braucht 38 Sekunden.

Windows 10 auf einer anderen SSD braucht 5 Sekunden.

Kann es sein weil ich beim partionieren LVM verwende ?
« Letzte Änderung: 14.07.2018, 09:30:52 von Porco »

Explorer4x4

  • Gast
Warum ist es soooooo wichtig, wie lange das BS zum hochfahren braucht? Ob 5 sec oder 2 min, ich will das BS doch nicht dauernd rauf und runter fahren, sondern mit arbeiten, und wenn es gestartet ist, läuft es doch problemlos, oder habt ihr dann immer noch Schwierigkeiten?.

Es wird einen Grund haben warum das so lahm läuft und den würde ich auch wissen wollen. Ist die CPU Auslastung zu hoch oder der RAM alle?, das wäre für mich ein Grund das update zu verschieben oder auszulassen. Es gab vor Jahren schon mal das Problem mit der Performance und ich hab den Eindruck das bei Mint Fehler "mitgeschleppt" werden aus alten Tagen.

Bei Bootverzögerungen sollte der erste Blick der fstab gelten, ob alle dort eingetragenen Partitionen auch erreichbar sind. Wenn nicht, sorgt das Warten für 90 Sekunden Pause... ::)

Zitat
Ausprobiert, leider Spuk nicht vorbei. Naja, ansonsten läuft. Andere Kernel ausprobiert ! Braucht 38 Sekunden.

Windows 10 auf einer anderen SSD braucht 5 Sekunden.

was sagt denn bitte:
journalctl -xb -p err

-- Logs begin at Fri 2018-07-13 10:49:45 CEST, end at Mon 2018-07-16 17:34:58 CEST. --
Jul 16 17:29:55 Kern kernel: nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 3e6684 [ IBUS ]
Jul 16 17:29:55 Kern kernel: nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 10ac08 [ IBUS ]
Jul 16 17:29:58 Kern lightdm[992]: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jul 16 17:29:58 Kern lightdm[992]: PAM adding faulty module: pam_kwallet.so
Jul 16 17:29:58 Kern lightdm[992]: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Jul 16 17:29:58 Kern lightdm[992]: PAM adding faulty module: pam_kwallet5.so
Jul 16 17:29:59 Kern lightdm[1091]: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jul 16 17:29:59 Kern lightdm[1091]: PAM adding faulty module: pam_kwallet.so
Jul 16 17:29:59 Kern lightdm[1091]: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Jul 16 17:29:59 Kern lightdm[1091]: PAM adding faulty module: pam_kwallet5.so
Jul 16 17:30:02 Kern colord-sane[956]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Jul 16 17:30:04 Kern lightdm[1291]: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jul 16 17:30:04 Kern lightdm[1291]: PAM adding faulty module: pam_kwallet.so
Jul 16 17:30:04 Kern lightdm[1291]: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Jul 16 17:30:04 Kern lightdm[1291]: PAM adding faulty module: pam_kwallet5.so
Jul 16 17:30:10 Kern pulseaudio[1584]: [pulseaudio] pid.c: Daemon already running.
Jul 16 17:30:34 Kern pulseaudio[1481]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
lines 1-19/19 (END)


scheinbar hat dein Rechner bei booten mit dem Program kwallet zu tun...
evt. mit einem fehlerhaften oder nicht vorhandenen link (/lib/security/pam_kwallet.so), wie Du selbst siehst.

https://askubuntu.com/questions/879557/slow-boot-on-ubuntu-16-04-issue-with-pam-kwallet5-so

wenn Du Wlan benutzt, könnte auch dort die lange Bootzeit ihre Ursache haben.
ein Check des Wlan-Treiber könnte nix schaden.
« Letzte Änderung: 16.07.2018, 19:59:36 von Hollex »

Habe das nicht installiert und nutze kein Wlan und ist auch kein WLAN Modul verbaut :(

Es soll Probleme mit dem Zufallsgenerator geben, weil nicht genug Zahlen zur Verfügung stehen wartet der Rechner einfach. Die Zahlen werden durch Eingaben wie Maus + Tastatur erzeugt und die benutzt niemand beim Booten. Ich hatte da gestern noch was gelesen zu....Warum haveged keine Abhilfe schaft weiß ich jetz auch nicht da dieses Programm einfach Zahlen liefert ohne Eingabegeräte
« Letzte Änderung: 17.07.2018, 12:13:05 von hanfiey »

 

2. Advent
2. Advent