Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.10.2018, 09:51:50

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 20930
  • Letzte: Enno65
Statistiken
  • Beiträge insgesamt: 552988
  • Themen insgesamt: 44616
  • Heute online: 474
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online

Autor Thema: [gelöst]  Zugriff auf SMB Share OpenMediavault  (Gelesen 1301 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Zugriff auf SMB Share OpenMediavault
« am: 15.05.2018, 22:52:29 »
Hallo,

ich beschäftige mich derzeit mit Linux und speziell dem Raspberry PI.
Auf dem Raspberry PI habe ich Openmediavault installiert. Als NAS für kleine Aufgaben ist der PI ausreichend.
In OMV habe ich eine Samba Freigabe eingerichtet. OMV Version ist 3.0.99.

Nun möchte ich mit Linux Mint (Mate 18.3 mit Kernel 4.13.0-41.) auf die SMB Freigabe zugreifen.
Die Freigabe soll beim Booten automatisch eingebunden werden und für jeden User gelten.
Ich habe dazu das Paket "cifs-utils" installiert. Danach habe ich einen Mountpunkt erstellt unter /media.
Dann habe ich die fstab in /etc bearbeitet.
Ich habe versucht mir die richtigen Infos von hier zu holen: https://wiki.ubuntuusers.de/Samba_Client_cifs/

Mein Eintrag in fstab sieht derzeit so aus:
//10.11.11.33/linux /media/nastest cifs username=benutzer,password=passwort,domain=WORKGROUP,sec=ntlm 0 0

Ich habe auch schon andere Varianten versucht. Ohne Domain, sec und 0 0.
Die Freigabe wird in Caja (Dateiexplorer von Mate) zwar angezeigt aber es kommt die Meldung:
Einhängen von nastest nicht möglich. Mount: only root can mount //10.11.11.33/linux on /media/nastest

Ich habe auch eine Synolgy ds218. Auf diese kann ich mit Linux Mint problemlos über cifs/smb zugreifen.
Mit meiner Ubuntu 18.04 LTS VM kann ich ohne Probleme auf beide Freigaben (Synolgy und Raspberry PI) zugreifen.
Es liegt also eindeutig an der Kombination von Linux Mint und dem Raspberry PI mit OMV.

Ich habe auch schon in OMV die Freigabe auf "public" gestellt.
Die Zeile in fstab habe ich angepasst und keinen Benutzer und Passwort eingetragen.
Dann fragt Linux Mint beim Booten nach einem Passwort für die Nas. Ich habe das Feld frei
gelassen und hatte Zugriff auf die Nas.
Ich möchte allerdings sehr gerne Benutzer+Passwort nutzen.

Ich möchte als Backup Programm "Veeam" nutzen. Unter Ubuntu ist es möglich
die Parameter direkt in Veeam einzugeben und auf die SMB Freigabe zuzugreifen.
Unter Linux Mint gibt es eine Fehlermeldung. Dazu habe ich einen Screenshot.


Unter Ubuntu ist alles problemlos möglich.
Nur Linux Mint macht Probleme mit OMV auf dem Raspberry PI.
Über Hilfe und einen guten Tipp würde ich mich sehr freuen.
Falls ihr noch mehr Daten braucht meldet euch bitte :)

Gruß Andreas
« Letzte Änderung: 30.05.2018, 23:01:17 von posti91 »

Re: Zugriff auf SMB Share OpenMediavault
« Antwort #1 am: 16.05.2018, 06:21:05 »
Hallo  :)
Es fehlt wohl die Version angabe in der fstab, versuch mal.
//10.11.11.33/linux /media/nastest cifs username=benutzer,password=passwort,domain=WORKGROUP,sec=ntlm,vers=3.0     0 0
« Letzte Änderung: 16.05.2018, 06:24:50 von Ramses55 »

Re: Zugriff auf SMB Share OpenMediavault
« Antwort #2 am: 16.05.2018, 19:40:34 »
Hallo,

das Problem besteht leider weiterhin.
Ich habe es auch schon mit dem persönlichen Einbinden versucht indem ich
einen Mountpunkt in meinem Home verzeichnis erstellt habe.
Die fstab habe ich soweit angepasst das "noauto" und "users" mit den in Optionen stehen.

Der Eintrag sieht so aus: //10.11.11.33/linux /home/andreas/pernas cifs noauto,users,username=user,password=passwort,domain=WORKGROUP,sec=ntlm,vers=3.0 0 0

Wenn ich versuche die Freigabe mit dem Befehl "mount /home/andreas/pernas" oder "sudo mount /home/andreas/pernas"
zu verbinden kommt die Fehlermeldung:
mount error(22): Invalid argument
Refer to the mount.cifs[8] manual page (e.g. man mount.cifs)


Ich weiß nicht was diese Meldung bedeutet. Auf jeden Fall ist es eine andere Meldung als
bei dem Versuch die Freigabe mit einem root Mountpunkt zu mounten.
Dort habe in fstab folgendes verwendet: //10.11.11.33/linux /media/nastest cifs username=user,password=passwort,domain=WORKGROUP,sec=ntlm,vers=3.0 0 0

Die mount.cifs scheint das Problem zu sein.
Ich kann mir aber auch vorstellen dass ich etwas in Openmediavault anpassen muss.
So langsam bin ich leicht am verzweifeln ::)
« Letzte Änderung: 16.05.2018, 19:54:16 von posti91 »

Re: Zugriff auf SMB Share OpenMediavault
« Antwort #3 am: 17.05.2018, 10:51:51 »
Hallo  :)
Tut mir leid da weiß ich dann auch nicht weiter.
Aber vielleicht sieht sich noch einer von den Profis hier das Problem an.

Re: Zugriff auf SMB Share OpenMediavault
« Antwort #4 am: 17.05.2018, 12:11:21 »
Nur mal so als blöde Zwischenfrage:

Warum SMB??

Ich binde bei mir alles mit NFS ein.

Meine Frau zb mountet einfach andere Freigaben ein als mein PC. Funktioniert wunderbar so.


Re: Zugriff auf SMB Share OpenMediavault
« Antwort #5 am: 17.05.2018, 14:41:26 »
Hallo,
Ich dachte eigentlich das smb das bessere Protokoll ist und auch einfacher einzurichten.
Jetzt habe ich gelesen das NFS im Linux Bereich der Standard ist. Ich werde es heute abend mit NFS versuchen.
Über eine Lösung für mein smb Problem würde ich mich trotzdem sehr freuen. Als it'ler gibt man sich mit "geht nicht" nur sehr ungern zufrieden.
Für die NFS Authentifizierung müssen Benutzer und Passwort auf der Nas und Linux mint identisch sein oder?
Ich werde mich da nochmal einlesen.

toffifee

  • Global Moderator
  • *****
Re: Zugriff auf SMB Share OpenMediavault
« Antwort #6 am: 17.05.2018, 14:50:43 »
Ich dachte eigentlich das smb das bessere Protokoll ist und auch einfacher einzurichten.
"Besser" ist fraglich, und "einfacher" auch. Langsamer ist es auf jeden Fall. Nötig ist es nur, wenn Windows im Spiel ist. Oder sonst welche Geräte, die nichts anderes können (z.B. TVs oder Settop Boxen).

Re: Zugriff auf SMB Share OpenMediavault
« Antwort #7 am: 17.05.2018, 17:21:06 »
Zugangsdaten müssen IMMER auf beiden Seiten identisch sein, sofern "das Scheunentor" nicht prinzipiell offen ist, gelle?
;-)

Zu NFS und OMV -> siehe hier:
https://www.linuxmintusers.de/index.php?topic=48681.msg682411#msg682411
-> Antwort #3 ... SO müssen Freigaben angelegt werden

Re: Zugriff auf SMB Share OpenMediavault
« Antwort #8 am: 17.05.2018, 20:09:04 »
Hallo,

ich bin jetzt auf NFS umgestiegen. Die Einrichtung ist tatsächlich deutlich einfacher.
Alle Einstellungen kenne ich noch nicht in OMV. Die Optionen bei NFS in OMV habe ich default
gelassen auf "subtree_check,insecure".
Ich kann jetzt direkt von Linux Mint und Ubuntu die Freigabe mounten :)
Mein Backup Programm Veeam macht allerdings unter beiden System dasselbe Problem.
Der Zugriff aus Veeam über NFS auf die Freigabe klappt weiterhin nicht. Die Fehlermeldung ist eine andere als bei SMB.
Ich schätze dass das ein Problem mit Veeam ist bzw. mit den Rechten mit denen Veeam ausgeführt wird.
Die Fehlermeldung ist gleich bei Ubuntu und Linux Mint.

Hier ein Screenshot:


Ich habe Veeam auch schon mit root Rechten gestartet. Allerdings ohne Erfolg.
Die Rechte auf /tmp/veeam habe ich auch schon angepasst so dass alle rwx dürfen.

Also insgesamt bin ich jetzt einen Schritt weiter. Dafür möchte ich mich schon einmal bei euch
bedanken :)

Re: Zugriff auf SMB Share OpenMediavault
« Antwort #9 am: 17.05.2018, 21:03:54 »
... und wenn ICH explizit geschrieben habe, mit welchen Optionen man die Freigaben anlegen muss, kannst DU mir das ruhig auch glauben! Das basiert auf ewig langem Einlesen in die Materie! Deswegen klappt die Freigabe auch nicht.....

Re: Zugriff auf SMB Share OpenMediavault
« Antwort #10 am: 19.05.2018, 20:31:32 »
Hallo,

danke für die Hilfe. Mit den Optionen in der NFS Freigabe hat es funktioniert :)
Ich habe bis jetzt nur ein paar Linux Tutorials gelesen. Also das Linux System kenne ich nur oberflächlich. In der shell kenne ich auch nur die grundlegenden Dinge. Navigieren im Dateisystem etc.
Gibt es Literatur bzw. Lernmaterial in dem man die Linux Best practise lernen kann?
Das es keine Abkürzung gibt um viel Erfahrung zu sammeln ist mir klar.
Zurzeit probiere ich aber einfach zu viel rum und komme zu keinem Ergebnis. Das normale troubleshooting wie Kreuztests etc helfen auch nur im Ansatz.
Vielen Dank nochmal für die Hilfe.

Re: Zugriff auf SMB Share OpenMediavault
« Antwort #11 am: 20.05.2018, 16:09:39 »
... na also! *schmunzelt
Klappt doch!

... zum System ......
Nun - wie immer dauert das einfach, sich etwas einzuarbeiten ... einzulesen .... na und? Macht doch nichts.....

Re: Zugriff auf SMB Share OpenMediavault
« Antwort #12 am: 21.05.2018, 21:58:28 »
Hallo,

das Problem ist leider wieder aufgetaucht.
Einen Tag lang hat es funktioniert. Nun erhalte ich wieder dieselbe Fehlermeldung.
"Insufficient privileges to access /tmp/veeam/10.11.11.33:linux."

Ich habe am System bewusst nichts geändert. Ich weiß nicht ob Updates daran Schuld sein können.
Der Fehler tritt auch unter Ubuntu auf.
Also so langsam bin ich wirklich ratlos. Neustart von OMV hat auch nicht geholfen.
Ich halte das langsam für ein Veeam spezifisches Problem.

Mir ist allerdings aufgefallen dass der Ordner /tmp/veeam/10.11.11.33/linux
nur die folgenden Rechte hat: drwx------
Ich kann auch keine Rechte ändern. Wenn ich "cmod +r 10.11.11.33/linux" eingebe
kommt die Meldung: "Das Dateisystem ist nur lesbar". Beim Versuch allen rwx zu geben kommt
dieselbe Meldung.
Also ich weiß wirklich nicht weiter.
Aussagekräftige Log Dateien habe ich weder in Veeam gefunden noch in OMV.

Eventuell habt ihr ja noch eine Idee. Ich habe auch schon im offiziellen Veeam Forum gefragt.
Mein Thread wird allerdings erstmal geprüft.



Re: Zugriff auf SMB Share OpenMediavault
« Antwort #13 am: 30.05.2018, 23:00:54 »
Hallo,

ich möchte meinen etwas komplizierten Thread gerne noch auflösen:

Es lag letztendlich an der USB 2.0 Dockingstation für meine HDD.
Die Hardware näher unter die Lupe zu nehmen ist mir erst in den Sinn gekommen
als die HDD nicht mehr erkannt wurde. Das daraus Fehler dieser Art entstehen war mir neu.
Bei meinen ganzen Versuchen wurde die HDD immer vom OS erkannt. Ich hatte gedacht es ist
ein reines Software Problem. Aber irgendwie hat sich der USB Dockingstation Defekt wohl
schon angedeutet.
Jetzt läuft mein Raspberry mit neuer USB Dockingstation schon seit einer Woche ohne Probleme.
Backups von Linux Mint werden ebenfalls regelmäßig erstellt.
Nochmal vielen Dank für eure Hilfe :)