Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
16.10.2018, 12:24:12

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 20920
  • Letzte: MarKant
Statistiken
  • Beiträge insgesamt: 552551
  • Themen insgesamt: 44583
  • Heute online: 538
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online

Autor Thema:  LM 18.3 Cinnamon: Dual Monitor - ein Bildschirm bleibt schwarz  (Gelesen 421 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo,

ich benutze Mint 18.3 mit zwei Monitoren. Das hat schon seit Version 17 bisher prima funktioniert -
bis vor einigen Wochen. Ich vermute, ich habe irgendein Update eingespielt oder irgendeine Einstellung verändert.
Und nach beim nächsten Reboot (vermute ich) war dann ein Bildschirm schwarz.

Booten und Anmeldung funktioniert.
Xrandr gibt folgende Ausgabe:

Screen 0: minimum 320 x 200, current 3840 x 1200, maximum 8192 x 8192
DP-1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 546mm x 352mm
   1920x1200     59.95*+
   1920x1080     60.00 
   1600x1200     60.00 
   1680x1050     59.88 
   1600x1000     60.01 
   1280x1024     75.02    60.02 
   1280x960      60.00 
   1152x864      75.00 
   1024x768      75.03    60.00 
   832x624       74.55 
   800x600       75.00    60.32 
   640x480       75.00    59.94 
   720x400       70.08 
DP-2 connected 1920x1200+1920+0 (normal left inverted right x axis y axis) 546mm x 352mm
   1920x1200     59.95*+
   1600x1200     60.00 
   1680x1050     59.88 
   1600x1000     60.01 
   1280x1024     75.02    60.02 
   1280x960      60.00 
   1152x864      75.00 
   1024x768      75.03    60.00 
   832x624       74.55 
   800x600       75.00    60.32 
   640x480       75.00    59.94 
   720x400       70.08

Ich lese das so: beide Bildschirme werden erkannt und sind aktiv.
DP-1 links zeigt was er soll.
DP-2 rechts davon zeigt nichts. Der Monitor bekommt auch kein Signal.

Die Maus macht allerdings nicht halt am rechten Rand vom Bildschirm links, sondern "verschwindet" ins schwarze
und taucht dann beim zurück bewegen auch wieder auf.

Das System läuft mit Kernel 4.10.0-42 und nvidia-340.104-0ubuntu.16.04.1
Ein Umschalten auf den Nouveau-Treiber hat nichts gebracht.

Ich habe jetzt durch alle möglichen Foren und Webseiten gestöbert. Es scheint kein gängiges Problem zu sein,
bzw. es wird dann immer xrandr empfohlen - verschiedene Dinge habe ich ausprobiert ohne Ergebnis.
Laut xrand ist ja auch alles prima.

Zur Sicherheit - ja, beide Monitore sind angeschlossen und funktionieren. Ich habe die Geräte auch schon einmal
vertauscht ohne Änderung.

Ich verstehe, dass ein Problem in einer kaputten Konfiguration des Desktops liegen könnte, aber ich verstehe nicht,
wo ich nachschauen sollte und wonach ich suchen sollte.

Hilft deinstallieren von bestimmten Komponenten normalerweise? Welche?
Ein neuerer Kernel hatte vor Monaten nicht funktioniert (4.13), sollte ich das damit noch mal probieren?
 
Für Tipps bin ich dankbar.

Christian

Re: LM 18.3 Cinnamon: Dual Monitor - ein Bildschirm bleibt schwarz
« Antwort #1 am: 10.05.2018, 16:44:28 »
Ergänzungen

ystem:    Host: kappa Kernel: 4.10.0-42-generic x86_64 (64 bit) Desktop: Cinnamon 3.6.7
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: FUJITSU product: CELSIUS R670
           Mobo: FUJITSU model: D2618-B1 v: S26361-D2618-B1
           Bios: FUJITSU // Phoenix v: 6.00 R1.21.2618.B1 date: 08/18/2011
CPU(s):    2 Quad core Intel Xeon E5540s (-HT-MCP-SMP-) cache: 16384 KB
           clock speeds: max: 2528 MHz 1: 1596 MHz 2: 1596 MHz 3: 1596 MHz 4: 1596 MHz 5: 1596 MHz
           6: 1596 MHz 7: 1596 MHz 8: 1596 MHz 9: 1596 MHz 10: 1596 MHz 11: 1596 MHz 12: 1596 MHz
           13: 1596 MHz 14: 1596 MHz 15: 1596 MHz 16: 1596 MHz
Graphics:  Card: NVIDIA GT218 [NVS 300]
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1200@59.95hz, 1920x1200@59.95hz
           GLX Renderer: Gallium 0.4 on NVA8 GLX Version: 3.0 Mesa 12.0.6
Audio:     Card-1 NVIDIA High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.0-42-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1256.3GB (5.4% used) ID-1: /dev/sda model: Samsung_SSD_850 size: 256.1GB
           ID-2: /dev/sdb model: WDC_WD1003FZEX size: 1000.2GB
Partition: ID-1: / size: 212G used: 7.1G (4%) fs: ext4 dev: /dev/sda5
           ID-2: /boot size: 472M used: 171M (39%) fs: ext2 dev: /dev/sda1
           ID-3: /var size: 23G used: 7.8G (36%) fs: ext4 dev: /dev/sdb5
           ID-4: /home size: 470G used: 35G (8%) fs: ext4 dev: /dev/sdb6
           ID-5: swap-1 size: 16.20GB used: 0.00GB (0%) fs: swap dev: /dev/sdb1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 324 Uptime: 24 min Memory: 1474.6/16035.5MB Client: Shell (bash) inxi: 2.2.35

06:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [NVS 300] [10de:10d8] (rev a2)
Subsystem: Hewlett-Packard Company GT218 [NVS 300] [103c:0862]
Kernel driver in use: nouveau

Re: LM 18.3 Cinnamon: Dual Monitor - ein Bildschirm bleibt schwarz
« Antwort #2 am: 10.05.2018, 16:45:33 »
Hi :)
lösche mal die
.config/monitors.xml und boote neu...

hast du eine eigene
/etc/X11/xorg.conf
angelegt? wenn ja, umbennen..

und zeige mal bitte als code block (siehe hilfe oben)
inxi -Fz

Re: LM 18.3 Cinnamon: Dual Monitor - ein Bildschirm bleibt schwarz
« Antwort #3 am: 10.05.2018, 17:11:37 »
Hallo,

danke für den Tipp! Das hat mein Problem jetzt noch nicht gelöst.
Die Datei monitors.xml wurde dann neu generiert und sieht jetzt vollständiger aus.

Was auffällt: der Wert "serial" ist bei beiden Monitoren gleich.
Es sind ja auch die gleichen Typen, aber sollte die ID zur Unterscheidung nicht evtl. unterschiedlich sein?

<monitors version="1">
  <configuration>
      <clone>no</clone>
      <output name="DP-1">
          <vendor>HWP</vendor>
          <product>0x26f7</product>
          <serial>0x01010101</serial>
          <width>1920</width>
          <height>1200</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="DP-2">
          <vendor>HWP</vendor>
          <product>0x26f7</product>
          <serial>0x01010101</serial>
          <width>1920</width>
          <height>1200</height>
          <rate>60</rate>
          <x>1920</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>no</primary>
      </output>
  </configuration>
</monitors>

Die Ausgabe von inxi -Fz steh oben.

Re: LM 18.3 Cinnamon: Dual Monitor - ein Bildschirm bleibt schwarz
« Antwort #4 am: 10.05.2018, 17:34:20 »
Hi :)
stimmt hier auch unterschiedlich..

installiere nochmal den nvidia aus dem ppa.. über die treiberverwaltung. müsste dann NVIDIA 340.106 sein
dann
sudo update-initramfs -u -k allund lösche die
.nvidia-settings-rc in deinem home...
und reboot
dann in den nvidia server settings im menü schauen ob da irgendwas merkwürdig ist.

die /var/log/Xorg.0.log gibt evtl. auch noch was her..


« Letzte Änderung: 10.05.2018, 17:45:49 von ehtron »

Hallo,

nach langem Probieren heute nach einer langen Pause die Kiste gestartet - und alles wieder schick!

Ich werde jetzt erst mal nicht mehr leichtfertig Updates einspielen...

Besten Dank an alle Tippgeber!

Christian