LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
17.08.2018, 00:00:00

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 20619
  • Letzte: DerAide
Statistiken
  • Beiträge insgesamt: 543827
  • Themen insgesamt: 43721
  • Heute online: 326
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online

Autor Thema:  LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.  (Gelesen 976 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Heute nach einem Neustart lief plötzlich Gis-Weather nicht mehr.

Erneute Installation brauchte nichts.

Daraufhin löschte ich das Gis-Weather-Profil unter .config in meinem /home.

Nun nimmt er aber keinen Ort mehr an, obwohl ich den exakt gleichen wie zuvor eingebe.
Er wird nicht übernommen.

Ich habe es mit Accu-Weather probiert
Den Orts-Code habe ich nach folgendem Muster eingebaut:
de/Ortsname/PLZ,Code
Angaben aus URL entnommen.

Mit Gismeteo, mit dem der URL entnommenen Ortscode, geht es auch nicht mehr.

Mehrmalige Deinstallations- (über "purge" im Terminal) und Reinstallationsversuche helfen genauso wenig wie verschiedene Kernels.
Was ist da los?

EDIT:
Wenn ich Gis-Weather übers Terminal starte, ergibt sich das hier:

gis-weather
Gis Weather 0.8.2.5
/usr/share/gis-weather/gis-weather.py:66: PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.
  from gi.repository import AppIndicator3
/usr/share/gis-weather/gis-weather.py:74: PyGIWarning: Rsvg was imported without specifying a version first. Use gi.require_version('Rsvg', '2.0') before import to ensure that the right version gets loaded.
  from gi.repository import Rsvg
Programmordner:
    /home/[USERNAME]/.config/gis-weather/gw_config1.json
Widget-Größe:
    Breite = 684 Höhe = 320 inklusive Zeileneinzug = 20
Ihr Desktop unterstützt Alpha-Transparenz
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
« Letzte Änderung: 09.05.2018, 01:04:15 von Centauri39 »

Re: LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
« Antwort #1 am: 09.05.2018, 10:45:27 »
Bei mir funzt seit heute Morgen es auch nicht mehr, bleibt beim herunterladen der Wetterdaten hängen und ich warte einfach mal ab, gehe davon aus, dass der Fehler es nicht in meinem System hängt.

System:    Host: ssd-ultimate Kernel: 4.15.0-15-generic x86_64 bits: 64 compiler: gcc v: 5.4.0
           Desktop: Xfce 4.12.3 tk: Gtk 2.24.28 info: xfce4-panel wm: Xfwm4 dm: lightdm 1.18.3
           Distro: Linux Mint 18.3 Sylvia

ultim-baer@ssd-ultimate ~ $ gis-weather
Gis Weather 0.8.2.5
/usr/share/gis-weather/gis-weather.py:66: PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.
  from gi.repository import AppIndicator3
Not found gir1.2-rsvg-2.0 (librsvg)
Programmordner:
    /home/ultim-baer/.config/gis-weather/gw_config1.json
Widget-Größe:
    Breite = 684 Höhe = 320 inklusive Zeileneinzug = 20
Ihr Desktop unterstützt Alpha-Transparenz
> Abfrage der Wetterdaten für 7 Tage

Re: LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
« Antwort #2 am: 09.05.2018, 10:49:24 »
Da sind vermutlich irgendwelche Server-Daten geändert worden.
Der Einzige, der noch geht, ist Yr.

Re: LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
« Antwort #3 am: 17.05.2018, 19:06:49 »
Ich vermute mal demnächst ein Upgrade.

Re: LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
« Antwort #4 am: 17.05.2018, 20:35:47 »
Evtl.Interessant ?

Zitat
May 09, 2018
My gis weather did not work, but I solved it in the following way. Turn off the gis weather process using the system monitor, after that delete the settings on the next path home/.config/gis-weather. Restart the gis-weather and set it up from the start, but instead of using the accuweather service, use some other offered. It seems that the problem is caused by using accuweather service.
the bug has been reported at: https://github.com/RingOV/gis-weather/issues/34

Re: LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
« Antwort #5 am: 17.05.2018, 21:48:28 »
Danke, das ist die Lösung.

Re: LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
« Antwort #6 am: 19.05.2018, 18:40:58 »
Die Lösung hat sich leider aufgelöst, Gismeteo funzt auch nicht mehr. Hab jetzt erst einmal GisWeather deinstalliert.

Re: LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
« Antwort #7 am: 19.05.2018, 20:46:39 »
Gismeteo funzt auch nicht mehr.
funzt ebenso nicht mehr auf LM18.3 Cinnamon: https://www.linuxmintusers.de/index.php?topic=48939.msg684790#msg684790
Bin auf's Weather-Desklet umgestiegen.
« Letzte Änderung: 20.05.2018, 11:14:32 von kuehhe1 »

Re: LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
« Antwort #8 am: 02.06.2018, 23:46:14 »
Zum Glück les ich endlich Eure Berichte hier.  Nach dem Urlaub funzt Gis bei mir nicht mehr und ich probier schon länger rum  :-[

Re: LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
« Antwort #9 am: 03.06.2018, 09:46:58 »
gis-weather funktioniert mit openweathermap. Am Besten neu installieren.
key holen bei:
http://openweathermap.org/API
Ort aus Liste wählen:
http://openweathermap.org/help/city_list.txt
Dann Neuinstallation.

Re: LM 18.1 MATE 64bit - Gis-Weather akzeptiert keinen Ort mehr.
« Antwort #10 am: 03.06.2018, 17:37:19 »
Danke für den Hinweis. Hat leider zwei Haken:
1.) Meine Wetterstation ist nicht in der Liste, die nächste verfügbare ist über 20 km entfernt. :-X
2.) Da muss man sich anmelden, somit scheidet es grundsätzlich aus.  :-\