Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.01.2021, 17:48:21

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25095
  • Letzte: Moggele
Statistiken
  • Beiträge insgesamt: 708980
  • Themen insgesamt: 57319
  • Heute online: 805
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  [LM9LXDE] sudo apt-get install ... # Fehlermeldung  (Gelesen 9117 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Tersus

  • Gast
[gelöst] [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« am: 27.10.2011, 19:03:24 »
Abend,

wenn ich gcc oder swi-prolog installieren will, kommt es zur Fehlermeldung.

Tersus@EeePC901 ~ $ sudo apt-get install gcc
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Paket gcc ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es veraltet
ist oder nur aus einer anderen Quelle verfügbar ist.
E: Paket gcc hat keinen Installationskandidaten

Tersus@EeePC901 ~ $ sudo apt-get install swi-prolog
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Paket swi-prolog ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es veraltet
ist oder nur aus einer anderen Quelle verfügbar ist.
E: Paket swi-prolog hat keinen Installationskandidaten

EDIT: [quote][/quote]-Block in [code][/code]-Block geändert
« Letzte Änderung: 30.10.2011, 11:59:14 von Tersus »

Freddy

  • Gast
Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #1 am: 27.10.2011, 19:08:54 »
hallo

die Fehlermeldung kommt daher das es nicht so in den Quellen ist, veruche mal das hier
und für swi-prolog:

Zitat
sudo apt-get install swi-prolog-clib


lg
turtle

Tersus

  • Gast
Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #2 am: 27.10.2011, 19:50:36 »
Tersus@EeePC901 ~ $ sudo apt-get install swi-prolog-clib
[sudo] password for a:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
E: Paket swi-prolog-clib konnte nicht gefunden werden

Das war es wohl auch nicht.

Und beim Installieren von GCC auf wiki.ubuntuusers.de kommt schon bei build-essentails die Meldung:

»build-essential« konnte nicht installiert werden (E:Probleme können nicht korrigiert werden, Sie haben gehaltene defekte Pakete.)

Ich habe mir doch sicher schon wieder irgendwas zerschossen ... , oder?

EDIT: [quote][/quote]-Block in [code][/code]-Block geändert

Freddy

  • Gast
Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #3 am: 27.10.2011, 19:53:09 »
sieht so aus, bei mir klappt es wunderbar
bekommst du auch eine fehlermeldung wenn
du

Zitat
sudo apt-get update && sudo apt-get upgrate

eingibst?


lg
turtle

Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #4 am: 27.10.2011, 20:02:14 »
Ein "swi-prolog-clib" gibt es bei mir hier, allerdings Ubuntu 11.10, auch nicht, sondern nur:
swi-prolog-doc - Dokumentation für SWI-Prolog-Interpreter und XPCE
swi-prolog - ISO/Edinburgh-style Prolog interpreter
swi-prolog-java - Bidirectional interface between SWI-Prolog and Java
swi-prolog-nox - ISO/Edinburgh-style Prolog interpreter (without X support)
swi-prolog-odbc - ODBC library for SWI-Prolog
swi-prolog-x - User interface library for SWI-Prolog (with X support)

Du solltest mal
sudo apt-get update && sudo apt-get -f install
eingeben.


Freddy

  • Gast
Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #5 am: 27.10.2011, 20:15:42 »
meine ausgabe zu swi-prolog-clib

$ sudo apt-get install swi-prolog-clib
[sudo] password for freddy:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libgmp3-dev libgmpxx4ldbl libncurses5-dev libreadline-dev libreadline6-dev
  swi-prolog
Vorgeschlagene Pakete:
  libgmp3-doc libmpfr-dev swi-prolog-doc prolog-el
Die folgenden NEUEN Pakete werden installiert:
  libgmp3-dev libgmpxx4ldbl libncurses5-dev libreadline-dev libreadline6-dev
  swi-prolog swi-prolog-clib
0 aktualisiert, 7 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 5.641kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 21,7MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]?

EDIT: [quote][/quote]-Block in [code][/code]-Block geändert

Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #6 am: 27.10.2011, 20:18:16 »
Dann ist das mittlerweile aus den Quellen geflogen, ich hatte ja einschränkend hinzugefügt, dass ich hier Oneiric am Laufen habe. Aber der TE verwendet ja auch Mint 9, insofern sollte es bei ihm dann in der Tat auch installierbar sein. Aber er hat ja offensichtlich noch andere Probleme, defekte Pakete.

Freddy

  • Gast
Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #7 am: 27.10.2011, 20:22:05 »
eben, ich hab ja auch mint 9, wie man unschwer sehen kann ;)


lg
turtle

Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #8 am: 27.10.2011, 20:26:20 »
Das habe ich auch gesehen, und dass es der TE hat, und deswegen ja auch dazu gesagt, dass ich es nicht habe.

Im übrigen ist laut Deiner eigenen Ausgabe das Paket, das der TE ürsprünglich installieren wollte, durchaus schon in den Quellen:
Zitat
Die folgenden zusätzlichen Pakete werden installiert:
(...)  swi-prolog

Er hat also in erster Linie ohnehin andere Paketverwaltungs-Probleme.
« Letzte Änderung: 27.10.2011, 20:30:55 von leonidas »

Freddy

  • Gast
Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #9 am: 27.10.2011, 20:28:38 »
ich weiß ;)

DeVIL-I386

  • Administrator
  • *****
Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #10 am: 27.10.2011, 21:24:55 »
Poste mal die Terminal-Ausgabe von: grep -h '^[[:blank:]]*[^#[:blank:]]' /etc/apt/sources.list /etc/apt/sources.list.d/*.list

Tersus

  • Gast
Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #11 am: 28.10.2011, 09:06:02 »
bekommst du auch eine fehlermeldung wenndu
Zitat
sudo apt-get update && sudo apt-get upgrate

eingibst?

Ja, bekomme ich, weil der Befehl updrate unbekannt ist.  ;D Spaß bei Seite, mit "upgrade" geht es, ja.
Du solltest mal
sudo apt-get update && sudo apt-get -f installeingeben.

Da gibt es auch keine Fehlermeldungen
Poste mal die Terminal-Ausgabe von: grep -h '^[[:blank:]]*[^#[:blank:]]' /etc/apt/sources.list /etc/apt/sources.list.d/*.list

Tersus@EeePC901 ~ $ grep -h '^[[:blank:]]*[^#[:blank:]]' /etc/apt/sources.list /etc/apt/sources.list.d/*.list
grep: /etc/apt/sources.list: Datei oder Verzeichnis nicht gefunden
deb http://ppa.launchpad.net/iaz/battery-status-devel/ubuntu lucid main
deb http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu lucid main
deb file:///usr/share/local-repository binary/
deb http://ppa.launchpad.net/lucid-bleed/ppa/ubuntu lucid main
deb http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu lucid main
deb http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu lucid main
deb http://ppa.launchpad.net/tualatrix/ppa/ubuntu lucid main #Ubuntu Tweak Stable Source
deb http://ppa.launchpad.net/webupd8team/jupiter/ubuntu lucid main

Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #12 am: 28.10.2011, 09:59:13 »
Zitat
grep: /etc/apt/sources.list: Datei oder Verzeichnis nicht gefunden


Das ist schlecht. Sehr schlecht. Du brauchst eine /etc/apt/sources.list mit folgendem Inhalt:

deb http://packages.linuxmint.com/ isadora main upstream import backport romeo
deb http://archive.ubuntu.com/ubuntu/ lucid main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ lucid-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ lucid partner
deb http://packages.medibuntu.org/ lucid free non-free

Tersus

  • Gast
Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #13 am: 28.10.2011, 15:44:25 »
Habe eine "sources.list.save" gefunden und diese noch mal unter "sources.list" gespeichert. Nun habe ich folgende Ausgabe:

Tersus@EeePC901 ~ $ grep -h '^[[:blank:]]*[^#[:blank:]]' /etc/apt/sources.list /etc/apt/sources.list.d/*.list
deb http://packages.linuxmint.com/ isadora main upstream import
deb http://packages.linuxmint.com/ isadora-lxde main upstream import
deb http://archive.ubuntu.com/ubuntu/ lucid main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ lucid-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ lucid partner
deb http://packages.medibuntu.org/ lucid free non-free
deb http://ppa.launchpad.net/swi-prolog-maintainer/git/ubuntu lucid main
deb http://ppa.launchpad.net/iaz/battery-status-devel/ubuntu lucid main
deb http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu lucid main
deb file:///usr/share/local-repository binary/
deb http://ppa.launchpad.net/lucid-bleed/ppa/ubuntu lucid main
deb http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu lucid main
deb http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu lucid main
deb http://ppa.launchpad.net/tualatrix/ppa/ubuntu lucid main #Ubuntu Tweak Stable Source
deb http://ppa.launchpad.net/webupd8team/jupiter/ubuntu lucid main

Re: [LM9LXDE] sudo apt-get install ... # Fehlermeldung
« Antwort #14 am: 28.10.2011, 18:15:07 »
Ja, und gehen die Installationen denn jetzt?