Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
11.12.2018, 12:53:18

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21174
  • Letzte: VanGreybe
Statistiken
  • Beiträge insgesamt: 560409
  • Themen insgesamt: 45419
  • Heute online: 529
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  LM 18.1 MATE 64bit - Skype geht nicht automatisch online  (Gelesen 1408 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #15 am: 13.03.2018, 11:32:43 »
Ich habe die 7390, da würde das auch so gehen oder mit Portweiterleitungen. Das Problem ist nur, bisher habe ich das bei Skype auch nie gebraucht.
Ich habe auch keine Änderungen zwischen vor und nach Auftreten des Problems, außer dass ich Gis-Weather nochmal von vorne installiert habe.
Ich wüsste allerdings nicht, wo da ein Zusammenhang sein sollte.
hier gibts im Router für Skype auch keinen Eintrag und zufällig ist ebnfalls Gis-Weather installiert.

Dann musst Du noch die Option "Skype im Hintergrund starten" aktivieren.
ich weis das hatten wir schon in Antwort '9
steht deine Skype Einstellung auf: "Skype im Hintergrund starten"?

Ich könnte mir  noch vorstellen das es in LinuxMint irgendwo eine Einstellung zur Priorität der Online gehenden Vorgänge gibt, z.B. Mint-Update Prio. 1 alle anderen Prio.2.3.... aber nach 20 Sekunden Verzögerung im Autostart sollten alle anderen Abfragen erledigt sein und Skype online gehen.

Wie sieht denn dein Skype Beenden Vorgehen aus, Beendest du Skype nur oder meldest du dich auch ab. Ich beende Skype nur, Abgemeldet hab ich mich noch nie.

Momentan bin ich ratlos  ::)
« Letzte Änderung: 16.03.2018, 14:26:09 von kuehhe1 »

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #16 am: 13.03.2018, 13:40:01 »
Gearde noch mal getestet: Skypeforlinux startet sowohl mit und ohne die angehängten Optionen:  %U & im geöffneten Fenster, wie sieht das in deiner Umgebung aus?

Weil Du da das geöffnete Skypefenster erwähnst, dachte ich, Du hättest die Hintergrundoption deaktiviert.
Eigentlich sollte beim Booten nur das Tray-Icon, ohne Programmfenster erscheinen.

Normalerweise lasse ich Skype beim Booten mitstarten und dann läuft das im Tray mit, bis ich es brauche oder runterfahre.
Ich melde mich nicht ab und beende es auch nie.
Einfach runterfahren, fertig.

Was mir aber auch noch auffällt ist, dass beim Booten vorm normalen Mint-Anmeldeschirm sporadisch ein zweites, schlichter aussehendes Anmeldefenster kommt.
Komischerweise, wie gesagt, nur sporadisch.
Die 10 Sekunden lasse ich ohne Eingabe durchlaufen, anschließend kommt der normale Anmeldeschirm (ebenfalls für 10 Sekunden), dann wird der Bildschirm gesperrt mit diesem Script, das im Autostart eingetragen ist...

sh -c "sleep 2; mate-screensaver-command --lock"
...und beim ersten Mausklick oder Raddrehen wird mein Passwort abgefragt (da ich immer automatisch den gleichen bzw. vorherigen User starten lasse).

Aber auch all das hat sich vor und nach Auftreten des Problems nicht geändert.
« Letzte Änderung: 13.03.2018, 13:45:40 von Centauri39 »

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #17 am: 13.03.2018, 14:39:32 »
Einfach runterfahren, fertig.
ok, soweit gleiches Vorgehen.

Was mir aber auch noch auffällt ist, dass beim Booten vorm normalen Mint-Anmeldeschirm sporadisch ein zweites, schlichter aussehendes Anmeldefenster kommt.
Ist das sporadisch kurzzeitig und schlichte Anmeldefenster ohne Hintergrundbild und zeigt am oberen Rand eine Art Menüleiste an? Mein Gedanke geht gerade in Richtung des lightdm Display-Managers aber den dürfte es unter LM18.1 noch gar nicht geben oder hast du in der Vergangenheit zwecks lightdm mal einen Installationsversuch unternommen?

Code: [Auswählen]
sh -c "sleep 2; mate-screensaver-command --lock"

...und beim ersten Mausklick oder Raddrehen wird mein Passwort abgefragt (da ich immer automatisch den gleichen bzw. vorherigen User starten lasse).
Vielleicht rührt das Problem aus der Automatischen Benutzeranmeldung und vereitelt den Skypelogin. Schalte den Autologin der Benutzeranmeldung doch mal testweise "Aus". Mich irritieren auch noch die "sleep 2; mate-screensaver-command --lock", könnte sein das es zu zeitlichen Überschneidungen kommt und der nach 2 Sekunden Verzögerung startende "mate-screensaver-command --lock" das nach weiteren 18 Sekunden beginnende Skypelogin verhindert!? Verkürze doch mal die Skype-Scriptzeit von 20 auf 5 und setze die Screensaver Zeit von 2 auf 10 Sekunden. So könnte das Skype-Script und Skype-Login ablaufen und erst anschliessend der Screensaver aktiv werden.

Momentan bin ich überfragt da sich unsere Dektop Versionen (Mate / Cinnamon) unterscheiden könnte es auch dadurch bedingt verschiedene Ursachen haben. Und es gibt noch einen weiteren Unterschied bei den LinuxMint Versionen, von 18.1 zu 18.3. Bei mir unter 18.3 könnte eventuell auch systemd zu einem anderen Verhalten beitragen, in der dconf ergibt die Suche nach Skype aber keinen Treffer. Vielleicht kann ein LM18.1 Mate User hier weiter Unterstützen.
« Letzte Änderung: 13.03.2018, 15:07:25 von kuehhe1 »

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #18 am: 13.03.2018, 16:08:21 »
Ist das sporadisch kurzzeitig und schlichte Anmeldefenster ohne Hintergrundbild und zeigt am oberen Rand eine Art Menüleiste an?
Das kann ich Dir leider gar nicht so spontan beantworten.
Das muss ich erst nochmal genau beobachten, wie es aussieht, wenn es das nächste Mal passiert.
Ich komme dann noch mal darauf zurück.

Dieses Screenlock-Script aber ich drin, weil ich den PC fernsteuern können wollte (per VNC mit Vino und Remmina).
Ohne das Script wird die Fernsteuerung aber erst nach dem Login aktiv, sodass ich mich nicht in den per WOL gestarteten PC hätte einloggen können.

Ich meine ok, mit dem Script wird die Fernsteuerung zwar auch erst nach dem Login aktiv, aber da ich, nach dem automatischen Login, mit dem Script eine "zusätzliche Sperre" drin habe, umgehe ich diesen Nachteil.
Wichtig war mir dabei, dass die Sperre, also der Screenlock, so schnell wie möglich aktiv wird, um evtl. unbefugte Zugriffe zu vermeiden.

Aber gut, das sind eigentlich alles eher nebensächliche Infos, da das alles lange vor Auftreten des Problems schon so konfiguriert war und immer problemlos lief.


könnte sein das es zu zeitlichen Überschneidungen kommt und der nach 2 Sekunden Verzögerung startende "mate-screensaver-command --lock" das nach weiteren 18 Sekunden beginnende Skypelogin verhindert!?

Solche Dinge habe ich auch schon berücksichtigt, indem ich versucht habe, mit dem "Skype-Autostart-delayed"-Script (selbst erfundener Name  ;) ) eine ausreichend lange Verzögerung so einzurichten, dass ich mit Mint bereits sicher online und eingeloggt bin, bis Skype gestartet wird.

Wie gesagt, das hat alles immer gut funktioniert. Ich weiß nicht, was da plötzlich los ist.
Keine Ahnung, aber vielleicht sollte ich einfach warten, bis das neue Mint 19 rauskommt und dann mal wieder neuaufsetzen.

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #19 am: 13.03.2018, 17:17:22 »
Keine Ahnung, aber vielleicht sollte ich einfach warten, bis das neue Mint 19 rauskommt und dann mal wieder neuaufsetzen.
Nun ja, ich bin zwar auch allem Neuen positiv aufgeschlossen, aber nur wegen Skype mein ansonsten "tadellos" laufendes LM18.3 aufzugeben werde ich nicht machen.

Zumal bei mir gar nicht sicher wäre ob nach einer LM19.x Installation mein Skype Bild korrekt angezeigt würde. Ich könnte ebenso gut auf ein installiertes Skype verzichten und es per Webinterface benutzen, aber auch da steht nach dem Wechsel auf das Neue skypeforlinux mein Bild seither Kopf und bedarf hier unter LinuxMint noch einer Lösung. Auf Win10 hingegen konnte es durch einen älteren, angepassten Camera Treiber bereinigt werden.

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #20 am: 13.03.2018, 18:22:58 »
Ich persönlich bin ja von der ganzen 18er-Reihe von Mint eher enttäuscht, nicht nur wegen Skype.

Ich habe mit der 16 begonnen (kurz vorm WinXP-Ende) und die 17.x war auch ganz ok,
aber die 18.x fand ich immer recht buggy, denn irgendwo hat die immer rumgezickt.
Meistens nur Kleinkram, aber der hat halt auf Dauer auch genervt.

Ich hoffe, dass das mit der 19 wieder besser wird.

Ich denke, alternativ werde ich sehr wahrscheinlich auch mal mal Ubuntu MATE 18.04 testen, denn das kommt ja auch bald.

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #21 am: 13.03.2018, 19:21:15 »
Ich hoffe, dass das mit der 19 wieder besser wird.
nun zu meiner Einstiegsversion LM17.3 Cin. kann ich nicht viel sagen, denn einige Tage nach der Erstinstallation erschien die LM18 Cin. da habe ich gleich noch mal neu installiert und damit funktionierte auch meine Kamera noch super und mit v4l2 konnte damit noch die Bildlage für Skype korrigiert werden, heute ist eine Anpassung der Cam für Skypeforlinux unmöglich.
Mein Produktivsystem mit ASUS K52jc Bj.2011 funktioniert bis auf skypeforlinux soweit gut. Alles was ich brauche ist installiert und eingerichtet, da werde ich auch nach Veröffentlichung der LM19 erst mal abwarten und schauen was so berichtet wird. >:(

Bis dahin, viel Erfolg.

« Letzte Änderung: 16.03.2018, 14:30:58 von kuehhe1 »

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #22 am: 15.03.2018, 16:15:14 »
Ich hab den Bootvorgang noch ein paar mal beobachtet und festgestellt, dass da teilweise das schlichtere Anmeldefenster kommt, aber auf schwarzem Hintergrund (kein "Wallpaper") und dass dann kein weiteres Anmeldefenster kommt.
Skype (mit derzeit aktiver Hintergrund-Start-Option und ohne Delay-Script) geht aber auch dann nur manchmal online, wird also blau. Meistens ist es weiß.

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #23 am: 15.03.2018, 20:16:45 »
wie gesagt:
Momentan bin ich überfragt da sich unsere Dektop Versionen (Mate / Cinnamon) unterscheiden könnte es auch dadurch bedingt verschiedene Ursachen haben. Und es gibt noch einen weiteren Unterschied bei den LinuxMint Versionen, von 18.1 zu 18.3. Bei mir unter 18.3 könnte eventuell auch systemd zu einem anderen Verhalten beitragen, in der dconf ergibt die Suche nach Skype aber keinen Treffer. Vielleicht kann ein LM18.1 Mate User hier weiter Unterstützen.

Ich hab den Bootvorgang noch ein paar mal beobachtet und festgestellt, dass da teilweise das schlichtere Anmeldefenster kommt, aber auf schwarzem Hintergrund (kein "Wallpaper") und dass dann kein weiteres Anmeldefenster kommt.
irgendwie hab ich beim nach deiner Beschreibung "schlichteren Anmeldefenster" den Verdacht das es sich dabei um den "lightdm" handelt. Hast du diesbezüglich in der Vergangenheit einen Installationsversuch unternommen? Was sagt Synaptik zur Suche nach "lightdm" ?


Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #24 am: 15.03.2018, 20:46:37 »
Von lightdm ist nichts installiert.

Das Seltsame ist, dass das nur sporadisch passiert.
Meistens kommt das normale Anmeldefenster von MATE.

Leider finde ich im Web kein Bild dieses Anmeldefensters.

Ich muss wohl erst mal warten, bis ich es selbst fotografieren kann.


Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #25 am: 16.03.2018, 14:19:18 »
Von lightdm ist nichts installiert.
sicher? was gibt das Terminal aus:dpkg -l lightdm* | egrep '^ii '

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #26 am: 16.03.2018, 16:05:02 »
Laut Synaptic ist nichts installiert und der Befehl ergibt auch keine Ausgabe.

Heute gab es doch wieder zwei Anmeldeschirme, den schlichten (hatte leider zwecks Foto das Handy nicht griffbereit) und den normalen und Skype war wieder "weiß".

Re: LM 18.1 MATE 64bit - Skype geht nicht automatisch online
« Antwort #27 am: 11.04.2018, 13:52:49 »
Momentan sieht es aus, als sei das Skype-Problem gelöst, allerdings erst durch Maßnahmen unter Win10 meines Dualboot-Rechners.

Für Win 10 gibt es derzeit (oder gab es gestern) ein gratis WiFi-Analyzer-Tool, dessen Download und Installation nur unter Win10 möglich ist.
Ferner braucht man dazu einen Microsoft-Account.
Nach Anlegen dieses Accounts stieß ich (immer noch auf Win10) zufällig auf einen Hinweis zu Skype und ich dachte ich geh mal rein, und schau, ob das richtig läuft.
Seitdem geht Skype auch wieder auf Mint richtig online.

Was das falsche Login-Fenster betrifft, das scheint auch verschwunden zu sein bzw. das richtige wieder richtig zu laufen, nach dem ich folgendes im Terminal erneut installiert habe.
sudo apt-get install mint-artwork-gnome mint-meta-mate mint-meta-core mint-artwork-common mintsystem ubuntu-system-adjustmentsVermutlich war wohl irgendwas mit mdm verbogen.
« Letzte Änderung: 11.04.2018, 14:25:33 von Centauri39 »