Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.07.2020, 17:41:40

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 670370
  • Themen insgesamt: 54315
  • Heute online: 470
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [erledigt] Probleme ohne Ende: Nach login-Fenster kein Cinnamon  (Gelesen 742 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« am: 08.03.2018, 09:36:00 »
Ich arbeite mit Windows 10 64Bit und mit dem immer noch aktuellsten Linux Mint und Cinnamon.

Ich bin jetzt zweimal bis zum Anmeldefenster gekommen, danach gebe ich mein Passwort ein und normalerweise sollte dann nach einigen Sekunden (manchmal auch länger) mit ziemlichem Getöse mein Cinnamon-Schreibtisch aufgehen.

Nun hatte ich zweimal hinterander den Effekt, dass zwar der Mauszeiger auf schwarzem Hintergrund auftauchte und auch zu bewegen war, aber der Cinnamon-Schreibtisch nicht auftauchte. Ich habe etwa 5 Minuten gewartet, dann abgebrochen und neu gestartet. Gleicher Effekt. Dann habe ich nochmal abgebrochen und wieder hochgefahren. Diesmal kommt die berühmte Fehlermeldung, die ich schon mehrmals hatte. Fehler, weiter mit <return> oder ctrl-D

Jetzt arbeite ich unter WIndows 10.

Ich habe die vergangenen Tage nur mit Mint gearbeitet, nicht mit Windows. Vorher habe ich die BIOS Einstellungen angeschaut, sieht ganz nromal aus. Hatte jeand dieses Problem schon mal. Es kann ja zunächst nicht am BIOS gelegen haben, sondern am Linux selbst. Ich habe zwar alles mehrfach gesichert, aber wenn ich alle halbe Jahre Linux neu installieren muss, ist das nicht sehr sexy.

Ich probiers jetzt nochmal. Wenn es jetzt geht, schreie ich Kakao!!!
« Letzte Änderung: 13.03.2018, 11:07:38 von Sonoptikon »

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #1 am: 08.03.2018, 09:58:07 »
KAKAO!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Nach ca. 20 Minuten hat sich der Cinnamon-Schreibtisch mit Getöse gemeldet. An sich ist das ja praktisch, man hört das ja auch, wenn man längst aufgegeben hat und irgendwo anders sitzt.

Nach etwa 20 Minuten war es so weit.

Ich fühle mich wie ein zweifelnder Christ (da ssind ja bekanntlich die wertvollsten): "Und er existiert doch ..."

Kann mir jemand diesen Effekt erklären?

Hintergrund: Ich habe gestern ein neues Sicherungstool gebastelt, Sicherung mit webdav in die Cloud - kann es sein, dass Reste dieses Prozesses noch verarbeitet worden sind? Oder was kann der Grund für diesen langen Zeitraum des Nachdenkens sein?

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #2 am: 08.03.2018, 10:09:11 »
Schau dir mal die /etc/fstab  und Netzwerksachen an. Da wird das System irgendwas suchen was nicht da ist. Das dauert :)

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #3 am: 08.03.2018, 10:58:19 »
Ich arbeite mit Windows 10 64Bit und mit dem immer noch aktuellsten Linux Mint und Cinnamon.
Also 18.3. Bitte auch so schreiben, da in wenigen Monaten 19 aktuell sein wird. Dann passt die Abgabe nicht mehr. Denke immer auch an die Nachwelt, die das liest.

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #4 am: 08.03.2018, 11:35:36 »
Ja, gerne, das mit der Nachwelt habe ich verinnerlicht.

Ich meine, die fstab ist sauber. Wo soll ich beim Netzwerk gucken?

Ich habe eine WD-Netzwerkplatte (die /nas/public), die gut funktioniert, aber manchmal nicht gemountet wird, da hilft dann ein beherztes "sudo mount -a", aber besser wäre, wenn ich wüsste, warum nicht gemountet wird:

#
# Windows-Verzeichnisse
#
/dev/sda2 /media/kairos/DATA ntfs    defaults    0    0 
/dev/sdb3 /media/kairos/OS ntfs    defaults    0    0
#
# Netzwerklaufwerke und 1und1-Cloud mounten
#
https://sd2dav.1und1.de /1und1 davfs uid=kairos,gid=kairos,_netdev,auto,defaults 0 0
#
//192.168.178.1/fritz.nas/ASMT-2105-01 /nas/fritz cifs vers=1.0,uid=kairos,gid=kairos,pass=,auto,defaults 0 0
#
//192.168.178.21/public /nas/public cifs uid=kairos,gid=kairos,pass=,auto,defaults 0 0
//192.168.178.21/media /nas/media cifs uid=kairos,gid=kairos,pass=,auto,defaults 0 0
//192.168.178.56/public /nas/iomega cifs vers=1.0,uid=kairos,gid=kairos,pass=,auto,defaults 0 0

Das "vers=1.0" bei der iomega-Festplatte ist notwendig, sonst wird nicht gemountet - auch sowas, was ich zufällig erfahren habe. Kommt sonst kein Mensch drauf ...

Bei den "Netzwerksachen", wo soll ich da gucken?

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #5 am: 08.03.2018, 12:22:05 »
Also: Es ist jetzt so, dass ich wieder beim Anmeldefenster lande. Beim letzten Mal hat es ca. 20 Minuten gedauert, bis ich nach der EIngab des Passworts auf den Cinnamon-Schreibtisch kam. Ich habe dann festgestellt, dass dei Cinnamon-Oberfläche extrem langsam ist, sp z.B. dauert es unendlich lang bis "Antwortet nicht", wenn ich das Dateien-Icon anklicke.
Andere Funktionen wie z.B. forefox oder Terminal gehen schnell.

Was auch Probleme macht: ls -l im Terminal. Dauert ewig. ps ax geht sehr schnell.

Wenn ich auf dem Schreibtisch ein Element markiere und z.B.mit der rechten Maustaste ändern will, geht nichts mehr. ich kann dann auch kein anderes Element mehr markieren.
Programme aus dem Menü heraus starten geht schnell.

Wenn ich runterfahren will, bekomme ich die Meldung, dass Cinnamon housekeeping noch läuft. Jetzt gerade wollte ich runterfahren, da ging gar nichts mehr, ich könnte nur noch abschalten. ich wollte ein Icon auf dem Schreibtisch verschieben, danach blieb alles stehen.

Gobt es die Möglichkeit, ein recover oder eine Neusinstallation auf das Cinnamon zu machen. ich gehe davon aus, dass die Cinnamon-Oberfläche die Probleme macht.

Wenn ich runterfahren will, bekomme ich eine Meldung über Programme, die noch laufen (warten / trotzde, runterfahren), und da ist immer cinnamon housekeeping dabei.
Auf der Cinnamon-Oberfläche funktioniert nichts mehr - im Grunde ja, aber es dauert extrem lang, und im Grunde kann man damit nicht mehr arbeiten.
« Letzte Änderung: 08.03.2018, 13:56:56 von Sonoptikon »

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #6 am: 08.03.2018, 14:30:07 »
Ich habe vor Jahren Win gekillt aber wo in der fstab ist dein mint installiert?

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=5b7 /                 ext4    errors=remount-ro 0       1
# /home was on /dev/sda2 during installation
UUID=2fc /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=849 none            swap    sw              0       0

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #7 am: 08.03.2018, 14:39:07 »
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda4 during installation
UUID=992fbc30-6e33-4c81-8a15-a62981387e1e /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda3 during installation
UUID=77C0-A3CA  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/sda5 during installation
UUID=bba3177c-b0ce-498e-8421-e64bc75f2ad1 none            swap    sw              0       0

Ich habe übrigens das 1und1 (sd2dav) rausgenommen, und plötzlich habe ich ein flottes System. Mir ist zwar nicht ganz klar, warum das so ist, weil das /1und1 ohne Probleme erreichbar war. Aber warum auch immer ...

Es scheint so, dass die Probleme teilweise auch vom Win ausgehen, aber ich kann es nciht lokalisieren. Leider brauche ich das Win noch für genau 2 Anwendungen, die auf dem Linux so definitiv nicht laufen (bei einem von beiden funktioniert nur der Sound nicht ...)

Mal Frage vorweg: Kann ich problemlos eine neue Partition für /home einrichten oder ist das kompliziert. Dann könnte ich ja jederzeit neu installieren, und ein/home wäre noch da.
« Letzte Änderung: 08.03.2018, 14:43:44 von Sonoptikon »

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #8 am: 08.03.2018, 14:47:37 »
/dev/sda2   /media/kairos/DATA   ntfs    defaults    0    0 
/dev/sdb3   /media/kairos/OS   ntfs    defaults    0    0
Wenn das in AW#4 deine fstab ist, so fällt auf, dass du hier mit unsicheren Gerätebezeichnern mountest statt die eindeutigen UUIDs zu verwenden! Eine potentielle Fehlerquelle.

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #9 am: 08.03.2018, 14:52:30 »
Ich habe übrigens das 1und1 (sd2dav) rausgenommen, und plötzlich habe ich ein flottes System.
Muss mal nachfragen: hat das denn JEMALS flott funktioniert MIT dem Eintrag? Oder hast du dir im Grunde damit erst den Bock geschossen?

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #10 am: 08.03.2018, 14:57:30 »
Ich habe übrigens das 1und1 (sd2dav) rausgenommen, und plötzlich habe ich ein flottes System.
Muss mal nachfragen: hat das denn JEMALS flott funktioniert MIT dem Eintrag? Oder hast du dir im Grunde damit erst den Bock geschossen?
Es hat eigentlich immer funktioniert. Bis heute.

Wie kann ich die Gerätebezeichnungen besser/sicherer machen?
Das ist übrigens bei der Installation von Mint so eingerichtet worden. Ich habe da nichts dran gemacht.

Lediglich die zweite Abteilung ab /1und1 stammt von mir

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #11 am: 08.03.2018, 15:00:39 »
blkid zeigt dir die UUIDs zu jeder Partition an. Du ersetzt dann /dev/sdXY durch UUID="blabla"

Re: Probleme ohne Ende: Nach login-Fenster kein Cinnamon
« Antwort #12 am: 08.03.2018, 15:03:25 »
DAnke. Und jetzt muss ich weg, bin Sonntag wieder erreichbar.
Aber es ist ein gutes Gefühl, dass alles erst mal läuft