Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
05.03.2021, 11:42:45

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 719932
  • Themen insgesamt: 58218
  • Heute online: 671
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Wo kann ich eine Meldung, die beim Hochstart angezeigt wird auslesen?  (Gelesen 3373 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: Wo kann ich eine Meldung, die beim Hochstart angezeigt wird auslesen?
« Antwort #15 am: 25.02.2018, 14:08:01 »
@kuehhe1 noch hier die Terminalausgabe - wie sehe ich jetzt, ob ubuntu wirklich auf sda1 und mint auf sda6 ist (wie ich vermute)?
~ $ sudo lsblk -o name,fstype,label,size,mountpoint,uuid,model,mode
NAME   FSTYPE LABEL   SIZE MOUNTPOINT UUID                                 MODEL   MODE
sr0                  1024M                                                 CDDVDW  brw-rw----
sda                 465,8G                                                 WDC WD5 brw-rw----
├─sda2                  1K                                                         brw-rw----
├─sda5 swap          15,9G [SWAP]     9bdf69f1-c0f2-4f6e-87d3-141acab1e624         brw-rw----
├─sda1 ext4           251G            1f550332-cc4e-47fd-b8f4-309d0ba772a0         brw-rw----
└─sda6 ext4         198,9G /          4bd3855e-1b60-4f60-98d3-01a1bce4fe82         brw-rw----
~ $

Ev. hat auch noch wer eine Idee zu meiner verblieben Frage unter Posting #14?
« Letzte Änderung: 25.02.2018, 14:32:58 von Worf »

wie sehe ich jetzt, ob ubuntu wirklich auf sda1 und mint auf sda6 ist (wie ich vermute)?
├─sda1 ext4           251G            1f550332-cc4e-47fd-b8f4-309d0ba772a0         brw-rw----
└─sda6 ext4         198,9G /          4bd3855e-1b60-4f60-98d3-01a1bce4fe82         brw-rw----
nun, da du von LinuxMint schreibst sollte es auf sda6 installiert sein, auch zu erkennen auch am "/"

Hast du zu deiner Grafikkarte schon die Forum Suche bemüht? Eventuell gibts da auch einen Zusammenhang mit deiner Kernelversion 4.13.0-36, da gibts verschiedene Meinungen zu denn bei nicht allzu neuester Hardware könnte es sein das du mit 4.4.0-116 weniger Probleme hättest. Aber das Grafikkartenproblem wär ein neues, eigenes Thema.
« Letzte Änderung: 25.02.2018, 16:01:51 von kuehhe1 »

Hi :)
ich meinte eigentlich den lts kernel 4.4er.... ;)

Moin,
sind die meldung mit einem anderen kernel auch da?
welcher wird benutzt?
Code: [Auswählen]
uname -r
deinen Gedankengang, speziell zum LTS 4.4er Kernel zu wechseln konnte der TE daraus wohl nicht entnehmen.

Grafikkarte ist recht neu, aber ich schau da mal weiter. Zur Anzeige der sda2 "Erweiterte Partition", die wird also in "Laufwerke" völlig falsch angezeigt, der Platz verteilt sich auf sda1 und 6. Da ist mir auch klar, dass da keine Prüfung mit fsck möglich war. Terminal zeigt das offenbar korrekt an.
Zum LTS 4.4 Kernel, soll ich das System mal mit dem hochfahren und auslesen, ist das so gemeint?

Hi :)
genau das war gemeint ;)

Also hochgefahren mit 4.4-Kernel geht nimmer, ich kann max. bis 4.8.00-53 zurück und das hab ich mal gemacht. Mit der dann erfolgten 800x600- oder noch kleineren max. Auflösung wars dann a bissl schwierig, aber ich hab keine andere Auflistung gefunden als die unter dem neuesten Kernel. Falsch, siehe nächstes Posting von mir #23!

Zu meiner Frage noch von #14:
Zitat
Könnte ein Teil der noch verbliebenen Meldungen ev. darauf zurückgehen, dass ich bei der Erstinstallation ein 2. DVD-Laufwerk drin hatte, das sich dann irgendwie verabschiedet hat (hatte noch keine Zeit, zu untersuchen, ob das einfach den Geist aufgegeben hat oder sonstwas, das wurde nicht mal mehr im Bios erkannt, daher hab ichs komplett abgehängt - also Connector und Strom weg).
Wenn ja, welche Meldungen wären das?
Über ACPI weiß ich nur soviel, dass das unter Linux noch nie so richtig fehlerfrei implementierbar war, aber ev. ist es hier nur der Hinweis auf das fehlende DVD-LW  :o
kann das ein Grund sein oder hängt das ev. mit dem Sound zusammen, da hatte ich in meinem Beitrag hier keine Antwort erhalten - siehe dortige #116 und davor: https://www.linuxmintusers.de/index.php?action=profile;u=109534;area=showposts;start=105
Ich krieg trotz Displayportverbindung den Sound nur über ein Zusatzkabel (Rundstecker grün also dieser minimale Soundanschluss, daher auch kein wirklicher "Sound")  >:(
« Letzte Änderung: 25.02.2018, 20:04:03 von Worf »

ich kann max. bis 4.8.00-53 zurück
wenn bisher Kernel 4.4 nicht installiert war müsstest du das natürlich zuvor erledigen. Dazu mit der Aktualisierungsverwaltung>Anzeigen>Linux Kernel aus der Linken Spalte die Version 4.4 vorauswählen ind der Rechten Spalte werden dann die verfügbaren angezeigt, dort den aktuellsten markieren und installieren. Anschließend neu Starten.

Zu meiner Frage noch von #14:
das kannst du nur austesten.
Wenn das Gerät wie du sagst nicht vom BIOS erkannt wird, würde ich zuerst einen Schaden bei den Kabeln (Strom / Datenkabel) ausgrenzen, auf Bruch / Beschädigung prüfen. Ist daran nichts zu erkennen, dann die Kabel tauschen oder erneuern. Hilft das auch nichts könntest du die SATA-Ports am Mo.Bo. tauschen und im BIOS beobachten. Wenn's dann noch nicht geht bleibt nur noch der Test an einem Externen SATA / USB Adapter oder in einem anderen Rechner.
ABER VORSICHT, das Ab- und Umstecken immer nur bei ausgeschaltetem Rechner und gezogenem 230V Netzteil.

Dein Soundproblem ist eine völlig Andere Baustelle und sollte in einem eigenen Thema weiter behandelt werden, ich denke aber das es eine Einstellungssache ist.
Edit:Hinweis: dein Direkt-Link funzt irgendwie nicht, ich finde darin die Antwort #116 nicht.
« Letzte Änderung: 25.02.2018, 20:32:18 von kuehhe1 »

Sobald ich wieder ans Gerät kann, mach ich das.
Zuvor noch eine Korrektur - Unter Kernel 4.8.00-53 hab ich doch abweichende Terminalausgaben. Vielleicht kann da schon wer was erkennen:
Zitat
Nur diese 2 Meldungen sind (unklarerweise) anders:
kern  :warn  : [    0.729110] MXM: GUID detected in BIOS
kern  :warn  : [    0.838869] nouveau 0000:01:00.0: DRM: Pointer to flat panel table invalid
Statt bisher an dieser stelle bei kernel 4.13:
kern  :warn  : [   21.961121] new mount options do not match the existing superblock, will be ignored
steht bei Kernel 4.8.00-53 (offenbar wegen der gpu):
kern  :warn  : [   22.034991] nvidia: loading out-of-tree module taints kernel.
kern  :warn  : [   22.034994] nvidia: module license 'NVIDIA' taints kernel.
kern  :warn  : [   22.034994] Disabling lock debugging due to kernel taint
kern  :warn  : [   22.042095] NVRM: loading NVIDIA UNIX x86_64 Kernel Modu-le  384.111  Tue Dec 19 23:51:45 PST 2017 (using threaded interrupts)
kern  :warn  : [   22.434554] new mount options do not match the existing superblock, will be ignored
kern  :warn  : [   23.386757] NVRM: Your system is not currently configured to drive a VGA console
                              on the primary VGA device. The NVIDIA Linux graphics driver
                              requires the use of a text-mode VGA console. Use of other console
                              drivers including, but not limited to, vesafb, may result in
                              corruption and stability problems, and is not supported.
Und dies klarerweise wegen des fehlenden CPU-updates:
~ $ dmesg -l err | head
[    0.000000] [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x22 (or later)

Noch immer unklar beim Kernel 4.13 von vorher (siehe oben):
kern  :warn  : [   21.961121] new mount options do not match the existing superblock, will be ignored
und das gibt’s bei beiden kernels ebenfalls noch:
~ $ dmesg -T | grep -i error
[So Feb 25 10:47:36 2018] RAS: Correctable Errors collector initialized.
[So Feb 25 10:47:55 2018] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro

@kuehhe1: komisch, der link geht bei mir, aber ich muss das eh nochmal angehen. Da kam nix unter Forum Hardware allgemein. Mach das dann extra.
« Letzte Änderung: 25.02.2018, 20:15:13 von Worf »

Zuvor noch eine Korrektur - Unter Kernel 4.8.00-53 hab ich doch abweichende Terminalausgaben.
Jeder Kernel kann dir andere Fehler bringen, versuche erst mal den 4.4er zu installieren und schaue nach den Meldungen. Ich bin jetzt gerade überfragt ob man vor einem Kernelwechsel zu einer andere Kernel-Linie in der Treiberverwaltung zuvor auf nouveau umstellen muss oder soll??

@kuehhe1: komisch, der link geht bei mir, aber ich muss das eh nochmal angehen.
ich hatte mich da falsch ausgedrückt, der Link aufs Thema an sich funktioniert, aber du verweist auf Antwort #116 und die finde ich nicht.
« Letzte Änderung: 25.02.2018, 21:54:58 von kuehhe1 »

Ich bin jetzt gerade überfragt ob man vor einem Kernelwechsel zu einer andere Kernel-Linie in der Treiberverwaltung zuvor auf neauveu umstellen muss oder soll??
Ist normal nicht nötig. Der Nvidia wird über dkms automatisch installiert und der Treiber läuft ja problemlos unter 4.4.0

Ganz sicher? Ich kenne jetzt gerade nicht den Hinweis der Aktualisierungsverwaltung. Beim Update innerhalb der Kernellinien geht's sicher, nur beim Schritt auf eine niedrigere Kernel-Version z.B. 4.13. > 4.1.0 oder 4.13. > 4.4. meine ich etwas in der Form gelesen zu haben. Das schau ich mir morgen an, bin gerade unterwegs.

Edit: Ich hab nun einiges gelesen finde aber nichts zum Thema Kernel Wechsel mit Bezug auf deaktivieren des nVidia und Umstellung auf nouveau. Dann habe ich mich dabei geirrt.
« Letzte Änderung: 26.02.2018, 10:52:29 von kuehhe1 »

Ich schau lieber auch noch, es soll ja nicht mehr durcheinanderbringen als auflösten.
Im Zweifelsfall lass ich die GPU außen vor.

Zum LTS Kernel 4.4: a)
Welchen der angeführten sollte ich denn installieren (den ältesten)?
b) Der Sinn ist die ev. höhere Kompatibilität / Stabilität im Gesamtsystem?
c) Wird der 4.13-er dann deinstalliert oder ist der nur deaktiviert und kann dann bei Bedarf wieder gestartet werden (beim Hochfahren in der Auswahl)?

Hab die fraglichen Meldungen mal zusammengefasst - was könnten denn die inhaltlich bedeuten, damit ich mal im Manual etc. nachrecherchieren kann:

Zitat
dmesg -x -l crit,err,warn
kern  :warn  : [    0.072698] PCCT header not found. --> Das finde ich nirgends heraus, worums da geht
kern  :warn  : [    0.582032] (NULL device *): hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info(). --> Könnte passen, wird ev. von Bios reguliert.
kern  :warn  : [    0.648474] i8042: PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp --> Könnte passen, weil es eine Umschaltmöglichkeit auf Direkt-Audio gibt, muss ich noch nachrecherchieren
kern  :warn  : [   19.759452] ACPI Warning: SystemIO range 0x0000000000001828-0x000000000000182F conflicts with OpRegion 0x0000000000001800-0x000000000000187F (\PMIO) (20170531/utaddress-247)
kern  :warn  : [   19.759459] ACPI Warning: SystemIO range 0x0000000000001C40-0x0000000000001C4F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20170531/utaddress-247)
kern  :warn  : [   19.759463] ACPI Warning: SystemIO range 0x0000000000001C30-0x0000000000001C3F conflicts with OpRegion 0x0000000000001C00-0x0000000000001C3F (\GPRL) (20170531/utaddress-247)
kern  :warn  : [   19.759465] ACPI Warning: SystemIO range 0x0000000000001C30-0x0000000000001C3F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20170531/utaddress-247)
kern  :warn  : [   19.759469] ACPI Warning: SystemIO range 0x0000000000001C00-0x0000000000001C2F conflicts with OpRegion 0x0000000000001C00-0x0000000000001C3F (\GPRL) (20170531/utaddress-247)
kern  :warn  : [   19.759471] ACPI Warning: SystemIO range 0x0000000000001C00-0x0000000000001C2F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20170531/utaddress-247)
--> Worum kanns denn da gehen, ACPI ist doch das allg. Energielevel-Management?
kern  :warn  : [   19.759474] lpc_ich: Resource conflict(s) found affecting gpio_ich detto?
kern  :warn  : [   21.542234] nvidia: loading out-of-tree module taints kernel.
kern  :warn  : [   21.542237] nvidia: module license 'NVIDIA' taints kernel.
kern  :warn  : [   21.542237] Disabling lock debugging due to kernel taint
kern  :warn  : [   21.550668] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.25  Wed Jan 24 20:02:43 PST 2018 (using threaded interrupts) --> Könnte ja passen, weil eigener Nvidia-Treiber und -Tools
kern  :warn  : [   22.407275] new mount options do not match the existing superblock, will be ignored --> Diese Meldung kommt nur mit Kernel 4.13: Was das bedeutet bzw. wie es beseitigt werden kann, würde mich interessieren
~ $ dmesg -T | grep -i err
[Mo Feb 26 13:36:47 2018] ACPI: IRQ0 used by override.
[Mo Feb 26 13:36:47 2018] ACPI: IRQ9 used by override.
[Mo Feb 26 13:36:47 2018] DMAR-IR: Use 'intremap=no_x2apic_optout' to override the BIOS setting.
[Mo Feb 26 13:36:47 2018] core: PMU erratum BJ122, BV98, HSD29 worked around, HT is on
[Mo Feb 26 13:36:47 2018] ACPI: Using IOAPIC for interrupt routing
[Mo Feb 26 13:36:47 2018] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 10 *11 12 14 15)
[Mo Feb 26 13:36:47 2018] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 *10 11 12 14 15)
[Mo Feb 26 13:36:47 2018] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 10 *11 12 14 15)
[Mo Feb 26 13:36:47 2018] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 *5 6 10 11 12 14 15)
[Mo Feb 26 13:36:47 2018] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[Mo Feb 26 13:36:47 2018] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[Mo Feb 26 13:36:47 2018] ACPI: PCI Interrupt Link [LNKG] (IRQs *3 4 5 6 10 11 12 14 15)
[Mo Feb 26 13:36:47 2018] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 *10 11 12 14 15)
--> Gehört zum ACPI-Komplex? Bedeutung=?
[Mo Feb 26 13:36:47 2018] RAS: Correctable Errors collector initialized.
[Mo Feb 26 13:37:06 2018] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro --> völlig unklar, wieso sda6 re-mounted werden musste oder wie lese ich das?
[Mo Feb 26 13:37:08 2018] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.25  Wed Jan 24 20:02:43 PST 2018 (using threaded interrupts) --> Das ist der eingespielte GPU-Treiber
« Letzte Änderung: 26.02.2018, 15:18:20 von Worf »

Welchen der angeführten sollte ich denn installieren (den ältesten)?
warum den Ältesten, ich würde den aktuellsten Kernel der 4.4er Reihe installieren = 4.4.0-116, so alt ist deine Grafikkarte doch nicht oder?

c) Wird der 4.13-er dann deinstalliert oder ist der nur deaktiviert und kann dann bei Bedarf wieder gestartet werden (beim Hochfahren in der Auswahl)?
Wenn du über die Aktualisierungsverwaltung (Akt.-Verw.) einen Kernel installierst bleibt der alte Kernel bis zum Neustart aktiv. Nach Neustart wird dann der zuletzt (neu) installierte geladen. Der alte Kernel bleibt installiert und kann manuell, vorzugsweise über die Akt.-Verw., entfernt werden.
Um den Kernel beim Start auszuwählen, bei einem Standardsystem ohne Dualboot ist das Grub-Auswahlmenü versteckt, muß beim Start die [Shift-Tast] gedrückt werden, dadurch gelangst du in das Auswahlmenü.

Hab die fraglichen Meldungen mal zusammengefasst - was könnten denn die inhaltlich bedeuten, damit ich mal im Manual etc. nachrecherchieren kann
Ähm, das Manual sollte eigentlich etwas über die Meldungen aussagen, recherchiere zuerst mal darin.

[Mo Feb 26 13:37:08 2018] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.25  Wed Jan 24 20:02:43 PST 2018 (using threaded interrupts) --> Das ist der eingespielte GPU-Treiber
Wie ich bereits sagte ich kenne mich mit deiner Grafikkarte nicht aus und nicht jeder Treiber, auch wenn er noch so neu ist, wird mit jedem Kernel laufen, dazu sollte eigentlich nVidia Angaben machen können. Vielleicht gibts dort Listen wer mit wem kann.

Im LMU-Wiki gibts einen Hinweis zur nVidia Installation:
Zitat
Manche Treiber brauchen einen bestimmten Kernel, was sich über die Aktualisierungsverwaltung > Anzeigen > Linux-Kernel  erledigen lässt.
Alternativ: https://www.linuxmintusers.de/index.php?action=wiki;page=Erstupdates_bzw._Mintupdater

Nun driftest Du bzw. wir so langsam vom eigentlichen Thema ab: "Wo kann ich eine Meldung, die beim Hochstart angezeigt wird auslesen?" Es geht immer mehr um ein, zwei andere Themen, Kernel und Grafikkarte bzw. welcher Kernel passt zur Grafikkarte. Besser wäre es dies wegen der Übersichtlichkeit hier zu  trennen. Erstelle am besten ein neues Thema zur Grafikkarte, zeige dein System mit inxi -Fz oder zumindest die Grafik mit inxi -G
Wie du Meldungen auslesen kannst weist du ja nun. Irgendwie, irgendwann machen die Moderatoren hier sonst 'nen Cut.
« Letzte Änderung: 26.02.2018, 17:57:01 von kuehhe1 »

PCCT header not found.
Diese oder ähnliche Meldungen (PCCT …) kommen oft beim Start. Was sie bedeuten und woher sie kommen, habe ich auch noch nicht herausgefunden. Sie scheinen aber keine negativen Auswirkungen zu haben, denn der Rechner fährt trotzdem normal hoch.

So ist es meiner Erfahrung nach auch mit den anderen "Warnungen", man muss sich darüber nicht den Kopf zerbrechen.
Ich verstehe die als eine Art Selbstgespräch des Rechners, nicht als wichtige Mitteilung für mich.

Gibt es aber ein tatsächliches Problem oder eine Fehlfunktion, kann man evtl. suchen, ob sich unter den kryptischen Ausgaben ein Hinweis auf die mögliche Ursache dafür finden lässt. Ist aber meistens ziemlich mühsam.
« Letzte Änderung: 26.02.2018, 18:23:26 von aexe »