Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.01.2021, 18:58:26

.
Einloggen mit Benutzername, Passwort und Sitzungslänge


Autor Thema:  [LMDE 2 ] Wie bekomme ich das aktuelle Audacity unter LMDE 2 zum laufen ?  (Gelesen 4137 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Audacity gibt es auch als Flatpak, gesehen in der LM 18.3 Anwendungsverwaltung. Versionsnummern stehen bei den Flatpaks leider nicht dabei.

Damit hast Du es doch. Damit kannst Du es Dir bauen.
Ansonsten das 2.1 er holen, das gibt es.

Selber bauen ist nicht mein Fall. Ich habe das Talent mein System zu zerschießen.
Wo würde ich denn eine passende Anleitung finden?

Selber bauen ist nicht mein Fall. Ich habe das Talent mein System zu zerschießen.
Wo würde ich denn eine passende Anleitung finden?
Links sind auf der Audacity-Seite. Wie gesagt, eine 2.1..... gibt es auch noch.

Audacity gibt es auch als Flatpak, gesehen in der LM 18.3 Anwendungsverwaltung. Versionsnummern stehen bei den Flatpaks leider nicht dabei.
Ist V 2.2.1 ! Geht Flatpak auch bei LMDE?

Zitat
Flatpak is available in Debian from Stretch onwards
https://wiki.debian.org/FlatpakHowto

Mit dem kompilieren komme ich nicht klar. Die Anleitung ist auf Englisch und die Befehle werden so nicht angenommen, obwohl ich Sie ins Terminal reinkopiert habe - als root.
Ausserdem scheint man noch ein paar andere Dateien mit einbinden zu müßen, Keine Ahnung wo ich die herbekommen und wie ich sie einbinden soll.
Wenn dann würde ich sie natürlich gern mit nutzen, denn dafür macht man sich ja die Arbeit,
Die beiliegende Anleitung habe ich mal reinkopiert:


Compilation and install instructions for GNU/Linux

Note: Audacity 2.2.0 requires gcc 4.9 or later. For Ubuntu 14.04 which only
has up to 4.8.4, see here for upgrade instructions:
   http://wiki.audacityteam.org/wiki/Upgrade_to_gcc_4.9

Audacity 2.2.0 requires wxWidgets 3.0.x, preferably 3.0.2, built with gtk2.
If not available in your distribution repository, it may be  downloaded from:
   https://github.com/wxWidgets/wxWidgets/releases/download/v3.0.2/wxWidgets-3.0.2.tar.bz2 .

On openSUSE, be sure to install wxWidgets without STL.

The latest Audacity development source code is available from:
   https://github.com/audacity/audacity

If you are not planning to do any development, the Audacity 2.2.0 release
minimal source tarball is recommended from:
http://www.audacityteam.org/download/source/ .

Other required dependencies:

Audacity 2.2.0 requires the local (included) versions of PortAudio and PortMidi.
Attempting to build with system library versions will fail.

libsndfile library is required and is included in the Audacity source.

libsoxr resampling library. If libsoxr-dev is not available as a system library,
the source code is included in the Audacity tarball.
CMake ( http://www.cmake.org/ ) is required to build a local copy of libsoxr.

Information about optional libraries may be available on:
   http://wiki.audacityteam.org/wiki/Developing_On_Linux#optional .

If you install libraries using a package management system like Apt or RPM,
you need to install the "dev" (development) packages for each library.


Compiling wxWidgets:

wxWidgets must be built with the default gtk2 option, not with gtk3, and
without STL (also default). Full instructions for compilation can be found in:
   wxWidgets-3.0.2/docs/gtk/


Compiling and installing Audacity:

As there have been fixes to several of the included libraries, compiling with
the included ('local') libraries is recommended. This also reduces the number of
dependencies that need to be installed. One common exception to this is the optional
FFmpeg library (see below)

From the root of the source tree, create a build directory, then change directory into it:
   mkdir build
   cd build

To see the compile-time options you can set:
   ../configure -h

Run the configure command with your preferred options, then 'make'
   ../configure -with-lib-preference="local system"
   make

On a multi-core system, build time can be considerably reduced by setting the -j (jobs)
switch equal to the number of cores. For example, on a quad core processor:
   make -j4

To install:
   make install  # as root
(The root command is often sudo on GNU/Linux, for example 'sudo make install'.)

If you want to do any development, you might want to generate a configure cache
and header dependencies:
   ./configure -C
   make dep

To uninstall:
   make uninstall #as root

To clean the build after modifying code:
   make clean

To clean and remove previous configure options:
   make distclean


FFmpeg support::

Audacity should be able to link dynamically to FFmpeg 1.2 to 2.3.x (libav 0.8 to 10),
but many distributions have more recent versions that fail to link dynamically.
To work around this issue, Audacity may be configured to use the system
FFmpeg library and disable dynamic loading. If this is done for both FFmpeg
and the optional LAME library, the "Libraries" option in Audacity's Preferences
is not required and is automatically removed.
   ../configure --with-lib-preference="local system" --with-ffmpeg=system \
                --with-lame=system --disable-dynamic-loading


Additional information about compiling on Linux may be found on the Audacity wiki:
   http://wiki.audacityteam.org/wiki/Developing_On_Linux

You can ask for help with compilation problems at:
   http://forum.audacityteam.org/viewforum.php?f=19 .

Dann nimm doch das Flatpak.

Mit dem kompilieren komme ich nicht klar.
Tu nie Dinge, von denen Du nicht weißt, was Du tust. Nimm Flatpak.


Zitat
Flatpak is available in Debian from Stretch onwards
https://wiki.debian.org/FlatpakHowto
LMDE 2 ist aber noch auf Debian 8 jessie das noch vor stretch (Debian 9) liegt und so mit Flatpack noch fremdeln wird.
Die mMn einfachste Lösung wäre ein AppImage, welches es fertig zumindest für Version 2.1.2 gibt / gab?:
https://bintray.com/probono/AppImages/Audacity
oder aktueller:
https://github.com/probonopd/audacity/releases

Wer will, kann sich auch ein AppImage selber basteln:
https://appimage.org/
https://github.com/AppImage/AppImageKit/wiki/Bundling-Audacity
« Letzte Änderung: 01.02.2018, 10:44:39 von aexe »

Nach einem AppImage hatte ich auch geschaut, das wäre am einfachsten; aber keines gefunden von der neuesten Version.

ZeckeSZ

  • Gast
Off-Topic:
oder Junest
Audacity funktioniert problemlos, allerdings nur, wenn ein Kernel >=4.0 eingesetzt wird (ein Hinweis wurde in dem von dir verlinkten Thread eingefügt). Mit dem eigentlich von LMDE2 verwendeten 3.16er wird schon der Start von JuNest mit Fehlermeldung abgebrochen.

Ich hab's so wie hier beschrieben installiert:

http://ubuntuhandbook.org/index.php/2017/11/install-audacity-2-2-0-ppa-ubuntu-17-10/

Vielleicht hilft es dir weiter.   ;D



Dass LMDE eigentlich keine PPAs kennt ist dir nicht bekannt? ;)

Nein.

Dann hilt's vermutlich in diesem Fall eher weniger.   :(

Aber vielleicht ist das "eigentlich" aufweichbar?