Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
23.01.2021, 04:40:55

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25123
  • Letzte: Ekki
Statistiken
  • Beiträge insgesamt: 710309
  • Themen insgesamt: 57424
  • Heute online: 488
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 0
Gäste: 292
Gesamt: 292

Autor Thema: [erledigt] "installArchives() failed" nach Installationsabbruch  (Gelesen 858 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] "installArchives() failed" nach Installationsabbruch
« am: 02.01.2018, 21:48:17 »
Guten Abend,

nun muß ich mich leider doch an die Community wenden, da ich eventuell ein schwerwiegendes Problem mit meinem Linux Mint 18.2 habe. Habe eigentlich nicht viel gemacht, aber ich kann euch erklären, wie es dazu gekommen ist. Plan ich wolle Quake3Arena installieren ! Habe die Original-CD eingelegt, die Anwendungsverwaltung gestartet, in die Suche quake eingegeben und 3 relevante Einträge gefunden.
Quake3          Quake iii arena menu entry and launcher scripts
Quake3-data     Installer for quake iii arena data files
Quake3-server   Quake iii arena dedicated server launcher scripts
Wollte dann zunächst mal die Quake3-data installieren, klickte es wie üblich an, aber leider blieb die Installation dann bei 83% stehen ! Ich wartete vielleicht fast eine halbe Stunde lang, nichts tat sich mehr, weder Festplatten, CPU- oder CD-Rom-Aktivität, brach dann die Installation manuell ab (X rechts oben im Fenster), was eventuell mein Verhängnis war. Ich startete die Anwendungsverwaltung und siehe da, nun war Quake3-data installiert. Folglich dachte ich noch es hätte vielleicht geklappt, und versuchte nun Quake3 zu installieren, leider erscheinte dann nur eine Fehlermeldung:
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/AptClient/AptClient.py", line 74, in _run
    cache.commit(acquire_progress_monitor, install_progress_monitor)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 519, in commit
    raise SystemError("installArchives() failed")
SystemError: installArchives() failed

wollte dann Quake3-data deinstallieren und bekam eine ähnliche Fehlermeldung:
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/AptClient/AptClient.py", line 80, in _run
    cache.commit(acquire_progress_monitor, install_progress_monitor)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 519, in commit
    raise SystemError("installArchives() failed")
SystemError: installArchives() failed

Ich befürchte, daß ich mir durch diesen Abbruch mein System komplett verschoßen habe und weiß leider nicht weiter. Klar eine Neuinstallation immer möglich, aber vielleicht könnt ihr mir helfen das System zu retten. Ich benutze übrigens Xfce (4.12.2) und Kernel ist 4.8.0-53.1
Was soll ich tun?


mfg
Oliver
« Letzte Änderung: 03.01.2018, 17:56:55 von Minute_Mint »

Re: "installArchives() failed" nach Installationsabbruch
« Antwort #1 am: 02.01.2018, 21:53:31 »
Achso, was ich vergessen habe, bei der o.g. Installation wurden zwei Usereingaben gefordert, erst die Adresse meines CD-Rom, hab dann dieses CD-Verzeichnis eingegeben
/media/user1/QUAKE3/
(hier lag vielleicht schon der Fehler)
fand hinterher heraus die wichtige pak0.pk3 liegt in /media/user1/QUAKE3/Quake3/baseq3/

bei der 2. Auswahl beließ ich die eingetragenen Internet-Adresse ohne sie zu prüfen, da mir keine bekannt war (die habe ich mir aber nicht notiert)
« Letzte Änderung: 02.01.2018, 21:57:19 von Minute_Mint »

Re: "installArchives() failed" nach Installationsabbruch
« Antwort #2 am: 03.01.2018, 01:20:18 »
Versuch mit der Paketverwaltung die Pakete zu reparieren/erneut installieren

Re: "installArchives() failed" nach Installationsabbruch
« Antwort #3 am: 03.01.2018, 12:11:10 »
Ich öffnete die Synaptik Paketverwaltung und sah mir unter Status in der Kategorie installiert (manuell) alle Symbole an, dort nur graue Ausrufungszeichen(=installiert, aktualisierbar), grüne Kästchen(installiert) -also keinmal rotes Ausrufungszeichen(=defekt), o.ä.
Klickte dann im Menü oben auf bearbeiten und "defekte Pakete reparieren", dann kam keine Meldung/Reaktion,
dann klickte ich noch unten "Benutzerdefinierte Filter" an und oben "Defekt", die Liste ist leer.
Wollte dann nochmal Quake3-data entfernen, dann stand da
"Eine andere Anwendung benutzt gerade APT: synaptic"
Habe die Synaptic Paketverwaltung geschlossen, und plötzlich ließ sich die Quake3-data einfach entfernen. Komisch gestern hatte ich genau da eine Fehlermeldung (und ich machte nicht einmal einen Neustart), vielleicht lag es auch an meinem Vorgehen.
Es sieht also erstmal so aus, als wäre das Problem so schnell wieder weg, wie es aufgetaucht war. Ich möchte die Situation aber noch genauer testen, um es endgültig als gelöst zu markieren. Danke für alle Beiträge !