Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.11.2020, 05:38:33

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24828
  • Letzte: kohlhaas
Statistiken
  • Beiträge insgesamt: 697109
  • Themen insgesamt: 56413
  • Heute online: 447
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 0
Gäste: 310
Gesamt: 310

Autor Thema: [gelöst]  Bios Einstellungen ändern für Mint Installation  (Gelesen 5978 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Bios Einstellungen ändern für Mint Installation
« am: 20.12.2017, 11:02:21 »
Es hört sich vielleicht etwas schräg an, aber leider lässt sich LM 18.3 KDE nicht auf einem Dell Inspiron 3552 so installieren, dass das System richtig gestartet wird. Die Installation selbst lief ganz normal durch und ich hatte auch nicht mit Problemen gerechnet, da Dell diesen einfachen Lapptop mit Ubuntu 14.04 ausgeliefert hat. Es soll ja auch nur LM als Betriebssystem drauf, also die Festplatte mit 50GB btrfs für /, 8GB swap und dem Rest ext4  /home gegeben.
Beim starten ist eine Zeit lang auch das LM-Logo mit den blinkenden Punkten zu sehen und dann wird der Bildschirm schwarz (wie ausgeschaltet). Das System wird aber wohl nicht runter gefahren sondern wartet im Hintergrund, denn erst wenn ich den Startknopf am Lapptop länger drücke, wird deutlich hörbar komplett abgeschaltet.
Zum testen habe ich nun eine ubuntu-16.04.iso gebrannt und damit installiert: die startet. Allerdings auch nur mit den geänderten Bios Einstellungen.

Die Boot-Einstellung im Bios (Aptio Setup Utility - American Megatrends, Inc.) habe ich geändert auf:
Fast Boot[Enabled]
Boot List Option[Legacy]
Secure Boot[Disabled]
Load Legacy Option Rom[Enabled]
Set Boot Priority
1st Boot Priority[Hard Drive]
2st Boot Priority[CD/DVD/CD-RW Drive]
3st Boot Priority[Diskette Drive]

Das war die ursprüngliche Einstellung, mit der kein Starten möglich ist.
Fast Boot[Enabled]
Boot List Option[UEFI]
File Browser Add Boot Option
File Browser Del Boot Option
Secure Boot[Disabled]
Load Legacy Option Rom[Enabled]
Boot Option Priorities
Boot Option #1[ubuntu]

Bin einfach nur noch Ratlos  :(
« Letzte Änderung: 21.12.2017, 16:30:48 von DaHeb »

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #1 am: 20.12.2017, 13:13:29 »
Zitat
Beim starten ist eine Zeit lang auch das LM-Logo mit den blinkenden Punkten zu sehen und dann wird der Bildschirm schwarz (wie ausgeschaltet).

Das der Bildschirm schwarz wird ist bei Mint normal. Das kann, unter Umständen, schon ca. 10...und ein paar mehr Sekunden dauern bevor der Desktop gestartet wird.

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #2 am: 20.12.2017, 13:17:39 »
Du hast nur UEFI abgeschaltet, das ist bei Mint aber kein Problem (64 bit vorausgesetzt). Dein Problem ist evtl. die Grafik.
Zeige bitte aus dem Live-System heraus
inxi -FxzBitte als Text mit der Maus ins Forum kopieren, nicht fotografieren.

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #3 am: 20.12.2017, 13:17:49 »
@ opajoerg: 10 Minuten und mehr aber nicht :(
@ toffifee: wird gemacht

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #4 am: 20.12.2017, 15:41:09 »
So, hier die Ausgabe von: inxi -Fxz
mint@mint ~ $ inxi -Fxz
System:    Host: mint Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: KDE Plasma 5.8.8 (Qt 5.6.1)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Inspiron 14-3452 v: 4.0.13
           Mobo: Dell model: 079W3P v: A00
           Bios: Dell v: 4.0.13 date: 12/22/2016
CPU:       Dual core Intel Celeron N3060 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6400
           clock speeds: max: 2480 MHz 1: 634 MHz 2: 1891 MHz
Graphics:  Card: Intel Device 22b1 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 400 (Braswell)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Device 2284 driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 01:00.0
           IF: wlp1s0 state: down mac: <filter>
           Card-2: Atheros usb-ID: 001-008
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 500.1GB (0.8% used)
           ID-1: /dev/sda model: ST500LM030 size: 500.1GB temp: 25C
           ID-1: swap-1 size: 4.20GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 34.0C mobo: 31.0C
           Fan Speeds (in rpm): cpu: N/A fan-1: 0
Info:      Processes: 157 Uptime: 5 min Memory: 430.6/3861.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #5 am: 20.12.2017, 16:59:47 »
Zitat
Festplatte mit 50GB btrfs für /
Frage1: Warum btrfs ?
Besonderheiten zu btrfs - siehe z.B. hier
https://wiki.ubuntuusers.de/Installieren_auf_Btrfs-Dateisystem/

Frage2: Du hast im UEFI/BIOS von "UEFI" auf "Legacy (=BIOS)" umgestellt -
Hast du zum Booten des Installations-Mediums auch den entsprechenden
Eintrag (Boot-Modus) gewählt ?

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #6 am: 20.12.2017, 17:22:00 »
Hi billyfox05,
bei btrfs kann ich jetzt gar nicht mehr sagen warum ich das (auch schon für meine anderen Kiste) benutze. Habe aber auch noch nichts Nachteiliges bemerkt.
Zum Bios siehe meinen EIngangspost: von UEFI auf Legacy umgestellt (die aufgelisteten Bios Einstellungen).
LM18.3 konnte ich ja (siehe oben) installieren:
Zitat
Die Installation selbst lief ganz normal durch

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #7 am: 20.12.2017, 17:32:30 »
Zitat
LM18.3 konnte ich ja (siehe oben) installieren:
ABER - nicht booten ?!
Eine mögliche Ursache könnte sein
- im UEFI/BIOS den Bootmodus "Legacy" eingestellt
- installiert aber im "UEFI-Bootmodus"
- ODER anders herum

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #8 am: 20.12.2017, 17:34:31 »
- im UEFI/BIOS den Bootmodus "Legacy" eingestellt
- installiert aber im "UEFI-Bootmodus"
Wie soll das gehen?

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #9 am: 20.12.2017, 20:12:34 »
nmM funktioniert es z.B. über das Bootmenü
zu dem Thema habe ich hier schon so viel gelesen
z.B. https://www.linuxmintusers.de/index.php?topic=39360.15
Beispiel:
- im UEFI als Bootmodus "Legacy" eingestellt
- im Bootmenü werden aber die Bootoptionen für Legacy und UEFI angezeigt
siehe Bild in #Antwort12
- wird jetzt die Bootoption beginnend mit UEFI... ausgewählt - läuft mW die Installation durch
das BS kann aber nicht gebootet werden.

das klappt mW auch umgekehrt - also im UEFI Bootmodus "UEFI" eingestellt / Bootoption nicht mit UEFI... beginnend.

Sollte ich mir FALSCHES zusammen gelesen/gereimt haben ? Nachvollziehen kann ich es "leider" nicht -
bei meinem Rechner werden immer nur die Bootoptionen passend zum Bootmodus angezeigt.
« Letzte Änderung: 20.12.2017, 20:15:45 von billyfox05 »

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #10 am: 21.12.2017, 10:00:37 »
So, jetzt habe ich mal folgendes ausprobiert:
Im Bios unter Boot
Fast Boot[Enabled]
Boot List Option[UEFI]
Fle Browser Add Boot OptionLeer (hier könnte aber das DVD Laufwerk mit der ISO ausgewählt werden)
File Browser Del Boot OptionLeer (hier kann ubuntu ausgewählt werden)
Secure Boot[Disabled]
Load Legacy Option Rom[Enabled]
Boot Option Priorities
Boot Option #1[ubuntu(Disabled)]

Nun das Boot Medium ausgewählt:
UEFI Options:
CDROM1 - UEFI OS......
LM Live gestartet (zur Auswahl stehen auch: abgesicherter Modus, Installation im OEM-Modus): LM Live startet nicht.

Bios Boot bei: Load Legacy Option Rom -> auch auf Disabled gestellt
Wieder UEFI Options -> CDROM1 - UEFI ... : LM Live startet

Jetzt anhand des WIKI-Artikels und in der Konsole getippert:
mint@mint ~ $ mount | grep efivars
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
mint@mint ~ $ sudo dmidecode -t 0
# dmidecode 3.0
Getting SMBIOS data from sysfs.
SMBIOS 2.8 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
        Vendor: Dell Inc.
        Version: 4.0.13
        Release Date: 12/22/2016
        Address: 0xF0000
        Runtime Size: 64 kB
        ROM Size: 6656 kB
        Characteristics:
                PCI is supported
                PNP is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                EDD is supported
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                ACPI is supported
                USB legacy is supported
                Smart battery is supported
                BIOS boot specification is supported
                Function key-initiated network boot is supported
                Targeted content distribution is supported
                UEFI is supported
        BIOS Revision: 4.0
mint@mint ~ $ sudo dmidecode -t 1
# dmidecode 3.0
Getting SMBIOS data from sysfs.
SMBIOS 2.8 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
        Manufacturer: Dell Inc.
        Product Name: Inspiron 14-3452
        Version: 4.0.13
        Serial Number: 9VNQLJ2
        UUID: 4C4C4544-0056-4E10-8051-B9C04F4C4A32
        Wake-up Type: Power Switch
        SKU Number: Not Specified
        Family: Inspiron
mint@mint ~ $ sudo efibootmgr -v
BootCurrent: 1001
Timeout: 0 seconds
BootOrder: 0000
Boot0000  ubuntu        VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
mint@mint ~ $ sudo parted -l
Modell: ATA ST500LM030-1RK17 (scsi)
Festplatte  /dev/sda:  500GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe   Typ       Dateisystem     Flags
 1      1049kB  496GB  496GB   primary   ext4            boot
 2      496GB   500GB  4201MB  extended
 5      496GB   500GB  4201MB  logical   linux-swap(v1)


Modell: SanDisk Cruzer Micro (scsi)
Festplatte  /dev/sdb:  4026MB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 1      1049kB  4024MB  4023MB  primary  fat32


Warnung: /dev/sr0 kann nicht zum Schreiben geöffnet werden (Das Dateisystem ist
nur lesbar). /dev/sr0 wurde nur lesbar geöffnet.
Modell: HL-DT-ST DVD+-RW GU90N (scsi)                                     
Festplatte  /dev/sr0:  2064MB
Sektorgröße (logisch/physisch): 2048B/2048B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 2      1909kB  11,5MB  9568kB  primary               esp
mint@mint ~ $ sudo efibootmgr
BootCurrent: 1001
Timeout: 0 seconds
BootOrder: 0000
Boot0000  ubuntu
mint@mint ~ $ sudo efibootmgr -n 1001
efibootmgr: Boot entry 1001 does not exist
So und jetzt leg ich mich erst mal hin. Die Installation kann ich auch heute Nachmittag anstoßen, falls nichts dagegen spricht. Nase zu Taschentücher voll: es reicht grad.

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #11 am: 21.12.2017, 13:33:37 »
Ich sehe auf der HD nur msdos Partionstabelle.
Für UEFI braucht aber GPT.
Somit fehlt auch die EFI Partition, wo Grub rein kommt.
« Letzte Änderung: 21.12.2017, 13:40:28 von tommix »

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #12 am: 21.12.2017, 15:13:36 »
da bin ich bei @tommix - laut "parted -l" nix zu sehen von UEFI und
von der o.g. Aufteilung mit 50GB btrfs für /, 8GB swap ebenfalls nix ?!

Jetzt solltest du dir überlegen was du willst -
1. im jetzigen "Legacy-Bootmodus" weiter machen oder
2. in den "UEFI-Bootmodus" wechseln
Beides scheint möglich und in beiden Fällen würde ich die Platte neu partitionieren
- für ein LinuxBS wird im allgemeinen eine Partition von ca. 25 GB empfohlen (nach Installation sind davon ca. 7 GB belegt)
- eine "Erweiterte Partition" gibt es bei UEFI nicht - ob du sie bei Legacy benötigst ?
- solltest du dich für UEFI entscheiden würde ich die Platte auf Partitionstabelle GPT umstellen
( ist bei Windows ein MUSS - bei Linux wohl nicht - da müsstest du dich dann im Netz belesen )

Gute Besserung - bleibe noch ein wenig liegen und denke darüber nach  ;D

Re: Bios Einstellungen ändern für Mint Installation
« Antwort #13 am: 21.12.2017, 16:25:09 »
Also erst mal: hat alles funktioniert. LM ist auf der Platte und startet durch  :o
Zitat von: toomix
Ich sehe auf der HD nur msdos Partionstabelle.
Für UEFI braucht aber GPT.
Somit fehlt auch die EFI Partition, wo Grub rein kommt.
Wurde vom Installer alles angelegt.
Zitat von: billyfox05
und von der o.g. Aufteilung mit 50GB btrfs für /, 8GB swap ebenfalls nix ?!
Hatte zuvor einen Test, nur mit ubuntu, das ja dann auch startete und da einfach nur die ganze Platte nehmen lassen. Habe aber jetzt nur ext4 genommen.
Um LM zum starten zu  bewegen, musst explizit Boot Option #1 [ubuntu(Disabled)] gesetzt werden. Mit Enabled gings nicht.

Der Link: Nach Linux installation Grub Error hat mich quasi auf die EFI Grundlagen und EFI Installieren gebracht.

Danke euch für die tolle Unterstützung