Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
16.12.2019, 14:35:02

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22964
  • Letzte: fxd
Statistiken
  • Beiträge insgesamt: 625134
  • Themen insgesamt: 50481
  • Heute online: 1057
  • Am meisten online: 1057
  • (Heute um 11:22:00)
Benutzer Online

Autor Thema:  Hab Xorg kaputt gemacht. =(  (Gelesen 1019 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hab Xorg kaputt gemacht. =(
« am: 07.12.2017, 16:29:05 »
Hi,

hab schon wieder ein Anliegen mit meinem LM17.3 KDE, diesmal hab ich den Xorg Treiber kaputt gemacht.
Da ich mit einem anderen Spiel das frisch gemoddet war komisch bunte Grafikfehler hatte, hab ich in der Treiberverwaltung von Xorg auf fglrx-update umgeschaltet. Brachte keine Besserung, vermutlich hat der Mod selbst einen Fehler ok. später, arbeiten, vergessen.
Stunden später wollte ich dann meinen Euro Trucker weiterspielen den ich bisher nur mitm Xorg gespielt habe da alles wunderbar läuft. Diesmal nicht, wunderte mich warum das alles so komisch aussieht, kantig, ruckelig usw... tja, der fglrx Treiber war noch aktiv wie ich es dann auch geschnallt habe, also Spiel aus, Treiber wieder wechseln in der Treiberverwaltung, Neustart.
Beim nächsten Spielstart ruckelte selbst das Intro (nun mit Xorg wieder), bis zum Spiel kam ich erst garnicht weil sich die Maus kaum kontrollieren lässt weil alles so ruckelt. Muss also irgentwas kaputt gemacht haben.  :(

Im Netz hab ich dann etwas gefunden um es wieder zu reparieren, dies hier:

remove:
Code:

sudo apt-get remove xserver-xorg

install:
Code:

sudo apt-get install xserver-xorg

reconfigure:
Code:

sudo dpkg-reconfigure xserver-xorg

Neustart, Spielstart, immer noch ruckelig. =(

Da war der quelloffene Treiber grad dabei mich Noob davon zu überzeugen das man den Prop.Treiber garnicht braucht und ich kill ihn dafür.  :( >:( :(


Re: Hab Xorg kaputt gemacht. =(
« Antwort #1 am: 07.12.2017, 16:43:07 »
Ich hätte dort gemacht sudo apt-get purge fglrx*Herumschrauben an den xserver-Paketen?
Gefährlich, wenn man Pech hat, zerlegt es das ganze System  :o

Re: Hab Xorg kaputt gemacht. =(
« Antwort #2 am: 07.12.2017, 16:48:05 »
jetzt grad hab ich wieder den fglrx aktiv, soll ich nun einfach wieder umstellen auf den xorg, der aber ruckelt wie hulle und dann den von dir genannten sudo befehl eingeben?

Re: Hab Xorg kaputt gemacht. =(
« Antwort #3 am: 07.12.2017, 16:50:46 »
- Treiberverwaltung umstellen auf xorg
- dann sudo apt-get purge fglrx*- Reboot

Re: Hab Xorg kaputt gemacht. =(
« Antwort #4 am: 07.12.2017, 17:01:35 »
juhu. von wegen Garfield ist stinkendfaul. Nix da, Garfield hat mir den Tag gerettet.  ;D :D ;)

Dankeschön.

Zwar meckert Play on Linux jetzt rum aber das Spiel funzt dennoch.  ;D
Das hier meint POL: http://img4web.com/i/435YK.jpg

Re: Hab Xorg kaputt gemacht. =(
« Antwort #5 am: 07.12.2017, 17:03:35 »
Das Hantieren mit verschiedenen Grafiktreibern ist immer mit Risiken verbunden  ;D

Re: Hab Xorg kaputt gemacht. =(
« Antwort #6 am: 07.12.2017, 17:11:34 »
Kenn ich noch von Windows, sry davon bin ich mittlerweile immer mehr genervt. Bei einem OS das man *noch* nicht so richtig kennt wie Linux denke ich mir das, daß mächtig böse werden kann.

Wat genau ham wir jetzt gemacht? Weil Purge klingt ziemlich endgültig, der Prop.Treiber ist vollständig weg, also das was in der Treiberverwaltung steht wäre garnicht mehr up-to-date? Da stehen 3 wählbare Einträge, Quelloffen, den ich nun wieder aktiv habe, fglrx update und fglrx. Die beiden fglrx sind vollständig zerstört oder einfach nur weg?

Purge... Säuberung ... hmmm glaub ich weiß was wir gemacht haben, nicht zerstört sondern gesäubert, isn Unterschied, eigentlich aber ich frag lieber den Profi.  ;D :D ;)

Re: Hab Xorg kaputt gemacht. =(
« Antwort #7 am: 07.12.2017, 17:21:08 »
Theoretisch könntest du den fglrx erneut installieren.
Übrigens -um das ganze noch etwas komplizierter zu machen- die fglrx wurden auch immer auf der AMD-Website zum Download angeboten (neuere Versionen als in der Treiberverwaltung).

Re: Hab Xorg kaputt gemacht. =(
« Antwort #8 am: 07.12.2017, 17:33:16 »
hehe  ;D

Nee, der letzte funktionierende AMD Propriertär für meine Karte ist von 2015. Hab die Hoffnung das es weiterhin so schön gut mitm quelloffenen läuft. Langfristig wenn dem nicht so ist müsste ich auf NVidia umsteigen wo ich aber nicht ganz so doll Lust zu habe, wo man noch nichtmal die Kosten erwähnt, wäre Zukunftsmusik.


Re: Hab Xorg kaputt gemacht. =(
« Antwort #9 am: 07.12.2017, 17:37:05 »
Von 2015 dürfte dann schon einer der letzten sein.
Das Thema hatten wir ja, das der fglrx nicht weiter gepflegt wird, also quasi am aussterben ist.

Re: Hab Xorg kaputt gemacht. =(
« Antwort #10 am: 07.12.2017, 17:41:03 »
Richtig, da nun die AMDGPU Treiber nun aktuell sind meine 4 Jahre alte Karte aber vor 2 Jahren gekaufte Karte nun zu alt sei usw... so macht man sich keine Freunde, AMD!  >:(

Achja, schaust Du bitte noch aufs Bild weiter oben wegen dem was Play on Linux zu meckern hat wegen der 32 bit Librarys?

Re: Hab Xorg kaputt gemacht. =(
« Antwort #11 am: 07.12.2017, 17:43:48 »
später, jetzt muss ich erstmal weg

Re: Hab Xorg kaputt gemacht. =(
« Antwort #12 am: 07.12.2017, 17:47:20 »
Ok, garkein Thema. ;)