Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.07.2018, 02:23:14

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 20480
  • Letzte: noobert
Statistiken
  • Beiträge insgesamt: 539240
  • Themen insgesamt: 43272
  • Heute online: 312
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online
Mitglieder: 5
Gäste: 228
Gesamt: 233

Autor Thema:  Virtualbox- VM startet nicht mehr  (Gelesen 1473 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Cosmo

  • Gast
Re: Virtualbox- VM startet nicht mehr
« Antwort #15 am: 01.11.2017, 15:27:37 »
Ich hab's befürchtet, weil im Manager für virtuelle Medien auch für diesen Snapshot keine Größenangaben zu lesen sind. Und noch etwas fällt auf: Laut der Liste der Snapshots müßte es noch eine weitere VDI für einen Snapshot geben, doch im Manager taucht diese überhaupt nicht auf.

Das deutet darauf hin, daß die zentrale VB-Konfigurationsdatei ~/.config/VirtualBox/VirtualBox.xml korrumpiert ist. Die Frage ist, warum das so ist. Abstüre des Host bei laufender VM?

Re: Virtualbox- VM startet nicht mehr
« Antwort #16 am: 01.11.2017, 15:38:53 »
Eine zweite VDI? Es ist aber doch nur eine installiert. Es gibt nur eine und ihre Snapshots. Wo siehst du da eine weitere?

Diese XML-Datei findet die Suche nicht. Der Host ist während der VM niemals abgestürzt.

Ich kann keine VM starten da angl. jedesmal das Bootmedium fehlt. Ein einbinden über die GUI wird auch stets mit bereits genannten Fehlern quittiert.




Cosmo

  • Gast
Re: Virtualbox- VM startet nicht mehr
« Antwort #17 am: 01.11.2017, 20:39:02 »
Der Screenshot in #12 zeigt, daß es zu der Maschine 3 Sicherungspunkte gibt, der Screenshot in #10 offenbart uns jedoch, daß nur 2 Differenz-Platten (das sind die mit den kryptischen Dateinamen) vorhanden sind (noch dazu ohne Größenangaben). Es muß aber für jeden Sicherungspunkt eine solche Differenz-Platte geben. Der Screenshot in #14 sagt uns, daß die erste in #10 zu sehende Differenz-Platte zum zweiten Sicherungspunkt gehört. Folglich fehlt die Differenz-Platte zum ersten Sicherungspunkt.

Darüber hinaus ist vermutlich die von mir in #15 genannte zentrale VB Konfigurationsdatei fehlerhaft.

Ob es zwischen dem Fehlen der ersten Differenz-Platte und der vermutlich beschädigten Konfigurationsdatei einen Zusammenhang gibt ist denkbar.

Zum Verständnis:
Sobald du einen Sicherungspunkt erstellst, erstellt VB eine Differenzplatte. Die Grundplatte - die bei der Erstellung der VM erzeugt wurde - wird eingefroren, alle Änderungen werden in der Differenzplatte geschrieben. Wird ein weiterer Sicherungspunkt, wird die vorhandene Differenzplatte ebenfalls eingefroren und Änderungen in einer weiteren Differenzplatte geschrieben. Da die Differenzplatten aber eben nur die Unterschiede zu den hierarchisch höheren Platten enthalten, werden alle eingefrorenen Platten unbedingt zum Lesen benötigt. - Zusammengefaßt: Zu jedem Sicherungspunkt gehört eine Differenzplatte und da fehlt bei dir eine - warum auch immer.

Re: Virtualbox- VM startet nicht mehr
« Antwort #18 am: 02.11.2017, 12:08:36 »
Auf der eingehangenen Partition liegt lediglich die Datei "XP.vdi". Die ist unter "media" gemounted.

In meinem Home finden sich im Ordner Virtual Box VMS folgende Dateien:
Order "Logs" mit 4 Logdateien. Leider kann ich daraus nichts erkennen.
Order "Snapshots" - ist leer! Wie kann das???
Datei "xp.vbox"
Datei XpVbox-prev (xml).

Wo sind denn die Snapshots hin? Hier stimmt doch hinten und vorne was nicht!  :o


Cosmo

  • Gast
Re: Virtualbox- VM startet nicht mehr
« Antwort #19 am: 02.11.2017, 12:30:40 »
Wo sich die Dateien für die Sicherungspunkte befinden sollten, läßt sich in den Einstellungen der VM -> Allgemein -> Erweitert kontrollieren. Wenn dort nichts ist, kannst du lediglich eine Suche nach den fehlenden Dateien ausführen. Ist die Suche ergebnislos, sind die Dateien - warum auch immer - im Nirwana.

Re: Virtualbox- VM startet nicht mehr
« Antwort #20 am: 02.11.2017, 13:03:05 »
Der Pfad stimmt aber dort ist nix. Warum auch immer! Wenn also keine Sicherungspunkte mehr vorhanden sind, kann man auch keine auswählen- logisch! Aber warum startet die VDI selbst nicht? Die ist doch da!

Cosmo

  • Gast
Re: Virtualbox- VM startet nicht mehr
« Antwort #21 am: 02.11.2017, 14:28:56 »
Was du startest, ist immer eine VM, und da alle Differenz-VDIs fehlen, gibt es auch keinen Sicherungspunkt, auf den sich diese VM zurücksetzen ließe.

Da die XP.vdi noch zu existieren scheint, kannst du eine neue VM erstellen, dort - anstatt eine neue virtuelle Festplatte zu erzeugen - diese XP.vdi einbinden. Achte allerdings darauf, daß die Einstellungen der VM (innerhalb des VB Managers vorzunehmen) identisch sein müssen, sonst wird XP auf xp.vdi möglicherweise nicht starten. Genauer gesagt: Die Einstellungen der neuen VM müssen identisch sein mit den Einstellungen der alten VM zum Zeitpunkt der Installation von XP; das sind möglicherweise nicht dieselben, die zur Zeit eingestellt sind.

Re: Virtualbox- VM startet nicht mehr
« Antwort #22 am: 02.11.2017, 18:36:06 »
Danke! Das hat schon mal funktioniert und ersparte mir eine Neuinstallation. Allerdings ist es nun ein frisches XP, bei dem alles fehlt, was ich extra in den Snaps gesichert hatte. Also muss das alles neu. Immerhin, so weit so gut! Mal sehen wie lang es diesmal gut geht...

Danke & Gruß  :)

Re: Virtualbox- VM startet nicht mehr
« Antwort #23 am: 19.11.2017, 19:12:06 »
Lange jedenfalls nicht...  :o

Wollte heute meine VM wieder starten und habe dasselbe Problem wieder! Hab nix gemacht, nix geändert nix sonst was und nach 9 Tagen findet VB seine VM mal wieder nicht mehr. Das gibts doch nicht, wer soll einem das noch glauben? Jetzt schlägts aber dreizehn! Was zum Teufel ist hier los?  :-\