Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
20.09.2019, 05:56:24

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22565
  • Letzte: huste511
Statistiken
  • Beiträge insgesamt: 608690
  • Themen insgesamt: 49278
  • Heute online: 371
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 3
Gäste: 290
Gesamt: 293

Autor Thema: [erledigt] Bootvorgang - Linux startet nicht mit Akku an Board  (Gelesen 1768 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

D-Ani

  • Gast
[erledigt] Bootvorgang - Linux startet nicht mit Akku an Board
« am: 11.09.2011, 21:58:24 »
Guten Abend,

mein Linux Mint 11 läuft nicht ganz so wie ich es mir wünschen würde obwohl es noch Recht Jung auf meinem Notebook ist.

Wenn ich meinen Akku drin lasse im Notebook will mein Linux nicht starten... Ich habe da einen grauen Bildschirm vor mir und Linux tut nichts mehr. Ist der Akku entfernt geht das Einwandfrei  ::) Zur Info mein Windows ist das egal das startet so oder so ^^ Liegt das daran das Mint meckert wegen Akku Kapazität 43,2%!?


P.S: Wenn das iwo anders hingehört bitte dorthin verschieben  ::)
« Letzte Änderung: 08.11.2011, 18:27:45 von D-Ani »

Korfox

  • Global Moderator
  • *****
Re: Style und Bootvorgang
« Antwort #1 am: 11.09.2011, 22:18:38 »
Sei bitte so gut und starte für jedes Problem einen eigenen Thread.
Vorschlag: Lass den hier für Problem A stehen, editier Problem B raus und starte dafür einen neuen Thread.
Zumal zu Problem B mEn hier im Forum schon was existiert. Müsste aber suchen.

D-Ani

  • Gast
Re: Bootvorgang - Linux startet nicht mit Akku an Board
« Antwort #2 am: 11.09.2011, 22:26:57 »
Also die SuFu hat mir diesbezüglich nicht weiter geholfen auf 11 Seiten  :(

Re: Bootvorgang - Linux startet nicht mit Akku an Board
« Antwort #3 am: 11.09.2011, 22:43:39 »
Liegt das daran das Mint meckert wegen Akku Kapazität 43,2%!?

Das glaube ich nicht. Die Foren wären gefüllt mit diesem Problem.
Und ich schiebe auch gerne zu hause den alten Akku rein damit der neue nicht tot geladen wird.
Der hat noch so ca. 5% seiner Kapazität.

Es könnte aber sein, dass gerade Dein Rechner/BIOS/Akku-Modell einen speziellen Bug hat.
Verrate uns doch mal den Typ.
Und frage Tante Google nach dem genauen Modell+Linux+Akku+Boot Problem.

MfG Olav

D-Ani

  • Gast
Re: Bootvorgang - Linux startet nicht mit Akku an Board
« Antwort #4 am: 12.09.2011, 09:40:48 »
Ich habe einen Siemens Fujitsu Amilo Li 3710. Google bietet mir eine Seite in den Suchergebnissen, aber das ist Windows und darüber hinaus hat es nicht viel gemein mit meinem Problem. Selbst bei Model+Linux+Boot Problem spuckt Tante Google fast auschließlich Windows aus  :(

Wie erwähnt unter Windows Vista habe ich das Problem nicht -.-

Re: Bootvorgang - Linux startet nicht mit Akku an Board
« Antwort #5 am: 12.09.2011, 20:57:47 »
Direkt für den Li 3710 kann ich das Problem jetzt auch nicht ergooglen.
Aber es hat schon mehrere Leute gegeben, die mit anderen Amilo-Notebooks exakt Dein Problem hatten.

Es wird vermutlich darauf hinaus laufen, dass Fujitsu-Siemens (wie die meisten Notebook-Hersteller) das ACPI nicht vernünftig umgesetzt haben.

Ist Dein System noch ungepatcht, oder laufen da schon Anpassungen für Laptops?

Du könntest mal die Ausgaben von
cat /etc/default/grubund
lsmodhier posten.

Und man könnte temporär alle Energiesparoptionen in der Energieverwaltung bei Akku- und Netzbetrieb deaktivieren.
Wenn es dann funktioniert hätte man schon mal einen Anhaltspunkt.

MfG Olav

D-Ani

  • Gast
Re: Bootvorgang - Linux startet nicht mit Akku an Board
« Antwort #6 am: 13.09.2011, 09:44:30 »
lsmod im zweiten Feld. Hier grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

So hier mal lsmod
Module                  Size  Used by
snd_hrtimer            12680  1
binfmt_misc            13213  1
sha256_generic         20911  2
cryptd                 19801  0
aes_i586               16956  1046
aes_generic            38023  1 aes_i586
parport_pc             32111  0
dm_crypt               22463  1
ppdev                  12849  0
ipt_REJECT             12512  1
ipt_LOG                12784  5
xt_limit               12541  7
xt_tcpudp              12531  8
ipt_addrtype           12535  4
xt_state               12514  7
ip6table_filter        12711  1
ip6_tables             22545  1 ip6table_filter
snd_hda_codec_realtek   255820  1
nf_nat_irc             12542  0
arc4                   12473  2
snd_hda_intel          24140  2
nf_conntrack_irc       13138  1 nf_nat_irc
snd_hda_codec          90901  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13274  1 snd_hda_codec
snd_pcm                80244  2 snd_hda_intel,snd_hda_codec
nf_nat_ftp             12548  0
nf_nat                 24827  2 nf_nat_irc,nf_nat_ftp
nf_conntrack_ipv4      19024  9 nf_nat
nf_defrag_ipv4         12649  1 nf_conntrack_ipv4
nf_conntrack_ftp       13106  1 nf_nat_ftp
snd_seq_midi           13132  0
joydev                 17322  0
nf_conntrack           69744  7 xt_state,nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_nat,nf_conntrack_ipv4,nf_conntrack_ftp
snd_rawmidi            25269  1 snd_seq_midi
snd_seq_midi_event     14475  1 snd_seq_midi
iptable_filter         12706  1
snd_seq                51291  3 snd_seq_midi,snd_seq_midi_event
ath5k                 144412  0
ath                    19141  1 ath5k
ip_tables              18125  1 iptable_filter
x_tables               21907  10 ipt_REJECT,ipt_LOG,xt_limit,xt_tcpudp,ipt_addrtype,xt_state,ip6table_filter,ip6_tables,iptable_filter,ip_tables
mac80211              257001  1 ath5k
snd_timer              28659  3 snd_hrtimer,snd_pcm,snd_seq
snd_seq_device         14110  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    55295  14 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
cfg80211              156212  3 ath5k,ath,mac80211
soundcore              12600  1 snd
snd_page_alloc         14073  2 snd_hda_intel,snd_pcm
psmouse                59039  0
serio_raw              12990  0
lp                     13349  0
parport                36746  3 parport_pc,ppdev,lp
usb_storage            43946  0
usbhid                 41704  0
hid                    77084  1 usbhid
uas                    17676  0
i915                  450979  3
drm_kms_helper         40745  1 i915
ahci                   21591  2
drm                   184133  4 i915,drm_kms_helper
r8169                  46630  0
libahci                25548  1 ahci
i2c_algo_bit           13184  1 i915
dm_raid45              88410  0
video                  18951  1 i915
xor                    21860  1 dm_raid45
btrfs                 527341  0
zlib_deflate           26594  1 btrfs
libcrc32c              12543  1 btrfs

Re: Bootvorgang - Linux startet nicht mit Akku an Board
« Antwort #7 am: 13.09.2011, 18:46:24 »
Gut, ich kann in der Grub-Configuration und in der Liste der geladenen Kernel-Mods schon mal nichts ungewöhnliches entdecken.

Du hast in /etc/default/grub die Zeile
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"stehen. Das ist die Grundeinstellung von Mint 11 und normalerweise auch ganz richtig so.
Allerdings verhindert es, dass Du den Bootvorgang genau beobachten kannst.

Ich würde sie daher mal ersetzen.
gksudo gedit /etc/default/grub# GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT=""
danach
sudo update-grubdamit Grub die Änderung auch übernimmt.

MfG Olav

McVoiceX

  • Gast
Re: Bootvorgang - Linux startet nicht mit Akku an Board
« Antwort #8 am: 14.09.2011, 02:06:26 »
Versuch doch mal im Bios ACPI abzuschalten. Hat bei mir auch geholfen. Aus unerfindlichen Gründen hat es nach einem Neustart mit ACPI dann funktioniert und ich betreibe mein Toshiba Satellite heute nach Lust und Laune mit oder ohne Akku. Linux-Systeme haben Probleme mit ACPI und geben sich beim Bios als 'Windows' aus, um Probleme beim Sytemstart zu vermeiden. Windows hat mit ACPI keine Probleme, deshalb läuft dein Vista.

Alternativ könntest du versuchen das Testen des Akkus beim Booten zu überspringen/auszulassen. Den Befehl dazu müsstest du dir allerdings googlen... den kenne ich auch (noch) nicht ;) Wenn du weisst, ob der Bildschirm beim Laden von Gnome grau wird/bleibt, schalte doch mal die Energieverwaltung in >System>Einstellungen>Startprogramme ab, nur das Häkchen entfernen...