Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
21.02.2019, 17:32:42

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21583
  • Letzte: manni1454
Statistiken
  • Beiträge insgesamt: 574983
  • Themen insgesamt: 46581
  • Heute online: 605
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  Linux Mint und Windows 10 Parallel | Windows nicht mehr im Bootmenu  (Gelesen 2572 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Wenn Linux automatisch gebootet wurde, zeigt
df -han, von welcher Partition, dann müsste man die andere ext4 einfach löschen können.
Aber bei diesem komischen Verhalten von Grub traut man sich kaum, Ratschläge zu geben.

im Endefekt war bei mir Win in UEFI modus installiert und Grub wurde die i386 Version installiert.

So weit ich mich erinnern kann, war das auch eine Meldung, die mir der Installer gegeben hatte.

Nach einer UEFI Installation von Mint mit Grub in die vorhandene Win EFI Partition hatte ich in dieser Hinsicht dann keine Probleme mehr soweit ich mich erinnere.

Wie genau hat das funktioniert?

Bei dir gibt es ja keine EFI-Partition, die Win angelegt hätte, so scheint Win wohl im BIOS-Modus installiert zu sein.
Die sda hat eine msdos-Tabelle, auch da dürfte Win nicht im UEFI-Modus installiert sein.
Man kann zwar Linux auf msdos im UEFI-Modus installieren, aber nicht Windows.
« Letzte Änderung: 18.06.2017, 16:34:18 von helli »

Vielleicht ist es gut, das vorher anzusehen:
http://wiki.ubuntu-forum.de/index.php?title=UEFI-Installation#Kleiner_Leitfaden_zur_Installation_auf_UEFI-Rechnern

Falls die Maschine ein UEFI-fähiger Rechner ist!
Lässt sich von Linux aus herausfinden mit sudo dmidecode -t0 | grep -Ei "BIOS boot|UEFI"
« Letzte Änderung: 18.06.2017, 16:31:42 von aexe »

Keine EFI Partition habe ich auch gerade gesehen.
War dein Win vorher mal auf der 750GB Platte?
Du könntest eine EFI Partition versuchsweise mal anlegen mit Gpartet zum beispiel und Grub2 drauf installieren.
Aber du bist hir auf jeden Fall auf einem Punkt wo du deine Daten sichern solltest und am besten einen Clone von deinen Festplatten ziehen um was noch von von deinem Win über ist auch einmal auf der Seite zu haben ich empfehle für so etwas clonezilla

Zitat
Bei dir gibt es ja keine EFI-Partition ...
das irritiert mich auch - warum hat die "sdb" eine "GPT-Partitionstabelle" ?
und Win10 hat eine Bootpartition (sda1) - habe ich auch noch nicht oft gesehen ?!
den
Zitat
Windows Logical Disk Manager
kenne ich leider auch nicht.
Ich denke - hier war mal was mit UEFI
@HydroHeiperGen
kannst / willst du zur Klärung beitragen ?

Edit: Verdacht hat sich weiter oben (Anwort #16) schon bestätigt !!!
Frischer Kaffee hat mich zeitlich abgelenkt  ;)  :D


« Letzte Änderung: 18.06.2017, 16:45:24 von billyfox05 »

warum hat die "sdb" eine "GPT-Partitionstabelle" ?
vermutlich wegen "Logical Disk/Volume Management" - warum auch immer das vorhanden ist.

1      1049kB  525MB  524MB   primary   ntfs            bootkönnte von einem ehemaligen Windows 7 stammen.

Wenn Win im UEFI-Mode installiert wäre müssten 4 Partitionen auf der Platte sein.
3 x ntfs und 1 x fat32 = EFI-Partition.
Linux müsste bei einer UEFI- Installation nach dem Passwort für Sec-Boot fragen.
Dies sind die besten Anzeichen für UEFI-Installationen.

Meist muss man dann noch Linux an die erste Stelle in der Bootreihenfolge setzen um in das Grub-Menü zu kommen.
So meine Erfahrungen mit UEFI-Installationen.
« Letzte Änderung: 18.06.2017, 16:49:47 von tommix »

Win10 Zwangs-Upgrade ?

@aexe
Hatte ich bisher nur von Windows 8 auf 10.
Aber es war egal W8 war im UEFI installiert.
War also das gleiche!
« Letzte Änderung: 18.06.2017, 19:10:47 von tommix »



Modell: ATA HGST HTS541075A9 (scsi)
Festplatte  /dev/sdb:  750GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt
Disk-Flags:

Nummer  Anfang  Ende    Größe   Dateisystem  Name                          Flags
 1      17,4kB  1066kB  1049kB               LDM metadata partition
 2      1066kB  134MB   133MB                Microsoft reserved partition  msftres
Deutet für mich auf eine mal vorhandene OEM UEFI Installation von einem Win hin, jedoch fehlen andere entscheidende Teile (EFI und Wiederhestellungs -Partition).
Mal ein inxi -Fxwürde mal aufklären was für ein Rechner da läuft.
Wenn es mal eine UEFI OEM Installation war könnte man das Win auch neu installieren wenn man an den Produkt-Key der Ursprünglichen Installation kommt Installationsimage kann man sich bei MS runterladen.
 

Wenn Win im UEFI-Mode installiert wäre müssten 4 Partitionen auf der Platte sein.
3 x ntfs und 1 x fat32 = EFI-Partition.
Bei mir (Win10 von Win 8 angehoben) sind es 2 x ntfs und 1 x fat32 (EFI)


Linux müsste bei einer UEFI- Installation nach dem Passwort für Sec-Boot fragen.
nicht zwangsläufig - hiesige Distributionen von "Devil..." seit LM 17.3 - werden von Secure-Boot akzeptiert -
s.h. keine Passwortabfrage auch bei Secure-Boot aktiv - zumindest ist das meine Erfahrung.

So sieht die Platte des Rechners aus
mint@mint ~ $ sudo parted --list
Model: ATA TOSHIBA MQ01ABF0 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  1075MB  1074MB  ntfs         Basic data partition  hidden, diag
 2      1075MB  1180MB  105MB   fat32        Basic data partition  boot, esp
 3      1180MB  1314MB  134MB   ntfs         Basic data partition  msftres
 4      1314MB  489GB   488GB   ntfs         Basic data partition  msftdata
 5      489GB   490GB   472MB   ntfs                               hidden, diag
 6      490GB   500GB   10.2GB  ntfs         Basic data partition  hidden, diag


Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Model: TSSTcorp CDDVDW SU-208DB (scsi)                                   
Disk /dev/sr0: 1833MB
Sector size (logical/physical): 2048B/2048B
Partition Table: mac
Disk Flags:

Number  Start   End     Size    File system  Name   Flags
 1      2048B   6143B   4096B                Apple
 2      1799MB  1802MB  2490kB               EFI

@billyfox05

Linux müsste bei einer UEFI- Installation nach dem Passwort für Sec-Boot fragen.
nicht zwangsläufig - hiesige Distributionen von "Devil..." seit LM 17.3 - werden von Secure-Boot akzeptiert -
s.h. keine Passwortabfrage auch bei Secure-Boot aktiv - zumindest ist das meine Erfahrung.
Da hast du leider einen Denkfehler. Wiki von Nuffi mit LM17.3:
Zitat
2. Secure-Boot abschalten / anderes Betriebssystem wählen. (Secure-Boot muss wohl nicht mehr abgeschaltet werden da
    Mint das wohl kann. Ab LM18 am besten Testen!  ;) )
Bei 17.3 muss Sec-Boot abgeschaltet werden, ab 18 ist die Frage nach dem Passwort.

Wie gesagt bei UEFI-Installation, bei BIOS installation keine Passwortabfrage.