Bildschirm flackern
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
15.08.2018, 09:16:01

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 20607
  • Letzte: nrgdw
Statistiken
  • Beiträge insgesamt: 543499
  • Themen insgesamt: 43693
  • Heute online: 257
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online

Autor Thema:  Bildschirm flackern  (Gelesen 5940 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Bildschirm flackern
« am: 13.05.2017, 21:10:33 »
Ich habe heute mal Linux Mint linuxmint-18.1-cinnamon-64bit Installiert.

Soweit hat auch alles geklappt leider habe ich ein Helligkeitsflimmern. Das habe ich aber nicht unter Windows.

Habe mal ein kleines Video gemacht
Datei von filehorst.de laden

Gerät:
Alienware 17 RC 2
GK: NVIDIA 970M und eine interne Intel HD 4600

Mit den GF Treiber Optionen habe ich schon gespielt. Hilft alles nix. Updates sind alle gemacht.

Achtet auf den Desktop Hintergrund. Das passiert auch wenn ich die Maus bewege.

Jemand eine Idee was ich da machen kann?

Intel Treiber habe ich schon Aktualisiert. Also mit dem Intel Tool dafür. Auch den Open Treiber von NVIDIA versucht. Bzw der wo unter Treiber empfohlen wird.

Ach ja bin Neuling auf dem Gebiet.
« Letzte Änderung: 13.05.2017, 21:38:13 von Koto »

Re: Bildschirm flackern
« Antwort #1 am: 21.05.2017, 22:25:26 »
Welchen Kernel fährst du?
Im Terminal eingeben:
uname -r
Wenn du noch den default-Kernel hast, müsstest du bei Kernel v. 4.4 sein.
Aktualisiere doch mal auf den die aktuellste 4.8er Kernelversion (und wenn der nicht geht auf den 4.10er).

Zu finden über den Updatemanager -> Linux-Kernel.

Re: Bildschirm flackern
« Antwort #2 am: 22.05.2017, 10:55:18 »
Hi :)
bleib mal erstmal beim neusten 4.4er.. erst wenn das nichts bringt, auf die nächste linie wechseln.
der 4.8er wird nicht mehr lange supportet.

Re: Bildschirm flackern
« Antwort #3 am: 28.05.2017, 21:11:37 »
Also ich hatte auch den Kernel geupdatet. Hat alles nix geholfen. Aktuell musste ich Linux aufgeben.

Ich hatte dasselbe Problem mit ubuntu,Antergos

Es flackert auch da.

Ich wollte nach der Anleitung
https://www.linuxmintusers.de/index.php?topic=23174.msg306662#msg306662

Den Treiber Aktualisieren. Aber ab den Punkt

Zitat
Jetzt muss der X-Server (das grafische System) beendet werden, da sonst der Nvidia-Installer die Arbeit verweigert:

War ende. Dann wird der Bildschirm komplett schwarz und blind tippen ist unmöglich. Ich weiß nicht mal ob das System noch aktiv ist. Also überhaupt Eingaben annehmen würde. Also da ist mir dann echt der Geduldsfaden gerissen.

Ist echt schade Cinnamon  ist das beste Linux was ich bis jetzt gesehen habe. Wäre das Flacker Problem nicht. Das ist dann leider ein echtes No Go.

Ach ja den Intel Treiber für die HD 4600 in der CPU hatte ich auch aktualisiert. Konnte das Intel Update Tool patchen. Damit es Cinnamon erkennt. Hat leider nix geholfen.
« Letzte Änderung: 28.05.2017, 21:57:26 von Koto »

Re: Bildschirm flackern
« Antwort #4 am: 28.05.2017, 22:33:15 »
Du kannst es ja mal mit LM 18.1 Mate versuchen, das hat nicht so hohe Anforderungen an die Grafik.

Re: Bildschirm flackern
« Antwort #5 am: 28.05.2017, 22:48:15 »
Ich wollte nach der Anleitung
https://www.linuxmintusers.de/index.php?topic=23174.msg306662#msg306662
Den Treiber Aktualisieren
Das ist wirklich nur für 17.x, steht ja auch drüber. Identisch mit der Version im (nicht erreichbaren) Wiki ist es auch nicht.
Für 18.1 siehe
https://www.linuxmintusers.de/index.php?topic=42476.msg603845#msg603845

Re: Bildschirm flackern
« Antwort #6 am: 29.05.2017, 13:21:58 »
Zitat
Du kannst es ja mal mit LM 18.1 Mate versuchen, das hat nicht so hohe Anforderungen an die Grafik.

Ich glaube nicht dass es am Desktop liegt. Wenn mir 3 Linux Disbus denselben Effekt zeigen. Kann es doch nicht der Desktop sein. Hatte ja schon andere probiert.

Und meine Hardware ist mit Linux unter Garantie nicht überfordert. Eher Linux mit der Hardware. :-)

Intel I7 4720HQ 2.60 ghz 16 Gig Ram sollte reichen.

@geobart

Danke für die Info. Ich werde das noch mal testen und dann berichten. Habe aber wenig Hoffnung.

Re: Bildschirm flackern
« Antwort #7 am: 29.05.2017, 17:12:46 »
So hilft alles nix.

Kernel 4.8 und 4.10 helfen nicht. 

Neue nvida Treiber 381 .22 helfen nicht.

Es bleibt beim Flackern. Wenn der Bildschirm kein Fenster zeigt. Sieht man das aus an der Maus Bewegung. Bewegt man Sie wird es leicht heller. Bleibt Sie stehen leicht dunkler.

Offenbar ein Hell Dunkel Problem. Hat man ein Fenster das den halben Bildschirm ausfüllt ohne eine Animation ist es weg. Wie in dem Video ein Statisches Flackern oder wenn man eben den Mauszeiger bewegt.


Re: Bildschirm flackern
« Antwort #8 am: 29.05.2017, 17:19:46 »
Hi :)
habe mir dein video geade mal angesehen..
sehr kurios..

da pumpt was im sekunden takt.
hast du das auch in der console?
strg-alt-f1

und (hab jetzt auf die schnelle nicht alles durchgelesen)
im anmeldefenster?

was macht er wenn du im bios stehst?

Re: Bildschirm flackern
« Antwort #9 am: 29.05.2017, 18:28:07 »
Also das Pumpen ist bei diesem Programm Fenster so konstant gewesen.

Ohne Fenster wird es heller wenn ich die Maus bewege. Und Dunkler wenn die Maus stillsteht.

Wenn ich ein größeres weißes Fenster habe. Ist der Effekt nicht. Offenbar liegt es irgendwie am Hell Dunkel Kontrast bei Bewegung von Objekten.

Im Bios, beim Booten in Windows usw ist das nicht.

Hier mal ein anderes Video.
Datei von filehorst.de laden

Man beachte sobald ich den Mauszeiger bewege. Ändert sich die Helligkeit. Man könnte meinen da läuft eine Auto Kontrast Automatik wie bei einigen LCD TVs. Um Bereiche abzudunkeln.

Defekt kann man ausließen da ja unter Windows und im Bios und beim Booten alles ok ist.

Ich danke auch schon an eine Engergiesparfunktion. Habe aber das Netzteil immer dran. Und hatte da auch schon was versucht unter Linux.

Re: Bildschirm flackern
« Antwort #10 am: 29.05.2017, 18:45:19 »
Und hier mal mit Terminal.

Link
Datei von filehorst.de laden

Man sieht auch da. Wenn ich die Maus bewege gibt es Schwankungen.

Helligkeit ändern hilft leider auch nix. Habe die MS Maus schon abgezogen. Treiber Aktualisiert.

Edit:
Wenn ich ein MKV Video abspiele ist der Effekt weg? Egal ob Vollbild oder kleines Fenster?
« Letzte Änderung: 29.05.2017, 19:09:16 von Koto »

klasie

  • Gast
Re: Bildschirm flackern
« Antwort #11 am: 29.05.2017, 19:31:20 »
Du könntest mal in der Datei xorg.conf nach der "Accelmethod" sehen.
(Ich glaube mich zu erinnern, auch schon gelesen zu haben, man solle im BIOS eine der beiden Grafikkarten deaktivieren).

Re: Bildschirm flackern
« Antwort #12 am: 29.05.2017, 19:43:01 »
Zitat
Du könntest mal in der Datei xorg.conf nach der "Accelmethod" sehen.
(Ich glaube mich zu erinnern, auch schon gelesen zu haben, man solle im BIOS eine der beiden Grafikkarten deaktivieren).

Das musst Du genauer ausführen. Bin Anfänger.

Wo soll die Datei sein. Wie komme ich dahin. Und was soll ich da ggf ändern?

Und soweit ich weiß, kann man im Bios keine Grafikkarten deaktivieren.

Re: Bildschirm flackern
« Antwort #13 am: 29.05.2017, 22:01:54 »
Aus meiner Sicht eine schlechte Empfehlung.
Du hast ja jetzt den Nvidia installiert. Zeig mal bitte die Terminalausgabe von inxi -G bitte im Codeblock.
Außerdem:  wurde das Prime-Leistenapplet zum Umschalten von NV auf Intel installiert? Zeigen die NV-Settings die Umschaltmöglichkeit?


Edit: Mich irritiert, dass Dell bei dem Notebook immer von "Grafikverstärker" spricht, wenn sie von der Nvidia reden.
« Letzte Änderung: 29.05.2017, 22:10:12 von geobart »

klasie

  • Gast
Re: Bildschirm flackern
« Antwort #14 am: 29.05.2017, 22:03:23 »
Rufe den Dateimanager auf. Dann klicke auf den Basisordner. Danach nutze die Suchfunktion und gib in das Suchfeld "xorg.conf" (ohne Anführungsstriche) ein. Es dauert jetzt ein Weilchen. Wenn die Ergebnisse angezeigt werden, klicke auf xorg.conf. Was steht dort bei "Accelmethod"?