Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
27.02.2021, 22:30:34

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 718691
  • Themen insgesamt: 58129
  • Heute online: 717
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [erledigt] 'Defekte Pakete' Problem  (Gelesen 7139 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] 'Defekte Pakete' Problem
« am: 03.05.2017, 22:33:20 »
Hallo, ich mach mal für mein Problem einen eigenen Thread auf:

Seit einigen Tagen lässt sich mein System (Cinn 18.1) nicht komplett aktualisieren.
Anfangs trat das Problem beim Aktualisieren des Kernels auf, mittlerweile ist es weiter zu LibreOffice gewandert.

Mir wird mitgeteilt, dass ich defekte Pakete habe. Deshalb hab ich schon die Tipps aus diesem Thread (https://www.linuxmintusers.de/index.php?topic=25136.msg597627#new) ausprobiert, leider ohne Erfolg.

Gerade hab ich wieder einen Versuch gestartet, diesmal kam diese Meldung:

E: /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb: »/usr/lib/libreoffice/share/filter/vml-shape-types.dpkg-new« kann nicht geöffnet werden: Vorgang nicht zulässig
Hat jemand eine Idee?

Danke schon mal, Erich
« Letzte Änderung: 15.05.2017, 01:30:44 von Erich »

Re: 'Defekte Pakete' Problem
« Antwort #1 am: 03.05.2017, 22:36:50 »
Auch schon
sudo dpkg --configure -aversucht?

Re: 'Defekte Pakete' Problem
« Antwort #2 am: 03.05.2017, 22:38:26 »
Zeig mal bitte die vollständige Ausgabe, inkl Eingabe.
Durchaus möglich, dass das nur eine Folgefehler ist.

Re: 'Defekte Pakete' Problem
« Antwort #3 am: 03.05.2017, 22:40:53 »
Ich bekomme dann das hier:
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libreoffice-java-common:
 libreoffice-java-common hängt ab von libreoffice-common (= 1:5.1.6~rc2-0ubuntu1~xenial2); aber:
  Version von libreoffice-common auf dem System ist 1:5.1.6~rc2-0ubuntu1~xenial1.

dpkg: Fehler beim Bearbeiten des Paketes libreoffice-java-common (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libreoffice-sdbc-hsqldb:
 libreoffice-sdbc-hsqldb hängt ab von libreoffice-java-common (>= 1:5.1.6~rc2~); aber:
  Paket libreoffice-java-common ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes libreoffice-sdbc-hsqldb (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 libreoffice-java-common
 libreoffice-sdbc-hsqldb


Re: 'Defekte Pakete' Problem
« Antwort #4 am: 04.05.2017, 01:41:31 »
Dieses Mal hab ich bei den Details folgende Meldung bekommen:
(Lese Datenbank ... 410186 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb ...
Entpacken von libreoffice-common (1:5.1.6~rc2-0ubuntu1~xenial2) über (1:5.1.6~rc2-0ubuntu1~xenial1) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb (--unpack):
 »/usr/lib/libreoffice/share/registry/main.xcd.dpkg-new« kann nicht geöffnet werden: Vorgang nicht zulässig
rmdir: konnte '/var/lib/libreoffice/share/prereg/' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice/share/' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice/program/' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice' nicht entfernen: Datei oder Verzeichnis nicht gefunden
Trigger für desktop-file-utils (0.22-1ubuntu5.1) werden verarbeitet ...
Trigger für gnome-menus (3.13.3-6ubuntu3.1) werden verarbeitet ...
Trigger für mime-support (3.59ubuntu1) werden verarbeitet ...
Trigger für gnome-icon-theme (3.12.0-1ubuntu3) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.15-0ubuntu1) werden verarbeitet ...
Trigger für shared-mime-info (1.5-2ubuntu0.1) werden verarbeitet ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Wiederherstellung wird versucht:
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libreoffice-java-common:
 libreoffice-java-common hängt ab von libreoffice-common (= 1:5.1.6~rc2-0ubuntu1~xenial2); aber:
  Version von libreoffice-common auf dem System ist 1:5.1.6~rc2-0ubuntu1~xenial1.

dpkg: Fehler beim Bearbeiten des Paketes libreoffice-java-common (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libreoffice-sdbc-hsqldb:
 libreoffice-sdbc-hsqldb hängt ab von libreoffice-java-common (>= 1:5.1.6~rc2~); aber:
  Paket libreoffice-java-common ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes libreoffice-sdbc-hsqldb (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 libreoffice-java-common
 libreoffice-sdbc-hsqldb

Re: 'Defekte Pakete' Problem
« Antwort #5 am: 04.05.2017, 07:36:16 »
Ich würde versuchen, das "zickende" Paket aus dem Cache zu löschen und hoffen, das es nach einem erneuten Download besser wird.
z.B. im Terminal mit diesem Befehl:
sudo rm /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb

Re: 'Defekte Pakete' Problem
« Antwort #6 am: 04.05.2017, 15:56:40 »
Hab's gerade versucht, leider kein Erfolg, die gleiche Meldung wie immer.

Ich hätte auch eher auf das Paket xenial1 als dem Übeltäter getippt.
apt-get dist-upgrade -s bringt mir folgende Meldung:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libreoffice-java-common : Hängt ab von: libreoffice-common (= 1:5.1.6~rc2-0ubuntu1~xenial2) aber 1:5.1.6~rc2-0ubuntu1~xenial1 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.

Ich hab schon daran gedacht, /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial1_all.deb zu entfernen, aber ich hab Angst, mein System damit total zu zerschießen.

Re: 'Defekte Pakete' Problem
« Antwort #7 am: 04.05.2017, 16:14:39 »
Das kannst du ohne weiteres löschen. Hilft und schadet nicht.
Das Problem ist, dass sich libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb nicht installieren lässt.
Weil:
»/usr/lib/libreoffice/share/registry/main.xcd.dpkg-new« kann nicht geöffnet werden: Vorgang nicht zulässig
rmdir: konnte '/var/lib/libreoffice/share/prereg/' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice/share/' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice/program/' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice' nicht entfernen: Datei oder Verzeichnis nicht gefunden
Die weiteren Fehler sind nur eine Folge von diesem und haben sich erledigt, sobald das Paket erfolgreich installiert werden konnte.
Das muss für jetzt reichen, melde mich heute abend noch mal

Re: 'Defekte Pakete' Problem
« Antwort #8 am: 04.05.2017, 16:35:24 »
Stimmt, das Löschen von xenial1 hat auch nichts gebracht.

Ich hab jetzt auch nochmal xenial2 gelöscht und anschließend in der Aktualisierungsverwaltung auf Auffrischen geklickt. Da hab ich trotzdem diese Meldung gekriegt:
Zitat
Die Abhängigkeiten von 1 Paket auf Ihrem System sind defekt.
Wählen sie den Filter »Defekte Pakete«, um dieses anzuzeigen.

Und ich hab extra nachgeguckt, ob xenial2 auch gelöscht ist. Kann es sein, dass das Problem eigentlich bei einem ganz anderen Paket liegt?

Re: 'Defekte Pakete' Problem
« Antwort #9 am: 04.05.2017, 16:44:30 »
Du löschst es damit nur aus dem Cache. Das ist keine Deinstallation.
Ist aber eigentlich keine schlechte Idee, mach mal
sudo apt-get -s remove libreoffice-common

Re: 'Defekte Pakete' Problem
« Antwort #10 am: 04.05.2017, 16:48:30 »
Verweigert ebenfalls die Mitarbeit:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libreoffice-core : Hängt ab von: libreoffice-common (> 1:5.1.6~rc2) soll aber nicht installiert werden
 libreoffice-help-en-us : Hängt ab von: libreoffice-l10n-en-us
 libreoffice-java-common : Hängt ab von: libreoffice-common (= 1:5.1.6~rc2-0ubuntu1~xenial2) soll aber nicht installiert werden
 libreoffice-l10n-de : Hängt ab von: libreoffice-common soll aber nicht installiert werden
 libreoffice-ogltrans : Hängt ab von: libreoffice-common soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

Re: 'Defekte Pakete' Problem
« Antwort #11 am: 04.05.2017, 17:44:24 »
Hi :)
wurde
sudo apt-get -f installeigentlich schon ausgeführt?

und bitte bringe den genutzen befehl mit, beim posten des ergebnisses..

Re: 'Defekte Pakete' Problem
« Antwort #12 am: 05.05.2017, 02:16:48 »
Hier die Ausgabe von sudo apt-get -f install:

sudo apt-get -f install
[sudo] Passwort für erich:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden zusätzlichen Pakete werden Installiert
  libreoffice-common
Vorgeschlagene Pakete:
  libreoffice-style-breeze libreoffice-style-hicontrast libreoffice-style-human libreoffice-style-oxygen libreoffice-style-sifr libreoffice-style-tango
Empfohlene Pakete:
  fonts-stix
Die folgenden Pakete werden aktualisiert (Upgrade):
  libreoffice-common
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen 22,2 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 1.024 B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] J
Holen:1 ftp://ftp.fu-berlin.de/linux/ubuntu xenial-updates/main amd64 libreoffice-common all 1:5.1.6~rc2-0ubuntu1~xenial2 [22,2 MB]
Es wurden 22,2 MB in 3 s geholt (6.843 kB/s). 
(Lese Datenbank ... 410186 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb ...
Entpacken von libreoffice-common (1:5.1.6~rc2-0ubuntu1~xenial2) über (1:5.1.6~rc2-0ubuntu1~xenial1) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb (--unpack):
 »/usr/lib/libreoffice/share/gallery/arrows.sdg.dpkg-new« kann nicht geöffnet werden: Vorgang nicht zulässig
rmdir: konnte '/var/lib/libreoffice/share/prereg/' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice/share/' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice/program/' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice' nicht entfernen: Datei oder Verzeichnis nicht gefunden
rmdir: konnte '/var/lib/libreoffice' nicht entfernen: Datei oder Verzeichnis nicht gefunden
Trigger für desktop-file-utils (0.22-1ubuntu5.1) werden verarbeitet ...
Trigger für gnome-menus (3.13.3-6ubuntu3.1) werden verarbeitet ...
Trigger für mime-support (3.59ubuntu1) werden verarbeitet ...
Trigger für gnome-icon-theme (3.12.0-1ubuntu3) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.15-0ubuntu1) werden verarbeitet ...
Trigger für shared-mime-info (1.5-2ubuntu0.1) werden verarbeitet ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libreoffice-common_1%3a5.1.6~rc2-0ubuntu1~xenial2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Re: 'Defekte Pakete' Problem
« Antwort #13 am: 05.05.2017, 10:22:59 »
Hi :)
ich vermute dein /usr/lib/libreoffice/ ist defekt..
beenne das mal um..
und versuche die installation erneut.

Re: 'Defekte Pakete' Problem
« Antwort #14 am: 05.05.2017, 15:10:31 »
Hallo Erich!
Hast du denn auch mal in der Synaptik-Paketverwaltung nachgeschaut?
Denn dort werden alle defekten Pakete und Abhängigkeitsprobleme angezeigt...und es wird auch eine Reparatur dieser Pakete angeboten.