Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
16.01.2021, 00:45:35

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25069
  • Letzte: rs_linux
Statistiken
  • Beiträge insgesamt: 708120
  • Themen insgesamt: 57251
  • Heute online: 515
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Nach jedem Neustart des Rechners ist kein Sound mehr möglich  (Gelesen 2202 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ralf-DC7FB

  • Gast
Moin Leutz;
tja , da bin ich mal wieder - mit einem anscheinend gelöstem Problem, das aber immer wieder auftritt.
Unter dem Link  :
https://www.linuxmintusers.de/index.php?topic=41345.msg587468#msg587468
wurde das schon mal lang und breit diskutiert.
Aber von vorne:
System hier:
BS: Linux Mint 18.1 Cinnamon 64 bit
Kernel 4.4..0-66 generic
Proz: Intel Core I5-2500CPU @ 3.30GHz x4
Grafik: Nvidia Corp G98 (Geforce8400 G5 Rev2)

Im Rechner sind 2 Soundkarten:
1x Onboard HDA Intel PCA (im BIOS nicht deaktiviert, aber ohne Lautsprecher)
und eine PCI-Card Xonar DX200 , hieran ist ein 5.1 er Soundsystem angeflanscht.
Wenn ich mit AlsaMixer im Terminal nachfrage, stellt System mir auch die beide zur Auswahl.
Als drittes bietet AlsaMixer "Standard" an.

Daraus ergibt sich für mich, das es nur dann was bringt, wenn ich die Xonar als Ausgabe wähle.
Wenn ich jetzt aber aber irgendein Musicstück mit Audacious anwähle, tut DIESE Software auch so, als ob sie es abspielen würde.
Damals schien das Problem gelöst, nachdem ich auch ein Kernelupdate machte.
Aber da ich zu diesem Zeitpunkt die Soundausgabe dringend brauchte, habe ich den Rechner bis gestern durchlaufen gelassen (ab und zu "Ruhezustand")
Da er aber gestern total abgeschmiert war, keine Internetverbindung aufbauen wollte, keine weitern Programme starten , also gaaarnix mehr tat,
habe ich ihn dann mal richtig ausgeschaltet
Und dann kam das , was ich befürchtete : Sound weg.
Ich bin Funkamateur und benutze den PC per Echolink als quasi Transceiver, weil ich nicht so viel Platz habe, um mir hier den Tisch mit Sendetechnik vollzustellen,
die ich dann noch nicht mal selbst handlen kann ( bin schwerbehindert)
Diese Betätigung ist so ziemlich die einzigste, die mir als behinderter Frührentner noch als Tor nach draußen blieb.
Deshalb ist dieses Dilemma für mich so wie Stimme und Ohren weg.
Also wenn mir da jemands weiterhelfen kann, wär ich sehr danbkar.

- tnx de DC7FB - Ralf
« Letzte Änderung: 17.04.2017, 09:42:55 von Ralf-DC7FB »

Ralf-DC7FB

  • Gast
Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #1 am: 17.04.2017, 10:14:11 »
PS) Ich hab auch schon versucht, bei Funkers - die ja den Ham-Spirit auf ihre Fahnen schreiben - Hilfe zu bekommen.
Aber von zweien hörte ich, das ich ja wohl selbst schuld wäre, wenn ich mich mit einem "Nischenprodukt" wie Linux abgäbe.
Unter Windows würde ALLES GANZ EINFACH funktioniern...... hahaha
Also ich kann definitiv vom Gegenteil berichten; wenn nicht das Prg selbst abschmiert, so kommt fast täglich ein Bluescreen.
Alternative wäre vielleicht ein MAC; aber  erstens zu teuer und 2tens ist das Softwareangebot für aktuelle Amateuerfunkanwendungen noch magerer als bei Linux

Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #2 am: 17.04.2017, 11:09:06 »
Hallo Ralf-DC7FB

vielleicht hast du das "ewig alte" Problem zwischen PulseAudio und Alsamixer: Bei einigen Soundkarten wollen sie einfach nicht richtig miteinander und PulseAudio stellt demzufolge falsche Lautstärkewerte ein. Meist ist äußerst sich diese "Erscheinung" in einer auf 100 Prozent gestellen Audio-Ausgabe. Es kann aber genauso gut in die andere Richtung gehen, also hin zu "kein Sound" oder "zu leise".

Möglicherweise hilft dir dieser Link weiter:
https://linuxundich.de/gnu-linux/stellt-pulseaudio-die-soundkarte-zu-schnell-auf-stumm/

In eine ähnliche Kerbe schlägt der folgende Link, der ebenfalls versucht, die "Standardeinstellungen" bei Systemstart zu verändern:
https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Per-application_volumes_change_when_the_Master_volume_is_adjusted


Ralf-DC7FB

  • Gast
Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #3 am: 17.04.2017, 11:41:21 »
Vielen Dank restmal ffür die Antwort.
Aber:
Bei mir ist nicht das Problem der "falschen" Lautstärke, sondern gar keine Lautstärke, weil das entsprechende Ausgabegerät zwar hardwaremäßig im Rechner steckt, jetzt nach dem vollständigem Booten aber nicht mehr ansprechbar ist, obwohl alsamixer die Anwesenheit bestätigt und auch eine scheinbare Wahlmöglichkeit vortäuscht.
Bei dem 2ten Link bin ich ein wenig skeptisch, ob man die für Arch-Linux geschriebenen tipps auch unter Linux Mint einfach so übernehmen kann.

Ralf-DC7FB

  • Gast
Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #4 am: 17.04.2017, 11:52:37 »
Schau mal bei den Bildern des ersten Posts;
Wenn man Alsamixer aufruft, zeigt Alsa 3 Soundmöglichkeiten, wobei ich nicht weiß, was mit Standard gemeint ist.
Beim Foto des Systemsounds wird aber nur eine nicht vorhandene Ausgabe angezeigt


Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #5 am: 17.04.2017, 12:01:50 »
Nach Reboot des Rechners springt die Auswahl der Soundcard gern mal auf default zurück. Nachdem du deine gewünschte Anwendung gestartet hast solltest Du dann im Mixer die passende Soundkarte auswählen. Dann sollte auch wieder Audio zu hören sein.

Ralf-DC7FB

  • Gast
Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #6 am: 17.04.2017, 12:18:49 »
Nach Reboot des Rechners springt die Auswahl der Soundcard gern mal auf default zurück. Nachdem du deine gewünschte Anwendung gestartet hast solltest Du dann im Mixer die passende Soundkarte auswählen. Dann sollte auch wieder Audio zu hören sein.

Genau das habe ich schon mehrfach versucht per alsamixer einzustellen, wie auch schon mehrfach beschrieben.
Welche Möglichkeiten gibt es denn unter LM 18.1 noch, um die passende Soundcard einzustellen?

Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #7 am: 17.04.2017, 12:38:37 »
Mit dem PulseAudioLautstärkeregler. Der ist recht komfortabel. https://wiki.ubuntuusers.de/pavucontrol/

Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #8 am: 17.04.2017, 12:41:01 »
Auswahl der Soundkarte via alsamixer?
Sieht zwar auf den ersten Blick so aus, aber leider ist das nicht möglich!
Geht über Pulseaudio via Klang-Applet oder Pulseaudio Lautstärkeregler.

Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #9 am: 17.04.2017, 12:47:46 »

Auswahl der Soundkarte via alsamixer?
...leider ist das nicht möglich!

Wäre mir neu.

Zitat
Geht über Pulseaudio via Klang-Applet oder Pulseaudio Lautstärkeregler.
Schrieb ich bereits.

Ralf-DC7FB

  • Gast
Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #10 am: 17.04.2017, 13:12:01 »
So, ich glaub, jetzt hab ich es
Der Tipp von nativeworld  brachte mich hierher:
https://wiki.ubuntuusers.de/PulseAudio/#Geraete-werden-nicht-erkannt
dort stand :

Geräte werden nicht erkannt


Sollte die Soundkarte nicht oder nicht mehr erkannt werden, kann man über einen Workaround doch noch zu einer Soundausgabe kommen. Dazu muss die Datei /etc/pulse/default.pa in einem Editor mit Rootrechten bearbeitet werden [3][4]. Die Zeilen

#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0

ändern und die Kommentierung (#-Zeichen) entfernen:

load-module module-alsa-sink device=hw:0
load-module module-alsa-source device=hw:0

Die Device-Nr. device=hw:0 ggf. den eigenen Gegebenheiten anpassen; es können auch mehrere Karten
(dazu entsprechend neue Zeilen erstellen) eingetragen werden.

Jetzt ist zumindest erstmal die Xonar wieder aktiv, wenn auch nur als Stereo, hat jetzt nur die beiden Front-LS,

Wenn jetzt noch jemand weiß, wie ich wieder zu meinem 5.1 Soundsystem komme, dann mach ich einen virtuellen Kniefall
Wenn mich nicht alles täuscht, konnte man das über das Profil, aber unter der Xonar wird mir keine Möglichkeit zum Editieren des Profils angeboten
« Letzte Änderung: 17.04.2017, 13:22:08 von Ralf-DC7FB »

Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #11 am: 17.04.2017, 13:14:15 »
Hat es einen tieferen Sinn, warum der onboard-Sound im BIOS nicht deaktiviert ist?
Deaktiviere sie doch mal und schau dann.....

Ralf-DC7FB

  • Gast
Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #12 am: 17.04.2017, 13:18:35 »
Hat es einen tieferen Sinn, warum der onboard-Sound im BIOS nicht deaktiviert ist?
Deaktiviere sie doch mal und schau dann.....
Ja, darüber (habe) hatte ich einen SDR-Empfänger angeschlossen, dessen Ausgabe ich quasi in einem virtuellem loop der Xonar zuführte.
Es ging um die Dekodierung von Digitalfunkarten  zB Morsedecoder. Einer hört -einer dekodiert.

Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #13 am: 17.04.2017, 13:33:06 »
Pulseaudio -> Konfiguration (letzter Reiter)

Ralf-DC7FB

  • Gast
Re: Nach jedem Neustart des Rechners ist kein Sound mehr möglich
« Antwort #14 am: 17.04.2017, 13:40:04 »
Pulseaudio -> Konfiguration (letzter Reiter)

Kannst Du das ein bischen genauer angeben?
Ich steh da ein wenig auf dem Schlauch. Vielleicht kannste Deinen Tip verdeutlichen .
« Letzte Änderung: 17.04.2017, 14:31:04 von Ralf-DC7FB »