Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.07.2020, 05:19:09

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24253
  • Letzte: chemin
Statistiken
  • Beiträge insgesamt: 670264
  • Themen insgesamt: 54299
  • Heute online: 254
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  [Gelöst] SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch  (Gelesen 4030 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch
« Antwort #15 am: 13.02.2017, 12:22:49 »
Wenn du damit deinen 1. Link meinst, der soll ja auch in Lubuntu funktionieren, was ebenfalls auf Lxde fußt. Wäre also auch eine Option.

Re: SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch
« Antwort #16 am: 13.02.2017, 12:23:54 »
Mein ich, danke!

Re: SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch
« Antwort #17 am: 13.02.2017, 16:10:43 »
Es scheint so, dass die KDE Apps (namentlich Krusader und Gwenview) für den Wechsel auf den anderen Desktop und die falsche Auflösung zuständig waren.
Auch wenn ich jetzt mit dem Workaround noch nicht in den Standby komme, so habe ich jetzt zumindest mal echte 1280*800 und nutze statt Krusader Double Commander.
Wenn sich da jetzt nicht wieder ein Fehler einschleicht, werde ich den Thread auf gelöst setzen.

Re: SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch
« Antwort #18 am: 13.02.2017, 16:45:23 »
KDE Komponenten bei nur 256 MB RAM? Nicht das wahre..... ;)

Re: SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch
« Antwort #19 am: 13.02.2017, 19:48:17 »
Ja, das war mir nicht klar. Aber jetzt nachdem ich das Laptop einmal richtig an und aus gemacht habe, ist das Problem wieder da :-/ Werde wohl mal LXDE bzw Peppermint OS ausprobieren.

Re: SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch
« Antwort #20 am: 13.02.2017, 19:50:44 »
Mit dieser RAM "Größe" braucht es einen leichten Desktop UND leichte Anwendungen! Also nix KDE-Programme, nix Firefox, nix LibreOffice...
« Letzte Änderung: 13.02.2017, 19:56:32 von toffifee »

Re: SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch
« Antwort #21 am: 13.02.2017, 19:57:18 »
Mit dieser RAM "Größe" braucht es einen leichten Desktop UND leichte Anwendungen! Also nix KDE, nix Firefox, nix LibreOffice...


Bleibt wohl nur Antix...  :)
http://distrowatch.com/table.php?distribution=antix
Zitat
03 February 2017

URGENT

It was brought to my attention by antiX user Rademes that the Dirty COW vulnerability was still present on 64 bit antiX-16 (not 64 bit antiX-16.1 nor 32 bit antiX-16)) after a dist-upgrade.

For some reason the correct linux-image deb was updated, but does not auto-upgrade even though the headers do.

All 64bit antiX-16 users (full, base and core) should do the following.

 apt-get update
 apt-get dist-upgrade
 apt-get install --reinstall linux-headers-4.4.10-antix.1-amd64-smp linux-image-4.4.10-antix.1-amd64-smp

anticapitalista, 03 February 2017, Thessaloniki


Oder doch endlich ein "Neuer" ?  ::)
« Letzte Änderung: 13.02.2017, 20:00:51 von Hubsi_Gberg »

thebookkeeper

  • aka AnanasDampf
  • *****
Re: SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch
« Antwort #22 am: 14.02.2017, 01:45:56 »
... Ich habe seit vier Tagen Linux Mint 18.1 Xfce 64 Bit laufen. Zwei Tage lief es auch ... mit 1280*800. Dann habe ich den Benutzer mal abgemeldet und wieder angemeldet und zum einen kam dann erst die Meldung, dass das Xfce Panel nun das erste mal gestartet wird (was lief dann vorher?) und die Auflösung ist nicht mehr bei 1280*800 ... Das Panel und das Design hat sich auch verändert ...
Statt Mint-Xfce wurde bei Dir Standard-Xfce gestartet (Leiste+Menü oben, kann man irgendwie wieder nach unten ziehen und Auflösung nachträglich anpassen), vermutlich wegen KDE-Anwendung. Wenn ich meine SIS-Grafik mit hoher Auflösung überlaste, wackelt/flimmert der Bildschirminhalt.

... Jede Mint-Version passt sich dem Zeitgeist etwas mehr an und schneidet dafür am hinteren Ende die "alten Zöpfe" ab ...
Bei meinem Mint13Xfce läuft SIS-Grafik sauber mit (vorinstallierten) freien Treiber:
maya@K7S41GX ~ $ lspci -nnk | grep -i VGA -A2
01:00.0 VGA compatible controller [0300]: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter [1039:6330]
Subsystem: ASRock Incorporation Device [1849:6331]
Kernel modules: sisfb
maya@K7S41GX ~ $ inxi -b
System:    Host: K7S41GX Kernel: 3.13.0-109-generic i686 (32 bit) Desktop: Xfce 4.10.0 Distro: Linux Mint 13 Maya
Machine:   System: American Megatrends product: K7S41GX version: 1.0
           Mobo: N/A model: K7S41GX version: 1.0 Bios: American Megatrends version: P2.00 date: 10/28/2004
CPU:       Single core AMD Sempron 2500+ (-UP-) clocked at 1799.897 MHz
Graphics:  Card: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
           X.Org: 1.11.3 drivers: sis (unloaded: fbdev,vesa) Resolution: 1280x720@60.0hz
           GLX Renderer: Gallium 0.4 on softpipe GLX Version: 2.1 Mesa 8.0.4
...

Es scheint so, dass die KDE Apps (namentlich Krusader und Gwenview) für den Wechsel auf den anderen Desktop und die falsche Auflösung zuständig waren ... habe ich jetzt zumindest mal echte 1280*800 und nutze statt Krusader Double Commander ...
Und warum nicht den vorinstallierten Thunar von Xfce?
« Letzte Änderung: 14.02.2017, 02:26:52 von thebookkeeper »

Re: SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch
« Antwort #23 am: 14.02.2017, 11:18:56 »
Mit dieser RAM "Größe" braucht es einen leichten Desktop UND leichte Anwendungen! Also nix KDE-Programme, nix Firefox, nix LibreOffice...

Also ganz so schlimm ist es bei meiner Kiste nich. Mint 13 lief mit Krusader, LibreOffice, Firefox. Klar, Firefox braucht etwas, gerade bei youtube war es grenzwertig aber es ging. Abgesehen von der falschen Auflösung, die ich auch bei Mint 13 hatte, ging auch Standby und das Design blieb so, wie ich es eingestellt hatte.
Kann es sein, dass der nicht funktionierende Standby mit 64 Bit zusammenhängt? Denn das Mint 13 hatte ich (bzw. habe ich auf dem anderen Laptop) als 32 Bit Version installiert.

Danke für deine Antwort thebookkeeper!


Bei meinem Mint13Xfce läuft SIS-Grafik sauber mit (vorinstallierten) freien Treiber:

Hast du denn 1280*800?


Es scheint so, dass die KDE Apps (namentlich Krusader und Gwenview) für den Wechsel auf den anderen Desktop und die falsche Auflösung zuständig waren ... habe ich jetzt zumindest mal echte 1280*800 und nutze statt Krusader Double Commander ...
Und warum nicht den vorinstallierten Thunar von Xfce?

Habe jetzt den Double Commander genommen. Ich arbeite gerne mit zwei Fenstern, komme ich schneller voran.
« Letzte Änderung: 14.02.2017, 11:25:19 von neolovich »

Re: SIS 671/771 und Linux Mint 18.1 XFCE Auflösung falsch
« Antwort #24 am: 16.02.2017, 11:26:29 »
Ich habe nun die LMDE Betsy laufen.
Mit der Anleitung aus folgendem Thread: http://forums.debian.net/viewtopic.php?f=6&t=120734&sid=e9c4b57792178b512714851b9c983727
1280*800 läuft, Standby läuft besser als mit dem Workaround aus meinem ersten Post, den ich auch auf Mint 13 verwende.
Also wenn jetzt keine Überraschung mehr kommt, ist es wohl gelöst.
Einzig die Icons im Notify Bereich sind noch fehlerhaft aber da finde ich sicher auch noch ne Lösung.
Als Anmerkung sei vielleicht noch erwähnt, dass nach der Installation und dann während dem ersten Updateprozess das Mate-Panel zwischenzeitlich verschwand. Habe erst rund 40 Updates installiert und dann neu gestartet. Das Panel war weg und es gab erneut Updates, die ich aber a) nicht sehen konnte, da das Panel und damit die Anzeige der Aktualisierungsverwaltung fehlte und b) im Terminal zurückgehalten wurden. Erfahrenere User wissen sicherlich wie man das im Terminal löst, ich habe es nur über die Aktualisierungsverwaltung lösen können, indem ich kurz das gnome-panel installiert habe und von da die Aktualisierungsverwaltung gestartet habe und alle Updates installiert habe.

Edit: Noch gibt es einen Grafikfehler bei LibreOffice aber das finde ich sicherlich auch noch.
« Letzte Änderung: 16.02.2017, 11:44:44 von neolovich »

Ich sagte ja, dass du mit dem System immer deine Zipperlein haben wirst. ;)

Wenn man Folgendes in die xorg.conf packt, funtkionieren die Benachrichtigungen und LibreOffice vernünftig. Ist ebenfalls aus dem Thread des Debian Forums, das ich oben verlinkt habe.

    Section "ServerLayout"
       Identifier     "X.org Configured"
       Screen      0  "Screen0" 0 0
       InputDevice    "Mouse0" "CorePointer"
       InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
       ModulePath   "/usr/lib/xorg/modules"
       FontPath     "/usr/share/fonts/X11/misc"
       FontPath     "/usr/share/fonts/X11/cyrillic"
       FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
       FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
       FontPath     "/usr/share/fonts/X11/Type1"
       FontPath     "/usr/share/fonts/X11/100dpi"
       FontPath     "/usr/share/fonts/X11/75dpi"
       FontPath     "built-ins"
    EndSection

    Section "Module"
           Load "dri"
           Load "v4l"
           Load "extmod"
           Load "type1"
           Load "freetype"
           Load "glx"
           Load "GLcore"
           Load "i2c"
           Load "bitmap"
           Load "ddc"
           Load "int10"
           Load "vbe"
           Load "speedo"
           Load "record"
           Load "dri2"
    EndSection

    Section "InputDevice"
       Identifier  "Keyboard0"
       Driver      "kbd"
    EndSection

    Section "InputDevice"
       Identifier  "Mouse0"
       Driver      "mouse"
       Option       "Protocol" "auto"
       Option       "Device" "/dev/input/mice"
       Option       "ZAxisMapping" "4 5 6 7"
    EndSection

    Section "Monitor"
         Identifier  "Monitor0"
         Vendorname  "Generic LCD Display"
         Modelname   "LCD Panel 1280x800"
         Horizsync   31.5 - 50.0
         Vertrefresh 56.0 - 65.0
         modeline    "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
         modeline    "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
         modeline    "1024x768@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
         modeline    "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
         Gamma       1.0
    EndSection

    Section "Server Flags"
           Option "IgnoreABI"
    EndSection

    Section "Device"
        Identifier  "Card0"
        VendorName  "Silicon Integrated Systems [SiS]"
        BoardName   "771/671 PCIE VGA Display Adapter"
        Busid     "PCI:1:0:0"
        Driver    "sisimedia"
        Screen 0
       Option   "DPMS"
            Option   "ShadowFB"
            Option   "MaxXFBMem"
       Option   "AccelMethod"        "XAA"
            VideoRam            262016
       Option   "PreferredMode"         "1280x800"
       Option   "EnableSiSCtrl"         "true"
       Option   "UseFBDev"         "true"
       Option   "DRI"           "true"
       Option   "TurboQueue"             "true"
       Option   "FastVram"               "true"
       Option   "UseSSE"                "true"
       Option   "UseTiming1280"         "true"
       Option   "RenderAccel"           "true"
       Option   "XAANoOffscreenPixmaps" "true"
       Option   "AllowGLXWithComposite" "true"
       Option   "AddARGBGLXVisuals"     "true"
       Option   "backingstore"          "true"
    EndSection

    Section "Screen"
           Identifier    "Screen0"
           Monitor       "Card0"
           Device        "Monitor0"
           Defaultdepth  24
           SubSection "Display"
           Viewport  0 0
                Depth     1
           Virtual   1280 800
                Modes     "1280x800@60"    "1024x768@60"    "800x600@60"    "640x480@60"
           EndSubSection
           SubSection "Display"
           Viewport  0 0
                Depth     4
           Virtual   1280 800
                Modes     "1280x800@60"    "1024x768@60"    "800x600@60"    "640x480@60"
           EndSubSection
           SubSection "Display"
           Viewport  0 0
                Depth     8
           Virtual   1280 800
                Modes     "1280x800@60"    "1024x768@60"    "800x600@60"    "640x480@60"
           EndSubSection
           SubSection "Display"
           Viewport  0 0
                Depth     15
           Virtual   1280 800
                Modes     "1280x800@60"    "1024x768@60"    "800x600@60"    "640x480@60"
           EndSubSection
           SubSection "Display"
           Viewport  0 0
                Depth     16
           Virtual   1280 800
            Modes     "1280x800@60"    "1024x768@60"    "800x600@60"    "640x480@60"
           EndSubSection
           SubSection "Display"
           Viewport  0 0
                Depth     24
           Virtual   1280 800
            Modes     "1280x800@60"    "1024x768@60"    "800x600@60"    "640x480@60"
           EndSubSection
    EndSection

    Section "DRI"
         Mode         0666
    EndSection

« Letzte Änderung: 17.02.2017, 23:09:39 von neolovich »