Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.10.2018, 09:17:45

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 20929
  • Letzte: bernd-52
Statistiken
  • Beiträge insgesamt: 552985
  • Themen insgesamt: 44616
  • Heute online: 467
  • Am meisten online: 680
  • (27.03.2018, 20:17:41)
Benutzer Online

Autor Thema: [erledigt] SoundJuicer und Paranoia/Lesegeschwindigkeit  (Gelesen 469 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] SoundJuicer und Paranoia/Lesegeschwindigkeit
« am: 02.02.2017, 15:04:17 »
Hi Ihr,

ich hab Linuxmint Cinnamon 18.1 64 bit.

SoundJuicer liest CDs extrem langsam aus, weil es den Paranoia-Modus verwendet. Der ließ sich früher über gconf abschalten, jetzt benutzt SoundJuicer dconf.

Die Ausgabe für die Eigenschaft ist:

> gsettings get org.gnome.sound-juicer paranoia
['fragment', 'overlap', 'scratch']

Laut früheren Anleitungen soll man den Wert auf 0 stellen oder in der neueren Version auf "disable". Nichts davon funktioniert bei mir, egal, wie ich "disable" angeben,, mit Anführungszeichen, als Array, ...:

> gsettings set org.gnome.sound-juicer paranoia 0
can not parse as value of type 'as':
  0
  ^
> gsettings set org.gnome.sound-juicer paranoia disable
unknown keyword:
  disable
  ^^^^^^^

Ich hab auch schon versucht, über ein Schema-Override zu arbeiten, auch da wird der Wert "disable" nicht erkannt:

> sudo glib-compile-schemas /usr/share/glib-2.0/schemas/
override for key 'paranoia' in schema 'org.gnome.sound-juicer' in override file '/usr/share/glib-2.0/schemas/99_org.gnome.sound-juicer.gschema.override' is not in the list of valid choices; ignoring override for this key.

Der Key müsste aber eigentlich stimmen, Auszug aus "org.gnome.sound-juicer.gschema.xml"

<key name="paranoia" flags="org.gnome.sound-juicer.paranoia">
<default>["fragment","overlap","scratch"]</default>
<summary>The paranoia mode to use</summary>
<description>Paranoia flags: disable; fragment; overlap; scratch; repair.</description>
</key>

Habt Ihr eine Idee, wie ich das ausschalten kann? Oder eine Empfehlung für einen anderen Ripper, der schneller ist? Kratzer etc. sind mir egal, Geschwindigkeit nicht.

Danke,

Gruß, Ekkart.
« Letzte Änderung: 02.02.2017, 16:39:23 von ekleinod »

Re: SoundJuicer und Paranoia/Lesegeschwindigkeit
« Antwort #1 am: 02.02.2017, 15:09:14 »
Hi :)
rippe doch mal mit rhythmbox .. on board


Re: SoundJuicer und Paranoia/Lesegeschwindigkeit
« Antwort #3 am: 02.02.2017, 16:39:04 »
Asunder sieht gut aus, danke für den Tip.

Dann gebe ich die Konfiguration von SoundJuicer auf und wende mich Asunder zu.

Re: SoundJuicer und Paranoia/Lesegeschwindigkeit
« Antwort #4 am: 02.02.2017, 17:01:52 »
Ripper X ist auch gut zu Rippen.

Re: SoundJuicer und Paranoia/Lesegeschwindigkeit
« Antwort #5 am: 15.04.2018, 10:04:46 »
Ich bin auch ein Freund von sound-juicer und habe noch ein wenig mit gsettings experimentiert. Die richtige Syntax, um den Wert vom Typ as ("array of strings") zu verändern lautet (zum Beispiel um die Standardwerte einzustellen):
$ gsettings set org.gnome.sound-juicer paranoia "['fragment','scratch','repair']"
Die Anzeige aller möglichen Werte zeigt, dass "disable" kein zulässiger String ist:
$ gsettings range org.gnome.sound-juicer paranoia
flags
'fragment'
'overlap'
'scratch'
'repair'
Es gibt aber die Möglichkeit 'disable', wie die Beschreibung zeigt:
$ gsettings describe org.gnome.sound-juicer paranoia
Paranoia-Modus: disable(deaktivieren); fragment(Fragment); overlap(überlappen); scratch(Kratzer); repair(reparieren)
Also müssen zum Abschalten offenbar alle flags ausgeschaltet werden:
$ gsettings set org.gnome.sound-juicer paranoia "[]"
Einen großen Geschwindigkeitsgewinn habe ich zwar damit auch nicht, aber immerhin kann ich nun einige CDs auslesen, die mit der Standardeinstellung unmöglich waren.