Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.02.2020, 00:41:21

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 23513
  • Letzte: stefan555
Statistiken
  • Beiträge insgesamt: 642954
  • Themen insgesamt: 52096
  • Heute online: 465
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 5
Gäste: 434
Gesamt: 439

Autor Thema: [erledigt] [Workaround] python-IDE eric wird nicht installiert (Abh. vo python3-pyqt5.qsci)  (Gelesen 2343 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo zusammen,

Habe das Problem auch auf https://forums.linuxmint.com gepostet - https://forums.linuxmint.com/viewtopic.php?f=47&t=237405

auf meinem Mint-18-KDE 64bit hat sich 'eric' DEinstalliert und lässt sich nicht mehr installieren:
# apt install eric
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 eric : Hängt ab von: python3-pyqt5.qsci soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

wie kann ich denn den Paketbetreuer informieren? ... oder gibt's eine andere Lösung?
« Letzte Änderung: 04.03.2017, 16:22:48 von gogo »

Z-App

  • Gast
Zitat
…Sie haben zurückgehaltene defekte Pakete. …
Das gilt es als erstes zu reparieren über Synaptic-Paketverwaltung
https://wiki.ubuntuusers.de/Synaptic/#Defekte-Pakete-reparieren.

Dann in der Konsole
apt-cache policy ericapt-cache policy python3-pyqt5.qsci

sry ich hatte nicht geschrieben, dass ich das schon erledigt habe (Bilder angehängt).

pc051 ~ # apt install -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
pc051 ~ # apt-cache policy eric
eric:
  Installiert:           (keine)
  Installationskandidat: 6.0.8-1
  Versionstabelle:
     6.0.8-1 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu xenial/universe i386 Packages
pc051 ~ # apt-cache policy python3-pyqt5.qsci
python3-pyqt5.qsci:
  Installiert:           (keine)
  Installationskandidat: 2.9.1+dfsg-4build1
  Versionstabelle:
     2.9.1+dfsg-4build1 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
pc051 ~ # apt install eric
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 eric : Hängt ab von: python3-pyqt5.qsci soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
pc051 ~ # apt install -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Bild1: Abhängigkeiten für die Installation von eric
Bild2: Fehler beim Installieren
Bild3: Fehler beim Beheben der defekten Pakete
ein "apt install -f" nachher gibt keinen Fehler...

Installation auf einem Ubuntu 16.4 LTS - kein Problem
Die Pakete sind aus demselben Repo wie die unter Linux Mint
apt-cache policy eric
eric:
  Installiert:           6.0.8-1
  Installationskandidat: 6.0.8-1
  Versionstabelle:
 *** 6.0.8-1 500
        500 http://at.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://at.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
        100 /var/lib/dpkg/status


apt-cache policy python3-pyqt5.qsci
python3-pyqt5.qsci:
  Installiert:           2.9.1+dfsg-4build1
  Installationskandidat: 2.9.1+dfsg-4build1
  Versionstabelle:
 *** 2.9.1+dfsg-4build1 500
        500 http://at.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status


apt-cache policy libqt5scintilla2-12v5
libqt5scintilla2-12v5:
  Installiert:           2.9.1+dfsg-4build1
  Installationskandidat: 2.9.1+dfsg-4build1
  Versionstabelle:
 *** 2.9.1+dfsg-4build1 500
        500 http://at.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

Z-App

  • Gast
Musste erst mal nachschauen, ob es so was gibt (kannte bislang nur why):
aptitude why-not python3-pyqt5.qsci

hm:
python3-pyqt5.qsci bringt "nix", da:
apt install python3-pyqt5.qsci
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-pyqt5.qsci : Depends: libqt5scintilla2-12v5 (>= 2.9) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

pc051 ~ # apt-cache policy libqt5scintilla2-12v5
libqt5scintilla2-12v5:
  Installed: (none)
  Candidate: 2.9.1+dfsg-4build1
  Version table:
     2.9.1+dfsg-4build1 500
        500 http://gd.tuwien.ac.at/opsys/linux/ubuntu/archive xenial/universe amd64 Packages

# aptitude why-not python3-pyqt5.qsci
Es kann kein Grund für die Entfernung von python3-pyqt5.qsci gefunden werden.

# aptitude why-not libqt5scintilla2-12v5
i   libqt5core5a Beschädigt libqt5scintilla2-12v5 (< 2.9.2+dfsg-2~)

letztendlich:
apt install  libqt5scintilla2-12v5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libqt5scintilla2-12v5 : Depends: libqt5core5a (>= 5.4.0) but it is not going to be installed
                         Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
                                  libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
                         Depends: libqt5printsupport5 (>= 5.0.2) but it is not going to be installed
                         Depends: libqt5widgets5 (>= 5.2.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

und vielleicht interessant auf meinem deutschen und meinem englischen System liefert "aptitude why libqt5core5a" unterschiedliche Antworten:
aptitude why libqt5core5a
i   qtbase5-dev Hängt ab von libqt5core5a (= 5.6.1+dfsg-3ubuntu7~~xenialoverlay1~2)

pc051 ~ $ aptitude why libqt5core5a
i plasma-integration Depends libqt5core5a (>= 5.6.0~beta)
... anyway - eric kann man auf beiden Systemen nicht installieren ... hab' einen Bug geschrieben
« Letzte Änderung: 16.01.2017, 08:23:53 von gogo »

Bug gilt auch für LM 18.01 KDE

Kann hier keiner helfen? Mittlerweile bin ich mit meinem Produktivsystem auf KDE-Neon umgezogen - aber das ist ja auch keine Lösung ...

Es gibt einen Workaround:
https://bugs.launchpad.net/linuxmint/+bug/1656433/comments/5

Man muss die Version 2.9.3 von libqt5scintilla2-12v5 und libqt5scintilla2-l10n manuell installieren (https://www.ubuntuupdates.org/package/core/yakkety/universe/base/libqt5scintilla2-l10n und https://www.ubuntuupdates.org/package/core/yakkety/universe/base/libqt5scintilla2-12v5 ), dann sind die Paketkonflikte gelöst.

Auch die Installation der neueren Versionen von 'eric' ist dann möglich. Um den QT-Designer nutzen zu können muss noch das Paket "qttools5-dev-tools" (aus den Quellen) nachinstalliert werden.
thx an GHPS ... der aufgrund eines Problems mit OpenSCAD diese Lösung erarbeitet hat.