Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.11.2019, 05:23:28

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 618674
  • Themen insgesamt: 49930
  • Heute online: 423
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 3
Gäste: 297
Gesamt: 300

Autor Thema:  Kamera-Bild wird in Skype nicht angezeigt [Mint 18, Cinnamon]  (Gelesen 1054 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo,

als Linux-Neuling habe ich Mint 18 mit Cinnamon installiert.

Mit Cheese sehe ich einwandfrei das von einer USB-Kamera aufgenommene bewegte Bild.
Skype bietet unter Optionen>Video die Webcam 'USB Camera (093a:2620) (/dev/video0)' an. Allerdings bleibt das Bild rechts daneben schwarz.

Hat jemand eine Idee, was ich besser machen kann?

thebookkeeper

  • aka AnanasDampf
  • *****
Re: Kamera-Bild wird in Skype nicht angezeigt [Mint 18, Cinnamon]
« Antwort #1 am: 09.10.2016, 23:16:04 »
Zitat
Webcam gibt nur in skype kein Bild aus

Skype gibt beim Video-Aufruf (bzw. im Testbild) nur ein schwarzes Bild aus, die Kamera funktioniert aber mit einer anderen Applikation wie Cheese, camorama o.ä.

Lösung:
https://wiki.ubuntuusers.de/Skype/#Loesung-Laden-der-Bibliothek-v4l1compat-so
Zitat
"... Laden der Bibliothek v4l1compat.so

Skype nutzt die erste Version der Video-Schnittstelle für Linux (V4L), die systemweit durch eine erweiterte Version (Version 2, V4L2) ersetzt wurde. Skype kann allerdings mit einer Bibliothek betrieben werden, die es zur aktuellen Video-Schnittstellen kompatibel macht. Diese Bibliothek ist enthalten im folgenden Paket und muss ggf. installiert werden:

    libv4l-0 ..."
« Letzte Änderung: 09.10.2016, 23:23:25 von thebookkeeper »

Re: Kamera-Bild wird in Skype nicht angezeigt [Mint 18, Cinnamon]
« Antwort #2 am: 10.10.2016, 19:31:18 »
Beim Ausführen von
LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype

werden folgende Kommentare angezeigt:
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
Gtk-Message: Failed to load module "atk-bridge"

Skype startet und es wird weiterhin kein Kamerabild angezeigt.

In dem Verzeichnis /usr/lib/x86_64-linux-gnu/libv4l/
befinden sich folgende Dateien:

drwxr-xr-x   3 root root   4096 Jun 28 14:13 .
drwxr-xr-x 114 root root 106496 Okt  9 17:20 ..
drwxr-xr-x   2 root root   4096 Jun 28 14:13 plugins
-rw-r--r--   1 root root   6136 Jan 25  2016 v4l1compat.so
-rw-r--r--   1 root root  10312 Jan 25  2016 v4l2convert.so

Vielleicht muss ich die Rechte für v4l1compat.so umstellen? Was muss ich tun bzw. prüfen?
« Letzte Änderung: 10.10.2016, 20:13:00 von jara01 »

Re: Kamera-Bild wird in Skype nicht angezeigt [Mint 18, Cinnamon]
« Antwort #3 am: 11.10.2016, 02:57:49 »
@jara01

Vielleicht muss ich die Rechte für v4l1compat.so umstellen? Was muss ich tun bzw. prüfen?
Nicht zwingend.
In dem betreffenden, von thebookkeeper verlinkten, Abschnitt gibt es ja auch noch einen Hinweis der auf die genannte Fehlermeldung verweist.
Zitat
...
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot ...
In diesem Falle muss die i386-Version von libv4l-0 nachinstalliert werden, der Pfad muss danach auf die 32-bit-Bibliothek weisen:
...
Prüfe das bitte vor weiteren Schritten mit
ll /usr/lib/i386-linux-gnu/libv4l/v4l1compat.sound hole ggf. die Installation des noch fehlenden Paketes wie beschrieben nach.

Re: Kamera-Bild wird in Skype nicht angezeigt [Mint 18, Cinnamon]
« Antwort #4 am: 11.10.2016, 17:54:44 »
Das war der entscheidende Tipp, Danke!!!

Wenn ich also Skype starte mit
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype
sehe ich unter Skype>Optionen>Video zum ersten Mal die Video-Bilder der Kamera.

Ich habe mir ein Scipt erstellt, in dem dieser Befehl ausgeführt wird, und kann dieses Script dann über einen Starter auf dem Desktop aufrufen oder über einen Eintrag im Startmenü>Sonstige.

Beim Start im Terminal gibt es allerdings die Meldung

Gtk-Message: Failed to load module "atk-bridge"

Welche Bedeutung hat das? Muss ich mglw. noch etwas installieren?
« Letzte Änderung: 13.10.2016, 20:39:42 von jara01 »