Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.07.2019, 05:03:49

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22259
  • Letzte: charblu
Statistiken
  • Beiträge insgesamt: 599043
  • Themen insgesamt: 48517
  • Heute online: 459
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 7
Gäste: 329
Gesamt: 336

Autor Thema:  [sdb] No Caching mode page found  (Gelesen 5407 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[sdb] No Caching mode page found
« am: 21.09.2016, 19:41:30 »
Hallo
ich nutze auf meinem Latop die Win 8.1 Version und boote über eine externe Festplatte mein LM 18. Der Mint Bootloader ist auf der sda.

Kurz nach dem Bootloader erscheint seit gestern folgende Meldung:
[  1.924208] nouveau 0000:01:00.0: priv: HUB0: 10ecc0  ffffffff (1840822c)
[  3.682687] sd 3:0:0:0: [sdb] No Caching mode page found
[  3.682718] sd 3:0:0:0: [sdb] Assumin drive cache: write through




Gerstern lief der Rechner problemlos. Habe auch schon verucht mit älterem Kernel zu booten .

Hat jemand einen Rat ?

Vielen Dank
« Letzte Änderung: 21.09.2016, 21:39:01 von Luette »

Re: [sdb] No Caching mode page found
« Antwort #1 am: 21.09.2016, 20:39:45 »

Re: [sdb] No Caching mode page found
« Antwort #2 am: 21.09.2016, 21:18:45 »
@Luette

Beschreibe bitte dein Problem etwas ausführlicher.
Die gelisteten Zeilen sind keine Fehlermeldung sondern eher Informationen zur Hardwareerkennung.
Im Normalfall (alles i.O.) sehen diese Abschnitte z.B so aus

DVD-Laufwerk
[XX XXX XX XX:XX:XX XXXX] sd 2:0:0:0: Attached scsi generic sg0 type 0
[XX XXX XX XX:XX:XX XXXX] sd 2:0:0:0: [sdy] 3915778 512-byte logical blocks: (2.00 GB/1.79 GiB)
[XX XXX XX XX:XX:XX XXXX] sd 2:0:0:0: [sdy] Write Protect is off
[XX XXX XX XX:XX:XX XXXX] sd 2:0:0:0: [sdy] Mode Sense: 43 00 00 00
[XX XXX XX XX:XX:XX XXXX] sd 2:0:0:0: [sdy] No Caching mode page found
[XX XXX XX XX:XX:XX XXXX] sd 2:0:0:0: [sdy] Assuming drive cache: write through
[XX XXX XX XX:XX:XX XXXX] scsi 3:0:0:0: CD-ROM            XXXXXX CDDVDW XX-XXXXX  XX00 PQ: 0 ANSI: 0
[XX XXX XX XX:XX:XX XXXX]  sdy: sdy1
[XX XXX XX XX:XX:XX XXXX] sd 2:0:0:0: [sdy] Attached SCSI removable disk

USB-Stick
[XX XXX XX XX:XX:XX XXXX] sd 6:0:0:0: [sdx] 15659008 512-byte logical blocks: (8.03 GB/7.52 GiB)
[XX XXX XX XX:XX:XX XXXX] sd 6:0:0:0: [sdx] Write Protect is off
[XX XXX XX XX:XX:XX XXXX] sd 6:0:0:0: [sdx] Mode Sense: 03 00 00 00
[XX XXX XX XX:XX:XX XXXX] sd 6:0:0:0: [sdx] No Caching mode page found
[XX XXX XX XX:XX:XX XXXX] sd 6:0:0:0: [sdx] Assuming drive cache: write through
[XX XXX XX XX:XX:XX XXXX]  sdx: sdx1 sdx2 < sdx5 >
[XX XXX XX XX:XX:XX XXXX] sd 6:0:0:0: [sdx] Attached SCSI removable disk

Willst du den Bootprozeß etwas intensiver beobachten ändere die Zeile mit den Bootparametern und entferne "splash quiet".
Diese Änderung bewirkt nur eine temporäre Änderung für diesen Start. Es erfolgt keine dauerhafte Speicherung.
Mglw. erfährst du so etwas merh über dein Problem.

Re: [sdb] No Caching mode page found
« Antwort #3 am: 21.09.2016, 21:54:02 »
ich wähle über Grub den Eintrag "Linux Mint...."

- es erscheinen kurz die drei o.g. Zeilen
- dann kurz das LM Symbol
- bis dann der Bildschirm schwarz bleibt

die ersten Zeilen erscheinen, mit folgenden weitern Infos

BusyBox v1.22.1 (Ubuntu 1:1.22.0-15ubuntu1) built-in shell (ash)
Enter `help`for a list of built-in commands

(initramfs)__
am Ende ein blinkender Cursor und ein schwarzer Bildschirm.
nach dem Befehl exit, kommt folgende Meldung
/dev/sdb2 contains a file system with errors, check forced
Inodes that were part of a corrupted orphan linked list found

/dev/sdb2 : UNEXPECTED INCONSISTENCY; Run fsck MANUALLY
            (i.e., without -a or -p options)
fsck exited with status code 4
The root filesystem on /dev/sdb2 requires a manual fsck

Hat die Platte einen Schaden ?
Gruß
« Letzte Änderung: 21.09.2016, 22:04:14 von Luette »

Re: [sdb] No Caching mode page found
« Antwort #4 am: 21.09.2016, 22:19:48 »
@Luette

Die Busybox ist nicht Mint.
Zitat
Willst du den Bootprozeß etwas intensiver beobachten ändere die Zeile mit den Bootparametern und entferne "splash quiet".
Habe auf die Schnelle ein Beispiel gesucht wo etwas ausführlicher erklärt wird wie du dort hinkommst. Gefunden habe ich nur dies.
http://www.if-not-true-then-false.com/2012/howto-change-runlevel-on-grub2/?PageSpeed=noscript
Bei dir muß aber kein Runlevel geändert werden. Die Beschreibung zeigt dir jedoch den Weg den du nehmen mußt um an die zu ändernden Parameter heranzukommen.

Ein Dateisystemcheck kann bei der Fehlermeldung auch nicht schaden.
Mach ihn direkt vom LiveSystem aus oder erstelle mit
sudo touch /fsckeinen Trigger der das beim nächsten Start automatisch erledigt.
Muß kein Plattendefekt sein, eher ein inkonsistentes Dateisystem. Das kann bereits passieren wenn das System nicht sauber heruntergefahren wurde.

Re: [sdb] No Caching mode page found
« Antwort #5 am: 21.09.2016, 22:28:32 »
Unabhängig von der Frage nach dem Dateisystem ("The root filesystem on /dev/sdb2 requires a manual fsck"), Busybox ist so ziemlich das letzte Loch auf dem der Grub pfeift.
Damit lässt sich fast nichts anfangen.
Ursche ist meistens, daß er kein Betriebssystem findet.
… und boote über eine externe Festplatte mein LM 18. Der Mint Bootloader ist auf der sda.
Wenn /dev/sda die interne Platte und LM auf der externen Platte installiert ist - keine besonders glückliche Idee. Meiner Meinung nach gehört Grub in so einem Fall in den MBR der externen Festplatte und der Rechner muss so eingestellt sein, daß er von einer externen USB-Festplatte bootet (Auswahl der Bootmedien, Präferenzen).

Ich würde mal die SuperGrub2Disk probieren, bei angeschlossener externer Platte.
Oder mit einem LM-18 Live-System starten.

Edit:  http://wiki.ubuntuusers.de/GRUB_2/Reparatur
« Letzte Änderung: 21.09.2016, 22:59:15 von aexe »

Re: [sdb] No Caching mode page found
« Antwort #6 am: 22.09.2016, 13:27:00 »
Hi :)
für mich sehen die sdb meldungen eher nach deaktiviertem cache der externen platte aus.. und das wird gemeldet.
mehr nicht.
ggf. mal in laufwerke nach den cache einstellungen der sdb schauen.

Re: [sdb] No Caching mode page found
« Antwort #7 am: 22.09.2016, 14:59:48 »
Diese Meldung:
[  3.682687] sd 3:0:0:0: [sdb] No Caching mode page found
[  3.682718] sd 3:0:0:0: [sdb] Assumin drive cache: write through
kenne ich von diversen externen Festplatten, aber das hat noch nie ein System am starten gehindert.
Manche Controller unterstützen das catching einfach nicht.

Re: [sdb] No Caching mode page found
« Antwort #8 am: 22.09.2016, 16:25:27 »
am Ende ein blinkender Cursor und ein schwarzer Bildschirm.
Das ist aber nicht schön.
Auch wenn es vermutlich eine andere Ursache hat.
Wäre sicher sinnvoll, mal abzuwarten, was der TE inzwischen erreicht hat und was der aktuelle Stand ist - wenn er sich denn überhaupt noch mal dazu meldet.
« Letzte Änderung: 22.09.2016, 16:28:42 von aexe »

Re: [sdb] No Caching mode page found
« Antwort #9 am: 22.09.2016, 16:33:53 »
Ist das System auf der Externen verschlüsselt ?

Re: [sdb] No Caching mode page found
« Antwort #10 am: 22.09.2016, 19:08:26 »

Muß kein Plattendefekt sein, eher ein inkonsistentes Dateisystem. Das kann bereits passieren wenn das System nicht sauber heruntergefahren wurde.

Das ist leider passiert.

@ DocHifi:  Nein Platte ist nicht verschlüsselt

Sichere mir erstmal \home und versuche am WE mal weiter. Bin ab morgen für eine Woche im Ausland ohne I-Net , Bislang schonmal herzlichen Dank für Eure Bemühungen.

Live CD läuft über externen DVD Brenner

Re: [sdb] No Caching mode page found
« Antwort #11 am: 23.09.2016, 13:49:24 »
Hi :)
ich würde erst mal von der live aus
fsck -y /dev/sdxX
versuchen.
xX an platte / partition anpassen.