Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
29.11.2020, 06:04:22

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24832
  • Letzte: Kowa
Statistiken
  • Beiträge insgesamt: 697315
  • Themen insgesamt: 56434
  • Heute online: 508
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 2
Gäste: 336
Gesamt: 338

Autor Thema:  Darf ich dieses java-file installieren?  (Gelesen 1666 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Darf ich dieses java-file installieren?
« am: 20.09.2016, 08:43:33 »
Hallo,
das System zeigt hier eine Warnung an, ob ich mir sicher sei, dieses update installieren zu wollen. s.h. Anhang
Kann ich dies bedenkenlos installieren?

Danke
Andy

Re: Darf ich dieses java-file installieren?
« Antwort #1 am: 20.09.2016, 09:40:50 »
Ist nur eine Warnung, dass das nicht aus den offiziellen Quellen stammt. Die Quelle konnte zudem nicht per Zertifikat sicher identifiziert werden. In der Regel kannst du das aber ignorieren.

Z-App

  • Gast
Re: Darf ich dieses java-file installieren?
« Antwort #2 am: 20.09.2016, 09:41:48 »
Was sagt das Terminal zu
apt-cache policy libservlet3.0-java

Re: Darf ich dieses java-file installieren?
« Antwort #3 am: 20.09.2016, 10:49:12 »
Was sagt das Terminal zu
apt-cache policy libservlet3.0-java

Zum Vergleich hier LM 18
apt-cache policy libservlet3.0-java
libservlet3.0-java:
  Installiert:           (keine)
  Installationskandidat: 7.0.68-1ubuntu0.1
  Versionstabelle:
     7.0.68-1ubuntu0.1 500
        500 http://ftp.uni-mainz.de/ubuntu xenial-updates/universe amd64 Packages
        500 http://ftp.uni-mainz.de/ubuntu xenial-updates/universe i386 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages
     7.0.68-1 500
        500 http://ftp.uni-mainz.de/ubuntu xenial/universe amd64 Packages
        500 http://ftp.uni-mainz.de/ubuntu xenial/universe i386 Packages
Bei mir nicht installiert und wurde mir heute auch nicht beim Dist-Upgrade angeboten.

Re: Darf ich dieses java-file installieren?
« Antwort #4 am: 20.09.2016, 13:53:21 »
Bei mir scheint da bereits eine Vorgängerversion vorhanden zu sein. Das heisst wohl, ich kann das update installieren

apt-cache policy libservlet3.0-java
libservlet3.0-java:
  Installiert:           7.0.52-1ubuntu0.6
  Installationskandidat: 7.0.52-1ubuntu0.7
  Versionstabelle:
     7.0.52-1ubuntu0.7 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
 *** 7.0.52-1ubuntu0.6 0
        500 http://archive.ubuntu.csg.uzh.ch/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     7.0.52-1 0
        500 http://archive.ubuntu.csg.uzh.ch/ubuntu/ trusty/main amd64 Packages

Re: Darf ich dieses java-file installieren?
« Antwort #5 am: 20.09.2016, 14:29:45 »
Das Update wird ja angeboten, weil solch ein Paket bereits installiert ist.
Bei meinem LM-18 gibt es das auch nicht, ich erinnere mich aber, das kürzlich bei einem anderen System schon gesehen zu haben.
Genauer: gestern, libservlet3.1-java_8.0.32-1ubuntu1.2_all.deb
Vermutlich wurde das ursprüngliche Paket als Abhängigkeit für eine nachträglich installierte Software mitgezogen.

Möglicherweise hat diese Warnung mit den seit kurzem verschärften Sicherheitsvorkehrungen von Ubuntu zu tun. Manche Zertifikate und schwache Überprüfungsfunktionen / Schlüssel (zB sha1) werden nicht mehr akzeptiert, bzw angemeckert.
Könnte ja sein, daß das für dieses Paket libservlet3.0-java auch zutrifft.
Bedeutet aber nicht unbedingt, daß es sich um Malware handelt.
Ich würde halt einstweilen auf die Aktualisierung verzichten und abwarten, wie sich die Angelegenheit entwickelt.

Edit
apt-cache rdepends libservlet3.0-java libservlet3.0-java
Reverse Depends:
  libservlet3.0-java-doc
  libtomcat7-java
  libservlet3.0-java-doc
  pki-base
  libtomcat7-java
  libtomcat-maven-plugin-java
  libsolr-java
  eclipse-platform
  libjsf-api-java
  libjetty8-java
  libjetty8-extra-java
  libequinox-osgi-java
  libderby-java
  libcommons-el-java
« Letzte Änderung: 20.09.2016, 14:52:15 von aexe »

Re: Darf ich dieses java-file installieren?
« Antwort #6 am: 20.09.2016, 14:52:01 »
Zitat
Könnte ja sein, daß das für dieses Paket libservlet3.0-java auch zutrifft.
Unwahrscheinlich, da die Ubuntuquellen den neueren SHA Standard nutzen.

Re: Darf ich dieses java-file installieren?
« Antwort #7 am: 20.09.2016, 14:57:53 »
Hab noch mal nachgesehen, in meinem LM-18 Cinnamon gibt es das Paket libservlet3.1-java
(Servlet 3.1, JSP 2.3, EL 3.0 and WebSocket 1.0 Java API classes, installiert)
Wo das herkommt und warum es da ist, weiß ich nicht.
Zitat
Apache Tomcat implements the Java Servlet and the JavaServer Pages (JSP)
specifications from Oracle, and provides a "pure Java" HTTP web server
environment for Java code to run.

Dieses Paket enthält die Bibliothek für Java Servlet und JSP.
sagt Synaptic
« Letzte Änderung: 20.09.2016, 15:07:09 von aexe »

Z-App

  • Gast
Re: Darf ich dieses java-file installieren?
« Antwort #8 am: 20.09.2016, 15:24:31 »
Das Update soll vom Server security.ubuntu.com kommen. Also wenn man dem nicht mehr vertrauen kann, wem dann?

Was meldet denn das Terminal bei
sudo apt-get updateWenn das Zertifikat nicht akzeptiert wird, müsste dort zum Schluss eine Warnung stehen; Nur die wäre interessant.

Re: Darf ich dieses java-file installieren?
« Antwort #9 am: 20.09.2016, 15:26:10 »
Zitat
in meinem LM-18 Cinnamon gibt es das Paket libservlet3.1-java
Vielleicht braucht Cinnamon die für irgendwas.

Re: Darf ich dieses java-file installieren?
« Antwort #10 am: 20.09.2016, 15:30:41 »
Hi :)

libservlet3.1-java ist hier installiert lm18 cin. frische test inst in der virtuellen.. nix javamässiges nachinstalliert.



Re: Darf ich dieses java-file installieren?
« Antwort #11 am: 20.09.2016, 18:22:52 »
Das kommt vom Paket tomcat8:
Zitat
Apache Tomcat implements the Java Servlet and the JavaServer Pages (JSP) specifications from Oracle, and provides a "pure Java" HTTP web server environment for Java code to run.

This package contains the Java Servlet and JSP library.

Re: Darf ich dieses java-file installieren?
« Antwort #12 am: 20.09.2016, 19:40:32 »
Ist denn tomcat überhaupt installiert?
MW gehört das nicht zum Mint-Standard, weder tomcat7 noch tomcat8.
« Letzte Änderung: 20.09.2016, 19:47:37 von aexe »

Re: Darf ich dieses java-file installieren?
« Antwort #13 am: 20.09.2016, 21:36:39 »
Danke für alle bisherigen Hinweise.

Hier noch der Code:
sudo apt-get update
Ign http://archive.ubuntu.csg.uzh.ch trusty InRelease
Ign http://dl.google.com stable InRelease                                     
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates InRelease                 
Ign http://ftp-stud.hs-esslingen.de rosa InRelease                             
Ign http://download.opensuse.org  InRelease                                   
Ign http://archive.canonical.com trusty InRelease                             
OK   http://ppa.launchpad.net trusty InRelease                                 
OK   http://archive.ubuntu.csg.uzh.ch trusty Release.gpg                       
OK   http://dl.google.com stable Release.gpg                                   
OK   http://ftp-stud.hs-esslingen.de rosa Release.gpg                         
OK   http://download.opensuse.org  Release.gpg                                 
OK   http://archive.canonical.com trusty Release.gpg                           
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/main amd64 Packages       
Ign http://ppa.launchpad.net trusty InRelease                                 
OK   http://ftp-stud.hs-esslingen.de rosa Release                             
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/restricted amd64 Packages
OK   http://dl.google.com stable Release                                       
OK   http://download.opensuse.org  Release                                     
OK   http://archive.canonical.com trusty Release                               
Ign http://ppa.launchpad.net trusty InRelease                                 
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/universe amd64 Packages   
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/multiverse amd64 Packages
OK   http://download.opensuse.org  Packages                                   
OK   http://ppa.launchpad.net trusty InRelease                                 
OK   http://dl.google.com stable/main amd64 Packages                           
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/main i386 Packages       
OK   http://archive.canonical.com trusty/partner amd64 Packages               
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/restricted i386 Packages 
OK   http://ppa.launchpad.net trusty InRelease                                 
OK   http://archive.canonical.com trusty/partner i386 Packages                 
OK   http://security.ubuntu.com trusty-security InRelease                     
OK   http://ppa.launchpad.net trusty InRelease                                 
OK   http://nightly.apt.ring.cx ring InRelease                                 
OK   http://archive.canonical.com trusty/partner Translation-en               
Ign http://ppa.launchpad.net trusty InRelease                                 
Ign http://extra.linuxmint.com rosa InRelease                                 
OK   http://ppa.launchpad.net trusty/main Sources                             
OK   http://archive.getdeb.net trusty-getdeb InRelease                         
OK   http://ppa.launchpad.net trusty/main amd64 Packages                       
OK   http://security.ubuntu.com trusty-security/main amd64 Packages           
OK   http://ppa.launchpad.net trusty/main i386 Packages                       
OK   http://ftp-stud.hs-esslingen.de rosa/main amd64 Packages                 
OK   http://ppa.launchpad.net trusty/main Translation-en                       
OK   http://ftp-stud.hs-esslingen.de rosa/upstream amd64 Packages             
OK   http://ppa.launchpad.net trusty Release.gpg                               
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/universe i386 Packages   
OK   http://ftp-stud.hs-esslingen.de rosa/import amd64 Packages               
OK   http://extra.linuxmint.com rosa Release.gpg                               
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/multiverse i386 Packages 
OK   http://security.ubuntu.com trusty-security/restricted amd64 Packages     
OK   http://ftp-stud.hs-esslingen.de rosa/main i386 Packages                   
OK   http://ppa.launchpad.net trusty Release.gpg                               
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/main Translation-en       
OK   http://archive.getdeb.net trusty-getdeb/apps amd64 Packages               
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/multiverse Translation-en
OK   http://nightly.apt.ring.cx ring/main amd64 Packages                       
OK   http://ppa.launchpad.net trusty/main Sources                             
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/restricted Translation-en
OK   http://archive.ubuntu.csg.uzh.ch trusty-updates/universe Translation-en   
OK   http://ppa.launchpad.net trusty/main amd64 Packages                       
OK   http://archive.ubuntu.csg.uzh.ch trusty Release                           
OK   http://archive.ubuntu.csg.uzh.ch trusty/main amd64 Packages               
OK   http://ppa.launchpad.net trusty/main i386 Packages                       
OK   http://security.ubuntu.com trusty-security/universe amd64 Packages       
OK   http://archive.getdeb.net trusty-getdeb/apps i386 Packages               
OK   http://ppa.launchpad.net trusty/main Translation-en                       
OK   http://ppa.launchpad.net trusty/main Sources                             
OK   http://archive.ubuntu.csg.uzh.ch trusty/restricted amd64 Packages         
OK   http://archive.ubuntu.csg.uzh.ch trusty/universe amd64 Packages           
OK   http://archive.ubuntu.csg.uzh.ch trusty/multiverse amd64 Packages         
OK   http://security.ubuntu.com trusty-security/multiverse amd64 Packages     
OK   http://archive.ubuntu.csg.uzh.ch trusty/main i386 Packages               
OK   http://archive.ubuntu.csg.uzh.ch trusty/restricted i386 Packages         
OK   http://ftp-stud.hs-esslingen.de rosa/upstream i386 Packages               
OK   http://archive.ubuntu.csg.uzh.ch trusty/universe i386 Packages           
OK   http://nightly.apt.ring.cx ring/main i386 Packages                       
OK   http://ppa.launchpad.net trusty/main amd64 Packages                       
OK   http://archive.ubuntu.csg.uzh.ch trusty/multiverse i386 Packages         
OK   http://extra.linuxmint.com rosa Release                                   
OK   http://ftp-stud.hs-esslingen.de rosa/import i386 Packages                 
Ign http://dl.google.com stable/main Translation-de_DE                         
OK   http://ppa.launchpad.net trusty/main i386 Packages                       
OK   http://archive.ubuntu.csg.uzh.ch trusty/main Translation-de               
OK   http://security.ubuntu.com trusty-security/main i386 Packages             
Ign http://dl.google.com stable/main Translation-de                           
OK   http://archive.ubuntu.csg.uzh.ch trusty/main Translation-en               
OK   http://ppa.launchpad.net trusty/main Translation-en                       
Ign http://download.opensuse.org  Translation-de_DE                           
Ign http://dl.google.com stable/main Translation-en                           
OK   http://archive.ubuntu.csg.uzh.ch trusty/multiverse Translation-de         
OK   http://ppa.launchpad.net trusty/main Sources                             
OK   http://archive.ubuntu.csg.uzh.ch trusty/multiverse Translation-en         
Ign http://download.opensuse.org  Translation-de                               
OK   http://ppa.launchpad.net trusty/main amd64 Packages                       
OK   http://archive.ubuntu.csg.uzh.ch trusty/restricted Translation-de         
Ign http://download.opensuse.org  Translation-en                               
OK   http://security.ubuntu.com trusty-security/restricted i386 Packages       
OK   http://archive.ubuntu.csg.uzh.ch trusty/restricted Translation-en         
OK   http://ppa.launchpad.net trusty/main i386 Packages                       
OK   http://archive.ubuntu.csg.uzh.ch trusty/universe Translation-de           
OK   http://ppa.launchpad.net trusty/main Translation-en                       
OK   http://archive.ubuntu.csg.uzh.ch trusty/universe Translation-en           
OK   http://ppa.launchpad.net trusty Release.gpg                               
OK   http://security.ubuntu.com trusty-security/universe i386 Packages         
OK   http://ppa.launchpad.net trusty Release                                   
OK   http://ppa.launchpad.net trusty Release                                   
OK   http://extra.linuxmint.com rosa/main amd64 Packages                       
OK   http://ppa.launchpad.net trusty Release                                   
OK   http://ppa.launchpad.net trusty/main Sources                             
OK   http://security.ubuntu.com trusty-security/multiverse i386 Packages       
OK   http://ppa.launchpad.net trusty/main amd64 Packages                       
OK   http://ppa.launchpad.net trusty/main i386 Packages                       
OK   http://security.ubuntu.com trusty-security/main Translation-en           
Ign http://archive.ubuntu.csg.uzh.ch trusty/main Translation-de_DE             
Ign http://archive.ubuntu.csg.uzh.ch trusty/multiverse Translation-de_DE       
Ign http://archive.ubuntu.csg.uzh.ch trusty/restricted Translation-de_DE       
Ign http://archive.ubuntu.csg.uzh.ch trusty/universe Translation-de_DE         
OK   http://ppa.launchpad.net trusty/main Sources                             
OK   http://security.ubuntu.com trusty-security/multiverse Translation-en     
OK   http://extra.linuxmint.com rosa/main i386 Packages                       
OK   http://ppa.launchpad.net trusty/main amd64 Packages                       
OK   http://security.ubuntu.com trusty-security/restricted Translation-en     
OK   http://ppa.launchpad.net trusty/main i386 Packages                       
OK   http://security.ubuntu.com trusty-security/universe Translation-en       
OK   http://ppa.launchpad.net trusty/main Sources                             
OK   http://ppa.launchpad.net trusty/main amd64 Packages                       
OK   http://ppa.launchpad.net trusty/main i386 Packages                       
Ign http://ftp-stud.hs-esslingen.de rosa/import Translation-de_DE             
Ign http://ftp-stud.hs-esslingen.de rosa/import Translation-de                 
Ign http://ftp-stud.hs-esslingen.de rosa/import Translation-en                 
Ign http://ftp-stud.hs-esslingen.de rosa/main Translation-de_DE               
Ign http://ftp-stud.hs-esslingen.de rosa/main Translation-de                   
Ign http://ftp-stud.hs-esslingen.de rosa/main Translation-en                   
Ign http://ftp-stud.hs-esslingen.de rosa/upstream Translation-de_DE           
Ign http://ftp-stud.hs-esslingen.de rosa/upstream Translation-de               
Ign http://ftp-stud.hs-esslingen.de rosa/upstream Translation-en               
Ign http://ppa.launchpad.net trusty/main Translation-de_DE                     
Ign http://archive.getdeb.net trusty-getdeb/apps Translation-de_DE             
Ign http://ppa.launchpad.net trusty/main Translation-de                       
Ign http://ppa.launchpad.net trusty/main Translation-en                       
Ign http://ppa.launchpad.net trusty/main Translation-de_DE                     
Ign http://archive.getdeb.net trusty-getdeb/apps Translation-de               
Ign http://ppa.launchpad.net trusty/main Translation-de                       
Ign http://ppa.launchpad.net trusty/main Translation-en                       
Ign http://archive.getdeb.net trusty-getdeb/apps Translation-en               
Ign http://ppa.launchpad.net trusty/main Translation-de_DE                     
Ign http://ppa.launchpad.net trusty/main Translation-de                       
Ign http://ppa.launchpad.net trusty/main Translation-en                       
Ign http://extra.linuxmint.com rosa/main Translation-de_DE                     
Ign http://nightly.apt.ring.cx ring/main Translation-de_DE                     
Ign http://extra.linuxmint.com rosa/main Translation-de
Ign http://nightly.apt.ring.cx ring/main Translation-de 
Ign http://extra.linuxmint.com rosa/main Translation-en 
Ign http://nightly.apt.ring.cx ring/main Translation-en 
Paketlisten werden gelesen... Fertig                     
W: Duplicate sources.list entry http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/Ubuntu_14.04/  Packages (/var/lib/apt/lists/download.opensuse.org_repositories_isv:_ownCloud:_desktop_Ubuntu%5f14.04_Packages)
W: Probieren Sie »apt-get update«, um diese Probleme zu korrigieren.

Re: Darf ich dieses java-file installieren?
« Antwort #14 am: 20.09.2016, 22:24:36 »
Zitat
Duplicate sources.list entry http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/Ubuntu_14.04/  Packages (/var/lib/apt/lists/download.opensuse.org_repositories_isv:_ownCloud:_desktop_Ubuntu%5f14.04_Packages)
Was willst du denn mit einem OpenSuse-Repo?
Und dann gleich doppelt!
Da würde ich mal aufräumen, in den 'Anwendungspaketquellen'.

Hat noch keiner geschrieben:
Hinweis: Bitte bei allen Supportanfragen unbedingt die verwendete Mint-Version und Desktopumgebung angeben. [?]
« Letzte Änderung: 20.09.2016, 22:28:58 von aexe »

 

1. Advent
1. Advent