Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
24.09.2020, 03:43:07

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24545
  • Letzte: AnGex
Statistiken
  • Beiträge insgesamt: 684055
  • Themen insgesamt: 55372
  • Heute online: 393
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 0
Gäste: 145
Gesamt: 145

Autor Thema:  Nach dem Update auf 17.3 läuft der HP-Drucker nicht mehr  (Gelesen 1165 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo liebe Forianer,
nachdem ich nun ein paar Stunden selbst mein Glück versucht habe, brauche ich wohl leider eure Hilfe... Mein (überlebensnotwendiger!) Netzwerkdrucker HP LaserJet 1025 läuft nicht mehr, seit ich auf Mint 17.3 (Cinnamon) geupdated habe.

Haupt-Fehlermeldung in CUSP ist "Filter failed".
Seit ich Diverses vesucht habe (s.u.), meldet CUSP "Datenübergabe unterbrochen (broken pipe)"

Was ich bisher schon probiert habe:
- ich bin in den Gruppen lpadmin und lp
- ich habe den Drucker in CUSP gelöscht und neu eingerichtet
- der Drucker ist shared
- alle Pakete rund um CUSP habe ich reinstalliert
- HPLIP habe ich reinstalliert
- Das Diagnose-Tool hp-doctor hat ne Menge gemacht - und eine Menge Fehlermeldungen ausgegeben

HP Linux Imaging and Printing System (ver. 3.15.2)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

 

Checking for Deprecated items....
error: This distro (i.e linuxmint  17.3) is either deprecated or not yet supported.
The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes*, n=no):y


Checking for HPLIP updates....
error: Failed to locate hp-upgrade utility


Checking for Dependencies....
warning: linuxmint-17.3 version is not supported. Using linuxmint-17 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 GNU/Linux
 Host: erik-laptop
 Proc: 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 GNU/Linux
 Distribution: linuxmint 17.3
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.15.2
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro  17.3 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.15.2

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip-doc/HTML
html=/usr/share/doc/hplip-3.15.2
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.15.2
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:
[plugin]
installed = 1
eula = 1
version = 3.14.3



Current contents of '~/.hplip/hplip.conf' file:
[last_used]
device_uri = hp:/net/HP_LaserJet_CP_1025nw?zc=NPI0571E2

[installation]
date_time = 08/15/16 11:27:06
version = 3.15.2


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

--------------------------
|  External Dependencies |
--------------------------

 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.10            OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.23          OK         -
 cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             1.7.2           OK         'CUPS Scheduler is running'
 network              network -wget                                                OPTIONAL        -               1.15            OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.6.18          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.6.31          OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.998           OK         -

-------------------------
|  General Dependencies |
-------------------------

 python3-pyqt4        PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             4.10.4          OK         -
 python3-pyqt4-dbus   PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             4.10.4          OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               1.0.23          OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             2.7.6           OK         -
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               1.1.7           OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.1.0           OK         -
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.0           OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               1.7.2           OK         -
 python3-devel        Python devel - Python development files                      REQUIRED        2.2             2.7.6           OK         -
 libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
 libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.7.2           OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               1.7.2           OK         -
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.0.1           OK         -
 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.19'         OK         -
 sane                 SANE - Scanning library                                      REQUIRED        -               1.0.23          OK         -
 python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.0             OK         -

---------------
|  COMPILEDEP |
---------------

 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               4.8.4           OK         -
 libtool              libtool - Library building support services                  REQUIRED        -               2.4.2           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             3.81            OK         -

----------------------
|  Python Extentions |
----------------------

 hpmudext             IO-Extension                                                 REQUIRED        -               3.15.2          OK         -
 cupsext              CUPS-Extension                                               REQUIRED        -               3.15.2          OK         -

-----------------------
|  Scan Configuration |
-----------------------

'/etc/sane.d/dll.d/hpaio' not found.
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.15.2          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.15.2          OK         -

-----------------------
|  Other Dependencies |
-----------------------


------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
HP_LaserJet_CP_1025nw
---------------------
Type: Unknown
Device URI: socket://192.168.1.69
PPD: /etc/cups/ppd/HP_LaserJet_CP_1025nw.ppd
PPD Description: HP LaserJet Cp 1025nw, hpcups 3.15.2, requires proprietary plugin
Printer status: printer HP_LaserJet_CP_1025nw is idle.  enabled since Mo 15 Aug 2016 11:Rendering completed
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

QL-570
------
Type: Unknown
Device URI: usb://Brother/QL-570?serial=E5Z461684
PPD: /etc/cups/ppd/QL-570.ppd
PPD Description: Brother QL-570 CUPS v1.1
Printer status: printer QL-570 is idle.  enabled since Mo 15 Aug 2016 09:12:04 CEST
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.


--------------
| PERMISSION |
--------------

 

Checking Permissions....
Permissions are correct.


Checking for Configured Queues....
error: PPD /etc/cups/ppd/HP-LaserJet-CP1025nw.ppd file not found
warning: HP-LaserJet-CP1025nw is not HP Device.
warning: Fail to read ppd=/etc/cups/ppd/HP-LaserJet-CP1025nw.ppd file
warning: Insufficient permission to access file /etc/cups/ppd/HP-LaserJet-CP1025nw.ppd
warning: Could not complete Queue(s) configuration check


Checking for HP Properitery Plugin's....
No plug-in printers are configured.
 
Diagnose completed...



More information on Troubleshooting,How-To's and Support is available on http://hplipopensource.com/hplip-web/index.html


Kann es sein, dass es noch keine Unterstützung für 17.3 gibt? Muss ich wieder downgraden? Ich bin verzweifelt und zu allem bereit - hauptsache der Drucker tut's wieder!   :'(

Habt schonmal vielen Dank!
Grüße
Talbo

 

Re: Nach dem Update auf 17.3 läuft der HP-Drucker nicht mehr
« Antwort #1 am: 15.08.2016, 12:30:01 »
Halleluja! Keinen Schimmer - und doch gelöst.  8)

Folgendermaßen:
Inzwischen habe ich in der Paketverwaltung entdeckt, dass HPLIP noch in der Version 3.15.2 installiert war. Die Unterstützung für Mint 17.3 gibt es aber erst ab 3.15.9 - also habe ich HPLIP manuell aktualisiert (http://hplipopensource.com/hplip-web/install/install/index.html).

Das alleine war's dann aber auch noch nicht. Wenn ich den Drucker in CUSP inzugefügt habe, gab's weiterhin ähnliche Fehler. Erst die Einrichtung über hp-setup (wie in der Anleitung oben beschrieben), macht den Unterschied!

Danke allen, die sich inzwischen ebenfalls mit der Sache hier beschäftigt haben!

Re: Nach dem Update auf 17.3 läuft der HP-Drucker nicht mehr
« Antwort #2 am: 15.08.2016, 14:37:10 »
Und manchmal geht es in Linux sogar einfacher als unter Windows:

Ich habe einen "HP Color LaserJet 2840" geschenkt bekommen - ein riesen Trumm und
deshalb habe ich den im Dachgeschoss aufgebaut. Vorhin habe ich den dann mal angeschlossen
(Strom und LAN). Notebook eingeschaltet, Drucker gesucht, Testseite gedruckt: Zack fäddisch!  :D

Jetzt der PC von meiner Frau (jaja, ich gebs ja zu, die hat wegen der Adobe-Suite immer noch Win10
als OS - also steinigt mich)...

Habs auch mal auf die doofe Tour (Drucker suchen) versucht, aber Win10 findet den nicht.
Auch mit der Installations-CD gings nicht  :o
Ich musste also den Sch... Drucker wieder herunterschleppen und per USB an den PC anbinden,
dann den Treiber installieren und dann das Teil wieder ins DG tragen, LAN-Kabel rein, Drucker suchen,
Windows-Update fahren, neustarten, noch mal irgend einen Scheiss nachinstallieren, bestätigen, neustarten
uuuuuuuuuuuuuund jetzt erst durfte ich die Testseite drucken  >:(


jibbetttdochnichsonekackeaberauch  ::)


Edit: Alle meine ThinPads mit LinuxMint haben den Drucker sofort gefunden - ohne schischie und ohne traraaaa  8)

Re: Nach dem Update auf 17.3 läuft der HP-Drucker nicht mehr
« Antwort #3 am: 15.08.2016, 15:52:24 »
Halleluja! Keinen Schimmer - und doch gelöst.  8)

Folgendermaßen:
Inzwischen habe ich in der Paketverwaltung entdeckt, dass HPLIP noch in der Version 3.15.2 installiert war. Die Unterstützung für Mint 17.3 gibt es aber erst ab 3.15.9 - also habe ich HPLIP manuell aktualisiert

Bei mir läuft die 3.15.2 problemlos seit 17.0 (jetzt 17.3). Kann ich also nicht bestätigen, dass es inkompatibel ist.

Grüße