Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
16.01.2021, 07:08:04

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25069
  • Letzte: rs_linux
Statistiken
  • Beiträge insgesamt: 708137
  • Themen insgesamt: 57252
  • Heute online: 515
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 4
Gäste: 311
Gesamt: 315

Autor Thema:  Probleme mit einem Medion MT6 Rechner  (Gelesen 819 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Probleme mit einem Medion MT6 Rechner
« am: 08.04.2016, 01:55:38 »
Meine LM-Kenntnisse sind leider immer noch bescheiden. Ich versuche sie allerdings zu verbessern. Ich habe LM 17.3 auf einem ältern Medion MT6 PC mit 2GB Ram und einer Radeon 9600 XT GraKa installiert. Das läuft erstaunlich gut. Probleme habe ich bislang nur folgende entdeckt:

- Beim Versuch das System mit zwei Monitoren (vom DVI und VGA Anschluss der Radeon Karte) zu starten ist Cinnamon abgestürzt. Das Problem konnte ich nicht lösen und deshalb habe ich die Mate Edition installiert. Da passiert das nicht. Nur der Shortcut WIN + Shift + links oder rechts funktioniert in Mate nicht so wie unter Cinnamon. Was mich wundert, dass auch unter Mate kein Treiber für display 1 installiert wird (siehe unten). Ich würde das Problem unter Cinnamon zumindest gern begreifen bzw. die Anforderungen gerne kennen. Auf einem neueren Rechner mit einem onboard AMD HD3000 Grafik Chip läuft Cinnamon mit zwei Monitoren bei mir einwandfrei.

- Ich habe unter Mate und Cinnamon mit

sudo lshw -html > ~/Systeminfo.html

einen Systembericht abgerufen. Beide sind identisch. Darin habe ich gesehen, dass es scheinbar noch Probleme mit einigen Treibern gibt. Die betroffenen Geräte sind unten in der Farbe rot umschrieben.

Ich weiß leider nicht, wie ich diese Probleme beseitigen kann und ob das überhaupt erforderlich ist. Soweit ich es bislang sehe, funktioniert unter Mate alles, bis auf Dinge, die ich möglicherweise gar nicht brauche. Das System ist bislang nur über die Aktualisierungsverwaltung auf dem neusten Stand gebracht worden und im Terminal habe ich eingegeben

sudo apt-get update

Über die Treiberverwaltung konnte ich nur den WiFi Treiber installieren. WLan funktionierte danach aber bestens.

-------- unproblematisch ---------
id:
display:            0
Beschreibung:       VGA compatible controller
Produkt:            RV360 [Radeon 9600/X1050 Series]
Hersteller:         Advanced Micro Devices, Inc. [AMD/ATI]
Physische ID:       0
Bus-Informationen:  pci@0000:01:00.0
Version:           00
Breite:             32 bits
Takt:               66MHz
Fähigkeiten:       agp agp-3.0 pm vga_controller bus_master
                    cap_list rom
Konfiguration:     
driver = radeon
latency = 32
mingnt = 8
Ressourcen:
irq :              16
memory :         d0000000-dfffffff
ioport :         a000(Größe=256)
memory :         f9000000-f900ffff
memory :         f8000000-f801ffff


------- problematisch ? -----------

id:      
display:            1
Beschreibung:       Display controller
Produkt:            RV350 [Radeon 9600/X1050 Series] (Secondary)
Hersteller:         Advanced Micro Devices, Inc. [AMD/ATI]
Physische ID:       0.1
Bus-Informationen:  pci@0000:01:00.1
Version:            00
Breite:             32 bits
Takt:               66MHz
Fähigkeiten:       pm cap_list
Konfiguration:
latency = 32
mingnt = 8
Ressourcen:
memory :         e0000000-efffffff
memory :         f9010000-f901ffff


id:                 generic
Beschreibung:       System peripheral
Produkt:            82865G/PE/P Processor to I/O Memory Interface
Hersteller:         Intel Corporation
Physische ID:       6
Bus-Informationen:  pci@0000:00:06.0
Version:            02
Breite:             32 bits
Takt:               33MHz
Konfiguration:
latency =    0
Ressourcen:
memory :         80000000-80000fff



id:                 communication
Beschreibung:       Communication controller
Produkt:            536EP Data Fax Modem
Hersteller:         Intel Corporation
Physische ID:       4
Bus-Informationen:  pci@0000:02:04.0
Version:            00
Breite:             32 bits
Takt:               33MHz
Fähigkeiten:       pm bus_master cap_list
Konfiguration:
latency = 32
Ressourcen:
memory :         fa000000-fa3fffff


id:                 serial
Beschreibung:       SMBus
Produkt:            82801EB/ER (ICH5/ICH5R) SMBus Controller
Hersteller:         Intel Corporation
Physische ID:       1f.3
Bus-Informationen:  pci@0000:00:1f.3
Version:            02
Breite:             32 bits
Takt:               33MHz
Konfiguration:
latency = 0
Ressourcen:
ioport :         500(Größe=32)


Ich habe das der Übersicht halber mal in Code-Blöcke gesetzt... Gruß Korfox
« Letzte Änderung: 08.04.2016, 07:20:51 von Korfox »

Re: Probleme mit einem Medion MT6 Rechner
« Antwort #1 am: 08.04.2016, 02:23:29 »
Willkommen Zimtstange!

Im Terminal wird mit
sudo apt-get updateaber nur eingelesen, welche Aktualisierungen verfügbar sind.
Die eigentliche Aktualisierung wird mit dem Befehl
sudo apt-get dist-upgradeausgeführt.

Re: Probleme mit einem Medion MT6 Rechner
« Antwort #2 am: 08.04.2016, 04:56:04 »
Hallo helli,

da ich diesen Rechner an einen Linux-Newbie verschenken und die erforderlichen Installationsschritte zum einfachen Nachmachen idiotensicher beschreiben will, habe ich mich bislang ausschießlich an diesen Vorgaben orientiert:

https://www.linuxmintusers.de/index.php?action=wiki;page=Erstupdates_bzw._Mintupdater

Da es ein Treiber- oder Hardwareproblem ist (und damit sich hier niemand rausreden kann), habe ich es mit:

sudo apt-get update && sudo apt-get install linux-generic && sudo apt-get dist-upgrade

nochmals versucht, aber alle Nachfragen bei Konfigurationsproblemen mit Vorgabe verneint. Zum Abschluss habe ich noch eingegeben:

sudo dpkg-reconfigure locales
sudo update-locale LANG=de_DE.utf8

Die rot eingefärbten Treiberprobleme sind dadurch nicht verschwunden. Das Problem besteht weiterhin.

Ich bräuchte etwas wie

sudo apt-get old-intel-ich5-chipset-driver

Damit zumindest sichergestellt ist, dass der Intel SMBus Controller und das Processor to I/O Memory Interface  richtig funktioniert, falls diese Geräte irgendwann im Hintergrund benötigt werden.

Re: Probleme mit einem Medion MT6 Rechner
« Antwort #3 am: 08.04.2016, 06:14:38 »
da ich diesen Rechner an einen Linux-Newbie verschenken und die erforderlichen Installationsschritte zum einfachen Nachmachen idiotensicher beschreiben will, habe ich mich bislang ausschießlich an diesen Vorgaben orientiert:

https://www.linuxmintusers.de/index.php?action=wiki;page=Erstupdates_bzw._Mintupdater
Hast Du in der Aktualisierungsverwaltung auch gemäss Screenshot die Haken gesetzt?


Re: Probleme mit einem Medion MT6 Rechner
« Antwort #4 am: 08.04.2016, 09:40:11 »
Nein habe ich nicht, weil ich
  • bislang noch nie erkennbare Probleme damit hatte und ich davon ausgegangen bin, dass mir das Linux Mint-Team in der installierten Standardeinstellung keine unsicheren Pakete über die Aktualisierungsverwaltung auf den Rechner schickt
  • mich noch nie für die Einstellungen in der Aktualisierungsverwaltung interessiert habe
  • niemand vorschreiben will, wie er sein System pflegt
Ich selbst spiele am Terminal nur dann herum, wenn es anders nicht geht. Entsprechend ändere ich  an den Standard-Einstellungen grundsätzlich nichts oder nur sehr wenig, und auch nur dann, wenn ich genau weiß, was und warum ich es tue.

Mit Haken wird mein Treiber-Problem nicht gelöst. Wir kommen vom Hölzchen aufs Stöckchen ...

Re: Probleme mit einem Medion MT6 Rechner
« Antwort #5 am: 08.04.2016, 10:07:34 »
Demnach wirst Du auch nicht das Handbuch für die ersten Schritte in Linux Mint gelesen haben.
https://www.linuxmintusers.de/files/Handbuch_DE_LM_17.3_Cinnamon.pdf

Könnte ja sein das damit dein Problem gelöst wird, hat ja nichts mit dem Terminal zu tun.
niemand vorschreiben will, wie er sein System pflegt
Will auch niemand, kann jeder wie er lustig ist.

Re: Probleme mit einem Medion MT6 Rechner
« Antwort #6 am: 08.04.2016, 10:30:07 »
Zitat
Shortcut WIN + Shift + links oder rechts

Enorm praktisch unter Cinnamon, wenn man bei einem erweiterten Desktop ein Anwendungsfenster auf den jeweils anderen Bildschirm "beamen" will. Die Funktion gibt es nicht unter Mate.

Das bei so alter Hardware Mate funzt, aber Cinnamon nicht, wundert mich nicht.
Das Thema Grafiktreiber kann man kurz abhandeln, da gibt es keine Alternative mehr zu dem offenen radeon-Treiber.
siehe auch http://www.linux-magazin.de/NEWS/AMD-bietet-Legacy-Treiber-fuer-alte-ATI-Karten-an
Man beachte das Datum (2009).
Was ich nicht verstehe, was konkret unter Mate jetzt nicht funktioniert (?)

Re: Probleme mit einem Medion MT6 Rechner
« Antwort #7 am: 09.04.2016, 15:22:12 »
Zitat
"Könnte ja sein das damit dein Problem gelöst wird, hat ja nichts mit dem Terminal zu tun"
Das Problem wurde damit nicht gelöst. Ich hab mir mit dist-upgrade ein anderes eingefangen. Dieses habe ich zeitaufwendig selbst gelöst.

Wenn es über LM was zu meckern gibt, dann ist es der Umstand, dass der Anwender bei Aktualisierungen keine Release Notes bekommt. Er weiß uU gar nicht, was auf seinem Rechner verändert wurde.

Zitat
"Was ich nicht verstehe, was konkret unter Mate jetzt nicht funktioniert (?)"

Der Rechner läuft mit 2GB RAM und Intel P4 3GHz ausgesprochen gut unter Mate und auch unter Cinnamon. Die Installation war mit beiden Systemen in wenigen Minuten perfekt erledigt. (Unter XP braucht man dafür mit unter mehrere Tage, wenige Stunden reichen nicht, wenn man den Rechner mit allen Updates installieren will). Da gibts unter LM nichts zu meckern und ein neuer Rechner läuft bei einfachen Anwendungen tatsächlich nicht erkennbar besser/schneller. In Cinnamon gibt es nach meinen Feststellungen nur Probleme beim Dual Monitor Einsatz. Möglicherweise gibts aber auch dafür eine undokumentierte Problemlösung, die ich bislang noch nicht herausgefunden habe. Leider konnte ich den Grund nicht herausfinden. Es hätte mich sehr interessiert, woran es lag. Unter Mate klappt der Dual Monitor Einsatz gut. Also kann es mE nicht nur am radeon-Treiber liegen. Möglicherweise kann mit xandr unter Mate die Einstellung noch etwas verbessert werden. Ansonsten fehlen halt die Cinnamon Panels und man hat keine Shortcuts zum beamen. Das ist mE nicht weiter schlimm. Mit der Mouse ist das einfach erledigt.

Hier in diesem Thread ging es nur um das Problem, dass für diesen Medion PC sowohl unter Cinnamon wie auch unter Mate für einige Geräte keine Treiber installiert sind. Die sind oben im unteren Codefenster alle gelistet und waren ursprünglich alle rot eingefärbt. Korfox hat sie im Codefenster schön versteckt. Das betrifft im wesentlichen den SMBus und das Interface zwischen Prozessor und I/O Memory Interface. Ich habe keine Ahnung, ob das irgendwann relevant werden könnte. Es kann aber sein, dass Linux das Probleme einfach durch Abfrage von Bios-Routinen löst und den Treiber für den SMBus überhaupt nicht benötigt.

Edit: Nicht alle Medion MT6 PCs laufen so gut. Bei einem zweiten mit genau dem gleichen Board, aber einer NVidia Geforce 6200, streikte die Linux-DVD. Es lag mE nicht am NVidia Treiberproblem. (Andere PCs mit einer Geforce 6200 habe ich bereits sehr erfolgreich unter Mate installiert.) Auch mit nomodeset statt quiet splash konnte ich nicht installieren. Die Ursache habe ich nicht herausgefunden. Dafür fehlte die Zeit. Kein Problem. Beide Rechner habe ich nicht mehr. Darüber bin ich sehr froh. Mit so alten Rechnern werde ich mich vermutlich nicht mehr beschäftigen. Allerdings bin ich überzeugt, das beiden Rechner bei guter Pflege für die nächsten 10 Jahre noch gut zu gebrauchen sind. In einem normalen Haushalt braucht man nicht mehr und findet eher wesentlich schlechtere, auch dann wenn sie neuer sind.