Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
02.03.2021, 03:32:42

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25330
  • Letzte: s1rv1val
Statistiken
  • Beiträge insgesamt: 719201
  • Themen insgesamt: 58167
  • Heute online: 470
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 5
Gäste: 363
Gesamt: 368

Autor Thema:  Cinnamon 17.3 installiert, jedoch kein Bootmanager  (Gelesen 3565 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo Forum,

ich bin ein absoluter Newbie bei Mint, möchte aber die Windowswelt verlassen, sobald ich für meine Win-Tools passende Alternativen unter Mint gefunden habe. Zum Einstieg habe ich mir ein Buch gekauft und mit der (für meinen Geschmack) recht guten Anleitung Mint 17.3 auf mein Notebook installiert, parallel zu Windows 8.1.

Windows läuft unter UEFI
Mint 17.3 64bit Cinnamon

Nach der Installation von USB-Stick kriege ich die Meldung, dass die Installation erfolgreich war. Starte ich die Kiste neu, wird direkt Windows gestartet ohne GRUB; im Windows-Bootmanager (über F12 zu erreichen) gibt es keinen LinuxMint-Eintrag.

Kann mir jemand einen Tipp geben wo ich suchen muss (bitte auf Anfänger-Niveau...)?


Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #1 am: 14.02.2016, 15:10:31 »
@Sheep225
Mein Vorschlag: Download des ISO-Images von Super Grub2 Disk und Anschließend auf eine CD brennen oder mit Rufus auf deinen USB-Stick bannen. Dann den Rechner von diesem Medium starten, und suchen lassen welche Installationen gefunden werden. Klappt das schreibst du Grub nach erfolgreichem Start noch einmal neu. Bis auf das letzte kannst du alles auch unter Windows erledigen.
Alternativ geht das auch unter Linux über die LiveDistri deines Sticks. Ablauf ist hier chroot-Methode beschrieben.

Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #2 am: 14.02.2016, 15:12:28 »
Hi :)
hattest du
secure boot im bios ausgeschaltet?

Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #3 am: 16.02.2016, 19:05:59 »
Klappt das schreibst du Grub nach erfolgreichem Start noch einmal neu.

Hallo Imumischabln,

kannst du mir das mit dem Neuschreiben kurz erklären (DAU bzw. Anfänger...) oder gibts einen Post wo das schon erläutert ist?
Muss ich mir irgendwie Sorgen machen dass ich Win zerschiessen könnte?

Vielen Dank!

Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #4 am: 16.02.2016, 19:10:03 »
Hi :)
hattest du
secure boot im bios ausgeschaltet?

Hallo ehtron,
in meinem UEFI-Setup gibts eine Option "Secure Boot = Standard", jedoch kann ich die gar nicht anwählen.
(Ich versuch einen Screenshot hinzukriegen und die UEFI/Bios-Version zu posten, sobald ich an meinem Rechner bin)
Vielleicht hat ja jemand eine Idee wie das hinzukriegen ist.....

...laut meinem Buch bietet nicht jede Uefi-Version eine Einstellung für Secure Boot, deshalb hatte ich gedacht dass es trotzdem möglich sein könnte...



Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #5 am: 16.02.2016, 19:19:43 »
Wenn Linux auch im UEFI-Modus installiert ist, lautet der Befehl für die Grub-Installation so:
sudo grub-install
Anschließend noch
sudo update-grubausführen, um den Windows-Eintrag in das Grub-Menü zu bekommen.

Bei manchen Rechnern muss man erst ein Passwort für das UEFI-Setup vergeben, um Einstellungen für Secure Boot ändern zu können.

Zitat
im Windows-Bootmanager (über F12 zu erreichen) gibt es keinen LinuxMint-Eintrag.
Eigentlich müsste ein "ubuntu" Eintrag im UEFI-Bootmenü zu finden sein, dies kann ich bei meinem Rechner mit der Esc Taste aufrufen:
« Letzte Änderung: 16.02.2016, 19:38:55 von helli »

Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #6 am: 16.02.2016, 21:57:29 »
Bei manchen Rechnern muss man erst ein Passwort für das UEFI-Setup vergeben, um Einstellungen für Secure Boot ändern zu können.

Also, dies war der Hinweis! Tatsächlich konnte ich Secure Boot deaktivieren nachdem ich ein Supervisor Passwort gesetzt habe.
Bilder von meinem Uefi sind unten.

Nachdem SecureBoot ausgeschaltet war habe voller Enthusiasmus versucht, Mint nochmals neu zu installieren. Alles hat sauber geklappt (wie auch schon zuvor), am Ende kam die Meldung dass die Installation fertig sei und ich nun neu starten soll.
Und dann die Enttäuschung: wieder nix!  :'( :(
Ziemlich am Ende der Installation habe ich eine Meldung gesehen, die in die Richtung von grub-install und update-grub ging, den genauen Text habe ich mir allerdings nicht gemerkt.

Den Windows-Bootmanager erreiche ich über F12, aber da gibt es nur einen Eintrag....

Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #7 am: 16.02.2016, 22:08:59 »
Im Uefi gibt es noch eine Option "Select an Uefi file..."; damit kann ich ein grub-irgendwas64.efi zu den "trusted files" hinzufügen; danach sehe ich Mint auch im Bootmanager, dies startet dann Grub und so komme ich auch an Mint heran, aber nach meinem Verständnis müsste doch Grub automatisch gestartet werden und dann sollte ich wählen können ob ich mit Mint oder Win weitermachen will.

Irgendwie stehe ich auf dem Schlauch.... bin für jede Hilfe dankbar



Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #8 am: 16.02.2016, 22:14:51 »
Tja, eigentlich müsste nun unter "Boot priortity order:" auch ein Eintrag "ubuntu" stehen und diesen müsste man an die erste Stelle setzen.

Zitat
danach sehe ich Mint auch im Bootmanager, dies startet dann Grub und so komme ich auch an Mint heran, aber nach meinem Verständnis müsste doch Grub automatisch gestartet werden und dann sollte ich wählen können ob ich mit Mint oder Win weitermachen will.

Dieser Eintrag muss im UEFI-Setup unter dem Reiter Boot unter "Boot priortity order:" an erster Stelle stehen, dann erscheint Grub auch sofort beim Booten.
Den ersten Eintrag anwählen → Enter drücken → Mint anwählen → Enter drücken und mit F10 speichern und das UEFI-Setup verlassen.

Sollte im Grub-Menü kein Win-Eintrag vorhanden sein, wäre
sudo update-grubim laufenden Linux nötig.
« Letzte Änderung: 16.02.2016, 23:20:33 von helli »

Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #9 am: 17.02.2016, 18:27:45 »
Noch eine neue Idee: bei der Installation, genauer im Partitionerungsmenü gibt es ein Dropdown-Feld "Gerät für die Bootloader-Installation".
Soll da die oberste Ebene /dev/sda stehen oder muss ich da eine bestimmte Partition auswählen...?
In meinem Buch wird darüber nichts geschrieben, deshalb habe ich den Eintrag /dev/sda übernommen.

... wie immer sorry für die Fragen....

Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #10 am: 17.02.2016, 18:48:47 »
Eigentlich hättest du die EFI-Partition sda2 angeben sollen, da Grub in dieser installiert wird.
Ich habe aber gehört, dass dies egal sei, weil bei grub-install die EFI-Partition automatisch gewählt wird.

Ich glaube auch eher, bei dir steht der ubuntu-Eintrag noch nicht an oberster Stelle bei den Bootoptionen, wenn Grub noch nicht beim Booten erscheint, denn vorhanden ist er ja, wie du selbst schreibst:
Zitat
danach sehe ich Mint auch im Bootmanager, dies startet dann Grub
« Letzte Änderung: 17.02.2016, 19:03:11 von helli »

Re: Cinnamon 17.3 installiert, jedoch kein Bootmanager
« Antwort #11 am: 17.02.2016, 20:17:20 »
Hallo helli,

danke für deine Geduld und die Erklärungen, es lag an meinem Bios/EFI ... :-[
Ich musste grubx64.efi wirklich als vertrauenswürdig im Efi-Menü hinzufügen, dann erschien Mint auch im Efi-Boot.
Nach allem was ich gelesen hatte hätte ich gedacht dass dies mit ausgeschaltetem Secure Boot automatisch geschieht.

Auf jeden Fall hat es nun geklappt, ich habe etwas gelernt, grub steht im Bootmenü zuoberst und Mint wird wunderbar gestartet  :D 8)
Diesen Post schreibe ich nun nicht mehr unter Windows, sondern tatsächlich unter Mint!!  ;D

Nun kann die grosse Testerei losgehen... zum Glück sieht das Wetter in unserer region fürs Wochenende nicht so toll aus  :P

Vielen Dank für die Hilfe!