Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.07.2020, 05:35:51

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24253
  • Letzte: chemin
Statistiken
  • Beiträge insgesamt: 670265
  • Themen insgesamt: 54299
  • Heute online: 254
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 7
Gäste: 93
Gesamt: 100

Autor Thema: [gelöst]  Bootloader erscheint nicht nach Partitionierung und Installierung von Linux Mint  (Gelesen 1524 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hi Leute.
Ich weiß, dieses Thema wurde bestimmt schon hunderte Male durchgenommen in diesem Forum. Allerdings komme auch ich nicht weiter bei meiner Installation.
Ich habe auf meinem Rechner Windows 10 laufen. Die Festplatte ist in zwei Teile aufgeteilt. C: mit dem OS war ca. 400 GB groß, D: mit den Daten 550 GB. Diese waren bei der Auslieferung schon so partitioniert.
Nun hatte ich die Idee mir Linux Mint 17.3 Cinnamon 64-bit zu installieren und zwar als zweites Betriebssystem neben Windows 10. Dazu wollte ich mir eine dritte Partition mit dem Betriebssystem machen. Diese sollte ca. 250 GB groß werden. Ich habe mir also gparted auf ne CD gebrannt und von dieser gebootet. Dann habe ich die Windowspartition verkleinert auf 250 GB da ich nicht mehr brauche und die Datenpartition auf ca. 450 GB verkleinert. Jetzt habe ich noch die Datenpartition nach hinten verschoben, damit Linux schneller läuft und jetzt zwischen Windows und den Daten liegt.
Daraufhin habe ich eine neue primäre Partition für Linux mit ext4 erstellt und eine Swap Partition mit etwas viel Speicherplatz da ich ieber zuviel als zuwenig dafür verbrauchen wollte. Es sind 16 GB. Insgesamt habe ich also jetzt eine Boot Partition, eine Recovery, eine Windows, zwei wenige MB große, von denen ich nicht weiß was sie machen, welche aber schon immer da waren und welche ich auch nach vorne geschoben habe, dann die Linux Partition, die Swap, die Daten, und eine Restore Partition die auch schon bei der Auslieferung bstanden hat. Beim Partitionieren hat eigentlich alles geklappt, Windows 10 startet und alle Dateien sind noch da soweit ich das beurteilen kann. Die Größe des belegten Speicherplatzes hat sich nicht verändert.
Nun habe ich Linux Mint auf einer DVD gestartet und installiert. Ich habe dabei auch die richtige Partition ausgewählt.
Nur wenn ich jetzt den Computer starte müsste doch jetzt eigentlich der Bootloader erscheinen, oder?
Das tut er bei mir nicht...
Liegt das daran, dass ich vergessen habe bei Windows 10 Fastboot zu deaktivieren was ich im nachhinnein noch getan habe?
Soll ich Linux Mint nochmal neu installieren, den Bootloader neu installieren oder was anderes?
Vielen Dank im vorraus für schnelle Antworten.
Jakob
« Letzte Änderung: 05.02.2016, 17:54:23 von mister_jakob »

HAllo und Wilkommen im Forum,

ich tippe ja auf ein "Mishmasch" zwischen UEFI und BIOS-Installation. Kannst du mal das Mint-System von DVD starten und da dann im Terminal
sudo parted -lausführen, bitte. DAs Ergebnis dann hier zeigen.

Die Ausgabe bitte im Codeblock, den erstellst du mit folgender Schaltfläche:

Entweder zuerst auf das '#' klicken und dann zwischen den Klammern einfügen, oder erst einfügen, dann markieren und auf '#' klicken.

Willkommen mister_jakob!

Falls es sich beim BIOS um UEFI handelt, könntest du mal unter dem Reiter Boot nachschauen, ob bei der Bootreihenfolge der ubuntu Eintrag an die erste Stelle gesetzt werden kann, dann müsste das Grubmenü beim Booten erscheinen.

Zitat
Liegt das daran, dass ich vergessen habe bei Windows 10 Fastboot zu deaktivieren was ich im nachhinnein noch getan habe?
Wohl kaum, aber es sollte deaktiviert bleiben, damit es unter Linux keine Probleme beim Zugriff auf die Win Partitionen gibt.
« Letzte Änderung: 31.01.2016, 11:48:23 von helli »

Model: ATA ST1000LM024 HN-M (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  106MB   105MB   fat32           EFI system partition          boot
 2      106MB   1050MB  944MB   ntfs            Basic data partition          hidden, diag
 3      1050MB  1184MB  134MB                   Microsoft reserved partition  msftres
 4      1184MB  270GB   268GB   ntfs            Basic data partition          msftdata
 5      270GB   270GB   472MB   ntfs                                          hidden, diag
 6      270GB   270GB   367MB   ntfs                                          hidden, diag
 9      270GB   539GB   268GB   ext4
10      539GB   556GB   17.2GB  linux-swap(v1)
 7      556GB   979GB   423GB   ntfs            Basic data partition          msftdata
 8      979GB   1000GB  21.5GB  ntfs            Basic data partition          hidden, diag


Error: Can't have a partition outside the disk! 

Das ist die Ausgabe.

Welchen Reiter meinst du? Ist der bei GParted?

Achso, den Reiter im Bios. Sorry
Kann ich gleich nachgucken, ich warte aber erstmal ob ich noch was in der Liveversion machen soll. Es dauert immer so ewig diese hochzufahren

Welchen Reiter meinst du? Ist der bei GParted?
Nein, den Findest du im BIOS (UEFI).

Das ist auf jeden Fall ein EFI-Rechner, schau also erstmal nach ob du wie von helli beschrieben die Reihenfolge ändern kannst.

Zitat
Welchen Reiter meinst du? Ist der bei GParted?
Der Reiter müsste sich im UEFI-Setup befinden, das beim Booten mit einer bestimmten Taste aufgerufen werden kann. Bei mir ist es die F2.

Gnub oder wie es auch immer hieß ist garnicht aufgelistet. Es gibt nur Windows Boot Manager und  Matshitabd welches das CD/DVD Laufwerk ist soweit ich weiß. Soll ich da jetzt einen Eintrag hinzufügen? Und wenn ja, wie geht das? Vielen Dank für eure Antworten!!!

Wurde das Linux auch im Uefi-Modus installiert ?

Grub wird dort auch nicht aufgelistet, aber ein Eintrag "ubuntu" müsste vorhanden sein, wenn eine UEFI-Installation erfolgreich war.
Wenn bei der Installation von einer DVD gebootet wurde sollte im UEFI-Setup CSM oder Legacy auf disabled stehen, damit die DVD im UEFI-Modus gebootet wird.

Hinweise zur UEFI-Installation findest du auch hier:
http://wiki.ubuntu-forum.de/index.php?title=Benutzer:Klaus_P
« Letzte Änderung: 31.01.2016, 12:20:26 von helli »

Ich weiß nicht, wann hätte man das auswählen können? Ich habe eigentlich nur wie gesagt die Partition als ext4 erstellt und dort nichts weiter verändert soweit ich mich erinnere. Dann habe ich Linux von der DVD gestartet, erweiterte Einstellungen oder wie es hieß ausgewählt und aus der Liste der Partitionen die gewünschte ausgewählt. Diese noch formatiert und das war es. Ich wüsste nicht wo ich was hätte umstellen können außer bei den Partitionen in GParted...

Man muss bereits im Uefi wählen, ob die DVD im Uefi-modus gestartet werden soll.
Bei Uefi gehört der grub nämlich nicht in den MBR, sondern in die Uefi Partition.
Das ist die  1      1049kB  106MB   105MB   fat32           EFI system partition          bootIch hab allerdings sonst keine große Ahnung von Uefi, da ich solche Hardware nicht habe.

Ich kann im Reiter Advanced bei USB Configuration auswählen, ob Legacy USB Support en- oder diabled sein soll. Dies stand jetzt noch auf enabled, soll ich das umstellen?

Ich kann im Reiter Advanced bei USB Configuration auswählen, ob Legacy USB Support en- oder diabled sein soll. Dies stand jetzt noch auf enabled, soll ich das umstellen?
Nein das ist ok so, die Option sorgt nur dafür, das zB. eine USB Tastatur bereits im Bios/Uefi funktioniert.
Du musst vor dem starten der DVD ins Uefi und dort bestimmen, in welchem Modus die DVD starten soll.
So zumindest habe ich gelesen.
« Letzte Änderung: 31.01.2016, 12:25:34 von DocHifi »

Zitat
sollte im UEFI-Setup CSM oder Legacy auf disabled stehen
Diese Einstellung müsste unter dem Reiter Boot zu finden sein.
Wenn man vor dem Booten die Bootoptionen aufruft und CSM oder Legacy auf enabled steht, hat man 2 Möglichkeiten von der DVD zu booten, bei einer steht UEFI davor, die hätte gewählt werden müssen.
« Letzte Änderung: 31.01.2016, 12:32:38 von helli »