Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
24.01.2021, 13:27:39

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25126
  • Letzte: HansW
Statistiken
  • Beiträge insgesamt: 710645
  • Themen insgesamt: 57438
  • Heute online: 783
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  SD-Karte wird nicht erkannt (egal welche) - Acer Extensa 5620Z  (Gelesen 1964 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] SD-Karte wird nicht erkannt (egal welche) - Acer Extensa 5620Z
« am: 22.09.2015, 11:26:05 »
Hallo Leute, ein Neuer grüßt Euch.
 

Bin noch bei der Installation und Inbetriebnahme: Linux Mint 17.2 Rafaela Cinnamon - Dualboot - WinXP -> Laptop Acer Extensa 5620Z 2MB Ram
Es läuft soweit alles, soweit ich das jetzt so als absoluter Linux-Neuling mit "null Ahnung" beurteilen kann.
 
Habe einiges zum Thema  SD-Karten Problematik  gelesen.
Ziel: Daten auf SD-Karte speichern, zur Weitergabe an externes Gerät. Häufiger Wechsel. Auch andere SD-Karten, 1,2,4 u. 8GB Karten.

Habe das System ca. eine Woche und bin noch am Einstellen und Programme ausprobieren.

Irgendwann zwischendurch ist die SD-Karten nach dem Systemstart mal erkannt worden.
Nach dem rausnehmen war sie weg und nach dem wieder einstecken ward sie nicht mehr gesehen.
Wollte sie dann in das System "einhängen" (hab´s irgendwo hier im Forum so gelesen), ging aber nicht,
da sie auch nach einem erneutem Systemstart nicht mehr aufgetaucht ist.
Dann habe ich eine Andere SD-Karte probiert (beide unter Win-XP in diesem Rechner les- u. beschreibbar).

Exfat-fuse und exfat-utils habe ich auch schon installiert.  Nix.

Aus einem anderen Beitrag:
"toffifee"  >  Da die Karten wahrscheinlich nicht mit exFAT formatiert sind, dürften die nachinstallierten Pakete nicht zur Lösung beitragen.
                   Es ist eher so, dass der Slot nur beim Start einmal initialisiert und abgefragt wird. Evtl. wird das bei einem neueren Kernel ja auch mal gefixt,
                   so wie bei mir ab Version 3.13.

Obwohl die Karte schon einmal von Linux-Mint erkannt worden ist.

Danach habe ich auf einen neuen Kernel 3.1.9 für Linux Mint (oder so) aktualisiert. - Das brachte aber auch keinen Erfolg.

Wie kann der SD-Karten-Slott (mit einer SD-Karte) vom  Acer Extensa 5620Z  erkannt und einbunden werden, das man wieder wie gewohnt damit arbeiten kann?

Vorab vielen Dank für eure Hilfe  -  Didi

« Letzte Änderung: 24.09.2015, 23:45:51 von Zebulon »

Hatte ich auch. Mir hat dies geholfen: http://stefanfrings.de/acer_one/
Aber vorsicht, könnte hardwareabhängig sein.
Schon mal mit eingesteckter SD-Karte gebootet? Dann ging's bei mir.
Viel Erfolg!

Hallo grüß Dich.

  Bei diesem Befehl  > setpci -s 00:1c.2 0x50.B=0x41 <  gibt das System aus:  keine Berechtigung zum ändern od. Schreibgeschützt (oder sowas).
                                                                                              ( sitze im Moment nicht vor dem System )

> . . .  Schon mal mit eingesteckter SD-Karte gebootet?  . . . < 

"Zebulon" schrieb: > Irgendwann zwischendurch ist die SD-Karten nach dem Systemstart mal erkannt worden.
                               Nach dem rausnehmen war sie weg und nach dem wieder einstecken ward sie nicht mehr gesehen.

Bis später  Didi

   ( Linux Mint 17.2 Rafaela Cinnamon - Dualboot - WinXP -> Laptop Acer Extensa 5620Z 2MB Ram )

Hallo ich grüsse alle Leser.   

Die Eingabe von :   setpci -s 00:1c.2 0x50.B=0x41
  gibt
pcilib: Cannot open /sys/bus/psi/devices/0000:00:1c.2/config

Als nächstes habe ich auf Win XP die Microsoft Aktualisierung mit der exfat-Erweiterung  installiert.
Danach habe ich die SD-Karte mit rechts-Klick im exfat-Format neu formatiert.  Habe eine Datei drauf Kopiert und die Karte im Slot belassen.

Den Rechner neu gestartet und Linux gab dann bei dem Neustart eine Fehlermeldung raus.
Sinngemäß;  Mit "S" das eingängen zu umgehen od. mit "M" manuell übers Terminal vorzunehmen.

Habe dann "S" gewählt. Das System startet durch und es erscheind wieder der gewohnte Desktop.
Bei der Ansicht; Rechner -> Geräte -> erscheind die  SD-Karte, auf die ich auch Zugriff habe.

Die SD-Karte dann einmal entfernt, wieder eingesteckt um erneuten Zugriff zu bekommen, Fehlanzeige.
Die SD-Karte wird erst wieder nach einem Linux-Neustart wieder erkannt.

Was ist nun geschehen?
1:) Wie bekomme ich den Zustand wieder hin, das Linux-Mint wieder normal "hochfährt".
2.) Was kann man tun, das Linux beim einstecken der SD-Karte erkennt, das da ein neues Medium eingesteckt worden ist.

Ich hoffe das mir Jemand weiterhelfen kann.

LG  Didi



In der fstab nachsehen, was da gemountet werden soll, aber nicht vorhanden ist, denn ich denke das gehört zu diner unvollständigen Meldung mit "S" und "M" dazu.
PP

In Windows nehme ich für SD-Karten den SD-Formatter, der für SD-Karten besser geeignet sein soll als alle betriebssystemeigenen Tools.

Formatiere in Mint die SD-Karte mit dem Tool "Laufwerke" in "Zubehör". Die Zahnräder öffnen Menü's.
Achte sehr drauf, dass du wirklich die SD angibst, das Tool (wie andere auch) formatiert dir schnell und hemmungslos dein XP (wie alt ist das denn...ohne Fat32?).

Zeig mal die Terminalausgabe von cat /etc/fstab - bitte im Codeblock.



« Letzte Änderung: 23.09.2015, 00:24:37 von geobart »

Hi  "peterpolki",   >  In der fstab nachsehen, was da gemountet werden soll, aber nicht vorhanden ist. . . . <

Was ist damit gemeint?   Meinst du das hier?    edit: Hi "geobart" habe erst nach meiner Antwort deinen Beitrag gelesen. > cat /etc/fstab <

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation
UUID=77943944-e840-42a1-9bb8-a1676695922e /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=d464c0c6-aca6-4216-9ae3-2c42d2b03e79 none            swap    sw              0       0
/dev/disk/by-uuid/0159-6699 /mnt/0159-6699 auto nosuid,nodev,nofail,x-gvfs-show 0 0

oder meinst du das hier?

# /lib/init/fstab: static file system information.
#
# These are the filesystems that are always mounted on boot, you can
# override any of these by copying the appropriate line from this file into
# /etc/fstab and tweaking it as you see fit.  See fstab(5).
#
# <file system> <mount point>             <type>          <options>                               <dump> <pass>
/dev/root       /                         rootfs          defaults                                     0 1
none            /proc                     proc            nodev,noexec,nosuid                          0 0
none            /proc/sys/fs/binfmt_misc  binfmt_misc     nodev,noexec,nosuid,optional                 0 0
none            /sys                      sysfs           nodev,noexec,nosuid                          0 0
none            /sys/fs/cgroup            tmpfs           optional,uid=0,gid=0,mode=0755,size=1024     0 0
none            /sys/fs/fuse/connections  fusectl         optional                                     0 0
none            /sys/kernel/debug         debugfs         optional                                     0 0
none            /sys/kernel/security      securityfs      optional                                     0 0
none            /sys/firmware/efi/efivars efivarfs        optional                                     0 0
none            /spu                      spufs           gid=spu,optional                             0 0
none            /dev                      devtmpfs,tmpfs  mode=0755                                    0 0
none            /dev/pts                  devpts          noexec,nosuid,gid=tty,mode=0620              0 0
none            /tmp                      none            defaults                                     0 0
none            /run                      tmpfs           noexec,nosuid,size=10%,mode=0755             0 0
none            /run/lock                 tmpfs           nodev,noexec,nosuid,size=5242880             0 0
none            /run/shm                  tmpfs           nosuid,nodev                                 0 0
none            /run/user                 tmpfs           nodev,noexec,nosuid,size=104857600,mode=0755 0 0
none            /sys/fs/pstore            pstore          optional                                     0 0

für mich sind das "Bömische Dörfer"  ;D

Gruß  Didi

« Letzte Änderung: 23.09.2015, 00:30:39 von Zebulon »

Im Terminal gksudo gedit /etc/fstab (Passworteingabe erfolgt "blind") und dann in der letzten Zeile ein # davorsetzen, speichern, Neustart.
Könnte schon reichen.

 
« Letzte Änderung: 23.09.2015, 00:55:06 von geobart »

gksudo gedit /etc/fstab Wenn man was schreiben will ...
ansonsten reicht 'cat'
Abspeichern und Editor schließen nicht vergessen.
« Letzte Änderung: 23.09.2015, 00:48:45 von aexe »

Off-Topic:
::) War grad abgelenkt..

Hallo grüßt Euch.

Das mit dem editieren und der "#" vor die letzte Zeile hat geklappt.  Danke das war fürś Booten die Lösung,
nun muß ich nur noch das mit der SD-Karte gebacken bekommen  ;D.

Bis später  Didi


Es muss sudo setpci -s 00:1c.2 0x50.B=0x41 heißen, jedenfalls funzt's bei mir. Meine SD-Karte war auch wieder weg.
Hab nochmal die Anleitung von http://stefanfrings.de/acer_one/ angewendet, um das in die Start-/Aufweckoption zu bekommen. Die setpci-Zeile hab ich mir vorsichtshalber in eine Textdatei gespeichert und wende sie ggf. im Terminal an (mit sudo...). Könnte man auch in einen Starter packen.

So, Neustart gemacht, jetzt wird die SD-Karte gemountet, wenn ich sie einstecke. Vorsicht: Der Anmeldebildschirm wollte auf einmal Englisch! (Auf die Flagge achten.) In der rc.local-Datei muss der Einschub vor die exit-Zeile gesetzt werden.

Danke dir, werde ich gleich nachher, wenn ich wieder am Rechner sitze ausprobieren.   Gruß  Didi


Hi "Motetus" grüß dich.

Habe es genau so wie du es dokumentiert hast, ausgeführt und es hat geklappt.

Zwei von drei SD-Karten werden sofort nach dem einstecken ins Gerät, erkannt und sind in Funktion.
Die die so nicht funzt, werde ich mal neu auf FAT32 formatieren, dann müsste es eigentlich auch klappen.

Danke nochmal an Alle die mit zur Lösung meiner Probleme beigetragen haben.   Didi   :D