Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.07.2020, 17:17:13

.
Einloggen mit Benutzername, Passwort und Sitzungslänge


Autor Thema:  Inoffizielles Linux Mint Debian 2 LXDE  (Gelesen 53279 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: Inoffizielles Linux Mint Debian 2 LXDE 32-Bit
« Antwort #135 am: 03.04.2015, 18:26:35 »
@aexe: Lxde hat keinen eigenen Menüeditor. Man kann aber zB "menulibre" nachinstallieren...
Ja eben, deswegen vermisse ich ihn ja auch !
menulibre hab ich (nicht sehr gründlich) getestet, hat nicht richtig funktioniert.

Jedenfalls habe ich jetzt die vorhin noch fehlenden Sachen (Chromium und Screenshot)
im Menu und im Panel als Starter :

1)  Das Paket menu wieder installiert

2)  Verzeichnis ~/.config/menus löschen, dann  update-menus
3)    Starter dem Panel hinzufügen
Nachdem das über die Panel-Einstellungs-GUI ('lxpanelctl config') immer noch nicht möglich war,
habe ich die Datei /home/$USER/.config/lxpanel/LXDE/panels/panel editiert.
Ausschnitt daraus : .....
}
Plugin {
  type=launchbar
  Config {
    Button {
      id=pcmanfm.desktop
    }
    Button {
      id=lxterminal.desktop
    }
    Button {
      id=menu://applications/Internet/firefox.desktop
    }
    Button {
      id=menu://applications/Internet/chromium.desktop
    }
    Button {
      id=menu://applications/Accessories/org.gnome.Screenshot.desktop
    }
  }
}
......
Danach das LX-Panel neu starten mit lxpanelctl restart
« Letzte Änderung: 03.04.2015, 18:36:12 von aexe »

Fritx

  • Gast
Re: Inoffizielles Linux Mint Debian 2 LXDE 32-Bit
« Antwort #136 am: 03.04.2015, 19:18:02 »
@aexe: Prima. Aber komisch ist die Sache schon. Wäre ja nervig, wenn du es jetzt immer so machen müsstest. Ich könnte mir aber immer noch vorstellen, dass sich Lxmenu und dieses Debianmenu irgendwie doch unter bestimmten Umständen in die Quere kommen. Bloße Vermutung, aber du hattest immerhin auch die Deinstallation von "menu" dazwischen.  Man braucht "menu" unter LXDE nicht. In einer Openbox-Session ist es für das Kontextmenü ganz schön. Siehe:

http://wiki.ubuntuusers.de/Openbox
Zitat
Um die aktuell installierten Programme ins Kontextmenü zu integrieren, gibt es mehrere Möglichkeiten:
ein Pipemenü (siehe Openbox/Pipemenü)
Debian-Menü
menu (universe)


Wie dem auch sein: warten wir mal ab, wie es bei der nächsten nachinstallierten Anwendung ist.
Gruss, Fritz

Re: Inoffizielles Linux Mint Debian 2 LXDE 32-Bit
« Antwort #137 am: 03.04.2015, 19:32:43 »
Anlegen von Startern im Panel mache ich nicht allzu oft, die wenigen, die ich gewohnt bin habe ich jetzt.
Aber Du hast den kritischen Punkt benannt :
Neu installierte Anwendungen sollten reibungslos und automatisch ins Menu integriert werden.

Hier kommen wir aber damit etwas ab vom Thema (LinuxMint News).
Wenn ich weitere Erkenntnisse gesammelt habe oder jemand schon welche dazu hat,
würde sich der LXDE- Bereich anbieten, den es ja auch noch gibt :
https://www.linuxmintusers.de/index.php?board=67.0


Re: Inoffizielles Linux Mint Debian 2 LXDE 32-Bit
« Antwort #138 am: 03.04.2015, 19:55:41 »
Das LXDE Menü ist einfach nur bescheiden.

Bei allen anderen Desktops kann man mit Leichtigkeit jedes Programm, vor allem

auch einen Starter für ein selbsterstelltes, ins Menü bringen.

Bei LXDE ist das nicht möglich.
« Letzte Änderung: 03.04.2015, 20:12:45 von BigApple »

Fritx

  • Gast
Re: Inoffizielles Linux Mint Debian 2 LXDE 32-Bit
« Antwort #139 am: 03.04.2015, 20:18:08 »
Neu installierte Anwendungen sollten reibungslos und automatisch ins Menu integriert werden.

Das ist normalerweise bei Lxde auch der Fall. Aber ich habe bis dato auch noch kein Lxde gesehen, bei der das Paket "menu" per default installiert gewesen wäre. In keinem der folgenden Metapaket ist das mit drin: lxde-core, lxde, lubuntu-core, lubuntu-desktop.

Aber du hast recht, lassen wir das jetzt hier mal so stehen.

Re: Inoffizielles Linux Mint Debian 2 LXDE 32-Bit
« Antwort #140 am: 03.04.2015, 20:29:36 »
Nachtrag :
Habe soeben weitere Anwendungen installiert (Me-Tv, obconf, obmenu)
Es sind automatisch Einträge im Menu erstellt worden.
Das LXDE Menü ist einfach nur bescheiden...
Das ist ja auch die Zielsetzung von LXDE, leichtgewichtig und schnell zu sein,
durch Beschränkung auf das Wesentliche und Verzicht auf manche "Komfort-Funktion".
Deshalb muss man halt gelegentlich mal etwas fummeln.
Wer das nicht will : bitteschön, KDE und Cinnamon gibt es ja auch noch.  ;)
« Letzte Änderung: 03.04.2015, 20:42:19 von aexe »

DeVIL-I386Threadstarter

  • Administrator
  • *****
Re: Inoffizielles Linux Mint Debian 2 LXDE
« Antwort #141 am: 04.04.2015, 08:08:59 »
Die ISOs wurden aktualisiert (u.a. Firefox 37, evince-gtk installiert).
Es gibt jetzt eine 64-Bit-ISO.



Wer einen Menü-Editor braucht, kann ihn sich selbst installieren.

Re: Inoffizielles Linux Mint Debian 2 LXDE 32-Bit
« Antwort #142 am: 04.04.2015, 13:03:45 »
Ein Mint-logout-banner (ähnlich Mint12) wäre der i-Punkt.

LXDE Mint12 logout-banner
LXDE Mint12 logout-banner
Besten Dank für die 64-Bit-Version.

Fritx

  • Gast
Re: Inoffizielles Linux Mint Debian 2 LXDE 32-Bit
« Antwort #143 am: 04.04.2015, 14:20:52 »
Ein Mint-logout-banner (ähnlich Mint12) wäre der i-Punkt.

Wo hast du das eingestellt?
Unter "~/.config/lxsession/LXDE/desktop.conf" habe ich erfolglos geändert in "quit_manager/image=/usr/share/mint-lxde/images/logout-banner.png"  :-[

DeVIL-I386Threadstarter

  • Administrator
  • *****
Re: Inoffizielles Linux Mint Debian 2 LXDE 32-Bit
« Antwort #144 am: 04.04.2015, 21:52:43 »
Ein Mint-logout-banner (ähnlich Mint12) wäre der i-Punkt.
Kannst du hiermit ändern (Terminal): sudo chmod +x /usr/bin/mint-lxde-logout
sed -i s/command=logout/action=mint-lxde-logout\\nname=Abmelden/g ~/.config/lxpanel/LXDE/panels/panel

Danach einmal vom System ab- und anmelden.


Re: Inoffizielles Linux Mint Debian 2 LXDE
« Antwort #145 am: 08.04.2015, 01:18:58 »
Was ist denn für ein Kernel in der 64bit Version enthalten? Das iso will bei mir in der VB nicht booten.
Oder liegt das daran das ich ein 32bit System als Host nutze?

Re: Inoffizielles Linux Mint Debian 2 LXDE
« Antwort #146 am: 08.04.2015, 02:05:39 »
Oder liegt das daran das ich ein 32bit System als Host nutze?
Ist bei mir auch so.
« Letzte Änderung: 11.04.2015, 00:39:59 von geobart »

Re: Inoffizielles Linux Mint Debian 2 LXDE
« Antwort #147 am: 08.04.2015, 02:20:12 »
Genauer gesagt: "Ist bei mir so"...

Ich hab auch nachgelesen, es gibt die Möglichkeit auf 32bit host Systemen 64bit Guests zu nutzen, allerdings muß dazu die CPU mitspielen.
Meine macht das wohl nicht.
https://www.virtualbox.org/manual/ch03.html#intro-64bitguests
Zitat
VirtualBox supports 64-bit guest operating systems, even on 32-bit host operating systems,[11] provided that the following conditions are met:
  • You need a 64-bit processor with hardware virtualization support (see Section 10.3, “Hardware vs. software virtualization”).
  • You must enable hardware virtualization for the particular VM for which you want 64-bit support; software virtualization is not supported for 64-bit VMs.

Re: Inoffizielles Linux Mint Debian 2 LXDE 32-Bit
« Antwort #148 am: 10.04.2015, 00:23:32 »
Das LXDE Menü ist einfach nur bescheiden.

Bei allen anderen Desktops kann man mit Leichtigkeit jedes Programm, vor allem

auch einen Starter für ein selbsterstelltes, ins Menü bringen.

Bei LXDE ist das nicht möglich.
Das ist natürlich auch unter LXDE möglich.
Einfach einen Starter erstellen und in
/home/nutzer/.local/share/applications/
ablegen, und schon ist er im Menü.

Re: Inoffizielles Linux Mint Debian 2 LXDE
« Antwort #149 am: 11.04.2015, 00:39:20 »
Genauer gesagt: "Ist bei mir so"...
Okay. Geändert. ::)